[PATCH] gnu: python-numpy: Update to 1.19.4.

  • Done
  • quality assurance status badge
Details
3 participants
  • Greg Hogan
  • Xinglu Chen
  • zimoun
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 6 Jan 2021 19:46
(address . guix-patches@gnu.org)
CA+3U0ZnX_tOhhUA_D-4-rFxiq4+gVU+zae8bThOYYU3STGzRVw@mail.gmail.com
From f5f390689908f065fd12abaeba8fa4e19e5e96c8 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Tue, 5 Jan 2021 16:23:24 +0000
Subject: [PATCH] gnu: python-numpy: Update to 1.19.4.

* gnu/packages/python-xyz.scm (python-numpy): Update to 1.19.4.
[native-inputs]: Add python-hypothesis.
---
gnu/packages/python-xyz.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ab10668a01..a049f257cb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -94,6 +94,7 @@
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Kristian Trandem <kristian@devup.no>
;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4515,7 +4516,7 @@ between language specification and implementation
aspects.")
(define-public python-numpy
(package
(name "python-numpy")
- (version "1.17.3")
+ (version "1.19.4")
(source
(origin
(method url-fetch)
@@ -4524,13 +4525,14 @@ between language specification and implementation
aspects.")
version "/numpy-" version ".tar.gz"))
(sha256
(base32
- "1ak9dmjja0q90a7fsxli51ypcwssh8c4pb6f8wkrsnf2xgdk6dy9"))))
+ "04w46xsllj7al9bfjk5zzs48xa9y300yzjh3ysrxnf38bml6m0zy"))))
(build-system python-build-system)
(inputs
`(("openblas" ,openblas)
("lapack" ,lapack)))
(native-inputs
`(("python-cython" ,python-cython)
+ ("python-hypothesis" ,python-hypothesis)
("python-pytest" ,python-pytest)
("gfortran" ,gfortran)))
(arguments
--
2.30.0
Attachment: file
G
G
Greg Hogan wrote on 14 Mar 2021 17:03
(address . guix-patches@gnu.org)
CA+3U0Zmwmhkuq5VfL_uu9dL5Hd12v4jrktmK6v6_Ho+5dqC8rQ@mail.gmail.com
Replacement patch for more recent version.

From bc7e702f26a7f1e9ff22cd9c3cd3f6c12dc72bdf Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Sun, 14 Mar 2021 15:40:41 +0000
Subject: [PATCH] gnu: python-numpy: Update to 1.20.1.

* gnu/packages/python-xyz.scm (python-numpy): Update to 1.20.1.
[native-inputs]: Add python-hypothesis.
---
gnu/packages/python-xyz.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dadf08f03d..f4e742b4fe 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -99,6 +99,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Ellis Keny? <me@elken.dev>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4542,7 +4543,7 @@ between language specification and implementation
aspects.")
(define-public python-numpy
(package
(name "python-numpy")
- (version "1.17.3")
+ (version "1.20.1")
(source
(origin
(method url-fetch)
@@ -4551,13 +4552,14 @@ between language specification and implementation
aspects.")
version "/numpy-" version ".tar.gz"))
(sha256
(base32
- "1ak9dmjja0q90a7fsxli51ypcwssh8c4pb6f8wkrsnf2xgdk6dy9"))))
+ "0vc4fr3429a1rrzfxbd05lifrh72bwcc5vavwlwr5jmlxdlivxcv"))))
(build-system python-build-system)
(inputs
`(("openblas" ,openblas)
("lapack" ,lapack)))
(native-inputs
`(("python-cython" ,python-cython)
+ ("python-hypothesis" ,python-hypothesis)
("python-pytest" ,python-pytest)
("gfortran" ,gfortran)))
(arguments
--
2.30.2

On Wed, Jan 6, 2021 at 1:46 PM Greg Hogan <code@greghogan.com> wrote:

Toggle quote (53 lines)
> From f5f390689908f065fd12abaeba8fa4e19e5e96c8 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Tue, 5 Jan 2021 16:23:24 +0000
> Subject: [PATCH] gnu: python-numpy: Update to 1.19.4.
>
> * gnu/packages/python-xyz.scm (python-numpy): Update to 1.19.4.
> [native-inputs]: Add python-hypothesis.
> ---
> gnu/packages/python-xyz.scm | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index ab10668a01..a049f257cb 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -94,6 +94,7 @@
> ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
> ;;; Copyright © 2019 Kristian Trandem <kristian@devup.no>
> ;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
> +;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -4515,7 +4516,7 @@ between language specification and implementation
> aspects.")
> (define-public python-numpy
> (package
> (name "python-numpy")
> - (version "1.17.3")
> + (version "1.19.4")
> (source
> (origin
> (method url-fetch)
> @@ -4524,13 +4525,14 @@ between language specification and implementation
> aspects.")
> version "/numpy-" version ".tar.gz"))
> (sha256
> (base32
> - "1ak9dmjja0q90a7fsxli51ypcwssh8c4pb6f8wkrsnf2xgdk6dy9"))))
> + "04w46xsllj7al9bfjk5zzs48xa9y300yzjh3ysrxnf38bml6m0zy"))))
> (build-system python-build-system)
> (inputs
> `(("openblas" ,openblas)
> ("lapack" ,lapack)))
> (native-inputs
> `(("python-cython" ,python-cython)
> + ("python-hypothesis" ,python-hypothesis)
> ("python-pytest" ,python-pytest)
> ("gfortran" ,gfortran)))
> (arguments
> --
> 2.30.0
>
Attachment: file
X
X
Xinglu Chen wrote on 14 Mar 2021 22:04
Re: [bug#45698] [PATCH] gnu: python-numpy: Update to 1.19.4.
87ft0xcuqu.fsf@yoctocell.xyz
On Sun, Mar 14 2021, Greg Hogan wrote:

Toggle quote (3 lines)
> * gnu/packages/python-xyz.scm (python-numpy): Update to 1.20.1.
> [native-inputs]: Add python-hypothesis.

Great, Numpy builds for me, but when I try to build Scipy which is often
used with Numpy, one test for Matplolib is failing. Any ideas?

Toggle snippet (41 lines)
=================================== FAILURES ===================================
___________________________________ test_gca ___________________________________

def test_gca():
fig = plt.figure()
ax1 = fig.add_axes([0, 0, 1, 1])
assert fig.gca(projection='rectilinear') is ax1
assert fig.gca() is ax1
ax2 = fig.add_subplot(121, projection='polar')
assert fig.gca() is ax2
assert fig.gca(polar=True) is ax2
ax3 = fig.add_subplot(122)
assert fig.gca() is ax3
# the final request for a polar axes will end up creating one
# with a spec of 111.
with warnings.catch_warnings(record=True) as w:
warnings.simplefilter('always')
# Changing the projection will throw a warning
assert fig.gca(polar=True) is not ax3
> assert len(w) == 1
E assert 2 == 1
E -2
E +1

/gnu/store/s3i6ps5fmyb5ld0rx37g23s7w8rzghl7-python-matplotlib-3.1.2/lib/python3.8/site-packages/matplotlib/tests/test_figure.py:168: AssertionError

[...]

-- Docs: https://docs.pytest.org/en/latest/warnings.html
= 1 failed, 5014 passed, 2139 skipped, 2 deselected, 9 xfailed, 8 xpassed, 36 warnings in 107.78s (0:01:47) =
command "python" "tests.py" "-v" "-m" "not network and not webagg" failed with status 1
builder for `/gnu/store/6kmizr8498mxiv7spsavznirva76yphh-python-matplotlib-3.1.2.drv' failed with exit code 1
build of /gnu/store/6kmizr8498mxiv7spsavznirva76yphh-python-matplotlib-3.1.2.drv failed
View build log at '/var/log/guix/drvs/6k/mizr8498mxiv7spsavznirva76yphh-python-matplotlib-3.1.2.drv.bz2'.
cannot build derivation `/gnu/store/hd6zbcgdf7sa9bj63rsw5ayyhrrlfndw-python-scipy-1.6.0.drv': 1 dependencies couldn't be built
guix build: error: build of `/gnu/store/hd6zbcgdf7sa9bj63rsw5ayyhrrlfndw-python-scipy-1.6.0.drv' failed
Z
Z
zimoun wrote on 15 Mar 2021 09:34
86r1kgdddh.fsf@gmail.com
Hi,

On Sun, 14 Mar 2021 at 22:04, Xinglu Chen <public@yoctocell.xyz> wrote:
Toggle quote (8 lines)
> On Sun, Mar 14 2021, Greg Hogan wrote:
>
>> * gnu/packages/python-xyz.scm (python-numpy): Update to 1.20.1.
>> [native-inputs]: Add python-hypothesis.
>
> Great, Numpy builds for me, but when I try to build Scipy which is often
> used with Numpy, one test for Matplolib is failing. Any ideas?

On my side, the update of numpy breaks other dependant packages too.

All the best,
simon
Z
Z
zimoun wrote on 26 Mar 2021 10:17
(name . Greg Hogan)(address . code@greghogan.com)(address . 45698@debbugs.gnu.org)
86r1k29sv7.fsf@gmail.com
Hi,

Since this update breaks many dependants, I am in favour to update Numpy
accordingly with the dependants or close this. WDYT?

All the best,
simon
G
G
Greg Hogan wrote on 26 Mar 2021 14:30
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 45698@debbugs.gnu.org)
CA+3U0ZkiQnb78obuRH7ymWwcMK2DTsS3AXRyt64wV6ev7bf+jA@mail.gmail.com
Hi Simon,

I have not had time to look further into the matplotlib build failure,
though I would like to. I did see the second patch also looking to update
numpy. I don't mind if you want to close this to reduce the outstanding
"bugs", or leave it open for another week and see if we can update the
dependencies.

Greg

On Fri, Mar 26, 2021 at 9:17 AM zimoun <zimon.toutoune@gmail.com> wrote:

Toggle quote (8 lines)
> Hi,
>
> Since this update breaks many dependants, I am in favour to update Numpy
> accordingly with the dependants or close this. WDYT?
>
> All the best,
> simon
>
Attachment: file
Z
Z
zimoun wrote on 27 Mar 2021 01:44
(name . Greg Hogan)(address . code@greghogan.com)(address . 45698@debbugs.gnu.org)
86wntt8lxy.fsf@gmail.com
Hi Greg,

On Fri, 26 Mar 2021 at 13:30, Greg Hogan <code@greghogan.com> wrote:

Toggle quote (2 lines)
> I have not had time to look further into the matplotlib build failure,

I guess Panda is probably also failing. Well, you can try:

$ ./pre-inst-env guix build -q \
$(./pre-inst-env guix refresh -l | cut -d':' -f2-)

if you have enough CPU power at hand.

Toggle quote (5 lines)
> though I would like to. I did see the second patch also looking to update
> numpy. I don't mind if you want to close this to reduce the outstanding
> "bugs", or leave it open for another week and see if we can update the
> dependencies.

For sure, the bug can still be open more than one week. :-) If you are
working on updating numpy with the dependants, neat! Thanks!

I was just scrolling Debbugs, I noticed that and I preferred to ask the
status now instead of 2 or more years later (as it happens when patches
are not included).

Thanks,
simon
Z
Z
zimoun wrote on 9 Jun 2021 23:50
(name . Greg Hogan)(address . code@greghogan.com)(address . 45698@debbugs.gnu.org)
86lf7ilnbo.fsf@gmail.com
Hi,


On Sat, 27 Mar 2021 at 01:44, zimoun <zimon.toutoune@gmail.com> wrote:
Toggle quote (23 lines)
> On Fri, 26 Mar 2021 at 13:30, Greg Hogan <code@greghogan.com> wrote:
>
>> I have not had time to look further into the matplotlib build failure,
>
> I guess Panda is probably also failing. Well, you can try:
>
> $ ./pre-inst-env guix build -q \
> $(./pre-inst-env guix refresh -l | cut -d':' -f2-)
>
> if you have enough CPU power at hand.
>
>> though I would like to. I did see the second patch also looking to update
>> numpy. I don't mind if you want to close this to reduce the outstanding
>> "bugs", or leave it open for another week and see if we can update the
>> dependencies.
>
> For sure, the bug can still be open more than one week. :-) If you are
> working on updating numpy with the dependants, neat! Thanks!
>
> I was just scrolling Debbugs, I noticed that and I preferred to ask the
> status now instead of 2 or more years later (as it happens when patches
> are not included).

Maybe this patch could go to core-updated. WDYT?

All the best,
simon
X
X
Xinglu Chen wrote on 10 Jun 2021 09:31
(address . 45698@debbugs.gnu.org)
87y2bi9nw8.fsf@yoctocell.xyz
On Wed, Jun 09 2021, zimoun wrote:

Toggle quote (29 lines)
> Hi,
>
>
> On Sat, 27 Mar 2021 at 01:44, zimoun <zimon.toutoune@gmail.com> wrote:
>> On Fri, 26 Mar 2021 at 13:30, Greg Hogan <code@greghogan.com> wrote:
>>
>>> I have not had time to look further into the matplotlib build failure,
>>
>> I guess Panda is probably also failing. Well, you can try:
>>
>> $ ./pre-inst-env guix build -q \
>> $(./pre-inst-env guix refresh -l | cut -d':' -f2-)
>>
>> if you have enough CPU power at hand.
>>
>>> though I would like to. I did see the second patch also looking to update
>>> numpy. I don't mind if you want to close this to reduce the outstanding
>>> "bugs", or leave it open for another week and see if we can update the
>>> dependencies.
>>
>> For sure, the bug can still be open more than one week. :-) If you are
>> working on updating numpy with the dependants, neat! Thanks!
>>
>> I was just scrolling Debbugs, I noticed that and I preferred to ask the
>> status now instead of 2 or more years later (as it happens when patches
>> are not included).
>
> Maybe this patch could go to core-updated. WDYT?

FYI he sent an updated patch a few weeks ago.

-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmDBv8cVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5QPoQAKpLTW2Lhpmp3567ZDEN6RQy7AAO
oCR2TBtSS2fxuemUGsg24RuY+D+4ZRUw9mkMVyRJZPHGZp8VfW6NRi2wF8wOOFHU
sskAaYmhqSninMbQcUKUw/tfUxsfSV6XlxkNt89EJNx4X8XkS/P5ySzWZ6KVgG4O
i3AYTboR+4N8vWP8597oqskQ36RO4wWs/IfRf/1cSaTp3oXAYUPDfS+W/2Zexc5W
eYJq2WAGFSkDhmh6rBhjzuL+G76FzB5q+r2j6GM5iBw5eU3mqUlS/yE8SnJjqTAd
mnYFE6G0uDWzFdb5JYcQiAjrdVHceA/ySUNg2zgLkwnLWDrv639eOFypqPrp+Ymy
tGjy6rvjihMqkGiXi1X8i3nvRWcrUqvaxiW7fh3nCgmmYQuKp5Qxa5LK0wdchV/j
/dik3EyTFd+pYLedUAEd7U5ftaTBRjZYdCij3Du1EVRsZ56pos3voVbJrYivB08r
LBj39319Ab10bOKJFpJq2SaHmDLlPZEeFezbK1000WTryZDUAg8FmSd8J3KeBBVJ
f4NLIXcN1usFzKPbdIx2zg2OZtxIRBdLF71lh25v56tpwJyIdaJTL3pylkIr+biv
d03P/3KR7vhnqo75qZpspUOXpjY4ZJcImCCDmdysd+dLYtJC+vLpf1zRoOfj1j8D
tNVXspKDojmSXcHk
=Xwf/
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 10 Jun 2021 10:32
(address . 45698-done@debbugs.gnu.org)
86a6nyktl7.fsf@gmail.com
Hi,

On Thu, 10 Jun 2021 at 09:31, Xinglu Chen <public@yoctocell.xyz> wrote:

Toggle quote (4 lines)
> FYI he sent an updated patch a few weeks ago.
>
> https://issues.guix.gnu.org/48703

Thanks. So closing in favor of patch#48703 which updates to 1.20.3.

All the best,
simon
Closed
?