[PATCH] Add nord-theme

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Ellis Kenyo
Owner
unassigned
Submitted by
Ellis Kenyo
Severity
normal
E
E
Ellis Kenyo wrote on 1 Jan 2021 15:20
(address . guix-patches@gnu.org)(name . Ellis Kenyo)(address . me@elken.dev)
20210101142014.25296-1-me@elken.dev
---
gnu/packages/gnome-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 2eb08da50f..8de59dac2e 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -649,3 +649,28 @@ language specification for the Language Server Protocol (LSP). This tool is
used in text editing environments to provide a complete and integrated
feature-set for programming Vala effectively.")
(license license:lgpl2.1+)))
+
+(define-public nord-theme
+ (let ((commit "07d764c5ebd5706e73d2e573f1a983e37b318915")
+ (revision "0"))
+ (package
+ (name "nord-theme")
+ (version (git-version "1.9.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/EliverLara/Nordic")
+ (commit commit)))
+ (sha256
+ (base32
+ "0y2s9d6h1b195s6afp1gb5rb1plfslkpbw2brd30a9d66wfvsqk0"))
+ (file-name (git-file-name name version))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ `(("." "share/themes/nord" #:exclude ("README.md" "LICENSE" "Art/" "package.json" "package-lock.json" "Gulpfile.js")))))
+ (home-page "https://github.com/EliverLara/Nordic")
+ (synopsis "Dark Gtk3.20+ theme created using the awesome Nord color pallete.")
+ (description "Nordic is a Gtk3.20+ theme created using the awesome Nord color pallete.")
+ (license license:gpl3))))
--
2.29.2
L
L
Leo Famulari wrote on 2 Jan 2021 03:59
(address . 45598@debbugs.gnu.org)
X+/hfFwh27h/Elj9@jasmine.lan
On Fri, Jan 01, 2021 at 02:20:14PM +0000, Ellis Kenyo via Guix-patches via wrote:
Toggle quote (2 lines)
> +(define-public nord-theme

Thanks!

Toggle quote (2 lines)
Should it be called "nordic-theme" instead? That seems to be the name
they picked.
E
E
Ellis Keny? wrote on 2 Jan 2021 06:38
(name . Leo Famulari)(address . leo@famulari.name)
596b17f7-bff7-4905-9ed4-6eac405160b6@elken.dev
The original theme it's based on is called "Nord" and that's the expectation from a user perspective, I'm not quite sure why they renamed it.

On 2 Jan 2021, 03:05, at 03:05, Leo Famulari <leo@famulari.name> wrote:
Toggle quote (10 lines)
>On Fri, Jan 01, 2021 at 02:20:14PM +0000, Ellis Kenyo via Guix-patches
>via wrote:
>> +(define-public nord-theme
>
>Thanks!
>
>> + (url "https://github.com/EliverLara/Nordic")
>
>Should it be called "nordic-theme" instead? That seems to be the name
>they picked.
Attachment: file
L
L
Leo Famulari wrote on 4 Jan 2021 00:34
(name . Ellis Keny?)(address . me@elken.dev)
X/JUaaaq0xh8kiRw@jasmine.lan
On Sat, Jan 02, 2021 at 05:38:23AM +0000, Ellis Keny? wrote:
Toggle quote (2 lines)
> The original theme it's based on is called "Nord" and that's the expectation from a user perspective, I'm not quite sure why they renamed it.

Sorry to be a stickler but we usually use upstream names. We might make
exceptions if other distros rename it as well, or if there is some
widely used interface with the other name.

Is that the case? If so, we can call it nord-theme. Otherwise we'll use
nordic-theme.
E
E
Ellis Keny? wrote on 4 Jan 2021 03:02
(name . Leo Famulari)(address . leo@famulari.name)
97c66616-f04a-4558-b7f5-701f22594ecf@elken.dev
I don't mind either way so I'm happy to have it merged as nordic! ??

On 3 Jan 2021, 23:40, at 23:40, Leo Famulari <leo@famulari.name> wrote:
Toggle quote (11 lines)
>On Sat, Jan 02, 2021 at 05:38:23AM +0000, Ellis Keny? wrote:
>> The original theme it's based on is called "Nord" and that's the
>expectation from a user perspective, I'm not quite sure why they
>renamed it.
>
>Sorry to be a stickler but we usually use upstream names. We might make
>exceptions if other distros rename it as well, or if there is some
>widely used interface with the other name.
>
>Is that the case? If so, we can call it nord-theme. Otherwise we'll use
>nordic-theme.
Attachment: file
L
L
Leo Famulari wrote on 4 Jan 2021 03:40
(name . Ellis Keny?)(address . me@elken.dev)(address . 45598-done@debbugs.gnu.org)
X/KALc/xqlBXlmhT@jasmine.lan
On Mon, Jan 04, 2021 at 02:02:17AM +0000, Ellis Keny? wrote:
Toggle quote (2 lines)
> I don't mind either way so I'm happy to have it merged as nordic! ??

Okay! Pushed as fdfc1c81ba018dd808b0dfd9827a73262c716808 with the name
"nordic-theme.

Thanks!

Closed
?