[PATCH 0/2] Add more r-mlr3 add-ons

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • Wiktor ?elazny
Owner
unassigned
Submitted by
Wiktor ?elazny
Severity
normal
W
W
Wiktor ?elazny wrote on 31 Dec 2020 13:46
(address . guix-patches@gnu.org)
20201231124608.1090-1-wz@freeshell.de
A false alarm yesterday regarding the r-mlr3pipelines determinism. I
confused the derivation hash with the build hash. As for r-mlr3ordinal,
the linter reported

./gnu/packages/cran.scm:25616:15: r-mlr3ordinal@0.1.0-9000-0.9febac9: the source file name should contain the package name

I don’t know what “source file name” is referenced here, so I’m
submitting the definition as it is.

Wiktor ?elazny (2):
gnu: Add r-mlr3pipelines.
gnu: Add r-mlr3ordinal.

gnu/packages/cran.scm | 62 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 62 insertions(+)


base-commit: 67497e20890348ebbd41612e2582b1745a80fec5
--
2.29.2
W
W
Wiktor ?elazny wrote on 31 Dec 2020 13:53
[PATCH 2/2] gnu: Add r-mlr3ordinal.
(address . 45565@debbugs.gnu.org)
20201231125341.1287-2-wz@freeshell.de
* gnu/packages/cran.scm (r-mlr3ordinal): New variable.
---
gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0837ddaf87..f429bd06fa 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25606,3 +25606,34 @@ Operations exist for data preprocessing, model fitting, and ensemble learning.
Graphs can themselves be treated as @code{mlr3} Learners and can therefore be
resampled, benchmarked, and tuned.")
(license license:lgpl3)))
+
+(define-public r-mlr3ordinal
+ (let ((commit "9febac983b11b7b1f477e5cf0212e5999cd2ed44")
+ (revision "0"))
+ (package
+ (name "r-mlr3ordinal")
+ (version (git-version "0.1.0-9000" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mlr-org/mlr3ordinal")
+ (commit commit)))
+ (sha256
+ (base32
+ "1icfhz1pjm0mlsn2y60gsrbk31b2p7xmpx3xsg7639rcgdb5f9gl"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-checkmate" ,r-checkmate)
+ ("r-data-table" ,r-data-table)
+ ("r-mlr3" ,r-mlr3)
+ ("r-mlr3misc" ,r-mlr3misc)
+ ("r-mlr3pipelines" ,r-mlr3pipelines)
+ ("r-nloptr" ,r-nloptr)
+ ("r-ordinal" ,r-ordinal)
+ ("r-paradox" ,r-paradox)
+ ("r-r6" ,r-r6)))
+ (home-page "https://mlr3ordinal.mlr-org.com/")
+ (synopsis "Ordinal Regression for @code{mlr3}")
+ (description "This package extends @code{mlr3} with support for
+performing ordinal regression.")
+ (license license:expat))))
--
2.29.2
W
W
Wiktor ?elazny wrote on 31 Dec 2020 13:53
[PATCH 1/2] gnu: Add r-mlr3pipelines.
(address . 45565@debbugs.gnu.org)
20201231125341.1287-1-wz@freeshell.de
* gnu/packages/cran.scm (r-mlr3pipelines): New variable.
---
gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 40f8e82c34..0837ddaf87 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25575,3 +25575,34 @@ tuning, e.g. Grid Search, Random Search, or Simulated Annealing. Various
termination criteria can be set and combined. The class @code{AutoTuner} provides a
convenient way to perform nested resampling in combination with @code{mlr3}.")
(license license:lgpl3)))
+
+(define-public r-mlr3pipelines
+ (package
+ (name "r-mlr3pipelines")
+ (version "0.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr3pipelines" version))
+ (sha256
+ (base32
+ "1x738b312mcvb0dif88sv4nlh3y6i47q0wagc5ggyh1hnqjiz71y"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-backports" ,r-backports)
+ ("r-checkmate" ,r-checkmate)
+ ("r-data-table" ,r-data-table)
+ ("r-digest" ,r-digest)
+ ("r-lgr" ,r-lgr)
+ ("r-mlr3" ,r-mlr3)
+ ("r-mlr3misc" ,r-mlr3misc)
+ ("r-paradox" ,r-paradox)
+ ("r-r6" ,r-r6)
+ ("r-withr" ,r-withr)))
+ (home-page "https://mlr3pipelines.mlr-org.com/")
+ (synopsis "Preprocessing Operators and Pipelines for @code{mlr3}")
+ (description "@code{mlr3pipelines} enriches @code{mlr3} with a diverse
+set of pipelining operators (PipeOps) that can be composed into graphs.
+Operations exist for data preprocessing, model fitting, and ensemble learning.
+Graphs can themselves be treated as @code{mlr3} Learners and can therefore be
+resampled, benchmarked, and tuned.")
+ (license license:lgpl3)))
--
2.29.2
R
R
Ricardo Wurmus wrote on 31 Dec 2021 20:20
Re: [bug#45565] [PATCH 0/2] Add more r-mlr3 add-ons
(name . Wiktor ?elazny)(address . wz@freeshell.de)(address . 45565-done@debbugs.gnu.org)
87lf00fujz.fsf@elephly.net
Hi Wiktor,

I’m terribly sorry for the delay. These two patches are fine and
slipped through the cracks. I updated the packages to the new input
style and pushed them to the “master” branch.

Toggle quote (7 lines)
> As for r-mlr3ordinal, the linter reported
>
> ./gnu/packages/cran.scm:25616:15: r-mlr3ordinal@0.1.0-9000-0.9febac9: the source file name should contain the package name
>
> I don’t know what “source file name” is referenced here, so I’m
> submitting the definition as it is.

This is due to the use of git-reference; you need to provide “file-name”
to give a name to the source checkout. I did this when I applied your
patches.

Thanks for these patches!

--
Ricardo
Closed
?