[PATCH] Adds python-serial

  • Done
  • quality assurance status badge
Details
5 participants
  • Maxim Cournoyer
  • Bruno Victal
  • Mathieu Othacehe
  • phodina
  • rdes
Owner
unassigned
Submitted by
rdes
Severity
normal
R
(name . rdes via Guix-patches via)(address . guix-patches@gnu.org)
D9k4_yhftAnUjvFdpnx6gnsOEJ_4BkfPLA9Uj85O0Pk6RkJdNemV0xks0kFdtV0f-NhGHD3hlF9sJu1r56gtZP7H1M78phA1MU-fLZM7_vE=@protonmail.com
Hello,

The attached patch adds python-serial.

Sent with [ProtonMail](https://protonmail.com) Secure Email.
Attachment: file
From 94c4d73deec179e05d2e8ad26a9ebfacabaf5e47 Mon Sep 17 00:00:00 2001
From: Ryan Desfosses <rdes@protonmail.com>
Date: Sat, 26 Dec 2020 12:48:25 -0500
Subject: [PATCH] gnu: python-serial: New variable.

* gnu/packages/python-xyz.scm (python-serial): New variable.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index acde5a5e5e..0c42a46102 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -93,6 +93,7 @@
;;; Copyright © 2020 Diego N. Barbato <dnbarbato@posteo.de>
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Kristian Trandem <kristian@devup.no>
+;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23201,3 +23202,27 @@ backport of the @code{dataclasses} module for Python 3.6.")
(description "@code{python-pywatchman} is a library to connect and
query Watchman to discover file changes.")
(license license:bsd-3)))
+
+(define-public python-serial
+ (package
+ (name "python-serial")
+ (version "0.0.97")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "serial" version))
+ (sha256
+ (base32
+ "0j7qjif5d9mxbdwcyyhr7fpcvjq7x16ar9n3mk95xgyx4yhm08al"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-future" ,python-future)
+ ("python-iso8601" ,python-iso8601)
+ ("python-pyyaml" ,python-pyyaml)))
+ (home-page
+ "https://bitbucket.com/davebelais/serial.git")
+ (synopsis
+ "A framework for serializing/deserializing JSON/YAML/XML into python class instances and vice versa")
+ (description
+ "A framework for serializing/deserializing JSON/YAML/XML into python class instances and vice versa")
+ (license license:expat)))
--
2.29.2
M
M
Mathieu Othacehe wrote on 6 Jan 2021 11:00
(name . rdes)(address . rdes@protonmail.com)(address . 45449@debbugs.gnu.org)
87czyipeqc.fsf@gnu.org
Hello Ryan,

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-serial): New variable.

Thanks for this patch. Running 'guix lint' reports several issues. The
indentation also has to be fixed.

You can read:
for further information on how to write the synopsis and description
fields.

Thanks,

Mathieu
P
P
phodina wrote on 3 Nov 2021 09:45
[PATCH v2] gnu: Add python-serial.
(name . 45449@debbugs.gnu.org)(address . 45449@debbugs.gnu.org)
2F4T0FL1OpArIdmKuueSPeyDx6uCe7ox2mc6F0wFR8xTcF4D5uqRruF572ouFHMOQdBJc7jTK0sYVnLWdWTRIpMmU7BMFeQGI6wwf9U9Qjc=@protonmail.com
Hi Mathieu,

here's the reworked patch.

Petr

Toggle snippet (50 lines)
* gnu/packages/python-xyz.scm (python-serial): New variable.

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 32d6b403d4..35c2bffd47 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -94,6 +94,7 @@
;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Ellis Keny? <me@elken.dev>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
@@ -1645,6 +1646,31 @@ (define-public python-semantic-version
(define-public python2-semantic-version
(package-with-python2 python-semantic-version))

+(define-public python-serial
+ (package
+ (name "python-serial")
+ (version "0.0.97")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "serial" version))
+ (sha256
+ (base32
+ "0j7qjif5d9mxbdwcyyhr7fpcvjq7x16ar9n3mk95xgyx4yhm08al"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-future" ,python-future)
+ ("python-iso8601" ,python-iso8601)
+ ("python-pyyaml" ,python-pyyaml)))
+ (home-page
+ "https://bitbucket.com/davebelais/serial.git")
+ (synopsis
+ "Framework for serializing/deserializing JSON/YAML/XML")
+ (description
+ "This package provides a framework for serializing/deserializing
+JSON/YAML/XML into python class instances and vice versa")
+ (license license:expat)))
+
(define-public python-serpent
(package
(name "python-serpent")
--
2.33.1
M
M
Maxim Cournoyer wrote on 16 Jan 2023 19:08
Re: bug#45449: [PATCH] Adds python-serial
(name . phodina)(address . phodina@protonmail.com)(name . 45449-done@debbugs.gnu.org)(address . 45449@debbugs.gnu.org)
87zgai4ajy.fsf_-_@gmail.com
Hi,

phodina <phodina@protonmail.com> writes:

Toggle quote (6 lines)
> Hi Mathieu,
>
> here's the reworked patch.
>
> Petr

The package upstream appears to have vanished, and the last pypi release
is from 2019. Closing this as done.

--
Thanks,
Maxim
B
B
Bruno Victal wrote on 31 Mar 2023 01:00
control-msg
(name . control)(address . control@debbugs.gnu.org)
74912071-f536-c8bc-4711-db295b4da0e6@makinata.eu
# done with 5c131aff691fa1cb0fafe71b5f2795902ae056a7
close 55819

# control fail?
close 45449

# no longer relevant
close 33078

# tags
tags 62551 patch
tags 62503 patch
tags 62461 patch
tags 62443 patch
tags 62428 patch
tags 61226 patch
tags 59893 patch
tags 59852 patch
tags 49451 patch
tags 49207 patch
tags 44258 patch


quit
?