[PATCH] gnu: miredo: Fix to use iproute2 from the store.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Doe
  • Efraim Flashner
Owner
unassigned
Submitted by
John Doe
Severity
normal
J
J
John Doe wrote on 17 Dec 2020 15:24
(address . guix-patches@gnu.org)(name . John Doe)(address . dftxbs3e@free.fr)
20201217142418.4497-1-dftxbs3e@free.fr
* gnu/packages/networking.scm (miredo):
[inputs]: Add iproute.
[arguments]: New phase 'patch-iproute2 that patches sources to use
iproute2 from the store.
---
gnu/packages/networking.scm | 19 ++++++++++++++-----
1 file changed, 14 insertions(+), 5 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1226b8606f..281c4a0179 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -688,13 +688,22 @@ or, more generally, MAC addresses of the same category of hardware.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-iproute2
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((iproute (assoc-ref inputs "iproute"))
+ (ip (string-append iproute "/sbin/ip")))
+ (substitute* "misc/client-hook.iproute"
+ (("/sbin/ip") ip))
+ #t)))
;; The checkconf test in src/ requires network access.
(add-before
- 'check 'disable-checkconf-test
- (lambda _
- (substitute* "src/Makefile"
- (("^TESTS = .*") "TESTS = \n"))
- #t)))))
+ 'check 'disable-checkconf-test
+ (lambda _
+ (substitute* "src/Makefile"
+ (("^TESTS = .*") "TESTS = \n"))
+ #t)))))
+ (inputs
+ `(("iproute" ,iproute)))
(home-page "https://www.remlab.net/miredo/")
(synopsis "Teredo IPv6 tunneling software")
(description
--
2.29.2
E
E
Efraim Flashner wrote on 26 Dec 2020 21:31
(name . John Doe)(address . dftxbs3e@free.fr)(address . 45296-done@debbugs.gnu.org)
X+edut22w7jBDQcH@3900XT
I fixed the patch to not also change the indentation on the other lines
and pushed it. Thanks!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl/nnboACgkQQarn3Mo9
g1EWZg//XR6Uv2v2UsyLw2vZeHmcJmwrgUheK2HLhpd58Gwevu5lcH7ECo9sQx7g
NEcrHgKX5+Dy6nulO4kxQA/k1MaMt9CsxczxjoJztU/xWq4A0loFXdfq6PfQiumH
TQfS9zokZHXqTQTng4SOimdnNSz/Vd2NyUrB4O3DpU0UlKqpdaqbjF2Rn+Nmxf3e
rI3V0jxXgVNsc3wHJYe/DlMEjZn2IBwSQnt1rndj9V2LSeE2VFohFFx+HFTcPLmM
tXKY1PEcbpgGTIIM4ib95On2P4sJot4kBb8rD4g5QsxxpXmdlCpsv6Gd1dd/cP78
TQytCpbbsGlm3GcUA1XjLrzIoUxBGRXjIno7CLMcsAUz/MqeJUMzjAFBfl9o4yLx
6hr42PblhLJOm/O0aDGu1rS1+ocXa+iGGure2uIPIdHI1uVucgu5DH3KS0hZN5YF
BwnVDhLiBXV0JpZQGpZvCi0PJbnxahEErB0DXY00bUtXeTFwkcanJDBG4/lqHJ68
LLnvllwYelnWSV231m4eaFbmJ1iTQhzd9otnYN+mx/kU162pbQ4DnldCDXcYo6uf
bjFngmMcXBp+gw5zxWjNHYr45HUTeFSc6Ea8KFrIqUGO/0MsG/RcI7Q1iSRIdhMe
T8v1fRPtTRYsHTV9KjNpD+91ONZZTQ/LKoUoTomyVikOlg0vktU=
=dq+R
-----END PGP SIGNATURE-----


Closed
?