[PATCH] gnu: Add sbcl-deeds.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Adam Kandur
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 25 Nov 2020 15:51
(name . Guix Patches)(address . guix-patches@gnu.org)
MMzstad--3-2@tuta.io
From dff5b35239667ed7d96c33846e88a4ffdb61c058 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Wed, 25 Nov 2020 17:50:34 +0300
Subject: [PATCH] gnu: Add sbcl-deeds.

* gnu/packages/lisp-xyz.scm (sbcl-deeds): New variable.
---
 gnu/packages/lisp-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fe2af3e..d650d4d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6031,6 +6031,33 @@ cookie headers, cookie creation, cookie jar creation and more.")
 neat APIs and connection-pooling.  It is meant to supersede Drakma.")
       (license license:expat))))
 
+(define-public sbcl-deeds
+  ;; taged branch is outdated
+  (let ((revision "1")
+        (commit "f5df54eac79b58a34030e0eb8acf3952c788410d"))
+    (package
+      (name "sbcl-deeds")
+      (version (git-version "1.1.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Shinmera/deeds")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "062cnb2dwli6pw3zvv46jfxyxdzcbzwsck5pa6nw03qf1j1hyg3k"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("closer-mop" ,sbcl-closer-mop)
+     ("bordeaux-threads" ,sbcl-bordeaux-threads)
+     ("sbcl-lambda-fiddle" ,sbcl-lambda-fiddle)
+     ("form-fiddle" ,sbcl-form-fiddle)))
+      (home-page "https://github.com/Shinmera/deeds")
+      (synopsis "Deeds is an Extensible Event Delivery System.")
+      (description "@code{deeds} allows for efficient event delivery to multiple handlers with a complex event filtering system.")
+      (license license:zlib))))
+
 (define-public cl-dexador
   (package
     (inherit (sbcl-package->cl-source-package sbcl-dexador))
--
2.28.0
G
G
Guillaume Le Vaillant wrote on 29 Nov 2020 15:43
(name . Adam Kandur)(address . rndd@tuta.io)(address . 44867-done@debbugs.gnu.org)
87lfekb4v4.fsf@yamatai
Pushed as 848114144681bc603a795725a53458808e213856 with some
modifications. Thanks.
Closed
?