gnu: Add xtitle.

  • Done
  • quality assurance status badge
Details
2 participants
  • elaexuotee
  • Nicolas Goaziou
Owner
unassigned
Submitted by
elaexuotee
Severity
normal
E
E
elaexuotee wrote on 22 Nov 2020 08:08
(address . guix-patches@gnu.org)
FTAFF969A0.2D1CNUE377A0P@wilsonb.com
This is a nice little CLI tool that outputs X window titles. It's the only tool
I've found that can asyncronously output window titles and they change or
update.
From c64251797b805aa119f687bcb3064def4df00908 Mon Sep 17 00:00:00 2001
From: "B. Wilson" <elaexuotee@wilsonb.com>
Date: Sun, 22 Nov 2020 16:02:13 +0900
Subject: [PATCH] gnu: Add xtitle.
To: guix-patches@gnu.org

gnu/packages/xdisorg.scm(xtitle): New variable.
---
gnu/packages/xdisorg.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 430b5ac770..a59b6e3358 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2020 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -110,6 +111,38 @@
;; packages outside the x.org system proper
+(define-public xtitle
+ (package
+ (name "xtitle")
+ (version "0.4.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/baskerville/xtitle")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0f5070k2bwarghl1vq886pl52xck1x5p7x3qhlfchsc2y3dcqms9"))))
+ (build-system gnu-build-system)
+ (inputs `(("libxcb" ,libxcb)
+ ("xcb-util-wm" ,xcb-util-wm)
+ ("xcb-util" ,xcb-util)))
+ (arguments
+ `(#:tests? #f ;no test suite
+ #:make-flags
+ (list
+ (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases (modify-phases %standard-phases (delete 'configure))))
+ (home-page "https://github.com/baskerville/xtitle")
+ (synopsis "Output X window titles")
+ (description "If arguments are given, @code{xtitle} outputs the title of
+ each specified window, otherwise it outputs the title of the active window.
+ With @emph{snoop} mode on, it continuously monitors the specified windows and
+ outputs when titles change.")
+ (license license:unlicense)))
+
(define-public arandr
(package
(name "arandr")
--
2.29.2
N
N
Nicolas Goaziou wrote on 24 Nov 2020 13:49
(name . elaexuotee--- via Guix-patches via)(address . guix-patches@gnu.org)
877dqarkcg.fsf@nicolasgoaziou.fr
Hello,

elaexuotee--- via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> gnu/packages/xdisorg.scm(xtitle): New variable.

I slightly tweaked indentation of the package definition, and pushed.
Thank you.

Regards,
--
Nicolas Goaziou
?