[PATCH] gnu: Add python-xlsxwriter.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Nicolas Goaziou
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 22 Nov 2020 03:40
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20201122024007.49460-1-monego@posteo.net
* gnu/packages/python-xyz.scm (python-xlsxwriter): New variable.
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 32235c22a1..0d53797a36 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5851,6 +5851,28 @@ a front-end for C compilers or analysis tools.")
(define-public python2-pycparser
(package-with-python2 python-pycparser))
+(define-public python-xlsxwriter
+ (package
+ (name "python-xlsxwriter")
+ (version "1.3.7")
+ (source
+ (origin
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jmcnamara/XlsxWriter")
+ (commit (string-append "RELEASE_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qg40r2mwrqfmhaxnary1cfgi0dwwazp5qga7c9p2cdji2v0x5rm"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/jmcnamara/XlsxWriter")
+ (synopsis "Python module for creating Excel XLSX files")
+ (description
+ "XlsxWriter is a Python module that can be used to write text, numbers,
+formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file.")
+ (license license:bsd-2)))
+
(define-public python-pywavelets
(package
(name "python-pywavelets")
--
2.20.1
N
N
Nicolas Goaziou wrote on 24 Nov 2020 13:55
(name . Vinicius Monego)(address . monego@posteo.net)(address . 44786@debbugs.gnu.org)
87360yrk1p.fsf@nicolasgoaziou.fr
Hello,

Vinicius Monego <monego@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-xlsxwriter): New variable.

Thank you.

Toggle quote (3 lines)
> + ;; There are no tests in the PyPI tarball.
> + (method git-fetch)

Is this the sole reason to not use PyPI here? If that's the case,
I wonder if it's worth reconsidering, because using PyPI makes updates
easier.

WDYT?

Regards,
--
Nicolas Goaziou
V
V
Vinicius Monego wrote on 24 Nov 2020 22:25
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 44786@debbugs.gnu.org)
87360y78h0.fsf@pureos
Hello,

Nicolas Goaziou writes:

Toggle quote (17 lines)
> Hello,
>
> Vinicius Monego <monego@posteo.net> writes:
>
>> * gnu/packages/python-xyz.scm (python-xlsxwriter): New variable.
>
> Thank you.
>
>> + ;; There are no tests in the PyPI tarball.
>> + (method git-fetch)
>
> Is this the sole reason to not use PyPI here? If that's the case,
> I wonder if it's worth reconsidering, because using PyPI makes updates
> easier.
>
> WDYT?

That is the sole reason. I prefer to enable tests because Python lacks
setup-time checking. Without tests, the build would succeed even if core
dependencies are unmet.

How does PyPI make updates easier, though? Refreshing works on GitHub.
E
E
Efraim Flashner wrote on 25 Nov 2020 08:37
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
20201125073752.GA24491@E5400
On Tue, Nov 24, 2020 at 01:55:30PM +0100, Nicolas Goaziou wrote:
Toggle quote (18 lines)
> Hello,
>
> Vinicius Monego <monego@posteo.net> writes:
>
> > * gnu/packages/python-xyz.scm (python-xlsxwriter): New variable.
>
> Thank you.
>
> > + ;; There are no tests in the PyPI tarball.
> > + (method git-fetch)
>
> Is this the sole reason to not use PyPI here? If that's the case,
> I wonder if it's worth reconsidering, because using PyPI makes updates
> easier.
>
> WDYT?
>

It is standard for us to use a git checkout when the pypi release
doesn't have the tests packaged. It's not uncommon for python packages
to build correctly but fail to run, and the test suite almost always
catches those.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl++CdAACgkQQarn3Mo9
g1FJCg/6A9XRBw3cDO5NK6omT5UUxZyru6+gv7irknJGJCz3sraAjE7tSei2+SFa
eRHodptHGPYEwZbLSm3Zeoh3jfxussI7cB3jb9z5cJ2tp09qcC4ha34yzZY2a+OU
lLtJc/yoiHi0TIH72u4z8gvWAy1jlQ+bEiOTseWz4YmmCzmxaPCOaQ2NLKk0kA+o
Pzq1JAbod8qlAatONOwp47gSTrPsCJ3xUYw0zd/y9LU9p5g6xg/YEuEGx1I4m/3P
SOxzPgOL7XmEteKIuOWG4v24/UA3zWckDEXnVZuLQBYAk+6GWAsl6L9lU0yBABVT
e6bxT5b1kHgR12xUxkDdXZS7dQs6+zdlpmNToHwpeQaXDSAnQ2Yd6ExMDu9YP0C2
d3D/aKTsEedH8Lh/AzHM6qcfTE/aXsl+e94d5Edx+jirQsZJrv+GrkSKB/kS/oer
lDnrR7uNya/z76X/dMho+F2tD1RgK1ltcsKRPh9ppisMs6CliU+AgePFKiS/wltC
kTqYqD6qlgTpPJz8fHsfIc+rh4t9pizAYvWXcNN59o1LePaVAGsKE3qBT50+wQeW
aQXi27zwAzGCSZMDx0l21cKsG24eoB6mVsqyUVJ6crGxjpFuowI7VxZBJobCTGT1
So5vXlMuldhc9f0EpheLkKK2A+Uah02jQ9iyUDiMsgZGyzLH4cw=
=u6oU
-----END PGP SIGNATURE-----


N
N
Nicolas Goaziou wrote on 26 Nov 2020 14:48
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87zh348c0h.fsf@nicolasgoaziou.fr
Hello,

Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (3 lines)
> It is standard for us to use a git checkout when the pypi release
> doesn't have the tests packaged.

I had not heard about this standard before. Considering many Python
packages are imported through PyPI, I genuinely wonder how common this
custom is, tho.

Fair enough. I applied the patch. Thank you!

Regards,
--
Nicolas Goaziou
Closed
?