[PATCH] services: Add 'xorg-server-service-type'.

  • Done
  • quality assurance status badge
Details
One participant
  • iyzsong
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 13 Nov 2020 15:00
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
OS0P286MB01784888BADFDE7B75CBAA3EA3E60@OS0P286MB0178.JPNP286.PROD.OUTLOOK.COM
From: ??? <iyzsong@member.fsf.org>

* gnu/services/xorg.scm (xorg-server-service-type): New service type.
(xorg-server-profile-service): New procedure.
---
gnu/services/xorg.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/services/xorg.scm b/gnu/services/xorg.scm
index 4590709187..33c3102514 100644
--- a/gnu/services/xorg.scm
+++ b/gnu/services/xorg.scm
@@ -45,6 +45,7 @@
#:use-module (gnu packages admin)
#:use-module (gnu packages bash)
#:use-module (gnu system shadow)
+ #:use-module (guix build-system trivial)
#:use-module (guix gexp)
#:use-module (guix store)
#:use-module (guix packages)
@@ -70,6 +71,7 @@
xorg-wrapper
xorg-start-command
xinitrc
+ xorg-server-service-type
%default-slim-theme
%default-slim-theme-name
@@ -483,6 +485,40 @@ a `service-extension', as used by `set-xorg-configuration'."
(xorg-configuration xorg-configuration))
config)))))))
+(define (xorg-server-profile-service config)
+ ;; XXX: profile-service-type only accepts <package> objects.
+ (list
+ (package
+ (name "xorg-wrapper")
+ (version (package-version xorg-server))
+ (source (xorg-wrapper config))
+ (build-system trivial-build-system)
+ (arguments
+ '(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((source (assoc-ref %build-inputs "source"))
+ (out (assoc-ref %outputs "out"))
+ (bin (string-append out "/bin")))
+ (mkdir-p bin)
+ (symlink source (string-append bin "/X"))
+ #t))))
+ (home-page (package-home-page xorg-server))
+ (synopsis (package-synopsis xorg-server))
+ (description (package-description xorg-server))
+ (license (package-license xorg-server)))))
+
+(define xorg-server-service-type
+ (service-type
+ (name 'xorg-server)
+ (extensions
+ (list (service-extension profile-service-type
+ xorg-server-profile-service)))
+ (default-value (xorg-configuration))
+ (description "Add @command{X} to the system profile, to be used with
+@command{startx}.")))
+
;;;
;;; SLiM log-in manager.
--
2.29.1
?
(address . 44621@debbugs.gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
OS0P286MB0178F639639827BED2350A8DA3E50@OS0P286MB0178.JPNP286.PROD.OUTLOOK.COM
Update patch to symlink 'Xorg' for 'sx':
From 3f15fe4f9e2fbbc48998453708102bb2c9dc8b48 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@member.fsf.org>
Date: Fri, 13 Nov 2020 21:57:04 +0800
Subject: [PATCH] services: Add 'xorg-server-service-type'.

* gnu/services/xorg.scm (xorg-server-service-type): New service type.
(xorg-server-profile-service): New procedure.
---
gnu/services/xorg.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/services/xorg.scm b/gnu/services/xorg.scm
index 4590709187..60611dc77d 100644
--- a/gnu/services/xorg.scm
+++ b/gnu/services/xorg.scm
@@ -45,6 +45,7 @@
#:use-module (gnu packages admin)
#:use-module (gnu packages bash)
#:use-module (gnu system shadow)
+ #:use-module (guix build-system trivial)
#:use-module (guix gexp)
#:use-module (guix store)
#:use-module (guix packages)
@@ -70,6 +71,7 @@
xorg-wrapper
xorg-start-command
xinitrc
+ xorg-server-service-type
%default-slim-theme
%default-slim-theme-name
@@ -483,6 +485,41 @@ a `service-extension', as used by `set-xorg-configuration'."
(xorg-configuration xorg-configuration))
config)))))))
+(define (xorg-server-profile-service config)
+ ;; XXX: profile-service-type only accepts <package> objects.
+ (list
+ (package
+ (name "xorg-wrapper")
+ (version (package-version xorg-server))
+ (source (xorg-wrapper config))
+ (build-system trivial-build-system)
+ (arguments
+ '(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((source (assoc-ref %build-inputs "source"))
+ (out (assoc-ref %outputs "out"))
+ (bin (string-append out "/bin")))
+ (mkdir-p bin)
+ (symlink source (string-append bin "/X"))
+ (symlink source (string-append bin "/Xorg"))
+ #t))))
+ (home-page (package-home-page xorg-server))
+ (synopsis (package-synopsis xorg-server))
+ (description (package-description xorg-server))
+ (license (package-license xorg-server)))))
+
+(define xorg-server-service-type
+ (service-type
+ (name 'xorg-server)
+ (extensions
+ (list (service-extension profile-service-type
+ xorg-server-profile-service)))
+ (default-value (xorg-configuration))
+ (description "Add @command{X} to the system profile, to be used with
+@command{sx} or @command{xinit}.")))
+
;;;
;;; SLiM log-in manager.
--
2.29.1
With this service, we can run 'sx' from the console as a normal user.


If you want to use 'xinit', put this into ~/.xserverrc:
Toggle snippet (4 lines)
tty=$(tty)
tty=${tty#/dev/tty}
X vt${tty}
?
(address . 44621-done@debbugs.gnu.org)
OSZP286MB0664F39B8F3940B09D4E9C77A38C9@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
Pushed, close now.
Closed
?