[PATCH] gnu: Add r-deconstructsigs.

  • Done
  • quality assurance status badge
Details
4 participants
  • Aniket Patil
  • Leo Famulari
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
Aniket Patil
Severity
normal
A
A
Aniket Patil wrote on 29 Oct 2020 18:09
(address . guix-patches@gnu.org)(name . Aniket Patil)(address . aniket112.patil@gmail.com)
20201029170949.178605-1-aniket112.patil@gmail.com
* gnu/packages/cran.scm (r-deconstructsigs): New variable.
---
gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 82caaf54f6..75d9ae7de2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24715,3 +24715,33 @@ modal regression and conditional density estimation in the
presence/absence of measurement error. Bandwidth selection is
also provided for each method.")
(license license:gpl2+)))
+
+(define-public r-deconstructsigs
+ (package
+ (name "r-deconstructsigs")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "deconstructSigs" version))
+ (sha256
+ (base32
+ "014x0nb23jb98666kaav2phkvmkr38pi38jv0dqd4jv7zp0gdf1a"))))
+ (properties
+ `((upstream-name . "deconstructSigs")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bsgenome" ,r-bsgenome)
+ ("r-bsgenome-hsapiens-ucsc-hg19"
+ ,r-bsgenome-hsapiens-ucsc-hg19)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-reshape2" ,r-reshape2)))
+ (home-page
+ "https://github.com/raerose01/deconstructSigs")
+ (synopsis "Identifies Signatures Present in a Tumor Sample")
+ (description
+ "Takes sample information in the form of the fraction of
+mutations in each of 96 trinucleotide contexts and identifies
+the weighted combination of published signatures that, when summed,
+most closely reconstructs the mutational profile.")
+ (license license:gpl2+)))
--
2.28.0
Z
Z
zimoun wrote on 22 Dec 2020 19:15
(address . 44311@debbugs.gnu.org)
868s9pu2pe.fsf@gmail.com
Hi Aniket,

(CC Ricardo since it could provide the correct gitlogy magic :-))

The patch does not apply because the file gnu/packages/cran.scm changed
in the meantime. I am sorry that we have not been enough reactive.

However, when creating the patch, you had used the option ’--base’;
which really helps because I would be able to apply it and rebase
myself.

Currently, I do not know how to do without copy/pasting by hand, so
loosing your authorship. Could you rebase on the top of master?

If you cannot, no worry. Just let me know.


Ricardo, any tip to bypass this kind of issue?

On Thu, 29 Oct 2020 at 22:39, Aniket Patil <aniket112.patil@gmail.com> wrote:
Toggle quote (44 lines)
> * gnu/packages/cran.scm (r-deconstructsigs): New variable.
> ---
> gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
> 1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
> index 82caaf54f6..75d9ae7de2 100644
> --- a/gnu/packages/cran.scm
> +++ b/gnu/packages/cran.scm
> @@ -24715,3 +24715,33 @@ modal regression and conditional density estimation in the
> presence/absence of measurement error. Bandwidth selection is
> also provided for each method.")
> (license license:gpl2+)))
> +
> +(define-public r-deconstructsigs
> + (package
> + (name "r-deconstructsigs")
> + (version "1.8.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (cran-uri "deconstructSigs" version))
> + (sha256
> + (base32
> + "014x0nb23jb98666kaav2phkvmkr38pi38jv0dqd4jv7zp0gdf1a"))))
> + (properties
> + `((upstream-name . "deconstructSigs")))
> + (build-system r-build-system)
> + (propagated-inputs
> + `(("r-bsgenome" ,r-bsgenome)
> + ("r-bsgenome-hsapiens-ucsc-hg19"
> + ,r-bsgenome-hsapiens-ucsc-hg19)
> + ("r-genomeinfodb" ,r-genomeinfodb)
> + ("r-reshape2" ,r-reshape2)))
> + (home-page
> + "https://github.com/raerose01/deconstructSigs")
> + (synopsis "Identifies Signatures Present in a Tumor Sample")
> + (description
> + "Takes sample information in the form of the fraction of
> +mutations in each of 96 trinucleotide contexts and identifies
> +the weighted combination of published signatures that, when summed,
> +most closely reconstructs the mutational profile.")
> + (license license:gpl2+)))

Cheers,
simon
L
L
Leo Famulari wrote on 22 Dec 2020 20:07
(name . zimoun)(address . zimon.toutoune@gmail.com)
X+JD75HbIcDAUzCx@jasmine.lan
On Tue, Dec 22, 2020 at 07:15:41PM +0100, zimoun wrote:
Toggle quote (3 lines)
> Currently, I do not know how to do without copy/pasting by hand, so
> loosing your authorship. Could you rebase on the top of master?

`git commit` allows you to choose the author. In cases like this one, I
sometimes use that feature:

$ git commit --signoff --author="Aniket Patil <aniket112.patil@gmail.com>"

If you wanted to make it really seamless, you can also reset the date:

$ git commit --signoff --author="Aniket Patil <aniket112.patil@gmail.com>" --date="Thu, 29 Oct 2020 22:39:49 +0530"
R
R
Ricardo Wurmus wrote on 22 Dec 2020 23:38
(name . Aniket Patil)(address . aniket112.patil@gmail.com)
87wnx9mpp5.fsf@elephly.net
Hi Aniket,

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-deconstructsigs): New variable.

I’m sorry, but we need to drop this patch because
gnu/packages/bioconductor.scm already contains this definition.

“Already” really isn’t quite the right word, because you submitted your
patch before I added the definition to the bioconductor module when
Simon and I upgraded our CRAN and Bioconductor packages.

This package is in the bioconductor module because it depends on the
Bioconductor package r-bsgenome-hsapiens-ucsc-hg19.

--
Ricardo
Closed
Z
Z
zimoun wrote on 23 Dec 2020 09:51
(address . 44311-done@debbugs.gnu.org)
86k0t8sy54.fsf@gmail.com
Hi Aniket,

On Tue, 22 Dec 2020 at 23:38, Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (9 lines)
>> * gnu/packages/cran.scm (r-deconstructsigs): New variable.
>
> I’m sorry, but we need to drop this patch because
> gnu/packages/bioconductor.scm already contains this definition.
>
> “Already” really isn’t quite the right word, because you submitted your
> patch before I added the definition to the bioconductor module when
> Simon and I upgraded our CRAN and Bioconductor packages.

Sorry Aniket to not have noticed and used your patch instead.

All the best,
simon
Closed
Z
Z
zimoun wrote on 23 Dec 2020 09:49
(name . Leo Famulari)(address . leo@famulari.name)
86mty4sy8n.fsf@gmail.com
Hi Leo,

On Tue, 22 Dec 2020 at 14:07, Leo Famulari <leo@famulari.name> wrote:
Toggle quote (13 lines)
> On Tue, Dec 22, 2020 at 07:15:41PM +0100, zimoun wrote:
>> Currently, I do not know how to do without copy/pasting by hand, so
>> loosing your authorship. Could you rebase on the top of master?
>
> `git commit` allows you to choose the author. In cases like this one, I
> sometimes use that feature:
>
> $ git commit --signoff --author="Aniket Patil <aniket112.patil@gmail.com>"
>
> If you wanted to make it really seamless, you can also reset the date:
>
> $ git commit --signoff --author="Aniket Patil <aniket112.patil@gmail.com>" --date="Thu, 29 Oct 2020 22:39:49 +0530"

Thank you. Once you wrote it, it appears obvious. :-)
I have definitely lacked of imagination.

Cheers,
simon
?