[PATCH 0/2] gnu: poetry: Update to 1.1.3.

DoneSubmitted by Tanguy Le Carrour.
Details
3 participants
  • Nicolas Goaziou
  • Marius Bakke
  • Tanguy Le Carrour
Owner
unassigned
Severity
normal
T
T
Tanguy Le Carrour wrote on 19 Oct 2020 15:26
(address . guix-patches@gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201019132649.13548-1-tanguy@bioneland.org
Tanguy Le Carrour (2): gnu: Add python-poetry-core. gnu: poetry: Update to 1.1.3.
gnu/packages/python-xyz.scm | 45 +++++++++++++++++++++++++------------ 1 file changed, 31 insertions(+), 14 deletions(-)
-- 2.28.0
T
T
Tanguy Le Carrour wrote on 19 Oct 2020 15:29
[PATCH 1/2] gnu: Add python-poetry-core.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201019132912.13941-1-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-poetry-core): New variable.--- gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++ 1 file changed, 20 insertions(+)
Toggle diff (33 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex 575ce40ac8..75733f31ad 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -12873,6 +12873,26 @@ powerful API: thread-safety; decorator syntax; support for memcached, redis, database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.") (license license:expat))) +(define-public python-poetry-core+ (package+ (name "python-poetry-core")+ (version "1.0.0")+ (source+ (origin+ (method url-fetch)+ (uri (pypi-uri "poetry-core" version))+ (sha256+ (base32+ "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))+ (build-system python-build-system)+ (home-page "https://github.com/python-poetry/poetry-core")+ (synopsis "Poetry PEP 517 Build Backend")+ (description+ "A PEP 517 build backend implementation developed for Poetry. This project+is intended to be a light weight, fully compliant, self-contained package allowing+PEP 517 compatible build frontends to build Poetry managed projects.")+ (license license:expat)))+ (define-public poetry (package (name "poetry")-- 2.28.0
T
T
Tanguy Le Carrour wrote on 19 Oct 2020 15:29
[PATCH 2/2] gnu: poetry: Update to 1.1.3.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201019132912.13941-2-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (poetry): Update to 1.1.3.[arguments]: Loosen constraints on python-keyring, python-tomlkit, python-packaging andpython-virtualenv.[propagated-inputs] Remove python-jsonschema, python-pyparsing and python-pyrsistent.Add python-packaging and python-poetry-core. Use python-requests-toolbelt-0.9.1.--- gnu/packages/python-xyz.scm | 25 +++++++++++-------------- 1 file changed, 11 insertions(+), 14 deletions(-)
Toggle diff (64 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex 75733f31ad..a41b4dd0d2 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -12896,7 +12896,7 @@ PEP 517 compatible build frontends to build Poetry managed projects.") (define-public poetry (package (name "poetry")- (version "1.0.10")+ (version "1.1.3") ;; Poetry can only be built from source with Poetry. (source (origin@@ -12904,7 +12904,7 @@ PEP 517 compatible build frontends to build Poetry managed projects.") (uri (pypi-uri "poetry" version)) (sha256 (base32- "1wm66xlsls4f0q4skmq96yb7aahjsqwgwvbrw4iax6rd4xfqj6sb"))))+ "0lvj5klbjkdxzbp9ins4mads3qzb47ycxfyh2hr35c245jgfisj9")))) (build-system python-build-system) (arguments `(#:tests? #f ;; Pypi does not have tests.@@ -12913,14 +12913,12 @@ PEP 517 compatible build frontends to build Poetry managed projects.") (add-before 'build 'patch-setup-py (lambda _ (substitute* "setup.py"- ;; poetry won't update version as 21.0.0 relies on python > 3.6- (("keyring>=20.0.1,<21.0.0") "keyring>=21.0.0,<22.0.0")- (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0")- ;; Reported upstream:- ;; <https://github.com/python-poetry/poetry/issues/2752>.- (("tomlkit>=0.5.11,<0.6.0") "tomlkit>=0.5.11,<0.7.0")- (("cleo>=0.7.6,<0.8.0") "cleo>=0.7.6,<0.9.0")- (("clikit>=0.4.2,<0.5.0") "clikit>=0.4.2,<0.7.0"))+ ;; Updating the following packages would force too many packages+ ;; to be rebuilt.+ (("keyring>=21.2.0,<22.0.0") "keyring>=21.0.0,<22.0.0")+ (("tomlkit>=0.7.0,<1.0.0") "tomlkit>=0.6.0,<1.0.0")+ (("packaging>=20.4,<21.0") "packaging>=20.0,<21.0")+ (("virtualenv>=20.0.26,<21.0.0") "virtualenv>=20.0.10,<21.0.0")) #t))))) (propagated-inputs `(("python-cachecontrol" ,python-cachecontrol)@@ -12928,15 +12926,14 @@ PEP 517 compatible build frontends to build Poetry managed projects.") ("python-cleo" ,python-cleo) ("python-clikit" ,python-clikit) ("python-html5lib" ,python-html5lib)- ("python-jsonschema" ,python-jsonschema) ("python-keyring" ,python-keyring) ("python-msgpack-transitional" ,python-msgpack-transitional)+ ("python-packaging" ,python-packaging) ("python-pexpect" ,python-pexpect) ("python-pkginfo" ,python-pkginfo)- ("python-pyparsing" ,python-pyparsing)- ("python-pyrsistent" ,python-pyrsistent)+ ("python-poetry-core" ,python-poetry-core) ("python-requests" ,python-requests)- ("python-requests-toolbelt" ,python-requests-toolbelt)+ ("python-requests-toolbelt" ,python-requests-toolbelt-0.9.1) ("python-shellingham" ,python-shellingham) ("python-tomlkit" ,python-tomlkit) ("python-virtualenv" ,python-virtualenv)))-- 2.28.0
N
N
Nicolas Goaziou wrote on 20 Oct 2020 13:51
Re: [bug#44077] [PATCH 1/2] gnu: Add python-poetry-core.
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)(address . 44077@debbugs.gnu.org)
87zh4h6roz.fsf@nicolasgoaziou.fr
Hello,
Tanguy Le Carrour <tanguy@bioneland.org> writes:
Toggle quote (2 lines)> * gnu/packages/python-xyz.scm (python-poetry-core): New variable.
Thank you.
Toggle quote (12 lines)> +(define-public python-poetry-core> + (package> + (name "python-poetry-core")> + (version "1.0.0")> + (source> + (origin> + (method url-fetch)> + (uri (pypi-uri "poetry-core" version))> + (sha256> + (base32> + "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))
Nitpick: move the string on the same line as `base32'.
Toggle quote (4 lines)> + (build-system python-build-system)> + (home-page "https://github.com/python-poetry/poetry-core")> + (synopsis "Poetry PEP 517 Build Backend")
Nitpick: I would avoid unnecessary capitalization:

Poetry PEP 517 build back-end
Toggle quote (5 lines)> + (description> + "A PEP 517 build backend implementation developed for Poetry. This project> +is intended to be a light weight, fully compliant, self-contained package allowing> +PEP 517 compatible build frontends to build Poetry managed projects.")
The first sentence should be complete, i.e., with a subject and a verb.
Otherwise, LGTM.
Regards,-- Nicolas Goaziou
N
N
Nicolas Goaziou wrote on 20 Oct 2020 13:55
Re: [bug#44077] [PATCH 2/2] gnu: poetry: Update to 1.1.3.
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)(address . 44077@debbugs.gnu.org)
87v9f56rjf.fsf@nicolasgoaziou.fr
Hello,
Tanguy Le Carrour <tanguy@bioneland.org> writes:
Toggle quote (4 lines)> + ;; Updating the following packages would force too many packages> + ;; to be rebuilt.> + (("keyring>=21.2.0,<22.0.0") "keyring>=21.0.0,<22.0.0")
python-keyring has only 6 dependent packages. Do you think this is still necessary?
AFAICT, there is no Guix package using Poetry so far. OOC, is a Poetrybuild system in order, or is it simpler that than?
LGTM!
Regards,-- Nicolas Goaziou
T
T
Tanguy Le Carrour wrote on 20 Oct 2020 17:30
Re: [bug#44077] [PATCH 1/2] gnu: Add python-poetry-core.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 44077@debbugs.gnu.org)
20201020153036.bwradn2fitkmfgfy@rafflesia
Hi,

Le 10/20, Nicolas Goaziou a écrit :
Toggle quote (15 lines)> Tanguy Le Carrour <tanguy@bioneland.org> writes:> > +(define-public python-poetry-core> > + (package> > + (name "python-poetry-core")> > + (version "1.0.0")> > + (source> > + (origin> > + (method url-fetch)> > + (uri (pypi-uri "poetry-core" version))> > + (sha256> > + (base32> > + "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))> > Nitpick: move the string on the same line as `base32'.
I have no clue what the rule is, but… most (but not all!?) packages in`gnu/packages/python-xyz.scm` have the string on a new line.I'll leave it on a new line if it's OK with you.

Toggle quote (7 lines)> > + (build-system python-build-system)> > + (home-page "https://github.com/python-poetry/poetry-core")> > + (synopsis "Poetry PEP 517 Build Backend")> > Nitpick: I would avoid unnecessary capitalization: > Poetry PEP 517 build back-end
Done!

Toggle quote (7 lines)> > + (description> > + "A PEP 517 build backend implementation developed for Poetry. This project> > +is intended to be a light weight, fully compliant, self-contained package allowing> > +PEP 517 compatible build frontends to build Poetry managed projects.")> > The first sentence should be complete, i.e., with a subject and a verb.
My bad! Updated!

Thanks again for your time!

-- Tanguy
T
T
Tanguy Le Carrour wrote on 20 Oct 2020 17:32
Re: [bug#44077] [PATCH 2/2] gnu: poetry: Update to 1.1.3.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 44077@debbugs.gnu.org)
20201020153229.x3jkpoyr6fubbf35@rafflesia
Hi,

Le 10/20, Nicolas Goaziou a �crit :
Toggle quote (11 lines)> Tanguy Le Carrour <tanguy@bioneland.org> writes:> > > + ;; Updating the following packages would force too many packages> > + ;; to be rebuilt.> > + (("keyring>=21.2.0,<22.0.0") "keyring>=21.0.0,<22.0.0")> > python-keyring has only 6 dependent packages. Do you think this is still necessary?> > AFAICT, there is no Guix package using Poetry so far. OOC, is a Poetry> build system in order, or is it simpler that than?
Actually, "keyring" has a different problem! But I forgot to mention it! Sorry!I'm updating the patch and sending a v2 of the set.
Thanks!
-- Tanguy
T
T
Tanguy Le Carrour wrote on 20 Oct 2020 17:39
[PATCH v2 1/2] gnu: Add python-poetry-core.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201020153921.18602-1-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-poetry-core): New variable.--- gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++ 1 file changed, 21 insertions(+)
Toggle diff (34 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex 575ce40ac8..d9f8073dad 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -12873,6 +12873,27 @@ powerful API: thread-safety; decorator syntax; support for memcached, redis, database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.") (license license:expat))) +(define-public python-poetry-core+ (package+ (name "python-poetry-core")+ (version "1.0.0")+ (source+ (origin+ (method url-fetch)+ (uri (pypi-uri "poetry-core" version))+ (sha256+ (base32+ "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))+ (build-system python-build-system)+ (home-page "https://github.com/python-poetry/poetry-core")+ (synopsis "Poetry PEP 517 build back-end")+ (description+ "The @code{poetry-core} module provides a PEP 517 build back-end implementation+developed for Poetry. This project is intended to be a light weight, fully compliant,+self-contained package allowing PEP 517 compatible build front-ends to build Poetry+managed projects.")+ (license license:expat)))+ (define-public poetry (package (name "poetry")-- 2.28.0
T
T
Tanguy Le Carrour wrote on 20 Oct 2020 17:39
[PATCH v2 2/2] gnu: poetry: Update to 1.1.3.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201020153921.18602-2-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (poetry): Update to 1.1.3.[arguments]: Loosen constraints on python-keyring, python-tomlkit, python-packaging andpython-virtualenv.[propagated-inputs] Remove python-jsonschema, python-pyparsing and python-pyrsistent.Add python-packaging and python-poetry-core. Use python-requests-toolbelt-0.9.1.--- gnu/packages/python-xyz.scm | 27 +++++++++++++-------------- 1 file changed, 13 insertions(+), 14 deletions(-)
Toggle diff (66 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex d9f8073dad..623612fb42 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -12897,7 +12897,7 @@ managed projects.") (define-public poetry (package (name "poetry")- (version "1.0.10")+ (version "1.1.3") ;; Poetry can only be built from source with Poetry. (source (origin@@ -12905,7 +12905,7 @@ managed projects.") (uri (pypi-uri "poetry" version)) (sha256 (base32- "1wm66xlsls4f0q4skmq96yb7aahjsqwgwvbrw4iax6rd4xfqj6sb"))))+ "0lvj5klbjkdxzbp9ins4mads3qzb47ycxfyh2hr35c245jgfisj9")))) (build-system python-build-system) (arguments `(#:tests? #f ;; Pypi does not have tests.@@ -12914,14 +12914,14 @@ managed projects.") (add-before 'build 'patch-setup-py (lambda _ (substitute* "setup.py"- ;; poetry won't update version as 21.0.0 relies on python > 3.6- (("keyring>=20.0.1,<21.0.0") "keyring>=21.0.0,<22.0.0")- (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0")- ;; Reported upstream:- ;; <https://github.com/python-poetry/poetry/issues/2752>.- (("tomlkit>=0.5.11,<0.6.0") "tomlkit>=0.5.11,<0.7.0")- (("cleo>=0.7.6,<0.8.0") "cleo>=0.7.6,<0.9.0")- (("clikit>=0.4.2,<0.5.0") "clikit>=0.4.2,<0.7.0"))+ ;; Newer versions of keyring produce a package with version "0.0.0"+ ;; Reported upstream: <https://github.com/jaraco/keyring/issues/469>+ (("keyring>=21.2.0,<22.0.0") "keyring>=21.0.0,<22.0.0")+ ;; Updating the following packages would force too many packages+ ;; to be rebuilt.+ (("tomlkit>=0.7.0,<1.0.0") "tomlkit>=0.6.0,<1.0.0")+ (("packaging>=20.4,<21.0") "packaging>=20.0,<21.0")+ (("virtualenv>=20.0.26,<21.0.0") "virtualenv>=20.0.10,<21.0.0")) #t))))) (propagated-inputs `(("python-cachecontrol" ,python-cachecontrol)@@ -12929,15 +12929,14 @@ managed projects.") ("python-cleo" ,python-cleo) ("python-clikit" ,python-clikit) ("python-html5lib" ,python-html5lib)- ("python-jsonschema" ,python-jsonschema) ("python-keyring" ,python-keyring) ("python-msgpack-transitional" ,python-msgpack-transitional)+ ("python-packaging" ,python-packaging) ("python-pexpect" ,python-pexpect) ("python-pkginfo" ,python-pkginfo)- ("python-pyparsing" ,python-pyparsing)- ("python-pyrsistent" ,python-pyrsistent)+ ("python-poetry-core" ,python-poetry-core) ("python-requests" ,python-requests)- ("python-requests-toolbelt" ,python-requests-toolbelt)+ ("python-requests-toolbelt" ,python-requests-toolbelt-0.9.1) ("python-shellingham" ,python-shellingham) ("python-tomlkit" ,python-tomlkit) ("python-virtualenv" ,python-virtualenv)))-- 2.28.0
N
N
Nicolas Goaziou wrote on 21 Oct 2020 21:46
Re: [bug#44077] [PATCH 1/2] gnu: Add python-poetry-core.
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)(address . 44077@debbugs.gnu.org)
87h7qn746a.fsf@nicolasgoaziou.fr
Hello,
Tanguy Le Carrour <tanguy@bioneland.org> writes:
Toggle quote (2 lines)> Le 10/20, Nicolas Goaziou a écrit :
[...]
Toggle quote (8 lines)>> > + (base32>> > + "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))>> >> Nitpick: move the string on the same line as `base32'.>> I have no clue what the rule is, but… most (but not all!?) packages in> `gnu/packages/python-xyz.scm` have the string on a new line.
Note that "everyone else does this" may not be a strong reason to dosomething. ;)
I suspect that most packages in this file come from the "pypi" importer,which automatically adds this newline character, for some reason.
Toggle quote (2 lines)> I'll leave it on a new line if it's OK with you.
This spurious newline character hurts my eyes and my logic, butultimately, it will not hurt me. So, if that's important to you, goahead.
Regards,-- Nicolas Goaziou
T
T
Tanguy Le Carrour wrote on 22 Oct 2020 09:20
[PATCH v3 1/2] gnu: Add python-poetry-core.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201022072056.5584-1-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-poetry-core): New variable.--- gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++ 1 file changed, 20 insertions(+)
Toggle diff (33 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex 575ce40ac8..bd8b062d42 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -12873,6 +12873,26 @@ powerful API: thread-safety; decorator syntax; support for memcached, redis, database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.") (license license:expat))) +(define-public python-poetry-core+ (package+ (name "python-poetry-core")+ (version "1.0.0")+ (source+ (origin+ (method url-fetch)+ (uri (pypi-uri "poetry-core" version))+ (sha256+ (base32 "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))+ (build-system python-build-system)+ (home-page "https://github.com/python-poetry/poetry-core")+ (synopsis "Poetry PEP 517 build back-end")+ (description+ "The @code{poetry-core} module provides a PEP 517 build back-end+implementation developed for Poetry. This project is intended to be+a light weight, fully compliant, self-contained package allowing PEP 517+compatible build front-ends to build Poetry managed projects.")+ (license license:expat)))+ (define-public poetry (package (name "poetry")-- 2.28.0
T
T
Tanguy Le Carrour wrote on 22 Oct 2020 09:20
[PATCH v3 2/2] gnu: poetry: Update to 1.1.3.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201022072056.5584-2-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (poetry): Update to 1.1.3.[arguments]: Loosen constraints on python-keyring, python-tomlkit, python-packaging andpython-virtualenv.[propagated-inputs] Remove python-jsonschema, python-pyparsing and python-pyrsistent.Add python-packaging and python-poetry-core. Use python-requests-toolbelt-0.9.1.--- gnu/packages/python-xyz.scm | 27 +++++++++++++-------------- 1 file changed, 13 insertions(+), 14 deletions(-)
Toggle diff (66 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex bd8b062d42..9446b37f6e 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -12896,7 +12896,7 @@ compatible build front-ends to build Poetry managed projects.") (define-public poetry (package (name "poetry")- (version "1.0.10")+ (version "1.1.3") ;; Poetry can only be built from source with Poetry. (source (origin@@ -12904,7 +12904,7 @@ compatible build front-ends to build Poetry managed projects.") (uri (pypi-uri "poetry" version)) (sha256 (base32- "1wm66xlsls4f0q4skmq96yb7aahjsqwgwvbrw4iax6rd4xfqj6sb"))))+ "0lvj5klbjkdxzbp9ins4mads3qzb47ycxfyh2hr35c245jgfisj9")))) (build-system python-build-system) (arguments `(#:tests? #f ;; Pypi does not have tests.@@ -12913,14 +12913,14 @@ compatible build front-ends to build Poetry managed projects.") (add-before 'build 'patch-setup-py (lambda _ (substitute* "setup.py"- ;; poetry won't update version as 21.0.0 relies on python > 3.6- (("keyring>=20.0.1,<21.0.0") "keyring>=21.0.0,<22.0.0")- (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0")- ;; Reported upstream:- ;; <https://github.com/python-poetry/poetry/issues/2752>.- (("tomlkit>=0.5.11,<0.6.0") "tomlkit>=0.5.11,<0.7.0")- (("cleo>=0.7.6,<0.8.0") "cleo>=0.7.6,<0.9.0")- (("clikit>=0.4.2,<0.5.0") "clikit>=0.4.2,<0.7.0"))+ ;; Newer versions of keyring produce a package with version "0.0.0"+ ;; Reported upstream: <https://github.com/jaraco/keyring/issues/469>+ (("keyring>=21.2.0,<22.0.0") "keyring>=21.0.0,<22.0.0")+ ;; Updating the following packages would force too many packages+ ;; to be rebuilt.+ (("tomlkit>=0.7.0,<1.0.0") "tomlkit>=0.6.0,<1.0.0")+ (("packaging>=20.4,<21.0") "packaging>=20.0,<21.0")+ (("virtualenv>=20.0.26,<21.0.0") "virtualenv>=20.0.10,<21.0.0")) #t))))) (propagated-inputs `(("python-cachecontrol" ,python-cachecontrol)@@ -12928,15 +12928,14 @@ compatible build front-ends to build Poetry managed projects.") ("python-cleo" ,python-cleo) ("python-clikit" ,python-clikit) ("python-html5lib" ,python-html5lib)- ("python-jsonschema" ,python-jsonschema) ("python-keyring" ,python-keyring) ("python-msgpack-transitional" ,python-msgpack-transitional)+ ("python-packaging" ,python-packaging) ("python-pexpect" ,python-pexpect) ("python-pkginfo" ,python-pkginfo)- ("python-pyparsing" ,python-pyparsing)- ("python-pyrsistent" ,python-pyrsistent)+ ("python-poetry-core" ,python-poetry-core) ("python-requests" ,python-requests)- ("python-requests-toolbelt" ,python-requests-toolbelt)+ ("python-requests-toolbelt" ,python-requests-toolbelt-0.9.1) ("python-shellingham" ,python-shellingham) ("python-tomlkit" ,python-tomlkit) ("python-virtualenv" ,python-virtualenv)))-- 2.28.0
T
T
Tanguy Le Carrour wrote on 22 Oct 2020 09:22
Re: [bug#44077] [PATCH 1/2] gnu: Add python-poetry-core.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 44077@debbugs.gnu.org)
20201022072207.nk5elqr53zoxqjbi@rafflesia
Hi Nicolas,

Le 10/21, Nicolas Goaziou a écrit :
Toggle quote (13 lines)> Tanguy Le Carrour <tanguy@bioneland.org> writes:> > Le 10/20, Nicolas Goaziou a écrit :> >> > + (base32> >> > + "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))> >> > >> Nitpick: move the string on the same line as `base32'.> >> > I have no clue what the rule is, but… most (but not all!?) packages in> > `gnu/packages/python-xyz.scm` have the string on a new line.> > Note that "everyone else does this" may not be a strong reason to do> something. ;)
+1 :-)The thing is, I'm not yet sure to understand the coding style, and`etc/indent-code.el` leaves you some (too much?) freedom.I've been happily using Black [1] to format my Python code for some time now,and I *might* have become a bit lazy!
[1]: https://github.com/psf/black

Toggle quote (5 lines)> I suspect that most packages in this file come from the "pypi" importer,> which automatically adds this newline character, for some reason.> > > I'll leave it on a new line if it's OK with you.
You've got me there! I imported it!Actually, I'd rather put everything on a single line if it fits (and`indent-code.el` does not complain when I put `sha256` and `base32` on thesame line). I just didn't want to be pointed at as "the guys who doesnot split the line". ^_^'

Toggle quote (4 lines)> This spurious newline character hurts my eyes and my logic, but> ultimately, it will not hurt me. So, if that's important to you, go> ahead.
Updated and pushed!
Thanks again for your time and your advice!
-- Tanguy
T
T
Tanguy Le Carrour wrote on 23 Oct 2020 08:54
[WIP][PATCH 0/2] gnu: poetry: Update to 1.1.3.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 44077@debbugs.gnu.org)
20201023065426.rsoz75yyhngtecoq@melmoth
Hi Nicolas,
I've just figured out that the updated version of Poetry crashes in some cases!
Actually, there are 2 ways of using Poetry :1- you manage your own virtual env (I do it with `direnv`)�;2- you let Poetry manage it.
Obviously, the one I use works, but the second one doesn't! I guess itrequires a newer version of `python-virtualenv`. So I guess this bugshould be marked as work in progress.
I'll let you know once I've solved the problem!
Best regards
-- Tanguy
T
T
Tanguy Le Carrour wrote on 30 Oct 2020 19:17
[PATCH v2 0/7] gnu: poetry: Update to 1.1.4.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 44077@debbugs.gnu.org)
20201030181714.ayacmnasqmpf3ucc@melmoth
Hi Nicolas,
I'm submitting an updated patch set.
Poetry seems to work in a `guix environement --pure --ad-hoc poetry`environment, but… I cannot install it into my profile because a lot ofpackages get rebuilt and, unfortunatly, some of them are failing! Forinstance `python-jedi` tests fail because my computer is too slow! :-(
Again, thanks for your time!
-- Tanguy
T
T
Tanguy Le Carrour wrote on 30 Oct 2020 19:17
[PATCH v2 1/7] gnu: python-packaging: Update to 20.4.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201030181823.5184-1-tanguy@bioneland.org
From: Tanguy Le Carrour <>
* gnu/packages/python-xyz.scm (python-packaging): Update to 20.4.[source]: Remove patch that has been merged upstream.--- gnu/packages/python-xyz.scm | 7 ++----- 1 file changed, 2 insertions(+), 5 deletions(-)
Toggle diff (26 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex cd8ee24cbf..aa69a64d5f 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -15726,17 +15726,14 @@ several utilities, as well as an API for building localization tools.") (define-public python-packaging (package (name "python-packaging")- (version "20.0")+ (version "20.4") (source (origin (method url-fetch) (uri (pypi-uri "packaging" version))- ;; XXX: The URL in the patch file is wrong, it should be- ;; <https://github.com/pypa/packaging/pull/256>.- (patches (search-patches "python-packaging-test-arch.patch")) (sha256 (base32- "1y2ip3a4ykkpgnwgn85j6hkspcl0cg3mzms97f40mk57vwqq67gy"))))+ "1y3rc1ams1i25calk6b9jf1gl85ix5a23a146swjvhdr8x7zfms3")))) (build-system python-build-system) (arguments `(#:phases (modify-phases %standard-phases-- 2.29.1
T
T
Tanguy Le Carrour wrote on 30 Oct 2020 19:17
[PATCH v2 2/7] gnu: python-virtualenv: Update to 20.1.0.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201030181823.5184-2-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-virtualenv): Update to 20.1.0.--- gnu/packages/python-xyz.scm | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (23 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex aa69a64d5f..4c9191cfa5 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -3132,14 +3132,14 @@ e.g. filters, callbacks and errbacks can all be promises.") (define-public python-virtualenv (package (name "python-virtualenv")- (version "20.0.10")+ (version "20.1.0") (source (origin (method url-fetch) (uri (pypi-uri "virtualenv" version)) (sha256 (base32- "0y6x41l3ja891993i4adylbbyly0r4m52n2d0a0y9y4h3lzyh4l5"))))+ "1043y8xdvwzwhkkqrv4ycr3sjh4kqr39iqk51nj5dwis947i3mmq")))) (build-system python-build-system) (native-inputs `(("python-mock" ,python-mock)-- 2.29.1
T
T
Tanguy Le Carrour wrote on 30 Oct 2020 19:17
[PATCH v2 3/7] gnu: python-distlib: Update to 0.3.1.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201030181823.5184-3-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-distlib): Update to 0.3.1.--- gnu/packages/python-xyz.scm | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (23 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex 4c9191cfa5..bb0fa6aedc 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -5508,14 +5508,14 @@ by pycodestyle.") (define-public python-distlib (package (name "python-distlib")- (version "0.3.0")+ (version "0.3.1") (source (origin (method url-fetch) (uri (pypi-uri "distlib" version ".zip")) (sha256 (base32- "08fyi2r246733vharl2yckw20rilci28r91mzrnnvcr638inw5if"))))+ "1wdzv7fsjhrkhh1wfkarlhcwa8m00mgcpdsvknmf2qy8f9l13xpd")))) (build-system python-build-system) (arguments `(#:phases-- 2.29.1
T
T
Tanguy Le Carrour wrote on 30 Oct 2020 19:17
[PATCH v2 4/7] gnu: python-pip: Update to 20.2.4.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201030181823.5184-4-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-pip): Update to 20.2.4.--- gnu/packages/python-xyz.scm | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (23 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex bb0fa6aedc..ac7674e567 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -9420,14 +9420,14 @@ responses, rather than doing any computation.") (define-public python-pip (package (name "python-pip")- (version "20.0.2")+ (version "20.2.4") (source (origin (method url-fetch) (uri (pypi-uri "pip" version)) (sha256 (base32- "0zwnlsjn6mb742cr995zfbk9v56ygxp8w3k49601r9by9kmcic3x"))))+ "18b4qcijwivvkj1g0hs4w8zjbks0bjzdjcrqybnhmyx0gs2rmjc5")))) (build-system python-build-system) (arguments '(#:tests? #f)) ; there are no tests in the pypi archive.-- 2.29.1
T
T
Tanguy Le Carrour wrote on 30 Oct 2020 19:17
[PATCH v2 5/7] gnu: python-tomlkit: Update to 0.7.0.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201030181823.5184-5-tanguy@bioneland.org
From: Tanguy Le Carrour <>
* gnu/packages/python-xyz.scm (python-tomlkit): Update to 0.7.0.[native-inputs]: Add python-pyyaml. [description]: Update description.--- gnu/packages/python-xyz.scm | 9 +++++---- 1 file changed, 5 insertions(+), 4 deletions(-)
Toggle diff (32 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex ac7674e567..234858e59e 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -12780,20 +12780,21 @@ docstring and colored output.") (define-public python-tomlkit (package (name "python-tomlkit")- (version "0.6.0")+ (version "0.7.0") (source (origin (method url-fetch) (uri (pypi-uri "tomlkit" version)) (sha256- (base32 "16jf0060csn8p500jnxa7m5h1sl3pzispvd11961dzrhh287dybl"))))+ (base32 "062n694sfv24ylda6nh8228y2q9hrvy554kqx84y7czsjfbg4mxc")))) (build-system python-build-system) (native-inputs- `(("python-pytest" ,python-pytest)))+ `(("python-pytest" ,python-pytest)+ ("python-pyyaml" ,python-pyyaml))) (home-page "https://github.com/sdispater/tomlkit") (synopsis "Style-preserving TOML library") (description- "TOML Kit is a 0.5.0-compliant TOML library. It includes a parser that+ "TOML Kit is a 1.0.0rc1-compliant TOML library. It includes a parser that preserves all comments, indentations, whitespace and internal element ordering, and makes them accessible and editable via an intuitive API. It can also create new TOML documents from scratch using the provided helpers. Part of the-- 2.29.1
T
T
Tanguy Le Carrour wrote on 30 Oct 2020 19:17
[PATCH v2 6/7] gnu: Add python-poetry-core.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201030181823.5184-6-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-poetry-core): New variable.--- gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++ 1 file changed, 20 insertions(+)
Toggle diff (33 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex 234858e59e..ad9d271ebb 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -12944,6 +12944,26 @@ powerful API: thread-safety; decorator syntax; support for memcached, redis, database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.") (license license:expat))) +(define-public python-poetry-core+ (package+ (name "python-poetry-core")+ (version "1.0.0")+ (source+ (origin+ (method url-fetch)+ (uri (pypi-uri "poetry-core" version))+ (sha256+ (base32 "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))+ (build-system python-build-system)+ (home-page "https://github.com/python-poetry/poetry-core")+ (synopsis "Poetry PEP 517 build back-end")+ (description+ "The @code{poetry-core} module provides a PEP 517 build back-end+implementation developed for Poetry. This project is intended to be+a light weight, fully compliant, self-contained package allowing PEP 517+compatible build front-ends to build Poetry managed projects.")+ (license license:expat)))+ (define-public poetry (package (name "poetry")-- 2.29.1
T
T
Tanguy Le Carrour wrote on 30 Oct 2020 19:17
[PATCH v2 7/7] gnu: poetry: Update to 1.1.4.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201030181823.5184-7-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (poetry): Update to 1.1.4.[arguments]: Loosen constraint on python-keyring only.[propagated-inputs] Remove python-jsonschema, python-pyparsing and python-pyrsistent.Add python-pip, python-packaging and python-poetry-core.Use python-requests-toolbelt-0.9.1.--- gnu/packages/python-xyz.scm | 23 +++++++++-------------- 1 file changed, 9 insertions(+), 14 deletions(-)
Toggle diff (62 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex ad9d271ebb..0a0a1e83d0 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -12967,7 +12967,7 @@ compatible build front-ends to build Poetry managed projects.") (define-public poetry (package (name "poetry")- (version "1.0.10")+ (version "1.1.4") ;; Poetry can only be built from source with Poetry. (source (origin@@ -12975,7 +12975,7 @@ compatible build front-ends to build Poetry managed projects.") (uri (pypi-uri "poetry" version)) (sha256 (base32- "1wm66xlsls4f0q4skmq96yb7aahjsqwgwvbrw4iax6rd4xfqj6sb"))))+ "1a2kgfiw66fvxhlqk5qc83s6l38czfh5hcsrbiy7qq5yfc8mlsll")))) (build-system python-build-system) (arguments `(#:tests? #f ;; Pypi does not have tests.@@ -12984,14 +12984,9 @@ compatible build front-ends to build Poetry managed projects.") (add-before 'build 'patch-setup-py (lambda _ (substitute* "setup.py"- ;; poetry won't update version as 21.0.0 relies on python > 3.6- (("keyring>=20.0.1,<21.0.0") "keyring>=21.0.0,<22.0.0")- (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0")- ;; Reported upstream:- ;; <https://github.com/python-poetry/poetry/issues/2752>.- (("tomlkit>=0.5.11,<0.6.0") "tomlkit>=0.5.11,<0.7.0")- (("cleo>=0.7.6,<0.8.0") "cleo>=0.7.6,<0.9.0")- (("clikit>=0.4.2,<0.5.0") "clikit>=0.4.2,<0.7.0"))+ ;; Newer versions of keyring produce a package with version "0.0.0"+ ;; Reported upstream: <https://github.com/jaraco/keyring/issues/469>+ (("keyring>=21.2.0,<22.0.0") "keyring>=21.0.0,<22.0.0")) #t))))) (propagated-inputs `(("python-cachecontrol" ,python-cachecontrol)@@ -12999,15 +12994,15 @@ compatible build front-ends to build Poetry managed projects.") ("python-cleo" ,python-cleo) ("python-clikit" ,python-clikit) ("python-html5lib" ,python-html5lib)- ("python-jsonschema" ,python-jsonschema) ("python-keyring" ,python-keyring) ("python-msgpack-transitional" ,python-msgpack-transitional)+ ("python-packaging" ,python-packaging) ("python-pexpect" ,python-pexpect)+ ("python-pip" ,python-pip) ("python-pkginfo" ,python-pkginfo)- ("python-pyparsing" ,python-pyparsing)- ("python-pyrsistent" ,python-pyrsistent)+ ("python-poetry-core" ,python-poetry-core) ("python-requests" ,python-requests)- ("python-requests-toolbelt" ,python-requests-toolbelt)+ ("python-requests-toolbelt" ,python-requests-toolbelt-0.9.1) ("python-shellingham" ,python-shellingham) ("python-tomlkit" ,python-tomlkit) ("python-virtualenv" ,python-virtualenv)))-- 2.29.1
T
T
Tanguy Le Carrour wrote on 26 Nov 2020 14:36
gnu: poetry: Update to 1.1.4.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 44077@debbugs.gnu.org)
20201126133621.bnjr7g5p3rjndr2n@melmoth
Hi Nicolas,
Sorry to ask you this, but not knowing exactly how the code review works,I just wanted to know if my patch hadn't fallen into oblivion.
If you don't have more time to spend on reviewing v2 — which I could understand! —,should I make a goodwill call on guix-devel?
Best regards,
-- Tanguy
N
N
Nicolas Goaziou wrote on 27 Nov 2020 21:14
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)(address . 44077@debbugs.gnu.org)
87mtz2tv49.fsf@nicolasgoaziou.fr
Hello,
Tanguy Le Carrour <tanguy@bioneland.org> writes:
Toggle quote (3 lines)> Sorry to ask you this, but not knowing exactly how the code review works,> I just wanted to know if my patch hadn't fallen into oblivion.
Well, it had, indeed… =/
I looked at it again, and it LGTM. However python-distlib has a lot ofdependents, so it needs to be applied on core-updates branch.
If there is no objection, I'll do that soon.
Regards,-- Nicolas Goaziou
T
T
Tanguy LE CARROUR wrote on 28 Nov 2020 15:11
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 44077@debbugs.gnu.org)
1606572132.b3t9ih4lho.astroid@melmoth.none
Hi Nicolas,

Excerpts from Nicolas Goaziou's message of November 27, 2020 9:14 pm:
Toggle quote (7 lines)> Tanguy Le Carrour <tanguy@bioneland.org> writes:> >> Sorry to ask you this, but not knowing exactly how the code review works,>> I just wanted to know if my patch hadn't fallen into oblivion.> > Well, it had, indeed… =/
No problem! ;-)I should consider myself lucky to have someone reviewing my patch on hisspare time! … all the more so I might be the only person using Poetry! ^_^'

Toggle quote (3 lines)> I looked at it again, and it LGTM. However python-distlib has a lot of> dependents, so it needs to be applied on core-updates branch.
Would have it been better for me to submit separate patches, as they arenot really specific to Poetry, and wait for them to be merged beforesubmitting a patch set with only `poetry-core` and `poetry`?

Toggle quote (2 lines)> If there is no objection, I'll do that soon.
The process is not yet clear to me. Out of sheer curiosity… can someone objectto a merge in master? Who would that be?
Thanks again for your help and your time!
-- Tanguy
N
N
Nicolas Goaziou wrote on 28 Nov 2020 16:41
(name . Tanguy LE CARROUR)(address . tanguy@bioneland.org)(address . 44077@debbugs.gnu.org)
874kl9trol.fsf@nicolasgoaziou.fr
Hello,
Tanguy LE CARROUR <tanguy@bioneland.org> writes:
Toggle quote (4 lines)> Would have it been better for me to submit separate patches, as they are> not really specific to Poetry, and wait for them to be merged before> submitting a patch set with only `poetry-core` and `poetry`?
The sole "problematic" patch is the one updating python-distlib, in thesense that it cannot be applied in the same branch as the others (unlesseverything goes into core-updates, of course).
If you can split the set into independent parts, i.e., if you don'treally need to update python-distlib prior to updating Poetry, we canprocess it differently.
Toggle quote (3 lines)> The process is not yet clear to me. Out of sheer curiosity… can someone object> to a merge in master? Who would that be?
Per (info "(guix) Submitting Patches"), packages with more than 1800dependent packages, as is the case with python-distlib, are updated inthe "core-updates" branch. If I apply it on master branch, it will bereverted presto by another commiter.
Does that make sense?
Regards,-- Nicolas Goaziou
T
T
Tanguy LE CARROUR wrote on 29 Nov 2020 18:56
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 44077@debbugs.gnu.org)
1606671968.b6x1phkual.astroid@melmoth.none
Hi!

Excerpts from Nicolas Goaziou's message of November 28, 2020 4:41 pm:
Toggle quote (14 lines)> Tanguy LE CARROUR <tanguy@bioneland.org> writes:> >> Would have it been better for me to submit separate patches, as they are>> not really specific to Poetry, and wait for them to be merged before>> submitting a patch set with only `poetry-core` and `poetry`?> > The sole "problematic" patch is the one updating python-distlib, in the> sense that it cannot be applied in the same branch as the others (unless> everything goes into core-updates, of course).> > If you can split the set into independent parts, i.e., if you don't> really need to update python-distlib prior to updating Poetry, we can> process it differently.
I'm working on it! But it's apparently rebuilding the World, which is reallyslow on my computer at home! :-(

Toggle quote (10 lines)>> The process is not yet clear to me. Out of sheer curiosity… can someone object>> to a merge in master? Who would that be?> > Per (info "(guix) Submitting Patches"), packages with more than 1800> dependent packages, as is the case with python-distlib, are updated in> the "core-updates" branch. If I apply it on master branch, it will be> reverted presto by another commiter.> > Does that make sense?
It's the last part that I still cannot figure out how it happens:"it will be reverted presto by another commiter".
It's not the "why", it the "how"! Are each commit on the master branchmonitored for quality/conformity?!Thanks to Chris's email, I've justed discovered Patchwork. Is it werethe "magic" happens?!
Regards,
-- Tanguy
T
T
Tanguy LE CARROUR wrote on 29 Nov 2020 20:34
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 44077@debbugs.gnu.org)
1606678280.id8is1pm08.astroid@melmoth.none
Hi,

Excerpts from Tanguy LE CARROUR's message of November 29, 2020 6:56 pm:
Toggle quote (18 lines)> Excerpts from Nicolas Goaziou's message of November 28, 2020 4:41 pm:>> Tanguy LE CARROUR <tanguy@bioneland.org> writes:>> >>> Would have it been better for me to submit separate patches, as they are>>> not really specific to Poetry, and wait for them to be merged before>>> submitting a patch set with only `poetry-core` and `poetry`?>> >> The sole "problematic" patch is the one updating python-distlib, in the>> sense that it cannot be applied in the same branch as the others (unless>> everything goes into core-updates, of course).>> >> If you can split the set into independent parts, i.e., if you don't>> really need to update python-distlib prior to updating Poetry, we can>> process it differently.> > I'm working on it! But it's apparently rebuilding the World, which is really> slow on my computer at home! :-(
I've tried to modify `python-virtualenv` to make it use our currentversion of `python-distlib`. Poetry builds, but it does not workproperly!
```$ poetry installCreating virtualenv test-4avGy1Vc-py3.8 in /home/tanguy/.cache/pypoetry/virtualenvs
ImportError
cannot import name 'enquote_executable' from 'distlib.scripts' (/gnu/store/2j3qn0ksry1qarwih9knh1ngr6zm2rci-python-distlib-0.3.0/lib/python3.8/site-packages/distlib/scripts.py)```
So I guess the version of distlib does matter and we cannot do without.

Regards
-- Tanguy
M
M
Marius Bakke wrote on 29 Nov 2020 21:06
Re: [bug#44077] gnu: poetry: Update to 1.1.4.
(address . 44077@debbugs.gnu.org)
877dq40vxk.fsf@gnu.org
Tanguy LE CARROUR <tanguy@bioneland.org> skriver:
Toggle quote (16 lines)> I've tried to modify `python-virtualenv` to make it use our current> version of `python-distlib`. Poetry builds, but it does not work> properly!>> ```> $ poetry install> Creating virtualenv test-4avGy1Vc-py3.8 in /home/tanguy/.cache/pypoetry/virtualenvs>> ImportError>> cannot import name 'enquote_executable' from 'distlib.scripts'> (/gnu/store/2j3qn0ksry1qarwih9knh1ngr6zm2rci-python-distlib-0.3.0/lib/python3.8/site-packages/distlib/scripts.py)> ```>> So I guess the version of distlib does matter and we cannot do without.
To get these patches on 'master' without rebuilding the world, you cancreate a new 'python-distlib' like so:
;; TODO: Merge with 'python-distlib' on the next rebuild cycle. (define-public python-distlib/next (package (inherit python-distlib) (version "1.2.3") (source (origin ...))))
...and in the packages that require the new version, refer to'python-distlib/next' instead of 'python-distlib'.
Does that make sense?
-----BEGIN PGP SIGNATURE-----
iQFDBAEBCgAtFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl/D/1cPHG1hcml1c0BnbnUub3JnAAoJEKKgbfKjOlT6ixYIAKcrdsCuQeEJgMmfmWm+suuaVmCFkD4plmFzkg1ne9mBYtb/1/0R+gQY0l0zbIpGEOWf3mglspG0t8z77nTjRoU+kCnXZA4F06IvMmOWUNU7QHYGFevKnSp17N9JjNiX/m5m/DXIbubA83ct0f9R9Utnnh3Db/6MJJ9GirtSfUH4Lxa/XJ3XgzY/c0NwC2czQkfvt7GUIOrbyEeFufu3KlzqU9DjkUOFHkogh37pFzOLo0DY5YqULwTfT82l+P82KUhBShOqk3JRT3LnuXibzjelVIlpLkUpmBvO5w8snI0bYvXrfwYDhNWUyDrztixnkZCEYCx6eaQAUBzjlwOhHes==vCne-----END PGP SIGNATURE-----
T
T
Tanguy LE CARROUR wrote on 30 Nov 2020 09:27
(address . 44077@debbugs.gnu.org)
1606724643.e3gcn2y8r4.astroid@rafflesia.none
Hi Marius!

Excerpts from Marius Bakke's message of November 29, 2020 9:06 pm:
Toggle quote (33 lines)> Tanguy LE CARROUR <tanguy@bioneland.org> skriver:> >> I've tried to modify `python-virtualenv` to make it use our current>> version of `python-distlib`. Poetry builds, but it does not work>> properly!>>>> ```>> $ poetry install>> Creating virtualenv test-4avGy1Vc-py3.8 in /home/tanguy/.cache/pypoetry/virtualenvs>>>> ImportError>>>> cannot import name 'enquote_executable' from 'distlib.scripts'>> (/gnu/store/2j3qn0ksry1qarwih9knh1ngr6zm2rci-python-distlib-0.3.0/lib/python3.8/site-packages/distlib/scripts.py)>> ```>>>> So I guess the version of distlib does matter and we cannot do without.> > To get these patches on 'master' without rebuilding the world, you can> create a new 'python-distlib' like so:> > ;; TODO: Merge with 'python-distlib' on the next rebuild cycle.> (define-public python-distlib/next> (package> (inherit python-distlib)> (version "1.2.3")> (source (origin ...))))> > ...and in the packages that require the new version, refer to> 'python-distlib/next' instead of 'python-distlib'.> > Does that make sense?
Yes, thanks, that's a great solution, indeed!
I'm only concerned about the poor soul who has to remember to get rid ofthe `python-distlib/next` and update `python-virtualenv` packagedefinition. I guess none of this is auto-magic, right?!
Regards
-- Tanguy
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:45
[PATCH v4 1/7] gnu: python-packaging: Update to 20.4.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094515.11190-1-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-packaging): Update to 20.4.[source]: Remove patch that has been merged upstream.--- gnu/packages/python-xyz.scm | 7 ++----- 1 file changed, 2 insertions(+), 5 deletions(-)
Toggle diff (26 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex 9e886150fb..8af593c5a6 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -15819,17 +15819,14 @@ several utilities, as well as an API for building localization tools.") (define-public python-packaging (package (name "python-packaging")- (version "20.0")+ (version "20.4") (source (origin (method url-fetch) (uri (pypi-uri "packaging" version))- ;; XXX: The URL in the patch file is wrong, it should be- ;; <https://github.com/pypa/packaging/pull/256>.- (patches (search-patches "python-packaging-test-arch.patch")) (sha256 (base32- "1y2ip3a4ykkpgnwgn85j6hkspcl0cg3mzms97f40mk57vwqq67gy"))))+ "1y3rc1ams1i25calk6b9jf1gl85ix5a23a146swjvhdr8x7zfms3")))) (build-system python-build-system) (arguments `(#:phases (modify-phases %standard-phases-- 2.29.2
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:45
[PATCH v4 2/7] gnu: Add python-distlib/next.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094515.11190-2-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-distlib/next): New variable.--- gnu/packages/python-xyz.scm | 13 +++++++++++++ 1 file changed, 13 insertions(+)
Toggle diff (26 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex 8af593c5a6..e5087751f3 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -5570,6 +5570,19 @@ relate to packaging and distribution of Python software. It is intended to be used as the basis for third-party packaging tools.") (license license:psfl))) +;; TODO: Merge with 'python-distlib' on the next rebuild cycle.+(define-public python-distlib/next+ (package+ (inherit python-distlib)+ (version "0.3.1")+ (source+ (origin+ (method url-fetch)+ (uri (pypi-uri "distlib" version ".zip"))+ (sha256+ (base32+ "1wdzv7fsjhrkhh1wfkarlhcwa8m00mgcpdsvknmf2qy8f9l13xpd"))))))+ (define-public python-distutils-extra (package (name "python-distutils-extra")-- 2.29.2
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:45
[PATCH v4 3/7] gnu: python-virtualenv: Update to 20.2.1.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094515.11190-3-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-virtualenv): Update to 20.2.1.[propagated-inputs] Use python-distlib/next instead of python-distlib.--- gnu/packages/python-xyz.scm | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)
Toggle diff (32 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex e5087751f3..e3cbca5d95 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -3135,14 +3135,14 @@ e.g. filters, callbacks and errbacks can all be promises.") (define-public python-virtualenv (package (name "python-virtualenv")- (version "20.0.10")+ (version "20.2.1") (source (origin (method url-fetch) (uri (pypi-uri "virtualenv" version)) (sha256 (base32- "0y6x41l3ja891993i4adylbbyly0r4m52n2d0a0y9y4h3lzyh4l5"))))+ "1rd6wmymsgv0cdsn50jwybcvbbslzym3mzffcjbl42l8br9cgap0")))) (build-system python-build-system) (native-inputs `(("python-mock" ,python-mock)@@ -3155,7 +3155,7 @@ e.g. filters, callbacks and errbacks can all be promises.") ("python-setuptools-scm" ,python-setuptools-scm))) (propagated-inputs `(("python-appdirs" ,python-appdirs)- ("python-distlib" ,python-distlib)+ ("python-distlib" ,python-distlib/next) ("python-filelock" ,python-filelock) ("python-six" ,python-six) ("python-importlib-metadata" ,python-importlib-metadata)))-- 2.29.2
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:45
[PATCH v4 5/7] gnu: python-tomlkit: Update to 0.7.0.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094515.11190-5-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-tomlkit): Update to 0.7.0.[native-inputs]: Add python-pyyaml. [description]: Update description.--- gnu/packages/python-xyz.scm | 9 +++++---- 1 file changed, 5 insertions(+), 4 deletions(-)
Toggle diff (32 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex 44428a0f2b..b7c7826a2f 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -12891,20 +12891,21 @@ docstring and colored output.") (define-public python-tomlkit (package (name "python-tomlkit")- (version "0.6.0")+ (version "0.7.0") (source (origin (method url-fetch) (uri (pypi-uri "tomlkit" version)) (sha256- (base32 "16jf0060csn8p500jnxa7m5h1sl3pzispvd11961dzrhh287dybl"))))+ (base32 "062n694sfv24ylda6nh8228y2q9hrvy554kqx84y7czsjfbg4mxc")))) (build-system python-build-system) (native-inputs- `(("python-pytest" ,python-pytest)))+ `(("python-pytest" ,python-pytest)+ ("python-pyyaml" ,python-pyyaml))) (home-page "https://github.com/sdispater/tomlkit") (synopsis "Style-preserving TOML library") (description- "TOML Kit is a 0.5.0-compliant TOML library. It includes a parser that+ "TOML Kit is a 1.0.0rc1-compliant TOML library. It includes a parser that preserves all comments, indentations, whitespace and internal element ordering, and makes them accessible and editable via an intuitive API. It can also create new TOML documents from scratch using the provided helpers. Part of the-- 2.29.2
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:45
[PATCH v4 6/7] gnu: Add python-poetry-core.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094515.11190-6-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-poetry-core): New variable.--- gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++ 1 file changed, 20 insertions(+)
Toggle diff (33 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex b7c7826a2f..768f3bc9df 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -13055,6 +13055,26 @@ powerful API: thread-safety; decorator syntax; support for memcached, redis, database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.") (license license:expat))) +(define-public python-poetry-core+ (package+ (name "python-poetry-core")+ (version "1.0.0")+ (source+ (origin+ (method url-fetch)+ (uri (pypi-uri "poetry-core" version))+ (sha256+ (base32 "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))+ (build-system python-build-system)+ (home-page "https://github.com/python-poetry/poetry-core")+ (synopsis "Poetry PEP 517 build back-end")+ (description+ "The @code{poetry-core} module provides a PEP 517 build back-end+implementation developed for Poetry. This project is intended to be+a light weight, fully compliant, self-contained package allowing PEP 517+compatible build front-ends to build Poetry managed projects.")+ (license license:expat)))+ (define-public poetry (package (name "poetry")-- 2.29.2
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:45
[PATCH v4 7/7] gnu: poetry: Update to 1.1.4.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094515.11190-7-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (poetry): Update to 1.1.4.[arguments]: Loosen constraint on python-keyring only.[propagated-inputs] Remove python-jsonschema, python-pyparsing and python-pyrsistent.Add python-pip, python-packaging and python-poetry-core.Use python-requests-toolbelt-0.9.1.--- gnu/packages/python-xyz.scm | 23 +++++++++-------------- 1 file changed, 9 insertions(+), 14 deletions(-)
Toggle diff (62 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex 768f3bc9df..f05be9dcb9 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -13078,7 +13078,7 @@ compatible build front-ends to build Poetry managed projects.") (define-public poetry (package (name "poetry")- (version "1.0.10")+ (version "1.1.4") ;; Poetry can only be built from source with Poetry. (source (origin@@ -13086,7 +13086,7 @@ compatible build front-ends to build Poetry managed projects.") (uri (pypi-uri "poetry" version)) (sha256 (base32- "1wm66xlsls4f0q4skmq96yb7aahjsqwgwvbrw4iax6rd4xfqj6sb"))))+ "1a2kgfiw66fvxhlqk5qc83s6l38czfh5hcsrbiy7qq5yfc8mlsll")))) (build-system python-build-system) (arguments `(#:tests? #f ;; Pypi does not have tests.@@ -13095,14 +13095,9 @@ compatible build front-ends to build Poetry managed projects.") (add-before 'build 'patch-setup-py (lambda _ (substitute* "setup.py"- ;; poetry won't update version as 21.0.0 relies on python > 3.6- (("keyring>=20.0.1,<21.0.0") "keyring>=21.0.0,<22.0.0")- (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0")- ;; Reported upstream:- ;; <https://github.com/python-poetry/poetry/issues/2752>.- (("tomlkit>=0.5.11,<0.6.0") "tomlkit>=0.5.11,<0.7.0")- (("cleo>=0.7.6,<0.8.0") "cleo>=0.7.6,<0.9.0")- (("clikit>=0.4.2,<0.5.0") "clikit>=0.4.2,<0.7.0"))+ ;; Newer versions of keyring produce a package with version "0.0.0"+ ;; Reported upstream: <https://github.com/jaraco/keyring/issues/469>+ (("keyring>=21.2.0,<22.0.0") "keyring>=21.0.0,<22.0.0")) #t))))) (propagated-inputs `(("python-cachecontrol" ,python-cachecontrol)@@ -13110,15 +13105,15 @@ compatible build front-ends to build Poetry managed projects.") ("python-cleo" ,python-cleo) ("python-clikit" ,python-clikit) ("python-html5lib" ,python-html5lib)- ("python-jsonschema" ,python-jsonschema) ("python-keyring" ,python-keyring) ("python-msgpack-transitional" ,python-msgpack-transitional)+ ("python-packaging" ,python-packaging) ("python-pexpect" ,python-pexpect)+ ("python-pip" ,python-pip) ("python-pkginfo" ,python-pkginfo)- ("python-pyparsing" ,python-pyparsing)- ("python-pyrsistent" ,python-pyrsistent)+ ("python-poetry-core" ,python-poetry-core) ("python-requests" ,python-requests)- ("python-requests-toolbelt" ,python-requests-toolbelt)+ ("python-requests-toolbelt" ,python-requests-toolbelt-0.9.1) ("python-shellingham" ,python-shellingham) ("python-tomlkit" ,python-tomlkit) ("python-virtualenv" ,python-virtualenv)))-- 2.29.2
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:45
[PATCH v4 4/7] gnu: python-pip: Update to 20.2.4.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094515.11190-4-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-pip): Update to 20.2.4.--- gnu/packages/python-xyz.scm | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (23 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex e3cbca5d95..44428a0f2b 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -9408,14 +9408,14 @@ responses, rather than doing any computation.") (define-public python-pip (package (name "python-pip")- (version "20.0.2")+ (version "20.2.4") (source (origin (method url-fetch) (uri (pypi-uri "pip" version)) (sha256 (base32- "0zwnlsjn6mb742cr995zfbk9v56ygxp8w3k49601r9by9kmcic3x"))))+ "18b4qcijwivvkj1g0hs4w8zjbks0bjzdjcrqybnhmyx0gs2rmjc5")))) (build-system python-build-system) (arguments '(#:tests? #f)) ; there are no tests in the pypi archive.-- 2.29.2
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:48
[PATCH v5 1/7] gnu: python-packaging: Update to 20.4.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094903.11700-1-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-packaging): Update to 20.4.[source]: Remove patch that has been merged upstream.--- gnu/packages/python-xyz.scm | 7 ++----- 1 file changed, 2 insertions(+), 5 deletions(-)
Toggle diff (26 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex 94fbc1f8f1..c71bc49063 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -15974,17 +15974,14 @@ several utilities, as well as an API for building localization tools.") (define-public python-packaging (package (name "python-packaging")- (version "20.0")+ (version "20.4") (source (origin (method url-fetch) (uri (pypi-uri "packaging" version))- ;; XXX: The URL in the patch file is wrong, it should be- ;; <https://github.com/pypa/packaging/pull/256>.- (patches (search-patches "python-packaging-test-arch.patch")) (sha256 (base32- "1y2ip3a4ykkpgnwgn85j6hkspcl0cg3mzms97f40mk57vwqq67gy"))))+ "1y3rc1ams1i25calk6b9jf1gl85ix5a23a146swjvhdr8x7zfms3")))) (build-system python-build-system) (arguments `(#:phases (modify-phases %standard-phases-- 2.29.2
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:48
[PATCH v5 2/7] gnu: Add python-distlib/next.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094903.11700-2-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-distlib/next): New variable.--- gnu/packages/python-xyz.scm | 13 +++++++++++++ 1 file changed, 13 insertions(+)
Toggle diff (26 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex c71bc49063..cd6681a7f6 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -5641,6 +5641,19 @@ relate to packaging and distribution of Python software. It is intended to be used as the basis for third-party packaging tools.") (license license:psfl))) +;; TODO: Merge with 'python-distlib' on the next rebuild cycle.+(define-public python-distlib/next+ (package+ (inherit python-distlib)+ (version "0.3.1")+ (source+ (origin+ (method url-fetch)+ (uri (pypi-uri "distlib" version ".zip"))+ (sha256+ (base32+ "1wdzv7fsjhrkhh1wfkarlhcwa8m00mgcpdsvknmf2qy8f9l13xpd"))))))+ (define-public python-distutils-extra (package (name "python-distutils-extra")-- 2.29.2
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:48
[PATCH v5 3/7] gnu: python-virtualenv: Update to 20.2.1.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094903.11700-3-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-virtualenv): Update to 20.2.1.[propagated-inputs] Use python-distlib/next instead of python-distlib.--- gnu/packages/python-xyz.scm | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)
Toggle diff (32 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex cd6681a7f6..df6624a175 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -3184,14 +3184,14 @@ e.g. filters, callbacks and errbacks can all be promises.") (define-public python-virtualenv (package (name "python-virtualenv")- (version "20.0.10")+ (version "20.2.1") (source (origin (method url-fetch) (uri (pypi-uri "virtualenv" version)) (sha256 (base32- "0y6x41l3ja891993i4adylbbyly0r4m52n2d0a0y9y4h3lzyh4l5"))))+ "1rd6wmymsgv0cdsn50jwybcvbbslzym3mzffcjbl42l8br9cgap0")))) (build-system python-build-system) (native-inputs `(("python-mock" ,python-mock)@@ -3204,7 +3204,7 @@ e.g. filters, callbacks and errbacks can all be promises.") ("python-setuptools-scm" ,python-setuptools-scm))) (propagated-inputs `(("python-appdirs" ,python-appdirs)- ("python-distlib" ,python-distlib)+ ("python-distlib" ,python-distlib/next) ("python-filelock" ,python-filelock) ("python-six" ,python-six) ("python-importlib-metadata" ,python-importlib-metadata)))-- 2.29.2
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:49
[PATCH v5 4/7] gnu: python-pip: Update to 20.2.4.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094903.11700-4-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-pip): Update to 20.2.4.--- gnu/packages/python-xyz.scm | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (23 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex df6624a175..d34867dc56 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -9538,14 +9538,14 @@ responses, rather than doing any computation.") (define-public python-pip (package (name "python-pip")- (version "20.0.2")+ (version "20.2.4") (source (origin (method url-fetch) (uri (pypi-uri "pip" version)) (sha256 (base32- "0zwnlsjn6mb742cr995zfbk9v56ygxp8w3k49601r9by9kmcic3x"))))+ "18b4qcijwivvkj1g0hs4w8zjbks0bjzdjcrqybnhmyx0gs2rmjc5")))) (build-system python-build-system) (arguments '(#:tests? #f)) ; there are no tests in the pypi archive.-- 2.29.2
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:49
[PATCH v5 5/7] gnu: python-tomlkit: Update to 0.7.0.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094903.11700-5-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-tomlkit): Update to 0.7.0.[native-inputs]: Add python-pyyaml. [description]: Update description.--- gnu/packages/python-xyz.scm | 9 +++++---- 1 file changed, 5 insertions(+), 4 deletions(-)
Toggle diff (32 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex d34867dc56..affeeb080e 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -13021,20 +13021,21 @@ docstring and colored output.") (define-public python-tomlkit (package (name "python-tomlkit")- (version "0.6.0")+ (version "0.7.0") (source (origin (method url-fetch) (uri (pypi-uri "tomlkit" version)) (sha256- (base32 "16jf0060csn8p500jnxa7m5h1sl3pzispvd11961dzrhh287dybl"))))+ (base32 "062n694sfv24ylda6nh8228y2q9hrvy554kqx84y7czsjfbg4mxc")))) (build-system python-build-system) (native-inputs- `(("python-pytest" ,python-pytest)))+ `(("python-pytest" ,python-pytest)+ ("python-pyyaml" ,python-pyyaml))) (home-page "https://github.com/sdispater/tomlkit") (synopsis "Style-preserving TOML library") (description- "TOML Kit is a 0.5.0-compliant TOML library. It includes a parser that+ "TOML Kit is a 1.0.0rc1-compliant TOML library. It includes a parser that preserves all comments, indentations, whitespace and internal element ordering, and makes them accessible and editable via an intuitive API. It can also create new TOML documents from scratch using the provided helpers. Part of the-- 2.29.2
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:49
[PATCH v5 6/7] gnu: Add python-poetry-core.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094903.11700-6-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-poetry-core): New variable.--- gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++ 1 file changed, 20 insertions(+)
Toggle diff (33 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex affeeb080e..6580d22994 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -13185,6 +13185,26 @@ powerful API: thread-safety; decorator syntax; support for memcached, redis, database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.") (license license:expat))) +(define-public python-poetry-core+ (package+ (name "python-poetry-core")+ (version "1.0.0")+ (source+ (origin+ (method url-fetch)+ (uri (pypi-uri "poetry-core" version))+ (sha256+ (base32 "1mgv276h1iphn5fqhp2sgkgd5d0c39hs33vgaf157x5ri7rlyrka"))))+ (build-system python-build-system)+ (home-page "https://github.com/python-poetry/poetry-core")+ (synopsis "Poetry PEP 517 build back-end")+ (description+ "The @code{poetry-core} module provides a PEP 517 build back-end+implementation developed for Poetry. This project is intended to be+a light weight, fully compliant, self-contained package allowing PEP 517+compatible build front-ends to build Poetry managed projects.")+ (license license:expat)))+ (define-public poetry (package (name "poetry")-- 2.29.2
T
T
Tanguy Le Carrour wrote on 30 Nov 2020 10:49
[PATCH v5 7/7] gnu: poetry: Update to 1.1.4.
(address . 44077@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201130094903.11700-7-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (poetry): Update to 1.1.4.[arguments]: Loosen constraint on python-keyring only.[propagated-inputs] Remove python-jsonschema, python-pyparsing and python-pyrsistent.Add python-pip, python-packaging and python-poetry-core.Use python-requests-toolbelt-0.9.1.--- gnu/packages/python-xyz.scm | 23 +++++++++-------------- 1 file changed, 9 insertions(+), 14 deletions(-)
Toggle diff (62 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex 6580d22994..1086d724f1 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -13208,7 +13208,7 @@ compatible build front-ends to build Poetry managed projects.") (define-public poetry (package (name "poetry")- (version "1.0.10")+ (version "1.1.4") ;; Poetry can only be built from source with Poetry. (source (origin@@ -13216,7 +13216,7 @@ compatible build front-ends to build Poetry managed projects.") (uri (pypi-uri "poetry" version)) (sha256 (base32- "1wm66xlsls4f0q4skmq96yb7aahjsqwgwvbrw4iax6rd4xfqj6sb"))))+ "1a2kgfiw66fvxhlqk5qc83s6l38czfh5hcsrbiy7qq5yfc8mlsll")))) (build-system python-build-system) (arguments `(#:tests? #f ;; Pypi does not have tests.@@ -13225,14 +13225,9 @@ compatible build front-ends to build Poetry managed projects.") (add-before 'build 'patch-setup-py (lambda _ (substitute* "setup.py"- ;; poetry won't update version as 21.0.0 relies on python > 3.6- (("keyring>=20.0.1,<21.0.0") "keyring>=21.0.0,<22.0.0")- (("pyrsistent>=0.14.2,<0.15.0") "pyrsistent>=0.14.2,<0.17.0")- ;; Reported upstream:- ;; <https://github.com/python-poetry/poetry/issues/2752>.- (("tomlkit>=0.5.11,<0.6.0") "tomlkit>=0.5.11,<0.7.0")- (("cleo>=0.7.6,<0.8.0") "cleo>=0.7.6,<0.9.0")- (("clikit>=0.4.2,<0.5.0") "clikit>=0.4.2,<0.7.0"))+ ;; Newer versions of keyring produce a package with version "0.0.0"+ ;; Reported upstream: <https://github.com/jaraco/keyring/issues/469>+ (("keyring>=21.2.0,<22.0.0") "keyring>=21.0.0,<22.0.0")) #t))))) (propagated-inputs `(("python-cachecontrol" ,python-cachecontrol)@@ -13240,15 +13235,15 @@ compatible build front-ends to build Poetry managed projects.") ("python-cleo" ,python-cleo) ("python-clikit" ,python-clikit) ("python-html5lib" ,python-html5lib)- ("python-jsonschema" ,python-jsonschema) ("python-keyring" ,python-keyring) ("python-msgpack-transitional" ,python-msgpack-transitional)+ ("python-packaging" ,python-packaging) ("python-pexpect" ,python-pexpect)+ ("python-pip" ,python-pip) ("python-pkginfo" ,python-pkginfo)- ("python-pyparsing" ,python-pyparsing)- ("python-pyrsistent" ,python-pyrsistent)+ ("python-poetry-core" ,python-poetry-core) ("python-requests" ,python-requests)- ("python-requests-toolbelt" ,python-requests-toolbelt)+ ("python-requests-toolbelt" ,python-requests-toolbelt-0.9.1) ("python-shellingham" ,python-shellingham) ("python-tomlkit" ,python-tomlkit) ("python-virtualenv" ,python-virtualenv)))-- 2.29.2
N
N
Nicolas Goaziou wrote on 30 Nov 2020 22:42
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)(address . 44077-done@debbugs.gnu.org)
877dq2ses2.fsf@nicolasgoaziou.fr
Hello,
Tanguy Le Carrour <tanguy@bioneland.org> writes:
Toggle quote (2 lines)> * gnu/packages/python-xyz.scm (poetry): Update to 1.1.4.
I applied the patches. Thank you.
Regards,-- Nicolas Goaziou
Closed
T
T
Tanguy LE CARROUR wrote on 1 Dec 2020 08:03
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 44077-done@debbugs.gnu.org)
1606806181.u92tdpbge3.astroid@melmoth.none
Excerpts from Nicolas Goaziou's message of November 30, 2020 10:42 pm:
Toggle quote (8 lines)> Hello,> > Tanguy Le Carrour <tanguy@bioneland.org> writes:> >> * gnu/packages/python-xyz.scm (poetry): Update to 1.1.4.> > I applied the patches. Thank you.
Thanks!
-- Tanguy
Closed
M
M
Marius Bakke wrote on 3 Dec 2020 22:39
Re: [bug#44077] gnu: poetry: Update to 1.1.4.
(address . 44077@debbugs.gnu.org)
87r1o6in7f.fsf@gnu.org
Tanguy LE CARROUR <tanguy@bioneland.org> skriver:
Toggle quote (43 lines)> Hi Marius!>>> Excerpts from Marius Bakke's message of November 29, 2020 9:06 pm:>> Tanguy LE CARROUR <tanguy@bioneland.org> skriver:>> >>> I've tried to modify `python-virtualenv` to make it use our current>>> version of `python-distlib`. Poetry builds, but it does not work>>> properly!>>>>>> ```>>> $ poetry install>>> Creating virtualenv test-4avGy1Vc-py3.8 in /home/tanguy/.cache/pypoetry/virtualenvs>>>>>> ImportError>>>>>> cannot import name 'enquote_executable' from 'distlib.scripts'>>> (/gnu/store/2j3qn0ksry1qarwih9knh1ngr6zm2rci-python-distlib-0.3.0/lib/python3.8/site-packages/distlib/scripts.py)>>> ```>>>>>> So I guess the version of distlib does matter and we cannot do without.>> >> To get these patches on 'master' without rebuilding the world, you can>> create a new 'python-distlib' like so:>> >> ;; TODO: Merge with 'python-distlib' on the next rebuild cycle.>> (define-public python-distlib/next>> (package>> (inherit python-distlib)>> (version "1.2.3")>> (source (origin ...))))>> >> ...and in the packages that require the new version, refer to>> 'python-distlib/next' instead of 'python-distlib'.>> >> Does that make sense?>> Yes, thanks, that's a great solution, indeed!>> I'm only concerned about the poor soul who has to remember to get rid of> the `python-distlib/next` and update `python-virtualenv` package> definition. I guess none of this is auto-magic, right?!
It's not automatic indeed. But as long as there is a source codecomment mentioning 'core-updates', 'staging' or 'rebuild cycle', chancesare some poor soul will take care of it appropriately in due time. ;-)
-----BEGIN PGP SIGNATURE-----
iQFDBAEBCgAtFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl/JWwQPHG1hcml1c0BnbnUub3JnAAoJEKKgbfKjOlT6vbYH/19jHqC7xh+gpYYSvrVO+Gppu5+ibxQ9kKUVHFliHo8+8jIaOaKxwzXk5mBOviDb7d0JBTnGtvjXywf11sD4BuVhkgtSbgodsdb+CHJKaqHLZ/2Z1PunrVPb8PN3mlIxIs0HEA+8VusB3n2EPeCYQ8ojgwsNr6Io03ft5D/IRQWa8daGTJD7hLBaSXMFpiwiuO9+FzScfqfTszb20C6OXEQ+9t1N/n/A1P689JlpUQd6uafalhfa0vgoYttuXM4aCf1qmJVmvz+JlE5+82+Usldg4gG74MhuV69AZyOXWTUM18ioCV6ms6oUKTsGGBUKD2UIVL2nwXdZK0ZEvSIWKBk==OBpB-----END PGP SIGNATURE-----
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send email to 44077@debbugs.gnu.org