[PATCH] build-system/haskell: Disable parallel builds.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 18 Oct 2020 00:10
(address . guix-patches@gnu.org)
20201017221006.19515-1-zimon.toutoune@gmail.com

PARALLEL-BUILD? introduced by commit 67cb9fa2357026ee42ec5bb0923ec4dc4a43abe2
leads to unreproducibility. Instead of reverting, default is set to #false
which allows user to locally build with parallelism.

* guix/build-system/haskell.scm (haskell-build): Turn off PARALLEL-BUILD? by
default.
---
guix/build-system/haskell.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (35 lines)
diff --git a/guix/build-system/haskell.scm b/guix/build-system/haskell.scm
index 8304e3b222..87085a50b0 100644
--- a/guix/build-system/haskell.scm
+++ b/guix/build-system/haskell.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2020 Timothy Sample <samplet@ngyro.com>
+;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -115,13 +116,17 @@ version REVISION."
(cons name propagated-names))))))
extra-directories))))))))
+;;; PARALLEL-BUILD? introduced by commit
+;;; 67cb9fa2357026ee42ec5bb0923ec4dc4a43abe2 leads to unreproducibility.
+;;; Instead of reverting, default is set to #false which allows user to
+;;; locally build with parallelism. See <http://issues.guix.gnu.org/43843#3>.
(define* (haskell-build store name inputs
#:key source
(haddock? #t)
(haddock-flags ''())
(tests? #t)
(test-target "test")
- (parallel-build? #t)
+ (parallel-build? #f)
(configure-flags ''())
(extra-directories ''())
(phases '(@ (guix build haskell-build-system)

base-commit: d14221bf65cfbe7f8f5b7cac44132087cab70bf5
--
2.28.0
M
M
Marius Bakke wrote on 19 Oct 2020 00:11
87sgabjib1.fsf@gnu.org
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (9 lines)
>
> PARALLEL-BUILD? introduced by commit 67cb9fa2357026ee42ec5bb0923ec4dc4a43abe2
> leads to unreproducibility. Instead of reverting, default is set to #false
> which allows user to locally build with parallelism.
>
> * guix/build-system/haskell.scm (haskell-build): Turn off PARALLEL-BUILD? by
> default.

Thanks! I shortened the comment a little and pushed to staging in
19d42e0e23a7f90ac2dcc1c279bd23a967ff0314.
-----BEGIN PGP SIGNATURE-----

iQFDBAEBCgAtFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl+MvZIPHG1hcml1c0Bn
bnUub3JnAAoJEKKgbfKjOlT6YesH/0wf7s/gxMXl8ZpGljFeECdLFOFlwGm7g44+
oMzgdM2/NMcgLlZ0FEhng7/3ViyKZ3GmCaLlP7iAEFRCkfA+7e0aic1VZgFqdojk
z4hXpfoKK0CnpI+cXT5mVvzP8iBZDjvgX2liHCPFeNICao3akkOclmdSN1/jPfDn
5UtpOOm2tYKn0McCoyhaKcBBdm/XlWIjyB5CyQSITQddi3VtAA8Lx7ZJa5cjz5C4
TnHCq7MAeTHcbRAH8Wfwi9XTQoL73MptAN8GOvHuTGMLCLFMUXAV/qwUHS3zl5r9
beu27yPjp0CjSmk9I6j5axVYMTlA9V+TejsN//Ej01ZPZwowSqM=
=7cRX
-----END PGP SIGNATURE-----

Closed
?