[PATCH 1/3] gnu: Add go-github-com-go-sql-driver-mysql.

  • Done
  • quality assurance status badge
Details
One participant
  • Ryan Prior
Owner
unassigned
Submitted by
Ryan Prior
Severity
normal
R
R
Ryan Prior wrote on 4 Oct 2020 07:22
(address . guix-patches@gnu.org)
20201004052202.29292-1-rprior@protonmail.com
* gnu/packages/golang.scm (go-github-com-go-sql-driver-mysql): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 001c864505..dfaaba47c3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3341,6 +3341,31 @@ without requiring a real database connection.")
(home-page "https://github.com/DATA-DOG/go-sqlmock")
(license license:expat))))
+(define-public go-github-com-go-sql-driver-mysql
+ (package
+ (name "go-github-com-go-sql-driver-mysql")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-sql-driver/mysql")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11x0m9yf3kdnf6981182r824psgxwfaqhn3x3in4yiidp0w0hk3v"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:tests? #f ;; tests require a network connection
+ #:import-path "github.com/go-sql-driver/mysql"))
+ (home-page "https://github.com/go-sql-driver/mysql")
+ (synopsis "MySQL driver for golang")
+ (description
+ "This is a pure Go implementaton of the MySQL API, compatible with
+golang's database/sql package.")
+ (license license:mpl2.0)))
+
(define-public go-golang-org-colorful
(package
(name "go-golang-org-colorful")
--
2.17.1
R
R
Ryan Prior wrote on 4 Oct 2020 07:34
Close duplicate
(name . 43786-close@debbugs.gnu.org)(address . 43786-close@debbugs.gnu.org)
vA3bKGZvE7n9xA61mREbMrnDWj95EWDWQAt-Dni4B8EDuHVElCWif6hvylRZEexnJk0VACixGq7VjUZ-2GpUw_zxs_Jr3WpUz_n6Ftibw1Q=@protonmail.com
Duplicate of 43785
Attachment: file
?