[PATCH] gnu: Add scantailor-advanced.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brendan Tildesley
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal
B
B
Brendan Tildesley wrote on 19 Sep 2020 07:52
(address . guix-patches@gnu.org)
20200919055230.21174-1-mail@brendan.scot
* gnu/packages/image-processing.scm (scantailor-advanced): New variable.
---
gnu/packages/image-processing.scm | 50 +++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (74 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 9158e14938..c480fae05a 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +34,7 @@
#:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system qt)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
@@ -1015,3 +1017,51 @@ substitued, as well as collage-style photomosaics, in which rectangular parts
of the source image at arbitrary positions (i.e. not aligned to a matrix) are
substituted by matching images.")
(license license:gpl2))))
+
+(define-public scantailor-advanced
+ (let ((commit "df1f8e25d16e08594d530c18de58f44b1fd7b0a5"))
+ (package
+ (name "scantailor-advanced")
+ (version (string-append "1.0.16-" (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brendan-t/scantailor-advanced")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jycvw39yg17zrd2fdmihskkwb3jx2j50479bnqh50jcndligb3f"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("boost" ,boost)
+ ("libjpeg" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Some tests require a display and fail with offscreen mode.
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (setenv "ARGS" "--exclude-regex \"imageproc_.*\"")
+ #t)))))
+ (home-page "https://github.com/4lex4/scantailor-advanced")
+ (synopsis "Clean up scanned pages")
+ (description "Scan Tailor is an interactive post-processing tool for
+scanned pages. It performs operations such as page splitting, deskewing,
+adding/removing borders, and others. You give it raw scans, and you get pages
+ready to be printed or assembled into a PDF or DJVU file. Scanning, optical
+character recognition, and assembling multi-page documents are out of scope of
+this project.
+
+Scan Tailer Advanced is a development of Scan Tailer that merges features and
+bug fixes from Scan Tailor Featured and Scan Tailor Enhanced versions. Guix's
+version additionally includes a Korean translation.")
+ (license license:gpl3+))))
--
2.28.0
M
M
Mathieu Othacehe wrote on 25 Sep 2020 14:29
(name . Brendan Tildesley)(address . mail@brendan.scot)(address . 43504@debbugs.gnu.org)
87imc2ca4j.fsf@gnu.org
Hello,

Toggle quote (4 lines)
> + (uri (git-reference
> + (url "https://github.com/brendan-t/scantailor-advanced")
> + (commit commit)))

What's the reason for not using the upstream 1.0.16 release? Is the only
reason the addition of the Korean translation? In that case, it could be
contributed upstream or added as a side patch I guess.

Thanks,

Mathieu
B
B
Brendan Tildesley wrote on 25 Sep 2020 22:46
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 43504@debbugs.gnu.org)
62CE0D94-95CB-48C7-A6AE-DC2184E87A0D@brendan.scot
On September 25, 2020 10:29:48 PM GMT+10:00, Mathieu Othacehe <othacehe@gnu.org> wrote:
Toggle quote (18 lines)
>
>Hello,
>
>> + (uri (git-reference
>> + (url
>"https://github.com/brendan-t/scantailor-advanced")
>> + (commit commit)))
>
>What's the reason for not using the upstream 1.0.16 release? Is the
>only
>reason the addition of the Korean translation? In that case, it could
>be
>contributed upstream or added as a side patch I guess.
>
>Thanks,
>
>Mathieu

Well I saw the merge request for it and it was ignored, so I just added it manually. Also I wasn't using the latest tag release but the latest commit because the release is 2 years old and there are many fixes and changes afterwards. This is not just the latest release plus the translation but the latest commit plus it, in my own repo. It didn't look like the channel owner was planning to make a release any time soon. Do you think I should just use the latest release then and not worry about it?
Attachment: file
M
M
Mathieu Othacehe wrote on 1 Oct 2020 09:37
(name . Brendan Tildesley)(address . mail@brendan.scot)(address . 43504@debbugs.gnu.org)
87tuvez9b6.fsf@gnu.org
Hello Brendan,

Toggle quote (4 lines)
> Well I saw the merge request for it and it was ignored, so I just added it manually. Also I wasn't using the latest tag release but the latest commit because the release is 2 years old and there
> are many fixes and changes afterwards. This is not just the latest release plus the translation but the latest commit plus it, in my own repo. It didn't look like the channel owner was planning
> to make a release any time soon. Do you think I should just use the latest release then and not worry about it?

The project is not explicitly discontinued, so maybe you could package
the latest upstream commit. Regarding your translation commit, I saw you
submitted a MR a few days ago, let's see if it gets a review.

Thanks,

Mathieu
B
B
Brendan Tildesley wrote on 1 Oct 2020 12:23
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 43504@debbugs.gnu.org)
8300a8c9-1021-5680-6024-9516b14ee55f@brendan.scot
On 1/10/20 7:37 am, Mathieu Othacehe wrote:
Toggle quote (13 lines)
> Hello Brendan,
>
>> Well I saw the merge request for it and it was ignored, so I just added it manually. Also I wasn't using the latest tag release but the latest commit because the release is 2 years old and there
>> are many fixes and changes afterwards. This is not just the latest release plus the translation but the latest commit plus it, in my own repo. It didn't look like the channel owner was planning
>> to make a release any time soon. Do you think I should just use the latest release then and not worry about it?
> The project is not explicitly discontinued, so maybe you could package
> the latest upstream commit. Regarding your translation commit, I saw you
> submitted a MR a few days ago, let's see if it gets a review.
>
> Thanks,
>
> Mathieu

I attached a new one that uses up stream's latest. By the way, to test
it, just take a photo of a page from a book, and try load it in. if you
can go through the steps processing it to a clean output then it should
be working ok.
From b2113f7dc97a3486ad79bf77ef139ef026305234 Mon Sep 17 00:00:00 2001
From: Brendan Tildesley <mail@brendan.scot>
Date: Thu, 17 Sep 2020 19:09:21 +1000
Subject: [PATCH] gnu: Add scantailor-advanced.

* gnu/packages/image-processing.scm (scantailor-advanced): New variable.
---
gnu/packages/image-processing.scm | 49 +++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)

Toggle diff (73 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 9158e14938..d9fd0e5baa 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +34,7 @@
#:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system qt)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
@@ -1015,3 +1017,50 @@ substitued, as well as collage-style photomosaics, in which rectangular parts
of the source image at arbitrary positions (i.e. not aligned to a matrix) are
substituted by matching images.")
(license license:gpl2))))
+
+(define-public scantailor-advanced
+ (let ((commit "3d1e74e6ace413733511086934a66f4e3f7a6027"))
+ (package
+ (name "scantailor-advanced")
+ (version (string-append "1.0.16-" (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/4lex4/scantailor-advanced")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0kixwjb2x457dq7927hkh34c803p7yh1pmn6n61rk9shqrcg492h"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("boost" ,boost)
+ ("libjpeg" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Some tests require a display and fail with offscreen mode.
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (setenv "ARGS" "--exclude-regex \"imageproc_.*\"")
+ #t)))))
+ (home-page "https://github.com/4lex4/scantailor-advanced")
+ (synopsis "Clean up scanned pages")
+ (description "Scan Tailor is an interactive post-processing tool for
+scanned pages. It performs operations such as page splitting, deskewing,
+adding/removing borders, and others. You give it raw scans, and you get pages
+ready to be printed or assembled into a PDF or DJVU file. Scanning, optical
+character recognition, and assembling multi-page documents are out of scope of
+this project.
+
+Scan Tailer Advanced is a fork of Scan Tailer that merges Scan Tailor Featured
+and Scan Tailor Enhanced versions as well as including many more bug fixes.")
+ (license license:gpl3+))))
--
2.28.0
M
M
Mathieu Othacehe wrote on 1 Oct 2020 14:23
(name . Brendan Tildesley)(address . mail@brendan.scot)(address . 43504-done@debbugs.gnu.org)
87ft6yyw10.fsf@gnu.org
Hey Brendan,

Toggle quote (5 lines)
> I attached a new one that uses up stream's latest. By the way, to test it,
> just take a photo of a page from a book, and try load it in. if you can go
> through the steps processing it to a clean output then it should be working
> ok.

Pushed as a76e9d13e9b5cad2bbfc0433d2f8d0eae2af0b05.

Thanks,

Mathieu
Closed
?