[PATCH] guix: build: Add a hint for unspecified value

  • Done
  • quality assurance status badge
Details
2 participants
  • Julien Lepiller
  • Ludovic Courtès
Owner
unassigned
Submitted by
Julien Lepiller
Severity
normal
J
J
Julien Lepiller wrote on 16 Sep 2020 23:40
(address . guix-patches@gnu.org)
20200916234003.35f2ac07@tachikoma.lepiller.eu
Hi Guix!

this patch adds a hint to guix build, when you try to build from a file
and it returns #<unspecified>. The most common error is when you copy
the structure from other guix modules and use `define-public` for your
package. The file returns #<unspecified> and you get this message:

Toggle quote (2 lines)
> #<unspecified>: not something we can build.

Which is not very helpful. Here is what happens with this change:

Toggle quote (14 lines)
> guix build: error: #<unspecified>: not something we can build
>
> hint: If you build from a file, make sure the last scheme expression
> returns a package value. `define-public' defines a variable, but
> returns #<unspecified>. To fix this, add a scheme expression at the
> end of the file that consists only of the package's variable name you
> defined. ex:
>
> (define-public my-package
> (package
> ...))
>
> my-package

If instead, you return a value that is not understood, the message is
simpler (as this is not something that happens out of confusion / being
new to guix or guile):

Toggle quote (5 lines)
> guix build: error: 1: not something we can build
>
> hint: If you build from a file, make sure the last scheme expression
> returns a package, gexp, derivation value or a list of such values.

(here the file returned "1" which we can't build :))
From b29a325ef52d402c9618bfe9f02e478134297c0f Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Wed, 16 Sep 2020 23:32:00 +0200
Subject: [PATCH] guix: build: Add a hint for unspecified value.

* guix/scripts/build.scm (options->things-to-build): Add a hint when we
cannot build something.
---
guix/scripts/build.scm | 24 +++++++++++++++++++++++-
1 file changed, 23 insertions(+), 1 deletion(-)

Toggle diff (51 lines)
diff --git a/guix/scripts/build.scm b/guix/scripts/build.scm
index 25418661b9..46d1415a4d 100644
--- a/guix/scripts/build.scm
+++ b/guix/scripts/build.scm
@@ -38,6 +38,7 @@
#:use-module (guix monads)
#:use-module (guix gexp)
#:use-module (guix profiles)
+ #:use-module (guix diagnostics)
#:autoload (guix http-client) (http-fetch http-get-error?)
#:use-module (ice-9 format)
#:use-module (ice-9 match)
@@ -46,6 +47,7 @@
#:use-module (srfi srfi-11)
#:use-module (srfi srfi-26)
#:use-module (srfi srfi-34)
+ #:use-module (srfi srfi-35)
#:use-module (srfi srfi-37)
#:use-module (gnu packages)
#:autoload (guix download) (download-to-store)
@@ -805,7 +807,27 @@ must be one of 'package', 'all', or 'transitive'~%")
build---packages, gexps, derivations, and so on."
(define (validate-type x)
(unless (or (derivation? x) (file-like? x) (gexp? x) (procedure? x))
- (leave (G_ "~s: not something we can build~%") x)))
+ (raise (make-compound-condition
+ (formatted-message (G_ "~s: not something we can build~%") x)
+ (condition
+ (&fix-hint
+ (hint
+ (if (unspecified? x)
+ (G_ "If you build from a file, make sure the last scheme
+expression returns a package value. @code{define-public} defines a variable,
+but returns #<unspecified>. To fix this, add a scheme expression at the end of
+the file that consists only of the package's variable name you defined. ex:
+
+@example
+(define-public my-package
+ (package
+ ...))
+
+my-package
+@end example")
+ (G_ "If you build from a file, make sure the last scheme
+expression returns a package, gexp, derivation value or a list of such
+values.")))))))))
(define (ensure-list x)
(let ((lst (match x
--
2.28.0
L
L
Ludovic Courtès wrote on 18 Sep 2020 22:35
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 43458@debbugs.gnu.org)
87lfh6u8kx.fsf@gnu.org
Julien Lepiller <julien@lepiller.eu> skribis:

Toggle quote (4 lines)
>>From b29a325ef52d402c9618bfe9f02e478134297c0f Mon Sep 17 00:00:00 2001
> From: Julien Lepiller <julien@lepiller.eu>
> Date: Wed, 16 Sep 2020 23:32:00 +0200
> Subject: [PATCH] guix: build: Add a hint for unspecified value.
^
I tend to use “guix build:” as the prefix for this file.

Toggle quote (3 lines)
> * guix/scripts/build.scm (options->things-to-build): Add a hint when we
> cannot build something.

Great idea!

Toggle quote (9 lines)
> + (raise (make-compound-condition
> + (formatted-message (G_ "~s: not something we can build~%") x)
> + (condition
> + (&fix-hint
> + (hint
> + (if (unspecified? x)
> + (G_ "If you build from a file, make sure the last scheme
> +expression returns a package value. @code{define-public} defines a variable,
> +but returns #<unspecified>. To fix this, add a scheme expression at the end of
^
@code

Toggle quote (2 lines)
> +the file that consists only of the package's variable name you defined. ex:

s/. ex:/as in this example:/

Toggle quote (11 lines)
> +@example
> +(define-public my-package
> + (package
> + ...))
> +
> +my-package
> +@end example")
> + (G_ "If you build from a file, make sure the last scheme
> +expression returns a package, gexp, derivation value or a list of such
> +values.")))))))))

s/derivation value/derivation/

Also s/scheme/Scheme/ throughout.

OK with these changes, thank you!

Ludo’.
J
J
Julien Lepiller wrote on 29 Sep 2020 15:16
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 43458-done@debbugs.gnu.org)
20200929151605.64af296c@tachikoma.lepiller.eu
Pushed as e75443d4f28ff1aa97e545f2b47b311c3a5ac32a, thanks for the
review!
Closed
?