[PATCH: Kdenlive Fixes #3]

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Prafulla Giri
Owner
unassigned
Submitted by
Prafulla Giri
Severity
normal
P
P
Prafulla Giri wrote on 16 Sep 2020 21:56
(address . guix-patches@gnu.org)
CAFw+=j3rU8QYw9H2MHh9wkqRSnMbiMk6zH2hXjqjUzJZrY3x-Q@mail.gmail.com
Esteemed Maintainers,

Attached are patches that bring in a few more polishings to the kdenlive
package.

1. Update kdenlive to 20.08.1
2. Add missing dependencies
3. Simplify 'wrap-executable phase

Notable is the fact that with patch #2 that adds a few missing
dependencies, kdenlive can now, finally, open files from the file-system
via it's file-chooser.

Regarding patch #3, while it does simplify the wrap-phase, the final
wrapper's exported variables are supersets of the previous wrapper's
exported variables. I noticed no regressions, and noticed that this change
gives 2 lines fewer warnings/errors.
Attachment: file
From 40e9b78970eb3f83b7fcc5ea0b648c75ceac62bc Mon Sep 17 00:00:00 2001
From: Prafulla Giri <pratheblackdiamond@gmail.com>
Date: Thu, 17 Sep 2020 00:55:58 +0545
Subject: [PATCH 3/3] gnu: kdenlive: simplify 'wrap-executable phase

* gnu/packages/kde.scm (kdenlive)[arguments]: Use getenv to set the
values of QT_PLUGIN_PATH and QML2_IMPORT_PATH in the wrapper during
the 'wrap-executable phase.
---
gnu/packages/kde.scm | 15 +++------------
1 file changed, 3 insertions(+), 12 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 13cbcb4e14..ce8d172696 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -190,32 +190,23 @@ This package contains GUI widgets for baloo.")
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
- (qtquickcontrols2 (assoc-ref inputs "qtquickcontrols2"))
(qtbase (assoc-ref inputs "qtbase"))
- (qtdeclarative (assoc-ref inputs "qtdeclarative"))
(frei0r (assoc-ref inputs "frei0r-plugins"))
(ffmpeg (assoc-ref inputs "ffmpeg"))
- (breeze (assoc-ref inputs "breeze"))
- (qml "/lib/qt5/qml"))
+ (breeze (assoc-ref inputs "breeze")))
(wrap-program (string-append out "/bin/kdenlive")
`("PATH" ":" prefix
,(list (string-append ffmpeg "/bin")))
`("XDG_DATA_DIRS" ":" prefix
,(list (string-append breeze "/share")))
`("QT_PLUGIN_PATH" ":" prefix
- ,(map (lambda (label)
- (string-append (assoc-ref inputs label)
- "/lib/qt5/plugins/"))
- '("qtbase" "qtsvg")))
+ ,(list (getenv "QT_PLUGIN_PATH")))
`("FREI0R_PATH" ":" =
(,(string-append frei0r "/lib/frei0r-1/")))
`("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
(,(string-append qtbase "/lib/qt5/plugins/platforms")))
`("QML2_IMPORT_PATH" ":" prefix
- (,(string-append qtquickcontrols qml)
- ,(string-append qtquickcontrols2 qml)
- ,(string-append qtdeclarative qml)))
+ ,(list (getenv "QML2_IMPORT_PATH")))
`("MLT_PREFIX" ":" =
(,(assoc-ref inputs "mlt")))))
#t)))))
--
2.28.0
From 37003415856fa468caba26c44ddccfdb79e8de6b Mon Sep 17 00:00:00 2001
From: Prafulla Giri <pratheblackdiamond@gmail.com>
Date: Wed, 16 Sep 2020 23:29:09 +0545
Subject: [PATCH 2/3] gnu: kdenlive: Add missing dependencies.

This change finally makes it possible to browse the
file-system using kdenlive's own file-chooser.

* gnu/packages/kde.scm (kdenlive):
[native-inputs]: Add pkg-config.
[inputs]: Add purpose and qtwebkit.
---
gnu/packages/kde.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 037623fc05..13cbcb4e14 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -151,6 +151,7 @@ This package contains GUI widgets for baloo.")
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)
("qttools" ,qttools)))
(inputs
`(("shared-mime-info" ,shared-mime-info)
@@ -178,6 +179,8 @@ This package contains GUI widgets for baloo.")
("qtquickcontrols2" ,qtquickcontrols2)
("kiconthemes" ,kiconthemes)
("breeze" ,breeze)
+ ("purpose" ,purpose)
+ ("qtwebkit" ,qtwebkit)
("qtgraphicaleffects" ,qtgraphicaleffects)
("kplotting" ,kplotting)))
(arguments
--
2.28.0
From 584f313cdce5fe45d26ff17e4515fdc8ba1bbf0c Mon Sep 17 00:00:00 2001
From: Prafulla Giri <pratheblackdiamond@gmail.com>
Date: Wed, 16 Sep 2020 22:10:18 +0545
Subject: [PATCH 1/3] gnu: kdenlive: Update to 20.08.1.

* gnu/packages/kde.scm (kdenlive): Update to 20.08.1.
---
gnu/packages/kde.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 75e7f39c4b..037623fc05 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -134,7 +134,7 @@ This package contains GUI widgets for baloo.")
(list license:lgpl2.1+ license:fdl1.2+))))
(define-public kdenlive
- (let ((version "20.04.1"))
+ (let ((version "20.08.1"))
(package
(name "kdenlive")
(version version)
@@ -147,7 +147,7 @@ This package contains GUI widgets for baloo.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0n0x34xmcn0k87rqnz0mk462b3al4gq56kn4m00rr428hafscdz7"))))
+ "15mpw1sysy7mky8fcj0x4zbspz0na7q76xdfj0j8hsggg9d3yq8l"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
--
2.28.0
P
P
Prafulla Giri wrote on 17 Sep 2020 19:10
Regarding blacklisted effects
(address . 43455@debbugs.gnu.org)
CAFw+=j0ev-muoNN3nHGd2Sak_Dm2n=Ep7s0rrPBCMdUuSDmhqQ@mail.gmail.com
If kdenlive is run from the terminal, it informs that quite a lot of
plugins are blacklisted. The 'erros' look something like:
```
"videostab" is blacklisted
"videostab2" is blacklisted
"burningtv" is blacklisted
...
...
...
```

I was under the impression that this was a packaging issue on our part. But
turns out, these plugins are blacklisted upstream:
Attachment: file
M
M
Mathieu Othacehe wrote on 18 Sep 2020 12:12
Re: [bug#43455] [PATCH: Kdenlive Fixes #3]
(name . Prafulla Giri)(address . pratheblackdiamond@gmail.com)(address . 43455-done@debbugs.gnu.org)
87wo0rz941.fsf@gnu.org
Hello,

Toggle quote (4 lines)
> 1. Update kdenlive to 20.08.1
> 2. Add missing dependencies
> 3. Simplify 'wrap-executable phase

Thanks for these patches! I did add your copyright, slightly edited some
commit messages and pushed :).

Mathieu

--
Closed
P
P
Prafulla Giri wrote on 18 Sep 2020 15:06
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 43455-done@debbugs.gnu.org)
CAFw+=j2UhjcR5ZUOWk_u2QuB1YQfmU+SGFeVqzhVEsWZXGeY1g@mail.gmail.com
Thank you very much, Mr. Othacehe.

On Fri, Sep 18, 2020 at 3:57 PM Mathieu Othacehe <othacehe@gnu.org> wrote:

Toggle quote (15 lines)
>
> Hello,
>
> > 1. Update kdenlive to 20.08.1
> > 2. Add missing dependencies
> > 3. Simplify 'wrap-executable phase
>
> Thanks for these patches! I did add your copyright, slightly edited some
> commit messages and pushed :).
>
> Mathieu
>
> --
> https://othacehe.org
>
Attachment: file
Closed
?