[PATCH 1/2] gnu: Add python-apiron.

  • Done
  • quality assurance status badge
Details
2 participants
  • Vinicius Monego
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 16 Sep 2020 21:54
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200916195441.25323-1-monego@posteo.net
* gnu/packages/python-web.scm (python-apiron): New variable.
---
gnu/packages/python-web.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7926539233..aaa406d547 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1879,6 +1879,39 @@ WebSocket usage in Python programs.")
"Purl is a Python package for handling URLs.")
(license license:expat)))
+(define-public python-apiron
+ (package
+ (name "python-apiron")
+ (version "5.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "apiron" version))
+ (sha256
+ (base32 "1qwbqn47sf0aqznj1snbv37v8ijx476qqkjf5l9pac7xjkxsr8qk"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "--cov" "-k"
+ ;; This test tries to connect to the internet.
+ "not test_call"))))))
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (home-page "https://github.com/ithaka/apiron")
+ (synopsis "Python wrapper for interacting with RESTful APIs")
+ (description
+ "@code{apiron} provides a declarative, structured configuration of
+services and endpoints with a unified interface for interacting with RESTful
+APIs.")
+ (license license:expat)))
+
(define-public python-requests
(package
(name "python-requests")
--
2.20.1
V
V
Vinicius Monego wrote on 16 Sep 2020 21:57
[PATCH 2/2] gnu: Add python-beren.
(address . 43454@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200916195706.25516-1-monego@posteo.net
* gnu/packages/python-web.scm (python-beren): New variable.
---
gnu/packages/python-web.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index aaa406d547..b0ad2240b6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1912,6 +1912,28 @@ services and endpoints with a unified interface for interacting with RESTful
APIs.")
(license license:expat)))
+(define-public python-beren
+ (package
+ (name "python-beren")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "beren" version))
+ (sha256
+ (base32 "1v3mdwfqsyza892zvs124ym9w1bkng1j56b7l4dwfjir3723xcgf"))))
+ (build-system python-build-system)
+ (arguments
+ ;; The test tries to open a connection to a remote server.
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-apiron" ,python-apiron)))
+ (home-page "https://github.com/teffalump/beren")
+ (synopsis "REST client for Orthanc DICOM servers")
+ (description
+ "@code{beren} provides a REST client for Orthanc, a DICOM server.")
+ (license license:gpl3+)))
+
(define-public python-requests
(package
(name "python-requests")
--
2.20.1
M
M
Mathieu Othacehe wrote on 18 Sep 2020 11:49
(name . Vinicius Monego)(address . monego@posteo.net)(address . 43454-done@debbugs.gnu.org)
87zh5nza6h.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/python-web.scm (python-beren): New variable.

Pushed both patches, thanks!

Mathieu
Closed
?