[PATCH] gnu: Add python-requests-ftp.

  • Done
  • quality assurance status badge
Details
2 participants
  • Konrad Hinsen
  • Leo Famulari
Owner
unassigned
Submitted by
Konrad Hinsen
Severity
normal
K
K
Konrad Hinsen wrote on 16 Sep 2020 17:10
(address . guix-patches@gnu.org)
m14knxzrii.fsf@khs-macbook.home
* gnu/packages/python-web.scm (python-requests-ftp): New variable.
---
gnu/packages/python-web.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7926539233..b75accccac 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2029,6 +2029,28 @@ with python-requests.")
`(;; FIXME: Some tests require network access.
#:tests? #f))))
+(define-public python-requests-ftp
+ (package
+ (name "python-requests-ftp")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests-ftp" version))
+ (sha256
+ (base32
+ "0yh5v21v36dsjsgv4y9dx4mmz35741l5jf6pbq9w19d8rfsww13m"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
+ (home-page
+ "http://github.com/Lukasa/requests-ftp")
+ (synopsis "FTP Transport Adapter for Requests.")
+ (description
+ "Requests-FTP is an implementation of a simple FTP transport
+adapter for use with the Requests library.")
+ (license license:asl2.0)))
+
(define-public python-oauthlib
(package
(name "python-oauthlib")
--
2.28.0
K
K
Konrad Hinsen wrote on 17 Sep 2020 09:26
(address . 43449@debbugs.gnu.org)
m1pn6kyicn.fsf@khs-macbook.home
I forgot to pass this through lint - new patch following,
with minor fixes in synopsis and home page.

Konrad.
K
K
Konrad Hinsen wrote on 17 Sep 2020 09:27
(address . 43449@debbugs.gnu.org)
m1o8m4yib6.fsf@khs-macbook.home
* gnu/packages/python-web.scm (python-requests-ftp): New variable.
---
gnu/packages/python-web.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7926539233..6bd413efca 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2029,6 +2029,28 @@ with python-requests.")
`(;; FIXME: Some tests require network access.
#:tests? #f))))
+(define-public python-requests-ftp
+ (package
+ (name "python-requests-ftp")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests-ftp" version))
+ (sha256
+ (base32
+ "0yh5v21v36dsjsgv4y9dx4mmz35741l5jf6pbq9w19d8rfsww13m"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
+ (home-page
+ "https://github.com/Lukasa/requests-ftp")
+ (synopsis "FTP Transport Adapter for Requests")
+ (description
+ "Requests-FTP is an implementation of a simple FTP transport
+adapter for use with the Requests library.")
+ (license license:asl2.0)))
+
(define-public python-oauthlib
(package
(name "python-oauthlib")
--
2.28.0
L
L
Leo Famulari wrote on 17 Sep 2020 19:28
Re: [bug#43449] [PATCH] gnu: Add python-requests-ftp.
(name . Konrad Hinsen)(address . konrad.hinsen@fastmail.net)(address . 43449-done@debbugs.gnu.org)
20200917172823.GA22913@jasmine.lan
On Thu, Sep 17, 2020 at 09:27:09AM +0200, Konrad Hinsen wrote:
Toggle quote (2 lines)
> * gnu/packages/python-web.scm (python-requests-ftp): New variable.

Thanks! Pushed as a96873565da1e9a7ef95ab06a5774b1207b86ead with a
followup commit to credit you as an author.
Closed
?