[PATCH 1/2] gnu: Add python-rnc2rng.

  • Done
  • quality assurance status badge
Details
2 participants
  • Konrad Hinsen
  • Ludovic Courtès
Owner
unassigned
Submitted by
Konrad Hinsen
Severity
normal
K
K
Konrad Hinsen wrote on 16 Sep 2020 12:19
(address . guix-patches@gnu.org)
m1een2yqfp.fsf@khs-macbook.home
* gnu/packages/python-xyz.scm (python-rnc2rng): New variable.
---
gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 24fc512178..fd58921953 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22016,3 +22016,31 @@ By default it uses the open Python vulnerability database Safety DB.")
(synopsis "Python wrapper for pandoc.")
(description "Thin Python wrapper for pandoc.")
(license license:expat)))
+
+(define-public python-rnc2rng
+ (package
+ (name "python-rnc2rng")
+ (version "2.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rnc2rng" version))
+ (sha256
+ (base32
+ "1kmp3iwxxyzjsd47j2sprd47ihhkwhb3yydih3af5bbfq0ibh1w8"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-rply" ,python-rply)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "test.py")
+ #t)))))
+ (home-page "https://github.com/djc/rnc2rng")
+ (synopsis
+ "RELAX NG Compact to regular syntax conversion library")
+ (description
+ "Converts RELAX NG schemata in Compact syntax (rnc) to
+equivalent schemata in the XML-based default RELAX NG syntax.")
+ (license license:expat)))
--
2.28.0
L
L
Ludovic Courtès wrote on 21 Sep 2020 23:30
(name . Konrad Hinsen)(address . konrad.hinsen@fastmail.net)(address . 43444-done@debbugs.gnu.org)
87k0wmizs4.fsf@gnu.org
Hi,

Konrad Hinsen <konrad.hinsen@fastmail.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-rnc2rng): New variable.

Applied with the changes below, thanks!

Ludo’.
Toggle diff (21 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 55ef5f5640..004f07cec2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22038,12 +22038,11 @@ and pandoc-citeproc.")
`(#:phases (modify-phases %standard-phases
(replace 'check
(lambda _
- (invoke "python" "test.py")
- #t)))))
+ (invoke "python" "test.py"))))))
(home-page "https://github.com/djc/rnc2rng")
- (synopsis
- "RELAX NG Compact to regular syntax conversion library")
+ (synopsis "Convert RELAX NG Compact to regular syntax")
(description
- "Converts RELAX NG schemata in Compact syntax (rnc) to
+ "This package provides the @command{rnc2rng} command-line tool as well as
+a Python library to convert RELAX NG schemata in Compact syntax (rnc) to
equivalent schemata in the XML-based default RELAX NG syntax.")
(license license:expat)))
Closed
?