[PATCH] gnu: Fix fetching the linux-libre deblobbing script.

  • Done
  • quality assurance status badge
Details
One participant
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 16 Sep 2020 03:05
(address . guix-patches@gnu.org)
77e65a3b34c2ab70b6f7516595dfa5cd6e6844a1.1600218322.git.leo@famulari.name
This is a followup to commit 105a037090d9a970a2c2336341d6673eff29e4cf.

* gnu/packages/linux.scm (linux-libre-deblob-scripts): Truncate the version in
the file-name, not the source URI.
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 59ffb334e0..2e47b81cf6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -195,9 +195,9 @@ defconfig. Return the appropriate make target if applicable, otherwise return
(method url-fetch)
(uri (string-append "https://linux-libre.fsfla.org"
"/pub/linux-libre/releases/" version "-gnu/"
- "deblob-" version))
+ "deblob-" (version-major+minor version)))
(file-name (string-append "linux-libre-deblob-"
- (version-major+minor version)))
+ version))
(sha256 deblob-hash))
(origin
(method url-fetch)
--
2.28.0
L
L
Leo Famulari wrote on 16 Sep 2020 05:23
(address . 43438-done@debbugs.gnu.org)
20200916032326.GA16229@jasmine.lan
Pushed as cca5720f410ce01e2b3ed7e4fde593e118f08f07
Closed
?