[PATCH 0/1] guix: scripts: build: Mention 'PACKAGE' in '--with-source' option.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 16 Sep 2020 00:15
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20200915221542.15177-1-zimon.toutoune@gmail.com
Dear,

It appears serveral times that I am confused by the transformation
"--with-source" where the CLI reports:

Toggle snippet (3 lines)
guix build: warning: transformation 'with-source' had no effect on

because I use "guix build --with-source=path/to/archive" where
'path/to/archive' does not match the package name. Then "guix build -h" says:

Toggle snippet (4 lines)
--with-source=SOURCE
use SOURCE when building the corresponding package

and all the others transformation options says:

Toggle snippet (13 lines)
--with-input=PACKAGE=REPLACEMENT
replace dependency PACKAGE by REPLACEMENT
--with-graft=PACKAGE=REPLACEMENT
graft REPLACEMENT on packages that refer to PACKAGE
--with-branch=PACKAGE=BRANCH
build PACKAGE from the latest commit of BRANCH
--with-commit=PACKAGE=COMMIT
build PACKAGE from COMMIT
--with-git-url=PACKAGE=URL
build PACKAGE from the repository at URL


All the best,
simon

zimoun (1):
guix: scripts: build: Mention 'PACKAGE' in '--with-source' option.

guix/scripts/build.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

--
2.28.0
Z
Z
zimoun wrote on 16 Sep 2020 00:17
[PATCH 1/1] guix: scripts: build: Mention 'PACKAGE' in '--with-source' option.
(address . 43436@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20200915221729.15863-1-zimon.toutoune@gmail.com
* guix/scripts/build.scm (show-transformation-options-help): Mention 'PACKAGE'
in '--with-source' option.
---
guix/scripts/build.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/guix/scripts/build.scm b/guix/scripts/build.scm
index 25418661b9..4592f23f26 100644
--- a/guix/scripts/build.scm
+++ b/guix/scripts/build.scm
@@ -427,7 +427,7 @@ a checkout of the Git repository at the given URL."
(define (show-transformation-options-help)
(display (G_ "
- --with-source=SOURCE
+ --with-source=PACKAGE=SOURCE
use SOURCE when building the corresponding package"))
(display (G_ "
--with-input=PACKAGE=REPLACEMENT
--
2.28.0
L
L
Ludovic Courtès wrote on 21 Sep 2020 23:15
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 43436-done@debbugs.gnu.org)
87sgbaj0gs.fsf@gnu.org
zimoun <zimon.toutoune@gmail.com> skribis:

Toggle quote (17 lines)
> * guix/scripts/build.scm (show-transformation-options-help): Mention 'PACKAGE'
> in '--with-source' option.
> ---
> guix/scripts/build.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/guix/scripts/build.scm b/guix/scripts/build.scm
> index 25418661b9..4592f23f26 100644
> --- a/guix/scripts/build.scm
> +++ b/guix/scripts/build.scm
> @@ -427,7 +427,7 @@ a checkout of the Git repository at the given URL."
>
> (define (show-transformation-options-help)
> (display (G_ "
> - --with-source=SOURCE
> + --with-source=PACKAGE=SOURCE

I added square brackets because PACKAGE is optional.

Thanks!

Ludo’.
Closed
?