[PATCH 0/1] Fix unreachable gdsl package

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 15 Sep 2020 16:01
(address . guix-patches@gnu.org)
20200915140134.15128-1-zimon.toutoune@gmail.com
Dear,

The mention of the gna.org closing down is reported in bug #25913
http://issues.guix.gnu.org/issue/25913. Therefore, the package gdsl is not
maintained and the both URLs source and home-page are now unreachable.
Currently, substitutes are available on <ci.guix.gnu.org> but nothing prevents
an unfortunate "guix gc". This patch uses Software Heritage as an archive for
upstream source, but since tarballs are not yet fully supported by SWH, the
support 'git-fetch' is used instead.

Last, let check the integrity of the switch.

Toggle snippet (21 lines)
$ guix time-machine --commit=f6dfe42 -- build gdsl
/gnu/store/yd0vadqjx998v76ynx27klg7i62ra1l1-gdsl-1.8

$ ./pre-inst-env guix build gdsl
/gnu/store/zp18gsfw128aam2ifh9rsfn7wxx1fnzh-gdsl-1.8

$ diff -r --no-dereference \
/gnu/store/zp18gsfw128aam2ifh9rsfn7wxx1fnzh-gdsl-1.8 \
/gnu/store/yd0vadqjx998v76ynx27klg7i62ra1l1-gdsl-1.8
diff -r --no-dereference /gnu/store/zp18gsfw128aam2ifh9rsfn7wxx1fnzh-gdsl-1.8/bin/gdsl-config /gnu/store/yd0vadqjx998v76ynx27klg7i62ra1l1-gdsl-1.8/bin/gdsl-config
3c3
< prefix=/gnu/store/zp18gsfw128aam2ifh9rsfn7wxx1fnzh-gdsl-1.8
---
> prefix=/gnu/store/yd0vadqjx998v76ynx27klg7i62ra1l1-gdsl-1.8
diff -r --no-dereference /gnu/store/zp18gsfw128aam2ifh9rsfn7wxx1fnzh-gdsl-1.8/lib/libgdsl.la /gnu/store/yd0vadqjx998v76ynx27klg7i62ra1l1-gdsl-1.8/lib/libgdsl.la
41c41
< libdir='/gnu/store/zp18gsfw128aam2ifh9rsfn7wxx1fnzh-gdsl-1.8/lib'
---
> libdir='/gnu/store/yd0vadqjx998v76ynx27klg7i62ra1l1-gdsl-1.8/lib'

zimoun (1):
gnu: gdsl: Replace 'url-fetch' by 'git-fetch'.

gnu/packages/datastructures.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

--
2.28.0
Z
Z
zimoun wrote on 15 Sep 2020 16:03
[PATCH 1/1] gnu: gdsl: Replace 'url-fetch' by 'git-fetch'.
(address . 43426@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20200915140343.15986-1-zimon.toutoune@gmail.com

* gnu/packages/datastructures.scm (gdsl)[source]: Replace 'url-fetch' by
'git-fetch'.
[home-page]: Update.
---
gnu/packages/datastructures.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index 3203f91608..ac091500fc 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -37,14 +37,15 @@
(name "gdsl")
(version "1.8")
(source (origin
- (method url-fetch)
- (uri (string-append "http://download.gna.org/gdsl/"
- "gdsl-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "") ; only hosted on Software Heritage
+ (commit "6adb53be8b8f9f2e4bbfc92d357eedeefb4c7430")))
(sha256
(base32
- "1v64jvlnj8jfpphphgjgb36p0kv50kwfyqncf0y12f16v8ydyiaw"))))
+ "0a52g12d9sf9hhcyvwfd7xdazj2a9i9jh97cnlqf2ymvwnvjk1g0"))))
(build-system gnu-build-system)
- (home-page "http://home.gna.org/gdsl/")
+ (home-page "https://web.archive.org/web/20170502005430/http://home.gna.org/gdsl/")
(synopsis "Generic data structures library")
(description "The Generic Data Structures Library (GDSL) is a collection
of routines for generic data structures manipulation. It is a re-entrant
--
2.28.0
L
L
Ludovic Courtès wrote on 21 Sep 2020 23:12
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 43426-done@debbugs.gnu.org)
87wo0mj0lk.fsf@gnu.org
Hi!

zimoun <zimon.toutoune@gmail.com> skribis:

Toggle quote (6 lines)
>
> * gnu/packages/datastructures.scm (gdsl)[source]: Replace 'url-fetch' by
> 'git-fetch'.
> [home-page]: Update.

Applied with the change below, to avoid the empty URI.

I’ve checked that the content hashes match:

Toggle snippet (6 lines)
$ (cd /tmp; tar xf $(guix build -S gdsl); guix hash -r /tmp/gdsl-1.8)
0a52g12d9sf9hhcyvwfd7xdazj2a9i9jh97cnlqf2ymvwnvjk1g0
$ guix hash -r $(./pre-inst-env guix build -S gdsl)
0a52g12d9sf9hhcyvwfd7xdazj2a9i9jh97cnlqf2ymvwnvjk1g0

Thanks,
Ludo’.
Toggle diff (15 lines)
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index ac091500fc..cd4126b22d 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -39,8 +39,9 @@
(source (origin
(method git-fetch)
(uri (git-reference
- (url "") ; only hosted on Software Heritage
+ (url "https://example.org") ;only hosted on Software Heritage
(commit "6adb53be8b8f9f2e4bbfc92d357eedeefb4c7430")))
+ (file-name (git-file-name name version))
(sha256
(base32
"0a52g12d9sf9hhcyvwfd7xdazj2a9i9jh97cnlqf2ymvwnvjk1g0"))))
Closed
?