[core-updates]: Add meson/latest and update wayland/sway.

  • Done
  • quality assurance status badge
Details
4 participants
  • bdju
  • Joshua Branson
  • Leo Famulari
  • Brendan Tildesley
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal
B
B
Brendan Tildesley wrote on 19 Aug 2020 01:57
(address . guix-patches@gnu.org)
8db6ed65-1f23-1490-2681-540209cc6c14@brendan.scot
I wanted to update sway but it requires a an update to wayland and
meson, which rebuilds thousands of things. I'm not sure the full process
for updating something like meson and wayland but I wanted to get the
ball rolling so I made these patches that add meson/latest and update
sway applied to the core-updates branch. I had tested them on master and
and was able to launch sway 1.5 just fine.
B
B
Brendan Tildesley wrote on 19 Aug 2020 01:58
[PATCH 1/5] gnu: Add meson/latest.
(address . 42923@debbugs.gnu.org)
20200818235856.31225-1-mail@brendan.scot
* gnu/packages/build-tools.scm (meson/latest): New variable.
---
gnu/packages/build-tools.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 7213c1bd0b..a464009761 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
+;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -222,6 +223,23 @@ resembles Python.")
;; People should probably install "meson", not "meson-for-build".
(properties `((hidden? . #t)))))
+(define-public meson/latest
+ ;; The rpath patch is no longer needed since this issue was resolved:
+ ;; https://github.com/mesonbuild/meson/issues/2567
+ (package
+ (inherit meson)
+ (name "meson")
+ (version "0.55.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mesonbuild/meson/"
+ "releases/download/" version "/meson-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1070kjiirxxdfppmrhi3wsc6rykay1zlciqrzayjhjg0hkw42mrv"))))
+ (properties `((hidden? . #t)))))
+
(define-public premake4
(package
(name "premake")
--
2.28.0
B
B
Brendan Tildesley wrote on 19 Aug 2020 01:58
[PATCH 2/5] gnu: wayland: Update to 1.18.0.
(address . 42923@debbugs.gnu.org)
20200818235856.31225-2-mail@brendan.scot
* gnu/packages/freedesktop.scm (wayland): Update to 1.18.0.
---
gnu/packages/freedesktop.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 23cd1aabf9..ff22ff2df3 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -637,14 +637,14 @@ Python.")
(define-public wayland
(package
(name "wayland")
- (version "1.17.0")
+ (version "1.18.0")
(source (origin
(method url-fetch)
(uri (string-append "https://wayland.freedesktop.org/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
- "194ibzwpdcn6fvk4xngr4bf5axpciwg2bj82fdvz88kfmjw13akj"))))
+ "0k995rn96xkplrapz5k648j651wc43kq817xk1x8280h16gsfxa6"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f))
--
2.28.0
B
B
Brendan Tildesley wrote on 19 Aug 2020 01:58
[PATCH 4/5] gnu: wlroots: Update to 0.11.0.
(address . 42923@debbugs.gnu.org)
20200818235856.31225-4-mail@brendan.scot
* gnu/packages/wm.scm (wlroots): Update to 0.11.0.
---
gnu/packages/wm.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2849873329..fb90173ef5 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -68,6 +68,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages bash)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages build-tools) ;; For meson/latest
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages calendar)
@@ -1312,7 +1313,7 @@ functionality to display information about the most commonly used services.")
(define-public wlroots
(package
(name "wlroots")
- (version "0.10.1")
+ (version "0.11.0")
(source
(origin
(method git-fetch)
@@ -1321,10 +1322,11 @@ functionality to display information about the most commonly used services.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0j2lh9vc92zhn44rjbia5aw3y1rpgfng1x1h17lcvj5m4i6vj0pc"))))
+ (base32 "08d5d52m8wy3imfc6mdxpx8swhh2k4s1gmfaykg02j59z84awc6p"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dlogind-provider=elogind")
+ #:meson ,meson/latest
#:phases
(modify-phases %standard-phases
(add-before 'configure 'hardcode-paths
--
2.28.0
B
B
Brendan Tildesley wrote on 19 Aug 2020 01:58
[PATCH 3/5] gnu: wayland-protocols: Update to 1.20.
(address . 42923@debbugs.gnu.org)
20200818235856.31225-3-mail@brendan.scot
* gnu/packages/freedesktop.scm (wayland-protocols): Update to 1.20.
---
gnu/packages/freedesktop.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index ff22ff2df3..997d3477e2 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -673,7 +673,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(define-public wayland-protocols
(package
(name "wayland-protocols")
- (version "1.18")
+ (version "1.20")
(source (origin
(method url-fetch)
(uri (string-append
@@ -681,7 +681,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
"wayland-protocols-" version ".tar.xz"))
(sha256
(base32
- "1cvl93h83ymbfhb567jv5gzyq08181w7c46rsw4xqqqpcvkvfwrx"))))
+ "1rsdgvkkvxs3cjhpl6agvbkm53vm7k8rg127j9y2vn33m2hvg0lp"))))
(build-system gnu-build-system)
(inputs
`(("wayland" ,wayland)))
--
2.28.0
B
B
Brendan Tildesley wrote on 19 Aug 2020 01:58
[PATCH 5/5] gnu: sway: Update to 1.5.
(address . 42923@debbugs.gnu.org)
20200818235856.31225-5-mail@brendan.scot
* gnu/packages/wm.scm (sway): Update to 1.5.
---
gnu/packages/wm.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index fb90173ef5..89d0a30712 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1359,7 +1359,7 @@ modules for building a Wayland compositor.")
(define-public sway
(package
(name "sway")
- (version "1.4")
+ (version "1.5")
(source
(origin
(method git-fetch)
@@ -1368,10 +1368,11 @@ modules for building a Wayland compositor.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "11qf89y3q92g696a6f4d23qb44gqixg6qxq740vwv2jw59ms34ja"))))
+ (base32 "0r3b7h778l9i20z3him9i2qsaynpn9y78hzfgv3cqi8fyry2c4f9"))))
(build-system meson-build-system)
(arguments
- `(#:phases
+ `(#:meson ,meson/latest
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'hardcode-paths
(lambda* (#:key inputs #:allow-other-keys)
--
2.28.0
J
J
Joshua Branson wrote on 21 Aug 2020 22:45
Re: [bug#42923] [PATCH 1/5] gnu: Add meson/latest.
(address . guix-patches@gnu.org)
87364fhgoj.fsf@dismail.de
Thanks for your work on this!

I believe that you can make your latest version of meson a "hidden"
package. You could name it something like "meson-latest", that way only
the newer version of sway would use it. And it wouldn't require a
rebuild of the world. Perhaps the same is true for wayland.

You can look for an example in the gcc.scm file. They have gcc-4.7 as a
hidden package. Users cannot install that package, instead they install
gcc-toolchain.

Thanks,

Joshua

--
Joshua Branson
Sent from Emacs and Gnus
B
B
Brendan Tildesley wrote on 22 Aug 2020 04:06
[core-updates]: Add meson/latest and update wayland/sway.
(address . 42923@debbugs.gnu.org)(address . jbranso@dismail.de)
3BA3F4FE-E4FE-4110-8B6A-1F0A5B0F109B@brendan.scot
I was under the impression that this is precisely what I had done. In Guix, the inputs of a package are typically refered to by its scheme symbol rather than its name, so this does not cause a rebuilt as I have used the symbol meson/latest. It will mean if someone runs Guix install meson, they will get this latest version by default, by that shouldn't matter. Most of the rebuilding should be caused by the fact that Wayland was also updated.

Are my assumptions wrong?
Attachment: file
B
B
Brendan Tildesley wrote on 22 Aug 2020 04:08
(address . 42923@debbugs.gnu.org)(address . jbranso@dismail.de)
54CDCFD5-64C2-4F61-8697-447987452F49@brendan.scot
Also it looks like I did make it hidden anyway…
Attachment: file
J
J
Joshua Branson wrote on 23 Aug 2020 16:39
(address . 42923@debbugs.gnu.org)
87wo1pfmto.fsf@dismail.de
Ah, my mistake. I withdraw my comment. I'll have to test your patches
at some point. I'd like to start using the latest sway!

--
Joshua Branson
Sent from Emacs and Gnus
B
(no subject)
(address . 42923@debbugs.gnu.org)
C54XYJ5YEPSF.LZY4307GNR51@masaki
+1 for wanting to use latest sway
B
B
Brendan Tildesley wrote on 29 Aug 2020 09:29
Can't run xwayland applications with Sway 1.5
(address . 42923@debbugs.gnu.org)
299f89d5-376d-0f1f-279d-7bc1d66eef14@brendan.scot
Currently, when I switch to Sway 1.5, it runs, but any X11 program
errors saying Cannot open display :0. Not sure what's causing it.
L
L
Leo Famulari wrote on 13 Dec 2020 20:46
Re: [bug#42923] [core-updates]: Add meson/latest and update wayland/sway.
(name . Brendan Tildesley)(address . mail@brendan.scot)(address . 42923-done@debbugs.gnu.org)
X9ZvlUD9U+WUKXKY@jasmine.lan
On Wed, Aug 19, 2020 at 09:57:26AM +1000, Brendan Tildesley wrote:
Toggle quote (7 lines)
> I wanted to update sway but it requires a an update to wayland and meson,
> which rebuilds thousands of things. I'm not sure the full process for
> updating something like meson and wayland but I wanted to get the ball
> rolling so I made these patches that add meson/latest and update sway
> applied to the core-updates branch. I had tested them on master and and was
> able to launch sway 1.5 just fine.

Unfortunately, it appears that somebody else pushed equivalent changes
without noticing these patches :/
Closed
?