Elixir build fails

  • Done
  • quality assurance status badge
Details
2 participants
  • Oskar Köök
  • zimoun
Owner
unassigned
Submitted by
Oskar Köök
Severity
normal
O
O
Oskar Köök wrote on 8 Aug 2020 13:04
(address . bug-guix@gnu.org)
MECjcmZ--3-2@maatriks.ee
Hi

Elixir build is failing for me. Don't have time to debug right now. This is the log:

phase `unpack' succeeded after 0.2 seconds
starting phase `make-git-checkout-writable'
phase `make-git-checkout-writable' succeeded after 0.0 seconds
starting phase `replace-paths'
Backtrace:
          18 (primitive-load "/gnu/store/7wsw0zq6zqvsqpl9g0j6gjanxwm…")
In ice-9/eval.scm:
   191:35 17 (_ #f)
In guix/build/gnu-build-system.scm:
    838:2 16 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
In ice-9/boot-9.scm:
  1736:10 15 (with-exception-handler _ _ #:unwind? _ # _)
In srfi/srfi-1.scm:
   857:16 14 (every1 #<procedure 7ffff4ef8e40 at guix/build/gnu-bui…> …)
In guix/build/gnu-build-system.scm:
   847:30 13 (_ _)
In ice-9/eval.scm:
    619:8 12 (_ #(#(#<directory (guile-user) 7ffff5bb9f00>) (# # …) …))
    619:8 11 (_ #(#(#(#<directory (guile-user) 7ffff5bb9f00>) # #) #))
In srfi/srfi-1.scm:
    634:9 10 (for-each #<procedure substitute-one-file (a)> _)
In ice-9/boot-9.scm:
  1736:10  9 (with-exception-handler _ _ #:unwind? _ # _)
In ice-9/ports.scm:
   445:17  8 (call-with-input-file _ _ #:binary _ #:encoding _ # _)
In guix/build/utils.scm:
   741:26  7 (_ _)
   767:26  6 (_ #<input: lib/mix/lib/mix/scm/git.ex 15> #<input-outp…>)
In srfi/srfi-1.scm:
   460:18  5 (fold #<procedure 7ffff5a7c040 at guix/build/utils.scm…> …)
In ice-9/eval.scm:
   202:51  4 (_ #(#(#(#(#(#(#(#<directory (guile-…> …)) …) …) …) …) …))
    163:9  3 (_ #(#(#(#(#(#(#(#<directory (guile-…> …)) …) …) …) …) …))
In unknown file:
           2 (string-append "cmd(\"" #f)
In ice-9/boot-9.scm:
  1669:16  1 (raise-exception _ #:continuable? _)
  1669:16  0 (raise-exception _ #:continuable? _)


In the latest commit the git input has been removed, which might be the issue: http://git.savannah.gnu.org/cgit/guix.git/commit/gnu/packages/elixir.scm?id=a749caa74e2a44a37d3a4af06cf4c18f9e463fbb

Best regards
Oskar
Z
Z
zimoun wrote on 5 Jul 2021 11:51
(name . Oskar Köök)(address . oskar@maatriks.ee)(address . 42760@debbugs.gnu.org)
878s2lks0b.fsf@gmail.com
Hi,

Thanks for the report and sorry for the delay.

On Sat, 08 Aug 2020 at 13:04, Oskar Köök <oskar@maatriks.ee> wrote:

Toggle quote (46 lines)
> Elixir build is failing for me. Don't have time to debug right now. This is
> the log:
>
> phase `unpack' succeeded after 0.2 seconds
> starting phase `make-git-checkout-writable'
> phase `make-git-checkout-writable' succeeded after 0.0 seconds
> starting phase `replace-paths'
> Backtrace:
>           18 (primitive-load "/gnu/store/7wsw0zq6zqvsqpl9g0j6gjanxwm…")
> In ice-9/eval.scm:
>    191:35 17 (_ #f)
> In guix/build/gnu-build-system.scm:
>     838:2 16 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
> In ice-9/boot-9.scm:
>   1736:10 15 (with-exception-handler _ _ #:unwind? _ # _)
> In srfi/srfi-1.scm:
>    857:16 14 (every1 #<procedure 7ffff4ef8e40 at guix/build/gnu-bui…> …)
> In guix/build/gnu-build-system.scm:
>    847:30 13 (_ _)
> In ice-9/eval.scm:
>     619:8 12 (_ #(#(#<directory (guile-user) 7ffff5bb9f00>) (# # …) …))
>     619:8 11 (_ #(#(#(#<directory (guile-user) 7ffff5bb9f00>) # #) #))
> In srfi/srfi-1.scm:
>     634:9 10 (for-each #<procedure substitute-one-file (a)> _)
> In ice-9/boot-9.scm:
>   1736:10  9 (with-exception-handler _ _ #:unwind? _ # _)
> In ice-9/ports.scm:
>    445:17  8 (call-with-input-file _ _ #:binary _ #:encoding _ # _)
> In guix/build/utils.scm:
>    741:26  7 (_ _)
>    767:26  6 (_ #<input: lib/mix/lib/mix/scm/git.ex 15> #<input-outp…>)
> In srfi/srfi-1.scm:
>    460:18  5 (fold #<procedure 7ffff5a7c040 at guix/build/utils.scm…> …)
> In ice-9/eval.scm:
>    202:51  4 (_ #(#(#(#(#(#(#(#<directory (guile-…> …)) …) …) …) …) …))
>     163:9  3 (_ #(#(#(#(#(#(#(#<directory (guile-…> …)) …) …) …) …) …))
> In unknown file:
>            2 (string-append "cmd(\"" #f)
> In ice-9/boot-9.scm:
>   1669:16  1 (raise-exception _ #:continuable? _)
>   1669:16  0 (raise-exception _ #:continuable? _)
>
>
> In the latest commit the git input has been removed, which might be the issue:
> http://git.savannah.gnu.org/cgit/guix.git/commit/gnu/packages/elixir.scm?id=a749caa74e2a44a37d3a4af06cf4c18f9e463fbb

Using Guix 3694c0d on x86_64, now the package elixir seems to build. Is
it fine for you? If yes, let close. Otherwise, please provide more
information. :-)

All the best,
simon
O
O
Oskar Köök wrote on 5 Jul 2021 17:50
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 42760@debbugs.gnu.org)
9766ee46-20ba-4cff-8f4d-346a26b53469@www.fastmail.com
Hi


Oskar
On Mon, 5 Jul 2021, at 12:51, zimoun wrote:
Toggle quote (59 lines)
> Hi,
>
> Thanks for the report and sorry for the delay.
>
> On Sat, 08 Aug 2020 at 13:04, Oskar Köök <oskar@maatriks.ee> wrote:
>
> > Elixir build is failing for me. Don't have time to debug right now. This is
> > the log:
> >
> > phase `unpack' succeeded after 0.2 seconds
> > starting phase `make-git-checkout-writable'
> > phase `make-git-checkout-writable' succeeded after 0.0 seconds
> > starting phase `replace-paths'
> > Backtrace:
> > 18 (primitive-load "/gnu/store/7wsw0zq6zqvsqpl9g0j6gjanxwm…")
> > In ice-9/eval.scm:
> > 191:35 17 (_ #f)
> > In guix/build/gnu-build-system.scm:
> > 838:2 16 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
> > In ice-9/boot-9.scm:
> > 1736:10 15 (with-exception-handler _ _ #:unwind? _ # _)
> > In srfi/srfi-1.scm:
> > 857:16 14 (every1 #<procedure 7ffff4ef8e40 at guix/build/gnu-bui…> …)
> > In guix/build/gnu-build-system.scm:
> > 847:30 13 (_ _)
> > In ice-9/eval.scm:
> > 619:8 12 (_ #(#(#<directory (guile-user) 7ffff5bb9f00>) (# # …) …))
> > 619:8 11 (_ #(#(#(#<directory (guile-user) 7ffff5bb9f00>) # #) #))
> > In srfi/srfi-1.scm:
> > 634:9 10 (for-each #<procedure substitute-one-file (a)> _)
> > In ice-9/boot-9.scm:
> > 1736:10 9 (with-exception-handler _ _ #:unwind? _ # _)
> > In ice-9/ports.scm:
> > 445:17 8 (call-with-input-file _ _ #:binary _ #:encoding _ # _)
> > In guix/build/utils.scm:
> > 741:26 7 (_ _)
> > 767:26 6 (_ #<input: lib/mix/lib/mix/scm/git.ex 15> #<input-outp…>)
> > In srfi/srfi-1.scm:
> > 460:18 5 (fold #<procedure 7ffff5a7c040 at guix/build/utils.scm…> …)
> > In ice-9/eval.scm:
> > 202:51 4 (_ #(#(#(#(#(#(#(#<directory (guile-…> …)) …) …) …) …) …))
> > 163:9 3 (_ #(#(#(#(#(#(#(#<directory (guile-…> …)) …) …) …) …) …))
> > In unknown file:
> > 2 (string-append "cmd(\"" #f)
> > In ice-9/boot-9.scm:
> > 1669:16 1 (raise-exception _ #:continuable? _)
> > 1669:16 0 (raise-exception _ #:continuable? _)
> >
> >
> > In the latest commit the git input has been removed, which might be the issue:
> > http://git.savannah.gnu.org/cgit/guix.git/commit/gnu/packages/elixir.scm?id=a749caa74e2a44a37d3a4af06cf4c18f9e463fbb
>
> Using Guix 3694c0d on x86_64, now the package elixir seems to build. Is
> it fine for you? If yes, let close. Otherwise, please provide more
> information. :-)
>
> All the best,
> simon
>
Attachment: file
Z
Z
zimoun wrote on 5 Jul 2021 17:53
(name . Oskar Köök)(address . oskar@maatriks.ee)(address . 42760-done@debbugs.gnu.org)
CAJ3okZ0v876np28uceNiB+UMZLAyof8AkPFFuENLi5JTkBkFGw@mail.gmail.com
Hi,

On Mon, 5 Jul 2021 at 17:50, Oskar Köök <oskar@maatriks.ee> wrote:

Toggle quote (2 lines)
Thanks. So closing. :-)

Cheers,
simon
Closed
?