[PATCH 1/2] gnu: android: export android-libcutils

  • Done
  • quality assurance status badge
Details
2 participants
  • Denis 'GNUtoo' Carikli
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Denis 'GNUtoo' Carikli
Severity
normal
D
D
Denis 'GNUtoo' Carikli wrote on 1 Aug 2020 22:16
(address . guix-patches@gnu.org)
20200801201625.27996-1-GNUtoo@cyberdimension.org
Android's libcutils is used by many Android components, and as Guix can be
used to bulid Android components, it is useful to export it as it can then
be reused as an input to packages being developped outside of the Guix
source code repository.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
gnu/packages/android.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 0fb4330d3e..af2b817298 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -229,7 +229,7 @@ in Main, System, Radio and Events sub-logs.")
various Android core host applications.")
(license license:asl2.0)))
-(define android-libcutils
+(define-public android-libcutils
(package
(name "android-libcutils")
(version (android-platform-version))
--
2.28.0
M
M
Mathieu Othacehe wrote on 3 Aug 2020 09:16
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
87h7tkurlr.fsf@gnu.org
Hello,

Toggle quote (5 lines)
> Android's libcutils is used by many Android components, and as Guix can be
> used to bulid Android components, it is useful to export it as it can then
> be reused as an input to packages being developped outside of the Guix
> source code repository.

This looks fine. I pushed those two patches with edited commit
messages. For future reference, very similar patches can be send in the
same serie :).

Thanks,

Mathieu
Closed
D
D
Denis 'GNUtoo' Carikli wrote on 5 Aug 2020 08:20
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
20200805082031.5f965503@primarylaptop.localdomain
On Mon, 03 Aug 2020 09:16:16 +0200
Mathieu Othacehe <othacehe@gnu.org> wrote:

Toggle quote (1 lines)
> Hello,
Hi,

Toggle quote (2 lines)
> This looks fine. I pushed those two patches with edited commit
> messages.
Thanks a lot. I'll probably have more patches that I need to send it
soon but I need to find a faster way to test them.

Toggle quote (3 lines)
> For future reference, very similar patches can be send in
> the same serie :).

How do I do that? I used the following command to send the patch:
Toggle quote (7 lines)
> git send-email --to="guix-patches@gnu.org" \
> --cc="Julien Lepiller <julien@lepiller.eu>" \
> --cc="Danny Milosavljevic <dannym@scratchpost.org>" \
> 0001-gnu-android-export-android-libcutils.patch \
> 0002-gnu-android-export-android-liblog.patch \
> ${sentinel}

Do I need to use --compose?

Denis.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAl8qT68ACgkQX138wUF3
4mMMuBAAqTxYJyG0mvOg5PTLb0YQLJLhYG9YWgL7IOLrWlgSWLb3jJij/np8ybzT
nKVec/ZzTXN92/MdcYEU2SQNcbfoeoLtJ5lJF8c/167O5y8aeHuaIpjp0Pe0ET4n
lCAYXSBPr/LIirG77XxTXxFGXv3Bg9gDxbDAlefELBJlGjqUHhjCsWOw8B20Itk8
TU0dOaLpgYCIHxhUHIROJ3KvQ0ioBpxv5An3lndZaVGEF5CjkhSghyfRgHSIcyXw
4fEuqOCdOVlCvQ+crGrGDOhQh6hL9UcNrlq4TVQD6SsgI+EygzwUF/d3kEQu3J5V
nwBV6n5K/P2Z+0NQik5sVgLuRCTd7c6XYpvRWBHg6tEEbxxBVaUf5czYHGehhuAi
hM2ST7NVM4g8mpmAlIYv3ILvDALnuTbkKp4zKJCpjeNQPOCpA+xqAX2JJZp96+VS
5IIKzLcrNCzH2n2ETC2PnQuYmYdlvhIM+N9PuwbgFHKEFD8k//bkjSK2rqXgsEPt
6wSZJVjjX3I7nLer9HswMeqOGEf3Q0m+dxWsFDpwXOVcmxbdifCjj7x8xRAnolkg
dDrRw5s9jLKaourkKr3oFMGHFQ/Z6uNBdwiJiigU7CoT4TjYE8jzhipZd9fabJuL
ucdeVPqBVrT2sjV++q5gw3uQxFcURRZp8bOMndpmCLNE1XgzdHM=
=Djz+
-----END PGP SIGNATURE-----


Closed
M
M
Mathieu Othacehe wrote on 5 Aug 2020 09:40
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
87r1sl35hy.fsf@gnu.org
Hello,

Toggle quote (8 lines)
> How do I do that? I used the following command to send the patch:
>> git send-email --to="guix-patches@gnu.org" \
>> --cc="Julien Lepiller <julien@lepiller.eu>" \
>> --cc="Danny Milosavljevic <dannym@scratchpost.org>" \
>> 0001-gnu-android-export-android-libcutils.patch \
>> 0002-gnu-android-export-android-liblog.patch \
>> ${sentinel}

Each time a mail is sent to "guix-patches@gnu.org" a new bug ticket is
created. You should first send either the cover letter or the first
patch, and then send all the subsequent patches to NNN@debbugs.gnu.org
where NNN is the ticket number created when the first patch is sent.

See the bottom of
further explications.

Thanks,

Mathieu
Closed
D
D
Denis 'GNUtoo' Carikli wrote on 5 Aug 2020 11:11
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
20200805111149.47b1ef9c@primarylaptop.localdomain
On Wed, 05 Aug 2020 09:40:25 +0200
Mathieu Othacehe <othacehe@gnu.org> wrote:
Toggle quote (8 lines)
> Each time a mail is sent to "guix-patches@gnu.org" a new bug ticket is
> created. You should first send either the cover letter or the first
> patch, and then send all the subsequent patches to NNN@debbugs.gnu.org
> where NNN is the ticket number created when the first patch is sent.
>
> See the bottom of
> https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html for
> further explications.
Thanks a lot.

I read that part in the manual some time ago but I didn't think of
(ab)using it in this way to get the intended result.

Denis.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAl8qd9YACgkQX138wUF3
4mM8DRAAlFZuQEloePjb2TkGi5fwN6I8j8VHD+gUrE0Pu3RX8pWsMA2z+w2raO62
8YpcBcAiqjmo78DN5Usjqht8bvvCvLrmLQUe6FSOQzhfKwcfyIZfTG44Y2uN70v+
On9KcLrUofCy8O/D2HgjXzhVrro07yUqgjxrB4v3Qt3a+9CPPwOTVwXsP7GWopGv
gC9MYrGY8PeDsULdkSZxeJHIfIZex8PyMTmJnFT1YGdpSdXfLZehw9BqV3N9TIJX
yrEHpSvd4N6I8KzZykAp6fAukdxCJmvpGr9SIaZmJxDco8o33ALcMi6owFHaC5VQ
vP4r8jNFwOBJW/J+y/z09dndnaPlTfUlGEYsVT4OkyGIn8pBQ+8u1ir6KMxc+q/Q
qh7ym4WtFFVmdrn0ujexQebd10Gn+CJdgqItvuPBlFiB63VvOKKz655zX0LRcp0F
Rj2amW/bROpEDI8FG/ovm32LVlxxrjaT9MBoYcyMNeEOONkubt1C0TymqXjEmK6y
xzM7O0VwAA+iioIzvWPMtS7R2wuunRUhn2ef78gVEjOZcqT347kXwP13sgt3vU/D
UxPhNcRKLqpzA+fQb6V+NAm5qUJ2WxS2ri50djGw90VelInqG4zdKLu1WesZbu4P
dh1Ax3Hf1vNnC6YVOYgpGMiebTjFPtGStBwStHgPglxtN9WucwA=
=NM0E
-----END PGP SIGNATURE-----


Closed
?