guix.gnu.org/videos don't play on iOS

  • Open
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Tobias Geerinckx-Rice
Severity
normal
T
T
Tobias Geerinckx-Rice wrote on 30 Jul 2020 01:08
(address . bug-guix@gnu.org)
87eeotaphb.fsf@nckx
Guix,

A sympathetic PotentialUser reported that they were unable to play
any of our home-page videos on their iPad. Even Firefox didn't
work.

Leo pointed out that we use the VP9 and Opus codecs — both of
which are still not supported by Apple[0][1]. Nor is Vorbis.

nginx can easily sniff iOS/Macintosh user agents and serve them an
inferior format to match, such as h264 with MP3 audio, which can
both be encoded using free software in Guix.

Kind regards,

T G-R

-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXyIBgAAKCRANsP+IT1Vt
eULsAQC3xTNDtL822fFEtoU98CjGbAvZPAg/9jL+jUP8KjNrewD9HoKDxaOGOHZA
zl5OQ3AcXD7ffuUvtDBbcQujsQZkOwY=
=F6hJ
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 30 Jul 2020 01:26
(name . Tobias Geerinckx-Rice via Bug reports for GNU Guix)(address . bug-guix@gnu.org)(address . 42607@debbugs.gnu.org)
20200729232657.GA15458@jasmine.lan
On Thu, Jul 30, 2020 at 01:08:48AM +0200, Tobias Geerinckx-Rice via Bug reports for GNU Guix wrote:
Toggle quote (4 lines)
> nginx can easily sniff iOS/Macintosh user agents and serve them an inferior
> format to match, such as h264 with MP3 audio, which can both be encoded
> using free software in Guix.

Here is where the videos are created:


------
$(NUMBER).clino.$(VIDEO).webm: \
$(VIDEO)/$(LOCALE_LANG)/durations.txt \
$(VIDEO)/$(LOCALE_LANG)/audios/all.mp3
ffmpeg -y -f concat -vsync cfr \
-i $(VIDEO)/$(LOCALE_LANG)/durations.txt \
-i $(VIDEO)/$(LOCALE_LANG)/audios/all.mp3 \
-c:a libopus -b:a 192k \
-c:v libvpx-vp9 -crf 31 -b:v 0 -pix_fmt yuv420p \
-af apad -shortest \
-vf fps=25 -threads 4 $(VIDEO)/$(LOCALE_LANG)/videos/$@;
make clean_noCli
------

So, we'd need to add a target that did "-c:a copy -c:v libx264" and add
some logic to create two videos instead of one. I didn't look into it
closely yet to see if that will be simple or not.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl8iBb0ACgkQJkb6MLrK
fwh5YA//TUSm5701kJ9m/eoHutwN3fkf/WlhrAM9MryVtgLVPTY6R0/lgucFWBD1
K63Hxd/QyzeoXpcpSkOT5cjepNhl0mPgOmeAMUbZyUbB/4aqY+urD0dODEH1ftLS
V1V4HzTyQNfMZbccAf0D5vPsESEx+RTXHFBrOvUit43DYz/vVNCsCpWOrqD3lgrU
lGbutGywiL+dFjTiub3Af3t/ZtlfTYO+nM8WpxGmnHTEdwNOKE3PotINn2j7brMM
qJdJWSDXYRngjMypflx+ttHlDHhQFLIrpir2EMMJ9W/kuL2oS2+ycnL4LPrDA8k+
XB+G1YTvs+eG/NdRy4ygvwXtnEhPiIrUPpAuSVpQCX/1OHRt/1FIWK1h4OSDTDYL
94Fc/lPmaV2s8zIX4U4nfbjupOHMMcOL6CffAswmNCHYaVdzTQrBBiO5cCWj7yld
C1SBS5nHN21v+PwRr6mh5xdG6SsONOa+m8zdlR2LGFuoIerej4YBKT+VUtUSfgv4
BpUeRaNjDwoOgKjgzFmMY8xZxFxhd3Tk22H4ZKnFSIJPhysskLUGRmbRZ1tAu708
iyPGHDXQIhmUiLdRlJI3uUP/chtIBAWrxyvsU3mFdnfDSEVsLlIJJOgAGy9c8Rw9
iBlWIxIo6laCMYQ1G47j7tPd9a+Me/8EycrELzZh/n0XIWvBaE4=
=o6IO
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 1 Feb 2021 21:54
(name . Tobias Geerinckx-Rice via Bug reports for GNU Guix)(address . bug-guix@gnu.org)(address . 42607@debbugs.gnu.org)
YBhqakLJgkRwDZQk@jasmine.lan
On Wed, Jul 29, 2020 at 07:26:57PM -0400, Leo Famulari wrote:
Toggle quote (26 lines)
> > nginx can easily sniff iOS/Macintosh user agents and serve them an inferior
> > format to match, such as h264 with MP3 audio, which can both be encoded
> > using free software in Guix.
>
> Here is where the videos are created:
>
> https://git.savannah.gnu.org/cgit/guix/videos.git/tree/Makefile
>
> ------
> $(NUMBER).clino.$(VIDEO).webm: \
> $(VIDEO)/$(LOCALE_LANG)/durations.txt \
> $(VIDEO)/$(LOCALE_LANG)/audios/all.mp3
> ffmpeg -y -f concat -vsync cfr \
> -i $(VIDEO)/$(LOCALE_LANG)/durations.txt \
> -i $(VIDEO)/$(LOCALE_LANG)/audios/all.mp3 \
> -c:a libopus -b:a 192k \
> -c:v libvpx-vp9 -crf 31 -b:v 0 -pix_fmt yuv420p \
> -af apad -shortest \
> -vf fps=25 -threads 4 $(VIDEO)/$(LOCALE_LANG)/videos/$@;
> make clean_noCli
> ------
>
> So, we'd need to add a target that did "-c:a copy -c:v libx264" and add
> some logic to create two videos instead of one. I didn't look into it
> closely yet to see if that will be simple or not.

Coming back to this, I don't remember why I suggested "c:a copy". We
would want to transcode the audio as well, because the standard codec is
h264/aac.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmAYamoACgkQJkb6MLrK
fwhujQ//VvY9OxbvtD8WedMI+vrZqf42mT6yBUrH6uCW6GsihZ9YIBnHXc+wbSty
5ha/Pdlzowme6hVn9CPXBsZ0AoKv/N7AZh8/XwTBnDo17u0O0GjgWNVgK84d+s5n
8jHt7kHSn8aXolNbvPr3mpFPAj66rbxLOKy85MGXURrGyJYYFufwOrRuhavyJ7uG
zyOc7/QA6K9gkp6ohxq6xvcjG4w0JrpVVJNfGbC4bEQ0M0HAtyvEo6l6LDxiOQiK
p3pn36MbFSgQkhZsgdI8TpG47YSbpLi9nKFsqx3XQD/2NJRuUl+HIBGMkg230sfj
m0EflvgvuD3e2MQ1mfdd8xdT9nLmWyorMZd+nDFGia+8yb8MMcob5knsIk0KPh3F
51tPz8xED7SrFWmNS3wnuJ5zKiBJMbKJ2O28G1o+C01l63Y49HTf92w5C+pD7Lu7
LknZrU9ISPVFXCGLuZb/I8SVd8sdEVxzlN6b9q2bb/4ZBFhkvdyQDnb2Jko67zlf
ylaZlJr8E8bl+Vc/MrITELrGdg2Ur5H5EOWJKy1TNj/enQmpgNFe+phGeAYs6lrE
wn52vICZzpEFBEaZ4U6aCXhrr/a2xxBByse19+VmcsMRzNeXIWoM5nf5ehfx80Xa
04o7gZfxPbquR2+T6EPxINP6M66GZ64cUqZTVm048YUvqscjVe4=
=gmRK
-----END PGP SIGNATURE-----


?