arm-none-eabi-toolchain fails to build

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Mathieu Othacehe
  • Jan Wielkiewicz
Owner
unassigned
Submitted by
Jan Wielkiewicz
Severity
normal
J
J
J
Jan Wielkiewicz wrote on 27 Jul 2020 18:39
(address . 42561@debbugs.gnu.org)
20200727183817.3cfa8e71@interia.pl
I think I fixed it, but someone needs to check it.
I looked at this issue as inspiration: https://issues.guix.gnu.org/41210
Now the package compiles, but it didn't fail yet, so it might be the
fix!
That's what I did:

index e3a9017ba5..c7b8fcc0ce 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -251,7 +251,7 @@ usable on embedded products.")
(origin-patches (package-source gcc-7))
(search-patches
"gcc-7-cross-environment-variables.patch"))))) (native-inputs
- `(("gcc@5" ,gcc-5)
+ `(("gcc@7" ,gcc-7)
("flex" ,flex)
("isl" ,isl-0.18)
,@(alist-delete "isl" (package-native-inputs xgcc))))



Jan Wielkiewicz
E
E
Efraim Flashner wrote on 28 Jul 2020 09:00
(name . Jan Wielkiewicz)(address . tona_kosmicznego_smiecia@interia.pl)(address . 42561@debbugs.gnu.org)
20200728070044.GC1151@E5400
On Mon, Jul 27, 2020 at 06:39:11PM +0200, Jan Wielkiewicz wrote:
Toggle quote (19 lines)
> I think I fixed it, but someone needs to check it.
> I looked at this issue as inspiration: https://issues.guix.gnu.org/41210
> Now the package compiles, but it didn't fail yet, so it might be the
> fix!
> That's what I did:
>
> index e3a9017ba5..c7b8fcc0ce 100644
> --- a/gnu/packages/embedded.scm
> +++ b/gnu/packages/embedded.scm
> @@ -251,7 +251,7 @@ usable on embedded products.")
> (origin-patches (package-source gcc-7))
> (search-patches
> "gcc-7-cross-environment-variables.patch"))))) (native-inputs
> - `(("gcc@5" ,gcc-5)
> + `(("gcc@7" ,gcc-7)
> ("flex" ,flex)
> ("isl" ,isl-0.18)
> ,@(alist-delete "isl" (package-native-inputs xgcc))))

The default gcc is already gcc@7. I'm test building it now with flex and
package-native-inputs xgcc. That gets the "correct" isl for gcc@7.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8fzRkACgkQQarn3Mo9
g1HohBAAmHirTJF2XlWOQigbveKE8sOEUGsv0jNCeFLEo2QHu+BMwHZhBjttryt2
4/x7cw4wB19jqnh1jzPHObu86O1KC53TUO2cn4hEBj7XduW95vv13qYxVAnQvxqv
JVYS//swSCX63eVHMmLVvl/kPbv7a4tuY0STitAPYwVoutm1rKcme8DVI/K2AYXr
IE2Ka24hszGqIxyQEypAdsvjgMDg2HgJAfvmaEJlbXs3pFNjskOqJaVPJQ5K7b/K
KC+lFPu7qTBu46VbP9iS1IrtTHk9V2ODfSidi071qYYLYL6MJcclGPiygkaogbXD
rYqt+YLJvmQXvvII3gvjU3a0AeFgwrHODIt/fWmYguUCEHYY4eRW0+1I3ak1Vqzf
797DMzlOMFT9eGs7pTnFaD0w6voDo2bVCO+9850i3uTSpFRtUc2xj7JxuTFoAeT2
Lz5vf0DBi/HWVa4Wcc6tta7LGUXeDcYYxlKCZFQM8MDhiaEGESk8jKIJah7jxNT0
upvpwxqBG78jr5kWfFNFfuiuxVgnylTFCh32T3fCMONjX5MgVCxUz2cZ5xU0U5ZT
7eqBirJexWDY+UwS4qBcZcDxg8FfzI3NFn2r8vMG8MvWLL0gZGawkoGKee4ca8yD
5iPh3PiE4+PoHgyJthWT93yFHXmuOfp8zqyCOxyAVaAZ6ZfRyuQ=
=m5JK
-----END PGP SIGNATURE-----


M
M
Mathieu Othacehe wrote on 30 Jul 2020 17:08
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87ime582hc.fsf@gnu.org
Closing this one, thanks to both of you!

Mathieu
Closed
?