[PATCH] doc: Fix texinfo identifiers in Version Control Services.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 5 Jul 2020 10:51
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20200705085156.9488-1-arunisaac@systemreboot.net
* doc/guix.texi (Version Control Services): Use @code, @file, @indicateurl
texinfo identifiers correctly.
---
doc/guix.texi | 45 +++++++++++++++++++++++----------------------
1 file changed, 23 insertions(+), 22 deletions(-)

Toggle diff (92 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index ce17c2de8e..e9f99de0ef 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -52,7 +52,7 @@ Copyright @copyright{} 2017, 2019, 2020 Maxim Cournoyer@*
Copyright @copyright{} 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice@*
Copyright @copyright{} 2017 George Clemmer@*
Copyright @copyright{} 2017 Andy Wingo@*
-Copyright @copyright{} 2017, 2018, 2019 Arun Isaac@*
+Copyright @copyright{} 2017, 2018, 2019, 2020 Arun Isaac@*
Copyright @copyright{} 2017 nee@*
Copyright @copyright{} 2018 Rutger Helling@*
Copyright @copyright{} 2018 Oleg Pykhalov@*
@@ -24926,39 +24926,40 @@ access to exported@footnote{By creating the magic file
Data type representing the configuration for @code{git-daemon-service}.
@table @asis
-@item @code{package} (default: @var{git})
+@item @code{package} (default: @code{git})
Package object of the Git distributed version control system.
-@item @code{export-all?} (default: @var{#f})
+@item @code{export-all?} (default: @code{#f})
Whether to allow access for all Git repositories, even if they do not
have the @file{git-daemon-export-ok} file.
@item @code{base-path} (default: @file{/srv/git})
Whether to remap all the path requests as relative to the given path.
-If you run git daemon with @var{(base-path "/srv/git")} on example.com,
-then if you later try to pull @code{git://example.com/hello.git}, git
-daemon will interpret the path as @code{/srv/git/hello.git}.
+If you run git daemon with @code{(base-path "/srv/git")} on example.com,
+then if you later try to pull @indicateurl{git://example.com/hello.git},
+git daemon will interpret the path as @file{/srv/git/hello.git}.
-@item @code{user-path} (default: @var{#f})
+@item @code{user-path} (default: @code{#f})
Whether to allow @code{~user} notation to be used in requests. When
-specified with empty string, requests to @code{git://host/~alice/foo} is
-taken as a request to access @code{foo} repository in the home directory
-of user @code{alice}. If @var{(user-path "path")} is specified, the
-same request is taken as a request to access @code{path/foo} repository
-in the home directory of user @code{alice}.
-
-@item @code{listen} (default: @var{'()})
+specified with empty string, requests to
+@indicateurl{git://host/~alice/foo} is taken as a request to access
+@code{foo} repository in the home directory of user @code{alice}. If
+@code{(user-path "path")} is specified, the same request is taken as a
+request to access @file{path/foo} repository in the home directory of
+user @code{alice}.
+
+@item @code{listen} (default: @code{'()})
Whether to listen on specific IP addresses or hostnames, defaults to
all.
-@item @code{port} (default: @var{#f})
+@item @code{port} (default: @code{#f})
Whether to listen on an alternative port, which defaults to 9418.
-@item @code{whitelist} (default: @var{'()})
+@item @code{whitelist} (default: @code{'()})
If not empty, only allow access to this list of directories.
-@item @code{extra-options} (default: @var{'()})
-Extra options will be passed to @code{git daemon}, please run
+@item @code{extra-options} (default: @code{'()})
+Extra options will be passed to @command{git daemon}, please run
@command{man git-daemon} for more information.
@end table
@@ -24990,14 +24991,14 @@ Package object of the Git distributed version control system.
@item @code{git-root} (default: @file{/srv/git})
Directory containing the Git repositories to expose to the world.
-@item @code{export-all?} (default: @var{#f})
+@item @code{export-all?} (default: @code{#f})
Whether to expose access for all Git repositories in @var{git-root},
even if they do not have the @file{git-daemon-export-ok} file.
@item @code{uri-path} (default: @file{/git/})
-Path prefix for Git access. With the default @code{/git/} prefix, this
-will map @code{http://@var{server}/git/@var{repo}.git} to
-@code{/srv/git/@var{repo}.git}. Requests whose URI paths do not begin
+Path prefix for Git access. With the default @file{/git/} prefix, this
+will map @indicateurl{http://@var{server}/git/@var{repo}.git} to
+@file{/srv/git/@var{repo}.git}. Requests whose URI paths do not begin
with this prefix are not passed on to this Git instance.
@item @code{fcgiwrap-socket} (default: @code{127.0.0.1:9000})
--
2.26.2
N
N
Nicolas Goaziou wrote on 6 Jul 2020 14:43
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 42214@debbugs.gnu.org)
87a70c7r1b.fsf@nicolasgoaziou.fr
Hello,

Arun Isaac <arunisaac@systemreboot.net> writes:

Toggle quote (3 lines)
> * doc/guix.texi (Version Control Services): Use @code, @file, @indicateurl
> texinfo identifiers correctly.

Thank you. Some nit-picking follows.

Toggle quote (2 lines)
> +If you run git daemon with @code{(base-path "/srv/git")} on example.com,

Git daemon

or

@command{git daemon}

and

@samp{example.com}

Toggle quote (5 lines)
> +specified with empty string, requests to
> +@indicateurl{git://host/~alice/foo} is taken as a request to access
> +@code{foo} repository in the home directory of user @code{alice}. If
> +@code{(user-path "path")} is specified, the same request is taken as a

Maybe

@code{(user-path "@var{path}")}

Toggle quote (2 lines)
> +request to access @file{path/foo} repository in the home directory of

and then @samp{@var{path}/foo}

Toggle quote (2 lines)
> +Path prefix for Git access. With the default @file{/git/} prefix, this

@samp{/git/}

Toggle quote (3 lines)
> +will map @indicateurl{http://@var{server}/git/@var{repo}.git} to
> +@file{/srv/git/@var{repo}.git}. Requests whose URI paths do not begin

In any case, it looks good.

Regards,
--
Nicolas Goaziou
A
A
Arun Isaac wrote on 6 Jul 2020 17:53
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 42214-done@debbugs.gnu.org)
87fta4abcv.fsf@systemreboot.net
Pushed with suggested changes, thanks for the review!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl8DSQAACgkQLiXui2GA
K7NPbgf9E6uuj7ag0x6CnT1xKmjjiGx3bbkPhKcOiJof7fa3ON8vPwoBFIp9GOGJ
91u/5n00k/SbxnBOQH7vksq+LpJkpuXLi2hyb+vvM9nflOOWl2zbUGleyAtkOdEJ
AD1RhBtEt4dbkZaOcfBOweqYlfdFL5JVnSL/2hBPmbUB/y3G00JhbYeIbDEdPXkY
wygMATYZebwwj/BcJwGh+5X6fANXzIlYzMeogDcT8NeWmCqh+iS46PbHWHkbiYBP
YT3gJKkV5HZvgKJY35zt2htiCOhTnG9boLFjHacvSjysZLd5gJz4g4mt996+Nn2z
VAywRZo6+AT2OTOM/Z837LEZF4LnvQ==
=Au3p
-----END PGP SIGNATURE-----

Closed
?