[PATCH] discovery: Fix typo.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 5 Jul 2020 00:16
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20200704221613.3939-1-arunisaac@systemreboot.net
* guix/discovery.scm (fold-module-public-variables*): In the docstring,
replace (PROC MODULE SYMBOL VARIABLE) with (PROC MODULE SYMBOL VARIABLE
RESULT).
---
guix/discovery.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (19 lines)
diff --git a/guix/discovery.scm b/guix/discovery.scm
index 7c5fed7f0e..b84b9ff370 100644
--- a/guix/discovery.scm
+++ b/guix/discovery.scm
@@ -153,9 +153,9 @@ SUB-DIRECTORY. Modules are listed in the order they appear on the path."
(reverse (fold-modules cons '() path #:warn warn)))
(define (fold-module-public-variables* proc init modules)
- "Call (PROC MODULE SYMBOL VARIABLE) for each variable exported by one of MODULES,
-using INIT as the initial value of RESULT. It is guaranteed to never traverse
-the same object twice."
+ "Call (PROC MODULE SYMBOL VARIABLE RESULT) for each variable exported by one
+of MODULES, using INIT as the initial value of RESULT. It is guaranteed to
+never traverse the same object twice."
;; Here SEEN is populated by variables; if two different variables refer to
;; the same object, we still let them through.
(identity ;discard second return value
--
2.26.2
M
M
Mathieu Othacehe wrote on 5 Jul 2020 10:00
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 42205@debbugs.gnu.org)
87pn9ajsr6.fsf@gnu.org
Hey,

Toggle quote (11 lines)
> (define (fold-module-public-variables* proc init modules)
> - "Call (PROC MODULE SYMBOL VARIABLE) for each variable exported by one of MODULES,
> -using INIT as the initial value of RESULT. It is guaranteed to never traverse
> -the same object twice."
> + "Call (PROC MODULE SYMBOL VARIABLE RESULT) for each variable exported by one
> +of MODULES, using INIT as the initial value of RESULT. It is guaranteed to
> +never traverse the same object twice."
> ;; Here SEEN is populated by variables; if two different variables refer to
> ;; the same object, we still let them through.
> (identity ;discard second return value

This looks fine. Do not hesitate to proceed without reviewing for those
typo fixing patches :).

Thanks for your patch,

Mathieu
A
A
Arun Isaac wrote on 5 Jul 2020 12:40
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 42205-done@debbugs.gnu.org)
871rlqutww.fsf@systemreboot.net
Toggle quote (3 lines)
> This looks fine. Do not hesitate to proceed without reviewing for those
> typo fixing patches :).

Ok, thanks! :-) Pushed to master.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl8Brg8ACgkQLiXui2GA
K7ObSggAkG6hUTAsnY+8QiB+W1wLfVKa0j1o2Ms+/11cPFkFYvZtzDteD8HanXHm
Swkc0eS3wwFZ2Wh+qerpGOfgPAqCPsKCYmBiXTcdATWyZMKn8JbYKQP4fdINyGlp
J9yNp4exSlCj4wJqiCSFYwHe6eFxkDQiczAgOm6P/vnRZdnkLfcQMhGyHH30GDZ0
ALXEQW74Z61v+Pr+GCbA0CPvQAe/4M13zc6zt+CEzytyrIhlFCsflXZdFNHR5wXx
IGyt/X1TjDRikiL7uOUdfFnDY/5qk4y9mn6YojWZofqjDKurZ4yy0aP6PBdtdBsJ
0TpWsomou5TEZGdhDyW4Lk8iYdULPg==
=7R6w
-----END PGP SIGNATURE-----

Closed
?