[PATCH] gnu: Add r-fhtest and its dependencies

  • Done
  • quality assurance status badge
Details
2 participants
  • Lo Peter
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Lo Peter
Severity
normal
L
L
Lo Peter wrote on 29 Jun 2020 10:02
(address . guix-patches@gnu.org)
CAEM+zmjKA6w9w3vp39LpMgaCaQrUsJVWkAbN-0cah+7yBdMtnA@mail.gmail.com
Dear all,

I am submitting a patch series for r-fhtest and its dependencies.
Note that one of its dependency r-kmsurv is not included here, because
I previously submitted its patch in patch 2 of bug#42107.

Regards,
Peter
P
P
Peter Lo wrote on 29 Jun 2020 10:03
[PATCH 1/5] gnu: Add r-icens.
(address . 42119@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629080340.13200-1-peterloleungyau@gmail.com
* gnu/packages/bioconductor.scm (r-icens): New variable.
---
gnu/packages/bioconductor.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 002f4a0edb..763c219d9e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8117,3 +8117,26 @@ dimensional mass cytometry data.")
Tool) analysis automatic by constructing a HTTP POST request according to
user's input and automatically retrieving results from GREAT web server.")
(license license:expat)))
+
+(define-public r-icens
+ (package
+ (name "r-icens")
+ (version "1.60.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Icens" version))
+ (sha256
+ (base32
+ "0fh7wgkrw20f61p06i87nccnbig9wv4m0jcg7cx1rw7g2ndnabgp"))))
+ (properties `((upstream-name . "Icens")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-survival" ,r-survival)))
+ (home-page
+ "https://bioconductor.org/packages/release/bioc/html/Icens.html")
+ (synopsis
+ "NPMLE for Censored and Truncated Data")
+ (description
+ "Many functions for computing the NPMLE for censored and
+truncated data.")
+ (license license:artistic2.0)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 10:03
[PATCH 2/5] gnu: Add r-mlecens.
(address . 42119@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629080340.13200-2-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-mlecens): New variable.
---
gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab5e57c0e2..8be110a9bd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22325,3 +22325,32 @@ across a wide array of bioinformatic R packages.")
and clustering large sequence datasets using fast alignment-free k-mer
counting and recursive k-means partitioning.")
(license license:gpl3)))
+
+(define-public r-mlecens
+ (package
+ (name "r-mlecens")
+ (version "0.1-4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "MLEcens" version))
+ (sha256
+ (base32
+ "0zlmrcjraypscgs2v0w4s4hm7qccsmaz4hjsgqpn0058vx622945"))))
+ (properties `((upstream-name . "MLEcens")))
+ (build-system r-build-system)
+ (home-page "http://stat.ethz.ch/~maathuis/")
+ (synopsis
+ "Computation of the MLE for bivariate (interval) censored data")
+ (description
+ "This package contains functions to compute the nonparametric
+maximum likelihood estimator (MLE) for the bivariate distribution
+of (X,Y), when realizations of (X,Y) cannot be observed directly. To
+be more precise, we consider the situation where we observe a set of
+rectangles that are known to contain the unobservable realizations
+of (X,Y). We compute the MLE based on such a set of rectangles. The
+methods can also be used for univariate censored data (see data set
+@code{cosmesis}), and for censored data with competing risks (see data
+set @code{menopause}). We also provide functions to visualize the
+observed data and the MLE.")
+ (license license:gpl2+)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 10:03
[PATCH 3/5] gnu: Add r-perm.
(address . 42119@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629080340.13200-3-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-perm): New variable.
---
gnu/packages/cran.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8be110a9bd..fe1a8e0b46 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22354,3 +22354,24 @@ methods can also be used for univariate censored data (see data set
set @code{menopause}). We also provide functions to visualize the
observed data and the MLE.")
(license license:gpl2+)))
+
+(define-public r-perm
+ (package
+ (name "r-perm")
+ (version "1.0-0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "perm" version))
+ (sha256
+ (base32
+ "0075awl66ynv10vypg63fcxk33qzvxddrp8mi4w08ysvimcyxijk"))))
+ (properties `((upstream-name . "perm")))
+ (build-system r-build-system)
+ (home-page
+ "https://cran.r-project.org/web/packages/perm/")
+ (synopsis
+ "Exact or Asymptotic permutation tests")
+ (description
+ "Perform Exact or Asymptotic permutation tests")
+ (license (list license:gpl2+ license:gpl3+))))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 10:03
[PATCH 4/5] gnu: Add r-interval.
(address . 42119@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629080340.13200-4-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-interval): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fe1a8e0b46..d3cd199130 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22375,3 +22375,30 @@ observed data and the MLE.")
(description
"Perform Exact or Asymptotic permutation tests")
(license (list license:gpl2+ license:gpl3+))))
+
+(define-public r-interval
+ (package
+ (name "r-interval")
+ (version "1.1-0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "interval" version))
+ (sha256
+ (base32
+ "1lln9jkli28i4wivwzqrsxvv2n15560f7msjy5gssrm45vxrxms8"))))
+ (properties `((upstream-name . "interval")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-icens" ,r-icens)
+ ("r-mlecens" ,r-mlecens)
+ ("r-perm" ,r-perm)
+ ("r-survival" ,r-survival)))
+ (home-page
+ "https://cran.r-project.org/web/packages/interval/")
+ (synopsis
+ "Weighted Logrank Tests and NPMLE for interval censored data")
+ (description
+ "This package provides functions to fit nonparametric survival
+curves, plot them, and perform logrank or Wilcoxon type tests.")
+ (license license:gpl2+)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 10:03
[PATCH 5/5] gnu: Add r-fhtest.
(address . 42119@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629080340.13200-5-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-fhtest): New variable.
---
gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d3cd199130..3d02139f87 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22402,3 +22402,34 @@ observed data and the MLE.")
"This package provides functions to fit nonparametric survival
curves, plot them, and perform logrank or Wilcoxon type tests.")
(license license:gpl2+)))
+
+(define-public r-fhtest
+ (package
+ (name "r-fhtest")
+ (version "1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "FHtest" version))
+ (sha256
+ (base32
+ "1wsn0j9ydpp9nfswiqg21p09kgkvaq8fh0y0h8syqgizah7i8vs2"))))
+ (properties `((upstream-name . "FHtest")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-interval" ,r-interval)
+ ("r-kmsurv" ,r-kmsurv)
+ ("r-mass" ,r-mass)
+ ("r-perm" ,r-perm)
+ ("r-survival" ,r-survival)))
+ (home-page
+ "https://cran.r-project.org/web/packages/FHtest/")
+ (synopsis
+ "Tests for Survival Data Based on the Fleming-Harrington Class")
+ (description
+ "This package provides functions to compare two or more survival
+curves with: a) The Fleming-Harrington test for right-censored data
+based on permutations and on counting processes. b) An extension of
+the Fleming-Harrington test for interval-censored data based on a
+permutation distribution and on a score vector distribution.")
+ (license license:gpl2+)))
--
2.17.1
R
R
Ricardo Wurmus wrote on 11 Sep 2020 21:37
Re: [bug#42119] [PATCH] gnu: Add r-fhtest and its dependencies
(name . Lo Peter)(address . peterloleungyau@gmail.com)(address . 42119-done@debbugs.gnu.org)
87lfhg14wt.fsf@elephly.net
Hi Peter,

Toggle quote (4 lines)
> I am submitting a patch series for r-fhtest and its dependencies.
> Note that one of its dependency r-kmsurv is not included here, because
> I previously submitted its patch in patch 2 of bug#42107.

Thank you for this patch set. I moved r-fhtest and r-interval to (gnu
packages bioconductor) because they (untypically for CRAN packages)
depend on Bioconductor things.

I heavily edited the description and synopses and pushed everything to
the “master” branch with commit 7e88ee9f02.

--
Ricardo
Closed
?