[PATCH] gnu: Add r-tidymodels and its many dependencies

  • Done
  • quality assurance status badge
Details
2 participants
  • Lo Peter
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Lo Peter
Severity
normal
L
L
Lo Peter wrote on 29 Jun 2020 07:48
(address . guix-patches@gnu.org)
CAEM+zmhTg9r7bUxbVQw7_L7YRYB6ToKpaO8bugE7Q3Vf=2JARg@mail.gmail.com
Dear all,

I am submitting a patch series for r-tidymodels and its many dependencies.

Regards,
Peter
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 02/17] gnu: Add r-workflows.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-2-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-workflows): New variable.
---
gnu/packages/cran.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 97025dda09..d8e8a88baa 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22358,3 +22358,36 @@ have. The goal of @code{hardhat} is to reduce the burden around building
new modeling packages by providing functionality for preprocessing,
predicting, and validating input.")
(license license:expat)))
+
+(define-public r-workflows
+ (package
+ (name "r-workflows")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "workflows" version))
+ (sha256
+ (base32
+ "14lzbszz7ybfzqa5zw1hfh81b8rbwwyza6x8nhpnknl6x4adqfql"))))
+ (properties `((upstream-name . "workflows")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cli" ,r-cli)
+ ("r-ellipsis" ,r-ellipsis)
+ ("r-generics" ,r-generics)
+ ("r-glue" ,r-glue)
+ ("r-hardhat" ,r-hardhat)
+ ("r-parsnip" ,r-parsnip)
+ ("r-rlang" ,r-rlang)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://github.com/tidymodels/workflows")
+ (synopsis "Modeling Workflows")
+ (description
+ "Managing both a @code{parsnip} model and a preprocessor, such
+as a model formula or recipe from @code{recipes}, can often be
+challenging. The goal of @code{workflows} is to streamline this
+process by bundling the model alongside the preprocessor, all within
+the same object.")
+ (license license:expat)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 01/17] gnu: Add r-hardhat.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-1-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-hardhat): New variable.
---
gnu/packages/cran.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab5e57c0e2..97025dda09 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22325,3 +22325,36 @@ across a wide array of bioinformatic R packages.")
and clustering large sequence datasets using fast alignment-free k-mer
counting and recursive k-means partitioning.")
(license license:gpl3)))
+
+(define-public r-hardhat
+ (package
+ (name "r-hardhat")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "hardhat" version))
+ (sha256
+ (base32
+ "10x8fw0skaqci03v2qqpbradbra9arm3s5pskcwm4wricd2imr40"))))
+ (properties `((upstream-name . "hardhat")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-glue" ,r-glue)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)
+ ("r-vctrs" ,r-vctrs)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://github.com/tidymodels/hardhat")
+ (synopsis "Construct Modeling Packages")
+ (description
+ "Building modeling packages is hard. A large amount of effort
+generally goes into providing an implementation for a new method that
+is efficient, fast, and correct, but often less emphasis is put on the
+user interface. A good interface requires specialized knowledge about
+S3 methods and formulas, which the average package developer might not
+have. The goal of @code{hardhat} is to reduce the burden around building
+new modeling packages by providing functionality for preprocessing,
+predicting, and validating input.")
+ (license license:expat)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 03/17] gnu: Add r-gpfit.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-3-peterloleungyau@gmail.com
8 gnu/packages/cran.scm (r-gpfit): New variable.
---
gnu/packages/cran.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d8e8a88baa..f101ccd285 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22391,3 +22391,26 @@ challenging. The goal of @code{workflows} is to streamline this
process by bundling the model alongside the preprocessor, all within
the same object.")
(license license:expat)))
+
+(define-public r-gpfit
+ (package
+ (name "r-gpfit")
+ (version "1.0-8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "GPfit" version))
+ (sha256
+ (base32
+ "05mpiyi2vxv0wqp422n1mnxa8msc4daq40cwpnpngbcwqhlgqkby"))))
+ (properties `((upstream-name . "GPfit")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lattice" ,r-lattice) ("r-lhs" ,r-lhs)))
+ (home-page
+ "https://cran.r-project.org/web/packages/GPfit/")
+ (synopsis "Gaussian Processes Modeling")
+ (description
+ "This package provides a computationally stable approach of
+fitting a Gaussian Process (GP) model to a deterministic simulator.")
+ (license license:gpl2)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 04/17] gnu: Add r-yardstick.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-4-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-yardstick): New variable.
---
gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f101ccd285..34b0591b27 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22414,3 +22414,34 @@ the same object.")
"This package provides a computationally stable approach of
fitting a Gaussian Process (GP) model to a deterministic simulator.")
(license license:gpl2)))
+
+(define-public r-yardstick
+ (package
+ (name "r-yardstick")
+ (version "0.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "yardstick" version))
+ (sha256
+ (base32
+ "1qkvbvc0cnwl5mkk47swnd8by84zz0qpy1996fziapn35qxvx9qa"))))
+ (properties `((upstream-name . "yardstick")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-generics" ,r-generics)
+ ("r-proc" ,r-proc)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rlang" ,r-rlang)
+ ("r-tidyselect" ,r-tidyselect)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://github.com/tidymodels/yardstick")
+ (synopsis
+ "Tidy Characterizations of Model Performance")
+ (description
+ "Tidy tools for quantifying how well model fits to a data set
+such as confusion matrices, class probability curve summaries, and
+regression metrics (e.g., RMSE).")
+ (license license:gpl2)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 05/17] gnu: Add r-rsample.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-5-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-rsample): New variable.
---
gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 34b0591b27..d524465a23 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22445,3 +22445,34 @@ fitting a Gaussian Process (GP) model to a deterministic simulator.")
such as confusion matrices, class probability curve summaries, and
regression metrics (e.g., RMSE).")
(license license:gpl2)))
+
+(define-public r-rsample
+ (package
+ (name "r-rsample")
+ (version "0.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rsample" version))
+ (sha256
+ (base32
+ "0s6hgq0rcv3ianyidq3n9z34y5ww51gaggqkwmwns9yyxmwfjcm8"))))
+ (properties `((upstream-name . "rsample")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-furrr" ,r-furrr)
+ ("r-generics" ,r-generics)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)
+ ("r-tidyselect" ,r-tidyselect)
+ ("r-vctrs" ,r-vctrs)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://rsample.tidymodels.org")
+ (synopsis "General Resampling Infrastructure")
+ (description
+ "Classes and functions to create and summarize different types
+of resampling objects (e.g. bootstrap, cross-validation).")
+ (license license:gpl2)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 06/17] gnu: Add r-dicedesign.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-6-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-dicedesign): New variable.
---
gnu/packages/cran.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d524465a23..8184b3576e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22476,3 +22476,22 @@ regression metrics (e.g., RMSE).")
"Classes and functions to create and summarize different types
of resampling objects (e.g. bootstrap, cross-validation).")
(license license:gpl2)))
+
+(define-public r-dicedesign
+ (package
+ (name "r-dicedesign")
+ (version "1.8-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "DiceDesign" version))
+ (sha256
+ (base32
+ "11s1m543kxd6gv4amh8z6pph1n67sj9sfwm6hjy83wfs65syf5vp"))))
+ (properties `((upstream-name . "DiceDesign")))
+ (build-system r-build-system)
+ (home-page "http://dice.emse.fr/")
+ (synopsis "Designs of Computer Experiments")
+ (description
+ "Space-Filling Designs and Uniformity Criteria.")
+ (license license:gpl3)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 07/17] gnu: Add r-dials.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-7-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-dials): New variable.
---
gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8184b3576e..ccbcef52bd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22495,3 +22495,37 @@ of resampling objects (e.g. bootstrap, cross-validation).")
(description
"Space-Filling Designs and Uniformity Criteria.")
(license license:gpl3)))
+
+(define-public r-dials
+ (package
+ (name "r-dials")
+ (version "0.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dials" version))
+ (sha256
+ (base32
+ "0fqxdlgwdwpmni2760yagrzqbniz72yl547fcmlx9kzazhzszgq0"))))
+ (properties `((upstream-name . "dials")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dicedesign" ,r-dicedesign)
+ ("r-dplyr" ,r-dplyr)
+ ("r-glue" ,r-glue)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-scales" ,r-scales)
+ ("r-tibble" ,r-tibble)
+ ("r-vctrs" ,r-vctrs)
+ ("r-withr" ,r-withr)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://dials.tidymodels.org/")
+ (synopsis
+ "Tools for Creating Tuning Parameter Values")
+ (description
+ "Many models contain tuning parameters (i.e. parameters that
+cannot be directly estimated from the data). These tools can be used
+to define objects for creating, simulating, or validating values for
+such parameters.")
+ (license license:gpl2)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 08/17] gnu: Add r-tune.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-8-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-tune): New variable.
---
gnu/packages/cran.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ccbcef52bd..bec5bfb45c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22529,3 +22529,46 @@ cannot be directly estimated from the data). These tools can be used
to define objects for creating, simulating, or validating values for
such parameters.")
(license license:gpl2)))
+
+(define-public r-tune
+ (package
+ (name "r-tune")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tune" version))
+ (sha256
+ (base32
+ "0xiidzkl0hbd0f7jh1v2kkg26wdgy33w74c9bmpjgy317ckhsz8h"))))
+ (properties `((upstream-name . "tune")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cli" ,r-cli)
+ ("r-crayon" ,r-crayon)
+ ("r-dials" ,r-dials)
+ ("r-dplyr" ,r-dplyr)
+ ("r-foreach" ,r-foreach)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-glue" ,r-glue)
+ ("r-gpfit" ,r-gpfit)
+ ("r-hardhat" ,r-hardhat)
+ ("r-lifecycle" ,r-lifecycle)
+ ("r-parsnip" ,r-parsnip)
+ ("r-purrr" ,r-purrr)
+ ("r-recipes" ,r-recipes)
+ ("r-rlang" ,r-rlang)
+ ("r-rsample" ,r-rsample)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)
+ ("r-workflows" ,r-workflows)
+ ("r-yardstick" ,r-yardstick)))
+ (home-page "https://github.com/tidymodels/tune")
+ (synopsis "Tidy Tuning Tools")
+ (description
+ "The ability to tune models is important. @code{tune} contains
+functions and classes to be used in conjunction with other
+@code{tidymodels} packages for finding reasonable values of
+hyper-parameters in models, pre-processing methods, and
+post-processing steps.")
+ (license license:expat)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 09/17] gnu: Add r-tidyposterior.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-9-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-tidyposterior): New variable.
---
gnu/packages/cran.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bec5bfb45c..74728ae155 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22572,3 +22572,45 @@ functions and classes to be used in conjunction with other
hyper-parameters in models, pre-processing methods, and
post-processing steps.")
(license license:expat)))
+
+(define-public r-tidyposterior
+ (package
+ (name "r-tidyposterior")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tidyposterior" version))
+ (sha256
+ (base32
+ "0wsv800w056ziqbnwal7ncmdy4li8cn5yrdx07w35b7j8kl4mwhg"))))
+ (properties `((upstream-name . "tidyposterior")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-generics" ,r-generics)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-lifecycle" ,r-lifecycle)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-rsample" ,r-rsample)
+ ("r-rstanarm" ,r-rstanarm)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)
+ ("r-vctrs" ,r-vctrs)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://tidyposterior.tidymodels.org")
+ (synopsis
+ "Bayesian Analysis to Compare Models using Resampling Statistics")
+ (description
+ "Bayesian analysis used here to answer the question: \"when
+looking at resampling results, are the differences between models
+'real'?\" To answer this, a model can be created were the performance
+statistic is the resampling statistics (e.g. accuracy or RMSE).
+These values are explained by the model types. In doing this, we can
+get parameter estimates for each model's affect on performance and
+make statistical (and practical) comparisons between models. The
+methods included here are similar to Benavoli et al (2017)
+<http://jmlr.org/papers/v18/16-305.html>.")
+ (license license:gpl2)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 10/17] gnu: Add r-tidypredict.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-10-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-tidypredict): New variable.
---
gnu/packages/cran.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 74728ae155..6721df2c14 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22614,3 +22614,36 @@ make statistical (and practical) comparisons between models. The
methods included here are similar to Benavoli et al (2017)
<http://jmlr.org/papers/v18/16-305.html>.")
(license license:gpl2)))
+
+(define-public r-tidypredict
+ (package
+ (name "r-tidypredict")
+ (version "0.4.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tidypredict" version))
+ (sha256
+ (base32
+ "1i6zl6wjz6wbpkmkc9z9ikp8zgck3qh38lar0r6q2jzl8fxpimg4"))))
+ (properties `((upstream-name . "tidypredict")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-generics" ,r-generics)
+ ("r-knitr" ,r-knitr)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://tidypredict.tidymodels.org")
+ (synopsis "Run Predictions Inside the Database")
+ (description
+ "It parses a fitted 'R' model object, and returns a formula in
+'Tidy Eval' code that calculates the predictions. It works with
+several databases back-ends because it leverages 'dplyr' and 'dbplyr'
+for the final 'SQL' translation of the algorithm. It currently
+supports lm(), glm(), randomForest(), ranger(), earth(),
+xgb.Booster.complete(), cubist(), and ctree() models.")
+ (license license:gpl3)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 11/17] gnu: Add r-janeaustenr.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-11-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-janeaustenr): New variable.
---
gnu/packages/cran.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6721df2c14..0dcf8d20f3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22647,3 +22647,26 @@ for the final 'SQL' translation of the algorithm. It currently
supports lm(), glm(), randomForest(), ranger(), earth(),
xgb.Booster.complete(), cubist(), and ctree() models.")
(license license:gpl3)))
+
+(define-public r-janeaustenr
+ (package
+ (name "r-janeaustenr")
+ (version "0.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "janeaustenr" version))
+ (sha256
+ (base32
+ "1wyn4qc28a3sval8shmyi2d7s4nl3jh96s8pzq871brxcmrncbwr"))))
+ (properties `((upstream-name . "janeaustenr")))
+ (build-system r-build-system)
+ (home-page
+ "https://github.com/juliasilge/janeaustenr")
+ (synopsis "Jane Austen's Complete Novels")
+ (description
+ "Full texts for Jane Austen's 6 completed novels, ready for text
+analysis. These novels are \"Sense and Sensibility\", \"Pride and
+Prejudice\", \"Mansfield Park\", \"Emma\", \"Northanger Abbey\", and
+\"Persuasion\".")
+ (license license:expat)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 12/17] gnu: Add r-tokenizers.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-12-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-tokenizers): New variable.
---
gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0dcf8d20f3..26c3c1e562 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22670,3 +22670,37 @@ analysis. These novels are \"Sense and Sensibility\", \"Pride and
Prejudice\", \"Mansfield Park\", \"Emma\", \"Northanger Abbey\", and
\"Persuasion\".")
(license license:expat)))
+
+(define-public r-tokenizers
+ (package
+ (name "r-tokenizers")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tokenizers" version))
+ (sha256
+ (base32
+ "006xf1vdrmp9skhpss9ldhmk4cwqk512cjp1pxm2gxfybpf7qq98"))))
+ (properties `((upstream-name . "tokenizers")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcpp" ,r-rcpp)
+ ("r-snowballc" ,r-snowballc)
+ ("r-stringi" ,r-stringi)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://lincolnmullen.com/software/tokenizers/")
+ (synopsis
+ "Fast, Consistent Tokenization of Natural Language Text")
+ (description
+ "Convert natural language text into tokens. Includes tokenizers
+for shingled n-grams, skip n-grams, words, word stems, sentences,
+paragraphs, characters, shingled characters, lines, tweets, Penn
+Treebank, regular expressions, as well as functions for counting
+characters, words, and sentences, and a function for splitting longer
+texts into separate documents, each with the same number of words.
+The tokenizers have a consistent interface, and the package is built
+on the @code{stringi} and @code{Rcpp} packages for fast yet correct
+tokenization in 'UTF-8'.")
+ (license license:expat)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 13/17] gnu: Add r-hunspell.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-13-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-hunspell): New variable.
---
gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 26c3c1e562..3c98bc2753 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22704,3 +22704,33 @@ The tokenizers have a consistent interface, and the package is built
on the @code{stringi} and @code{Rcpp} packages for fast yet correct
tokenization in 'UTF-8'.")
(license license:expat)))
+
+(define-public r-hunspell
+ (package
+ (name "r-hunspell")
+ (version "3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "hunspell" version))
+ (sha256
+ (base32
+ "0mwqw5p0ph083plm2hr2hqr50bjg2dw862dpsfm4l2fgyy3rryq1"))))
+ (properties `((upstream-name . "hunspell")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-digest" ,r-digest) ("r-rcpp" ,r-rcpp)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://github.com/ropensci/hunspell#readmehttps://hunspell.github.io")
+ (synopsis
+ "High-Performance Stemmer, Tokenizer, and Spell Checker")
+ (description
+ "Low level spell checker and morphological analyzer based on the
+famous @code{hunspell} library <https://hunspell.github.io>. The
+package can analyze or check individual words as well as parse text,
+latex, html or xml documents. For a more user-friendly interface use
+the @code{spelling} package which builds on this package to automate
+checking of files, documentation and vignettes in all common
+formats.")
+ (license (list license:gpl2 license:lgpl2.1 license:mpl1.1))))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 14/17] gnu: Add r-tidytext.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-14-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-tidytext): New variable.
---
gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3c98bc2753..37afec7774 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22734,3 +22734,37 @@ the @code{spelling} package which builds on this package to automate
checking of files, documentation and vignettes in all common
formats.")
(license (list license:gpl2 license:lgpl2.1 license:mpl1.1))))
+
+(define-public r-tidytext
+ (package
+ (name "r-tidytext")
+ (version "0.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tidytext" version))
+ (sha256
+ (base32
+ "0gck3f039qkpkwn92jlyfan76w0xydg17bh6nsg9qlba7c35kzs6"))))
+ (properties `((upstream-name . "tidytext")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-generics" ,r-generics)
+ ("r-hunspell" ,r-hunspell)
+ ("r-janeaustenr" ,r-janeaustenr)
+ ("r-matrix" ,r-matrix)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-stopwords" ,r-stopwords)
+ ("r-stringr" ,r-stringr)
+ ("r-tokenizers" ,r-tokenizers)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://github.com/juliasilge/tidytext")
+ (synopsis
+ "Text Mining using 'dplyr', 'ggplot2', and Other Tidy Tools")
+ (description
+ "Text mining for word processing and sentiment analysis using
+@code{dplyr}, @code{ggplot2}, and other tidy tools.")
+ (license license:expat)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 15/17] gnu: Add r-parsnip.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-15-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-parsnip): New variable.
---
gnu/packages/cran.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 37afec7774..cf259a795a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22768,3 +22768,40 @@ formats.")
"Text mining for word processing and sentiment analysis using
@code{dplyr}, @code{ggplot2}, and other tidy tools.")
(license license:expat)))
+
+(define-public r-parsnip
+ (package
+ (name "r-parsnip")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "parsnip" version))
+ (sha256
+ (base32
+ "1p33absjd2lnq5aikr42him4b724qzxr1pzvdnazg789f763i47l"))))
+ (properties `((upstream-name . "parsnip")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-generics" ,r-generics)
+ ("r-globals" ,r-globals)
+ ("r-glue" ,r-glue)
+ ("r-magrittr" ,r-magrittr)
+ ("r-prettyunits" ,r-prettyunits)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)
+ ("r-vctrs" ,r-vctrs)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://parsnip.tidymodels.org")
+ (synopsis
+ "Common API to Modeling and Analysis Functions")
+ (description
+ "This package provides a common interface is provided to allow
+users to specify a model without having to remember the different
+argument names across different functions or computational
+engines (e.g. 'R', 'Spark', 'Stan', etc).")
+ (license license:gpl2)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 16/17] gnu: Add r-infer.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-16-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-infer): New variable.
---
gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cf259a795a..9f7f952217 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22805,3 +22805,33 @@ users to specify a model without having to remember the different
argument names across different functions or computational
engines (e.g. 'R', 'Spark', 'Stan', etc).")
(license license:gpl2)))
+
+(define-public r-infer
+ (package
+ (name "r-infer")
+ (version "0.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "infer" version))
+ (sha256
+ (base32
+ "0m00xhzrvmskwj4jwncakwxhzivn9pyiylq4r8s6ny4yiwqg303m"))))
+ (properties `((upstream-name . "infer")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-glue" ,r-glue)
+ ("r-magrittr" ,r-magrittr)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/tidymodels/infer")
+ (synopsis "Tidy Statistical Inference")
+ (description
+ "The objective of this package is to perform inference using an
+expressive statistical grammar that coheres with the tidy design
+framework.")
+ (license license:cc0)))
--
2.17.1
P
P
Peter Lo wrote on 29 Jun 2020 07:50
[PATCH 17/17] gnu: Add r-tidymodels.
(address . 42117@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200629055042.8565-17-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-tidymodels): New variable.
---
gnu/packages/cran.scm | 47 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9f7f952217..8adca7a8cc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22835,3 +22835,50 @@ engines (e.g. 'R', 'Spark', 'Stan', etc).")
expressive statistical grammar that coheres with the tidy design
framework.")
(license license:cc0)))
+
+(define-public r-tidymodels
+ (package
+ (name "r-tidymodels")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tidymodels" version))
+ (sha256
+ (base32
+ "1bi5vh80f6f2ibhyaapgnl7q1mkkx8425vj6ci0ml5rb7l8jhjm8"))))
+ (properties `((upstream-name . "tidymodels")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-broom" ,r-broom)
+ ("r-cli" ,r-cli)
+ ("r-crayon" ,r-crayon)
+ ("r-dials" ,r-dials)
+ ("r-dplyr" ,r-dplyr)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-infer" ,r-infer)
+ ("r-magrittr" ,r-magrittr)
+ ("r-parsnip" ,r-parsnip)
+ ("r-pillar" ,r-pillar)
+ ("r-purrr" ,r-purrr)
+ ("r-recipes" ,r-recipes)
+ ("r-rlang" ,r-rlang)
+ ("r-rsample" ,r-rsample)
+ ("r-rstudioapi" ,r-rstudioapi)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyposterior" ,r-tidyposterior)
+ ("r-tidypredict" ,r-tidypredict)
+ ("r-tidytext" ,r-tidytext)
+ ("r-tune" ,r-tune)
+ ("r-workflows" ,r-workflows)
+ ("r-yardstick" ,r-yardstick)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://github.com/tidymodels/tidymodels")
+ (synopsis
+ "Easily Install and Load the 'Tidymodels' Packages")
+ (description
+ "The tidy modeling \"verse\" is a collection of packages for
+modeling and statistical analysis that share the underlying design
+philosophy, grammar, and data structures of the tidyverse.")
+ (license license:gpl3)))
--
2.17.1
R
R
Ricardo Wurmus wrote on 11 Sep 2020 18:58
Re: [bug#42117] [PATCH] gnu: Add r-tidymodels and its many dependencies
(name . Lo Peter)(address . peterloleungyau@gmail.com)(address . 42117-done@debbugs.gnu.org)
87o8mc1c92.fsf@elephly.net
Hi Peter,

Toggle quote (2 lines)
> I am submitting a patch series for r-tidymodels and its many dependencies.

I have reworked the synopses and descriptions, and in one case the
licenses, and pushed the series of patches with commit 23bd6f6 to the
“master” branch.

I’m now upgrading these packages to the latest version.

Thank you and my apologies for the delay!

--
Ricardo
Closed
?