[PATCH] gnu: Add plover.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Nicolas Goaziou
Severity
normal
N
N
Nicolas Goaziou wrote on 29 Jun 2020 00:53
(address . guix-patches@gnu.org)
20200628225346.22751-1-mail@nicolasgoaziou.fr
* gnu/local.mk (plover): New variable.
(GNU_SYSTEM_MODULES): Add stenography.scm.
---
gnu/local.mk | 1 +
gnu/packages/stenography.scm | 65 ++++++++++++++++++++++++++++++++++++
2 files changed, 66 insertions(+)
create mode 100644 gnu/packages/stenography.scm

Toggle diff (85 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 8bb56010c2..967f86fb7b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -504,6 +504,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/stalonetray.scm \
%D%/packages/statistics.scm \
%D%/packages/stb.scm \
+ %D%/packages/stenography.scm \
%D%/packages/storage.scm \
%D%/packages/suckless.scm \
%D%/packages/swig.scm \
diff --git a/gnu/packages/stenography.scm b/gnu/packages/stenography.scm
new file mode 100644
index 0000000000..f0193da25f
--- /dev/null
+++ b/gnu/packages/stenography.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages stenography)
+ #:use-module (guix build-system python)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages libusb)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages wxwidgets))
+
+(define-public plover
+ (package
+ (name "plover")
+ (version "3.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openstenoproject/plover.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "114rlxvq471fyifwcdcgdad79ak7q3w2lk8z9nqhz1i9fg05721c"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (native-inputs
+ `(("python2-mock" ,python2-mock)
+ ("python2-pytest" ,python2-pytest)
+ ("python2-setuptools-scm" ,python2-setuptools-scm)))
+ (inputs
+ `(("python2-appdirs" ,python2-appdirs)
+ ("python2-dbus" ,python2-dbus)
+ ("python2-hidapi" ,python2-hidapi)
+ ("python2-pyserial" ,python2-pyserial)
+ ("python2-wxpython" ,python2-wxpython)
+ ("python2-xlib" ,python2-xlib)))
+ (home-page "https://www.openstenoproject.org/plover/")
+ (synopsis "Stenography engine")
+ (description
+ "Plover (rhymes with @emph{lover}) is a desktop application that
+allows anyone to use stenography to write on their computer, up to
+speeds of 200WPM and beyond.")
+ (license license:gpl2+)))
+
--
2.26.2
M
M
Mathieu Othacehe wrote on 5 Jul 2020 11:47
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 42114@debbugs.gnu.org)
871rlqjnsx.fsf@gnu.org
Hello Nicolas,

Toggle quote (14 lines)
> + (arguments
> + `(#:python ,python-2))
> + (native-inputs
> + `(("python2-mock" ,python2-mock)
> + ("python2-pytest" ,python2-pytest)
> + ("python2-setuptools-scm" ,python2-setuptools-scm)))
> + (inputs
> + `(("python2-appdirs" ,python2-appdirs)
> + ("python2-dbus" ,python2-dbus)
> + ("python2-hidapi" ,python2-hidapi)
> + ("python2-pyserial" ,python2-pyserial)
> + ("python2-wxpython" ,python2-wxpython)
> + ("python2-xlib" ,python2-xlib)))

It seems that this packages supports Python 3, any particular reason to
stick with Python 2 revision?

Otherwise, this looks fine.

Thanks,

Mathieu
N
N
Nicolas Goaziou wrote on 6 Jul 2020 15:03
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 42114@debbugs.gnu.org)
874kqk7q48.fsf@nicolasgoaziou.fr
Hello,

Mathieu Othacehe <othacehe@gnu.org> writes:

Toggle quote (17 lines)
>> + (arguments
>> + `(#:python ,python-2))
>> + (native-inputs
>> + `(("python2-mock" ,python2-mock)
>> + ("python2-pytest" ,python2-pytest)
>> + ("python2-setuptools-scm" ,python2-setuptools-scm)))
>> + (inputs
>> + `(("python2-appdirs" ,python2-appdirs)
>> + ("python2-dbus" ,python2-dbus)
>> + ("python2-hidapi" ,python2-hidapi)
>> + ("python2-pyserial" ,python2-pyserial)
>> + ("python2-wxpython" ,python2-wxpython)
>> + ("python2-xlib" ,python2-xlib)))
>
> It seems that this packages supports Python 3, any particular reason to
> stick with Python 2 revision?

Thank you for the review.

What makes you think it supports Python 3? It seems yet-to-be-released
4.0 will do, but not the stable 3.1.1, AFAIK. In any case, using Python
3, two tests fail in the same manner:

try:
this = chr(ESCAPES[this][1])
except KeyError:
if c in ASCIILETTERS:
> raise s.error('bad escape %s' % this, len(this))
E re.error: bad escape \c at position 1


Regards,
--
Nicolas Goaziou
M
M
Mathieu Othacehe wrote on 6 Jul 2020 17:09
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 42114@debbugs.gnu.org)
874kqk7k9y.fsf@gnu.org
Hello Nicolas,

Toggle quote (4 lines)
> What makes you think it supports Python 3? It seems yet-to-be-released
> 4.0 will do, but not the stable 3.1.1, AFAIK. In any case, using Python
> 3, two tests fail in the same manner:

You're right, I was fooled by Ubuntu which is packaging a development
version[1]. Feel free to proceed with your patch.

Thanks,

Mathieu

N
N
Nicolas Goaziou wrote on 7 Jul 2020 18:52
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 42114-done@debbugs.gnu.org)
87h7uj5kty.fsf@nicolasgoaziou.fr
Hello,

Mathieu Othacehe <othacehe@gnu.org> writes:

Toggle quote (3 lines)
> You're right, I was fooled by Ubuntu which is packaging a development
> version[1]. Feel free to proceed with your patch.

Applied. I'll keep an eye on the 4.0 release.

Thank ou for the review.

Regards,
--
Nicolas Goaziou
Closed
?