[PATCH] gnu: Add r-flexsurv and dependency

  • Done
  • quality assurance status badge
Details
2 participants
  • Lo Peter
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Lo Peter
Severity
normal
L
L
Lo Peter wrote on 28 Jun 2020 09:42
(address . guix-patches@gnu.org)
CAEM+zmi1UU5N5yMCUdKpmmFuBZQfpEez_vdJq3c6GJ7DaouHtg@mail.gmail.com
Dear all,

I am submitting a patch series of r-flexsurv and its dependency.

Regards,
Peter
P
P
Peter Lo wrote on 28 Jun 2020 09:44
[PATCH 1/2] gnu: Add r-muhaz.
(address . 42103@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200628074414.6986-1-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-muhaz): New variable.
---
gnu/packages/cran.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab5e57c0e2..b6cc9b48c3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22325,3 +22325,26 @@ across a wide array of bioinformatic R packages.")
and clustering large sequence datasets using fast alignment-free k-mer
counting and recursive k-means partitioning.")
(license license:gpl3)))
+
+(define-public r-muhaz
+ (package
+ (name "r-muhaz")
+ (version "1.2.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "muhaz" version))
+ (sha256
+ (base32
+ "08qh43zx6h3yby44q2vxphfvmfdmqxpgyp0734yn341sy9n8pkkk"))))
+ (properties `((upstream-name . "muhaz")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-survival" ,r-survival)))
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page
+ "https://cran.r-project.org/web/packages/muhaz")
+ (synopsis
+ "Hazard Function Estimation in Survival Analysis")
+ (description
+ "Produces a smooth estimate of the hazard function for censored data.")
+ (license (list license:gpl2+ license:gpl3+))))
--
2.17.1
P
P
Peter Lo wrote on 28 Jun 2020 09:44
[PATCH 2/2] gnu: Add r-flexsurv.
(address . 42103@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200628074414.6986-2-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-flexsurv): New variable.
---
gnu/packages/cran.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b6cc9b48c3..0ddd0d29d2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22348,3 +22348,40 @@ counting and recursive k-means partitioning.")
(description
"Produces a smooth estimate of the hazard function for censored data.")
(license (list license:gpl2+ license:gpl3+))))
+
+(define-public r-flexsurv
+ (package
+ (name "r-flexsurv")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "flexsurv" version))
+ (sha256
+ (base32
+ "0x7p1rv51pplfyyzcg63ssb8z56mig7y0363hkr0219w3cvyq9nr"))))
+ (properties `((upstream-name . "flexsurv")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-desolve" ,r-desolve)
+ ("r-mstate" ,r-mstate)
+ ("r-muhaz" ,r-muhaz)
+ ("r-mvtnorm" ,r-mvtnorm)
+ ("r-quadprog" ,r-quadprog)
+ ("r-rcpp" ,r-rcpp)
+ ("r-survival" ,r-survival)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://github.com/chjackson/flexsurv-dev")
+ (synopsis
+ "Flexible Parametric Survival and Multi-State Models")
+ (description
+ "Flexible parametric models for time-to-event data, including
+the Royston-Parmar spline model, generalized gamma and generalized F
+distributions. Any user-defined parametric distribution can be
+fitted, given at least an R function defining the probability density
+or hazard. There are also tools for fitting and predicting from fully
+parametric multi-state models.")
+ (license license:gpl2+)))
--
2.17.1
R
R
Ricardo Wurmus wrote on 11 Sep 2020 08:02
Re: [bug#42103] [PATCH] gnu: Add r-flexsurv and dependency
(name . Lo Peter)(address . peterloleungyau@gmail.com)(address . 42103-done@debbugs.gnu.org)
87pn6s3l6w.fsf@elephly.net
Hi Peter,

Toggle quote (2 lines)
> I am submitting a patch series of r-flexsurv and its dependency.

I changed synopsis and description of both package definitions and
pushed them to the master branch with commit 9e4ef763ea.

Sorry for the delay!

--
Ricardo
Closed
?