updated guix package build fails: tests/git-authenticate.log Error 1

  • Done
  • quality assurance status badge
Details
2 participants
  • Jan Nieuwenhuizen
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jan Nieuwenhuizen
Severity
normal
J
J
Jan Nieuwenhuizen wrote on 27 Jun 2020 09:41
(address . bug-guix@gnu.org)
877dvtx8el.fsf@gnu.org
Hi,

On current master (35691bf5dc69e4d482b31fab63e3bd73ffece755, and "some
time" earlier), updating guix (see attached patch) and running

Toggle snippet (3 lines)
./pre-inst-env guix build guix --keep-failed --verbosity=1

fails like so

Toggle snippet (16 lines)
PASS: tests/gexp.scm
SKIP: tests/git.scm
make[4]: *** [Makefile:5274: tests/git-authenticate.log] Error 1
make[4]: Leaving directory '/tmp/guix-build-guix-1.1.0-13.35691bf.drv-0/source'
make[3]: *** [Makefile:5256: check-TESTS] Error 2
make[3]: Leaving directory '/tmp/guix-build-guix-1.1.0-13.35691bf.drv-0/source'
make[2]: *** [Makefile:5505: check-am] Error 2
make[2]: Leaving directory '/tmp/guix-build-guix-1.1.0-13.35691bf.drv-0/source'
make[1]: *** [Makefile:5033: check-recursive] Error 1
make[1]: Leaving directory '/tmp/guix-build-guix-1.1.0-13.35691bf.drv-0/source'
make: *** [Makefile:5507: check] Error 2

Test suite failed, dumping logs.
command "make" "check" failed with status 2

Contents of /tmp/guix-build-guix-1.1.0-13.35691bf.drv-0/source/tests/git-authenticate.log:

Toggle snippet (37 lines)
Backtrace:
2 (primitive-load-path "tests/git-authenticate.scm")
In ice-9/eval.scm:
259:9 1 (_ #f)
In unknown file:
0 (search-path ("/tmp/guix-build-guix-1.1.0-13.35691b…" …) …)

ERROR: In procedure search-path:
Wrong type (expecting string): #f
test-name: unsigned commits
location: /tmp/guix-build-guix-1.1.0-13.35691bf.drv-0/source/tests/git-authenticate.scm:43
source:
+ (test-assert
+ "unsigned commits"
+ (with-temporary-git-repository
+ directory
+ '((add "a.txt" "A")
+ (commit "first commit")
+ (add "b.txt" "B")
+ (commit "second commit"))
+ (with-repository
+ directory
+ repository
+ (let ((commit1 (find-commit repository "first"))
+ (commit2 (find-commit repository "second")))
+ (guard (c ((unsigned-commit-error? c)
+ (oid=? (git-authentication-error-commit c)
+ (commit-id commit1))))
+ (authenticate-commits
+ repository
+ (list commit1 commit2)
+ #:keyring-reference
+ "master")
+ 'failed)))))
result: SKIP

Greetings,
Janneke
From bc29c78ac33d9f4e037bbe2a8104873a5644df57 Mon Sep 17 00:00:00 2001
From: "Jan (janneke) Nieuwenhuizen" <janneke@gnu.org>
Date: Thu, 7 May 2020 18:25:26 +0200
Subject: [PATCH] gnu: guix: Update to 1.1.0-13.35691bf5dc6.

* gnu/packages/package-management.scm (guix): Update to 1.1.0-13.35691bf5dc6
---
gnu/packages/package-management.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index bfecf110ca..bf5e59fb4b 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -118,8 +118,8 @@
;; Note: the 'update-guix-package.scm' script expects this definition to
;; start precisely like this.
(let ((version "1.1.0")
- (commit "c00564192a9924ab2218c243342963aba89d67d1")
- (revision 12))
+ (commit "35691bf5dc69e4d482b31fab63e3bd73ffece755")
+ (revision 13))
(package
(name "guix")
@@ -135,7 +135,7 @@
(commit commit)))
(sha256
(base32
- "008ywpdkc5f2jh25x6rr9glzvq4a6qih7v73w5dbxscpddx5c5g2"))
+ "0hh31lbbbmjkwlxvp4fzrdz0r8p9233h2zlf71r4gccsjqh16pra"))
(file-name (string-append "guix-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com | Avatar® http://AvatarAcademy.com
--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
L
L
Ludovic Courtès wrote on 28 Jun 2020 23:33
(name . Jan Nieuwenhuizen)(address . janneke@gnu.org)(address . 42077-done@debbugs.gnu.org)
87h7uueuzx.fsf@gnu.org
Hey!

Jan Nieuwenhuizen <janneke@gnu.org> skribis:

Toggle quote (23 lines)
> On current master (35691bf5dc69e4d482b31fab63e3bd73ffece755, and "some
> time" earlier), updating guix (see attached patch) and running
>
> ./pre-inst-env guix build guix --keep-failed --verbosity=1
>
>
> fails like so
>
> PASS: tests/gexp.scm
> SKIP: tests/git.scm
> make[4]: *** [Makefile:5274: tests/git-authenticate.log] Error 1
> make[4]: Leaving directory '/tmp/guix-build-guix-1.1.0-13.35691bf.drv-0/source'
> make[3]: *** [Makefile:5256: check-TESTS] Error 2
> make[3]: Leaving directory '/tmp/guix-build-guix-1.1.0-13.35691bf.drv-0/source'
> make[2]: *** [Makefile:5505: check-am] Error 2
> make[2]: Leaving directory '/tmp/guix-build-guix-1.1.0-13.35691bf.drv-0/source'
> make[1]: *** [Makefile:5033: check-recursive] Error 1
> make[1]: Leaving directory '/tmp/guix-build-guix-1.1.0-13.35691bf.drv-0/source'
> make: *** [Makefile:5507: check] Error 2
>
> Test suite failed, dumping logs.
> command "make" "check" failed with status 2

Oops, fixed in 0a8dd8aae5fad365c2f429d48e4085a3b3388332.

Thanks,
Ludo’.
Closed
J
J
Jan Nieuwenhuizen wrote on 29 Jun 2020 09:48
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 42077-done@debbugs.gnu.org)
87lfk6wbwv.fsf@gnu.org
Ludovic Courtès writes:

Hello,

Toggle quote (5 lines)
>> Test suite failed, dumping logs.
>> command "make" "check" failed with status 2
>
> Oops, fixed in 0a8dd8aae5fad365c2f429d48e4085a3b3388332.

Thank you. Oh, I suppose that was easy once you spotted it; that was
what I hoped anyway. I tried following the backtrace and looking for
search-patch instances for a bit...but it wasn't obvious.

Greetings,
Janneke

--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
Closed
?