[PATCH] gnu: Add python-pytest-lazy-fixture

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 20 Jun 2020 22:38
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200620203849.39700-1-monego@posteo.net
* gnu/packages/check.scm (python-pytest-lazy-fixture): New variable.
---
gnu/packages/check.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 7d7fd189bc..7b98c029a5 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -971,6 +972,36 @@ supports coverage of subprocesses.")
(define-public python2-pytest-runner-2
(package-with-python2 python-pytest-runner-2))
+(define-public python-pytest-lazy-fixture
+ (package
+ (name "python-pytest-lazy-fixture")
+ (version "0.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-lazy-fixture" version))
+ (sha256
+ (base32 "1b0hmnsxw4s2wf9pks8dg6dfy5cx3zcbzs8517lfccxsfizhqz8f"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Make the installed plugin discoverable by Pytest.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv"))))))
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/tvorog/pytest-lazy-fixture")
+ (synopsis "Use fixtures in @code{pytest.mark.parametrize}")
+ (description "This plugin helps to use fixtures in
+@code{pytest.mark.parametrize}")
+ (license license:expat)))
+
+(define-public python2-pytest-lazy-fixture
+ (package-with-python2 python-pytest-lazy-fixture))
+
(define-public python-pytest-mock
(package
(name "python-pytest-mock")
--
2.20.1
E
E
Efraim Flashner wrote on 22 Jun 2020 20:20
(name . Vinicius Monego)(address . monego@posteo.net)(address . 41969-done@debbugs.gnu.org)
20200622182039.GD22974@E5400
Looks good. I added a period at the end of the description and adjusted
the indentation slightly. I also removed the python2 variant since we're
not adding more python2 packages unless they're actually used for
something.

Patch pushed!


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl7w9ncACgkQQarn3Mo9
g1F1yRAAlrcDC9GVovHpQ+pyNYyefooslBr7nNCyQ4Xn4vHWocxMDJxZ50fxoWAH
gi7oKvUUeMn6DcCRbpAztThucXPyLKRXY5y60VigfkSNuJSy/nsZCKnQvSwx+JkL
1cbEOo+gG7c+MF3H9TrLoKxZXYCHrxlxWNls+WUpv+LpOF4+FoMTWOc5rpQyqe//
OkcBHheHcB9hEIXFshvYVNwaulnjsBNDIMyiigEpkx5y3/x+zP9dnnwL26u/pS8B
QQDsktS7+UMV50Vm4F0+c+Sb6ioDyKFAVdqwnxq5n8tSWjTGjnkx7i/7UhQN52qw
sntTZMdw2j4qOZo3YcNDHEKuwcFjjNYwNmronRsm1MFc/jF3LycFvOLqe3BvpuKc
vdTwdEGiUJTezk3G0AJewaXf1+E1SMMP/lBdSnFJgD/eC7FjjOAGYnEEt4UoveOP
ezFB7vi08ddlXO5q3iQ9/4fcj5pmj+LVQQFjh/CucShtfdtheRJ9Yfk6t5kMePRf
LiYRTkz2fkvjV+k/EsoFKTqSoUg6tCdhrLxQmGKpNOqjsL1jLJznSxPNY1IqHC7/
l4sQMkIqkelkGnxToFmI4hGMLpPH7bcWh9jUq0FCL+ALZZJGsPd2zhWdqBSrdNZP
WtLyWJPf851Ae+dPqm959TQzI4mM6hMWuPHB7tgJ1iTk3SUtIOM=
=04/U
-----END PGP SIGNATURE-----


Closed
?