[PATCH] Add BurgerSpace

  • Done
  • quality assurance status badge
Details
One participant
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Nicolas Goaziou
Severity
normal
N
N
Nicolas Goaziou wrote on 15 Jun 2020 22:56
(address . guix-patches@gnu.org)
87imfscak9.fsf@nicolasgoaziou.fr
Hello,

The following add flatzebra game engine and BurgerSpace.

Regards,
--
Nicolas Goaziou
From ca2ce13ceef85dff43ebb90f8a53b71042afd49d Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Mon, 15 Jun 2020 21:55:33 +0200
Subject: [PATCH 1/2] gnu: Add flatzebra.

* gnu/packages/game-development.scm (flatzebra): New variable.
---
gnu/packages/game-development.scm | 37 +++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index ddd171c5d2..58dbb98f78 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1999,6 +1999,43 @@ hardware from multiple vendors without requiring that applications have
specific knowledge of the hardware they are targeting.")
(license license:bsd-3)))
+(define-public flatzebra
+ (package
+ (name "flatzebra")
+ (version "0.1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://perso.b2b2c.ca/~sarrazip/dev/"
+ "flatzebra-" version ".tar.gz"))
+ (sha256
+ (base32 "1x2dy41c8vrq62bn03b82fpmk7x4rzd7qqiwvq0mgcl5rmasc2c8"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-sdl-config
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; XXX: sdl-config in sdl-union is a link to sdl-config from
+ ;; plain sdl package. As a consequence, the prefix is wrong.
+ ;; Force correct one with "--prefix" argument.
+ (let ((sdl-union (assoc-ref inputs "sdl")))
+ (setenv "SDL_CONFIG"
+ (string-append sdl-union
+ "/bin/sdl-config --prefix="
+ sdl-union)))
+ #t)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("sdl" ,(sdl-union (list sdl sdl-image sdl-mixer)))))
+ (home-page "http://perso.b2b2c.ca/~sarrazip/dev/burgerspace.html")
+ (synopsis "Generic game engine for 2D double-buffering animation")
+ (description
+ "Flatzebra is a simple, generic C++ game engine library supporting 2D
+double-buffering.")
+ (license license:gpl2+)))
+
(define-public fna
(package
(name "fna")
--
2.26.2
From bf559b567493c26093a681d81d4feb3a942b3add Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Mon, 15 Jun 2020 21:56:36 +0200
Subject: [PATCH 2/2] gnu: Add burgerspace.

* gnu/packages/games.scm (burgerspace): New variable.
---
gnu/packages/games.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 10ac8cb550..fc19c25c85 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10560,6 +10560,33 @@ soldiers, jeeps and tanks. The gameplay is simple but it is not that easy to
get high scores.")
(license license:gpl2+)))
+(define-public burgerspace
+ (package
+ (name "burgerspace")
+ (version "1.9.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://perso.b2b2c.ca/~sarrazip/dev/"
+ "burgerspace-" version ".tar.gz"))
+ (sha256
+ (base32 "1005a04rbn4lzjrpfg0m394k2mfaji63fm2qhdqdsxila8a6kjbv"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("flatzebra" ,flatzebra)))
+ (home-page "http://perso.b2b2c.ca/~sarrazip/dev/burgerspace.html")
+ (synopsis "Avoid evil foodstuffs and make burgers")
+ (description
+ "This is a clone of the classic game BurgerTime. In it, you play
+the part of a chef who must create burgers by stepping repeatedly on
+the ingredients until they fall into place. And to make things more
+complicated, you also must avoid evil animate food items while
+performing this task, with nothing but your trusty pepper shaker to
+protect you.")
+ (license license:gpl2+)))
+
(define-public 7kaa
(package
(name "7kaa")
--
2.26.2
N
N
Nicolas Goaziou wrote on 29 Jun 2020 01:04
(address . 41881-done@debbugs.gnu.org)
875zbax05a.fsf@nicolasgoaziou.fr
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (2 lines)
> The following add flatzebra game engine and BurgerSpace.

Applied. Closing.
Closed
?