[PATCH] gnu: openscad: Add patch to fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brice Waegeneire
  • Steve Sprang
Owner
unassigned
Submitted by
Steve Sprang
Severity
normal
S
S
Steve Sprang wrote on 5 Jun 2020 20:10
(address . guix-patches@gnu.org)
CA+xn8YDH0XKA0iufRozWOmOyhuEWFFtdMdKv3ze8boU2JBLSwA@mail.gmail.com

From 870b1541e78ad172fa39ac76e968837bc33624fe Mon Sep 17 00:00:00 2001
From: Steve Sprang <scs@stevesprang.com>
Date: Fri, 5 Jun 2020 11:05:06 -0700
Subject: [PATCH] gnu: openscad: Add patch to fix build.

* gnu/packages/engineering.scm (openscad): Use it.
* gnu/packages/patches/openscad-parser-boost-1.72.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
---
gnu/local.mk | 1 +
gnu/packages/engineering.scm | 5 +++-
.../patches/openscad-parser-boost-1.72.patch | 26 +++++++++++++++++++
3 files changed, 31 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/openscad-parser-boost-1.72.patch

Toggle diff (62 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 01ec893310..05b9c5b8d4 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1328,6 +1328,7 @@ dist_patch_DATA = \
%D%/packages/patches/openocd-nrf52.patch \
%D%/packages/patches/openssh-hurd.patch \
%D%/packages/patches/openresolv-restartcmd-guix.patch \
+ %D%/packages/patches/openscad-parser-boost-1.72.patch \
%D%/packages/patches/openssl-runpath.patch \
%D%/packages/patches/openssl-1.1-c-rehash-in.patch \
%D%/packages/patches/openssl-c-rehash-in.patch \
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 2102f8d295..fab3ee0261 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2263,7 +2263,10 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
".src.tar.gz"))
(sha256
(base32
- "0nbgk5q5pgnw53la0kccdcpz2f4xf6d6076rkn0q08z57hkc85ha"))))
+ "0nbgk5q5pgnw53la0kccdcpz2f4xf6d6076rkn0q08z57hkc85ha"))
+ (patches
+ (search-patches
+ "openscad-parser-boost-1.72.patch"))))
(build-system cmake-build-system)
(inputs
`(("boost" ,boost)
diff --git a/gnu/packages/patches/openscad-parser-boost-1.72.patch b/gnu/packages/patches/openscad-parser-boost-1.72.patch
new file mode 100644
index 0000000000..35311e6173
--- /dev/null
+++ b/gnu/packages/patches/openscad-parser-boost-1.72.patch
@@ -0,0 +1,26 @@
+https://github.com/openscad/openscad/commit/b6c170cc5d.patch
+
+From b6c170cc5dd1bc677176ee732cdb0ddae57e5cf0 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Fri, 25 Oct 2019 15:10:26 +0000
+Subject: [PATCH] Add missing header bootlegged by Boost < 1.72
+
+src/parser.y:76:6: error: no template named 'stack' in namespace 'std'
+std::stack<LocalScope *> scope_stack;
+~~~~~^
+---
+ src/parser.y | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/parser.y b/src/parser.y
+index 7f4fd56ca7..4c77c989ea 100644
+--- a/src/parser.y
++++ b/src/parser.y
+@@ -46,6 +46,7 @@
+ #include "printutils.h"
+ #include "memory.h"
+ #include <sstream>
++#include <stack>
+ #include <boost/filesystem.hpp>
+ #include "boost-utils.h"
+ #include "feature.h"
--
2.26.2
B
B
Brice Waegeneire wrote on 6 Jun 2020 18:28
(name . Steve Sprang)(address . steve.sprang@gmail.com)(address . 41725-done@debbugs.gnu.org)
87lfl0kvkn.fsf@waegenei.re
Hello Steve,

Thank you for the patch.

I can't find a failed build on ci.guix.gnu.org but building it locally
it failed. Your patch fixed that.

Pushed as c08a784c58bca8df048bc98276aa4fcf0d61d8b3 with minor cosmetic
tweaks.

- Brice
Closed
?