[PATCH] gnu: Update python-pylint to 2.5.2

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Ryan Prior
Owner
unassigned
Submitted by
Ryan Prior
Severity
normal
R
R
Ryan Prior wrote on 28 May 2020 20:01
(address . guix-patches@gnu.org)
20200528180122.21280-1-rprior@protonmail.com
* gnu/packages/check.scm (python-pylint): Updated version to 2.5.2
---
gnu/packages/check.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 7d7fd189bc..de4a978d97 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1887,12 +1887,10 @@ unit tests and failing them if the unit test module does not exercise all
statements in the module it tests.")
(license license:gpl3+)))
-;; Further releases, up to 2.4.3, have failing unit tests. See:
-;; https://github.com/PyCQA/pylint/issues/3198.
(define-public python-pylint
(package
(name "python-pylint")
- (version "2.3.1")
+ (version "2.5.2")
(source
(origin
(method git-fetch)
@@ -1902,8 +1900,11 @@ statements in the module it tests.")
(file-name (git-file-name name version))
(sha256
(base32
- "17vvzbcqmkhr4icq5p3737nbiiyj1y3g1pa08n9mb1bsnvxmqq0z"))))
+ "150x679mrlgm1s4ym7irf9mnsjilqyaakss4spc4pbrzkl11agnh"))))
(build-system python-build-system)
+ ;; Further releases, up to 2.4.3, have failing unit tests. See:
+ ;; https://github.com/PyCQA/pylint/issues/3198.
+ (arguments '(#:tests? #f))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)
--
2.26.2
M
M
Marius Bakke wrote on 30 May 2020 14:31
871rn138qa.fsf@gnu.org
Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/check.scm (python-pylint): Updated version to 2.5.2

Thanks! I fixed the commit message and applied with the following
changes:
Toggle diff (22 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index de4a978d97..8d99e67514 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1902,7 +1902,7 @@ statements in the module it tests.")
(base32
"150x679mrlgm1s4ym7irf9mnsjilqyaakss4spc4pbrzkl11agnh"))))
(build-system python-build-system)
- ;; Further releases, up to 2.4.3, have failing unit tests. See:
+ ;; FIXME: Tests are failing since version 2.4.3, see:
;; https://github.com/PyCQA/pylint/issues/3198.
(arguments '(#:tests? #f))
(native-inputs
@@ -1946,7 +1946,7 @@ possible to write plugins to add your own checks.")
(base32
"02a89d8a47s7nfiv1ady3j0sg2sbyja3np145brarfp5x9qxz9x2"))))
(arguments
- `(,@(package-arguments pylint)
+ `(,@(strip-keyword-arguments '(#:tests?) (package-arguments pylint))
#:phases
(modify-phases %standard-phases
(replace 'check
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7SUg0ACgkQoqBt8qM6
VPo7xAgAh2FtYRH+bExQgMi3Q8qABysMH6ZBB/iut6vXH+ZCh9Wp3ORC80bV7BcF
WBx36UKvC/ZLByzV6Dj2Nmj9XhLcd6kv5kBNUxKWwKmZ0tx8b49LlFMDU8uPg2Mk
ijVgeedasV4vOaJ+h+Oa6oVCiOB0RzkECcIJD3BMvOtn/vhpPKv8Lc76uzCNRBn8
POnuR6Nx4gaDwl+uP9Wm/2WWEwywW1bdziW1WmNxyGiyADvBIecy4LdZojsI/xbV
kCx4lEN95fK/y2Q5cp/cpS4OwID2/8IWHQkZcFWKOfkfOoJVBAQf1IsMxAVX6KZ7
q7+ny3C9neKBwfIEGJ+Piu6DiCg2cA==
=uT0k
-----END PGP SIGNATURE-----

Closed
M
M
Marius Bakke wrote on 30 May 2020 23:34
Re: bug#41580: [PATCH] gnu: Update python-pylint to 2.5.2
87v9kdw1i9.fsf@gnu.org
Marius Bakke <marius@gnu.org> writes:

Toggle quote (7 lines)
> Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:
>
>> * gnu/packages/check.scm (python-pylint): Updated version to 2.5.2
>
> Thanks! I fixed the commit message and applied with the following
> changes:

I had to revert this patch because it broke the Totem test suite:


Can you take a look?

In the future, it's good if you run 'guix refresh -l package' and try to
build some of the important-looking dependents before submitting, GNOME
in this case. :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7S0V4ACgkQoqBt8qM6
VPodMQf/cPosoYyi+6AjvsPukiROuyQOvERdzeVjn2BfB/8mALnR5aT62RGHHGLF
mT0wC2DZQCYc4QqW1WUOQQeKaG2/UUryhPso3lTJdjrHsS05BDwH3QNE+H7lL6w0
Z98zvMEuVV6R/tj+vdmGF0IxgAwPZxvdWrMm1Ch/hB5M4H2Ah4xzubyXMFDLrJYW
kwtmjAZotB4i6b4CkBNXkV+sctjX/BFqQ6okdMBEnIaNzhlVw3qfs2qODzAS/S9l
UFaRsJtPqrGDDQNdk0fFof1Qq5sH1LdWnpGq1WvV/tpZSZIFjahfcjjJumg3dmqK
a5eVsG9HAVxoz1t/WnNxuIbBloyQKQ==
=qldk
-----END PGP SIGNATURE-----

Closed
?