[PATCH] gnu: Add remid-lv2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 27 May 2020 02:37
(name . Guix patches)(address . guix-patches@gnu.org)
94c136949f58964383c2fabe6a28aa80bc3c79ea.camel@zrythm.org
Hi,

This patch adds the reMID LV2 plugin.

Thanks,
Alex
From ba3a5a3d309e128cd87a4a4b0058b5088f522853 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 27 May 2020 01:35:03 +0100
Subject: [PATCH] gnu: Add remid-lv2.

* gnu/packages/music.scm (remid-lv2): new variable.
---
gnu/packages/music.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f01978d118..9cfda8e88c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5341,6 +5341,42 @@ hall reverb and a room reverb. Both are available as LV2 plugins as well
as JACK standalone applications.")
(license license:gpl3+)))
+(define-public remid-lv2
+ (package
+ (name "remid-lv2")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ssj71/"
+ "reMID.lv2/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1kffpv90a967wwpsa0jb1jp5qnhf85m4ap8nfw8wih71rcrgg4h3"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests included
+ (inputs
+ `(("glib" ,glib)
+ ("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-1)
+ ("lv2" ,lv2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/ssj71/reMID.lv2")
+ (synopsis
+ "MIDI-controlled implementation of the SID 6581 chip used in the
+Commodore 64")
+ (description
+ "The 6581 SID chip is the sound chip used in the Commodore 64 computer.
+reMID is a MIDI implementation of the 6581 SID chip using the reSID library
+to provide a virtual SID-based synthesizer, controllable in real-time via
+MIDI. It includes support for scripted instruments that allow complex sonic
+control of the chip.")
+ (license license:gpl2)))
+
(define-public zlfo
(package
(name "zlfo")
--
2.26.2
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl7NtloACgkQAi6uQjE9
cPM4GQf/aXUphu4kzG4dFrGG8CJQ57qXqelwzAK0ezcvBL4zhz6cdyaRJNZAtPN3
Afhlj6yy3hYlYrCLayktl2J4e2UhKyW1qwhGH5iHYvLWjbj8H51CZHxV4ZLQ2cBz
xxrlZkrpv8bR3FPZ21qNKtgH9aXVOGeBVR8X55mm3lomd8Mby/qjsvdCWRXVNNLL
B4qAx9GAGTeAr8BA0dA+Yr2AlkmMcug7sJN8VtQLA6Li1l3uFFvn9Ubt5/jTsJ7G
HDOac3nWNjzS9CDc0KV5XLAbIHXLJ7K0JEd/y5MXfUK9Vcn3WWMHyXHZqx9OCTTi
/28pZV8RmL38Grm8VTmXnsSdqHDx/Q==
=u+9D
-----END PGP SIGNATURE-----


M
M
Marius Bakke wrote on 30 May 2020 13:33
87lfl93beq.fsf@gnu.org
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (4 lines)
> Hi,
>
> This patch adds the reMID LV2 plugin.

Thanks!

[...]

Toggle quote (11 lines)
> +(define-public remid-lv2
> + (package
> + (name "remid-lv2")
> + (version "0.3")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/ssj71/"
> + "reMID.lv2/archive/v"
> + version ".tar.gz"))

The GitHub /archive/ URLs are not stable: they might fall out of GitHubs
cache and be regenerated, with different time stamps. So we should use
git-fetch here instead.

This is different from "/releases/", which are uploaded. Unfortunately
GitHubs UI makes it difficult to tell the difference short of looking at
the URL.

Toggle quote (13 lines)
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "1kffpv90a967wwpsa0jb1jp5qnhf85m4ap8nfw8wih71rcrgg4h3"))))
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f)) ; no tests included
> + (inputs
> + `(("glib" ,glib)
> + ("alsa-lib" ,alsa-lib)
> + ("jack" ,jack-1)
> + ("lv2" ,lv2)))

Nit: we usually sort inputs. Helpful when there are dozens.

Toggle quote (13 lines)
> + (native-inputs
> + `(("pkg-config" ,pkg-config)))
> + (home-page "https://github.com/ssj71/reMID.lv2")
> + (synopsis
> + "MIDI-controlled implementation of the SID 6581 chip used in the
> +Commodore 64")
> + (description
> + "The 6581 SID chip is the sound chip used in the Commodore 64 computer.
> +reMID is a MIDI implementation of the 6581 SID chip using the reSID library
> +to provide a virtual SID-based synthesizer, controllable in real-time via
> +MIDI. It includes support for scripted instruments that allow complex sonic
> +control of the chip.")

Why yes, I know some of these words :-) would it make sense to define
"SID" here with @acronym?

Toggle quote (2 lines)
> + (license license:gpl2)))

This is actually GPL2+, because none of the source files say "version 2
only" (and some actually say explicitly GPL2-or-later).

Can you send an updated patch?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7SRH0ACgkQoqBt8qM6
VPrwDQgAhfbM6fDn8enOodbKasKOuvelgAeq5C+y28Sx23P45uf2Qeh6b1r18wNG
SeTmyRbyYwlG7nVBTa6+KyT/AbY0NGQPu9DRlww7Y20UbKrD2q6k4KOp9St1YFEv
sr8l58VAcGfa4fldMnspQKpCH8rwKIO30mNutWOLrgjO6zIH0TSO5aa9z4EF8qkF
iDTVDG/9/jOhIgZQsaGHNg9S8nNkp43ET/NQhXWs9Z7Cg52d/3Uv3SIV60cGLFRS
VUx/iDb3x9Y6IKbyaPWxn00HgmPLd9iFXl8rC5OSwfijgqnnppF5OOSXXXUvmHbg
/XuTptc+dePD3l3WNjdv+qBMLQMBGA==
=xp0n
-----END PGP SIGNATURE-----

A
A
Alexandros Theodotou wrote on 8 Jul 2020 21:43
aca7c83d38d8a004658f98d347a5977f13e53ffa.camel@zrythm.org
Hi,

Thanks for the feedback.

I fixed the patch although I'm not sure what to do with the
description/summary - I don't know what those are either, I just know
that it's a cool audio plugin. Feel free to edit it.

Thanks,
Alex

On Sat, 2020-05-30 at 13:33 +0200, Marius Bakke wrote:
Toggle quote (77 lines)
> Alexandros Theodotou <alex@zrythm.org> writes:
>
> > Hi,
> >
> > This patch adds the reMID LV2 plugin.
>
> Thanks!
>
> [...]
>
> > +(define-public remid-lv2
> > + (package
> > + (name "remid-lv2")
> > + (version "0.3")
> > + (source
> > + (origin
> > + (method url-fetch)
> > + (uri (string-append "https://github.com/ssj71/"
> > + "reMID.lv2/archive/v"
> > + version ".tar.gz"))
>
> The GitHub /archive/ URLs are not stable: they might fall out of
> GitHubs
> cache and be regenerated, with different time stamps. So we should
> use
> git-fetch here instead.
>
> This is different from "/releases/", which are
> uploaded. Unfortunately
> GitHubs UI makes it difficult to tell the difference short of looking
> at
> the URL.
>
> > + (file-name (string-append name "-" version ".tar.gz"))
> > + (sha256
> > + (base32
> > + "1kffpv90a967wwpsa0jb1jp5qnhf85m4ap8nfw8wih71rcrgg4h3"
> > ))))
> > + (build-system cmake-build-system)
> > + (arguments
> > + `(#:tests? #f)) ; no tests included
> > + (inputs
> > + `(("glib" ,glib)
> > + ("alsa-lib" ,alsa-lib)
> > + ("jack" ,jack-1)
> > + ("lv2" ,lv2)))
>
> Nit: we usually sort inputs. Helpful when there are dozens.
>
> > + (native-inputs
> > + `(("pkg-config" ,pkg-config)))
> > + (home-page "https://github.com/ssj71/reMID.lv2")
> > + (synopsis
> > + "MIDI-controlled implementation of the SID 6581 chip used in
> > the
> > +Commodore 64")
> > + (description
> > + "The 6581 SID chip is the sound chip used in the Commodore
> > 64 computer.
> > +reMID is a MIDI implementation of the 6581 SID chip using the
> > reSID library
> > +to provide a virtual SID-based synthesizer, controllable in real-
> > time via
> > +MIDI. It includes support for scripted instruments that allow
> > complex sonic
> > +control of the chip.")
>
> Why yes, I know some of these words :-) would it make sense to define
> "SID" here with @acronym?
>
> > + (license license:gpl2)))
>
> This is actually GPL2+, because none of the source files say "version
> 2
> only" (and some actually say explicitly GPL2-or-later).
>
> Can you send an updated patch?
From 7cc536dfeeea735afb8e15f83c5eef8aac020c4f Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 20:39:38 +0100
Subject: [PATCH] gnu: Add remid-lv2.

* gnu/packages/music.scm (remid-lv2): New variable.
---
gnu/packages/music.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index d0f5bee3a0..6042015dda 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5419,6 +5419,42 @@ automation that comes as an LV2 plugin bundle with a custom UI.")
(home-page "https://git.zrythm.org/cgit/ZLFO/")
(license license:agpl3+)))
+(define-public remid-lv2
+ (package
+ (name "remid-lv2")
+ (version "0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ssj71/reMID.lv2.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "062kriniidsrhzwrf89kfxm9wb0cmgrl07asnlmgil8vcl7gl9y5"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests included
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("glib" ,glib)
+ ("jack" ,jack-1)
+ ("lv2" ,lv2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/ssj71/reMID.lv2")
+ (synopsis
+ "MIDI-controlled implementation of the SID 6581 chip used in the
+Commodore 64")
+ (description
+ "The 6581 SID chip is the sound chip used in the Commodore 64 computer.
+reMID is a MIDI implementation of the 6581 SID chip using the reSID library
+to provide a virtual SID-based synthesizer, controllable in real-time via
+MIDI. It includes support for scripted instruments that allow complex sonic
+control of the chip.")
+ (license license:gpl2+)))
+
(define-public vl1-emulator
(package
(name "vl1-emulator")
--
2.27.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl8GIdMACgkQAi6uQjE9
cPPZtQf9HoNWh4JNOdR7rXCoVedyNkzFcBGfHFxlb0AAQAT8kDilbEYcnpXDp+V0
vyRqDZM0H9cP2Rp8P252g51IGCnusfd3EbwNsxqYeq60pGXiqt+Ns5lLFEexb8nG
K8QhmiAr7WTWagNmvXy9PPwer98NQYb0yBLab2NyBxr8Ruv7b7vqPQl2FE1MGtQZ
n6Z3eQHZQ2W7xAXuOROEXLvnfrTJzz4oiTCqcdd9EFVtzls1FC4USMaHl3W1JoFw
88D9LfhVhdtEqmM64G1CTzRzXYz5X8uTJDhuw9Y4f4W5bbxXxfvnhuJPiVEoOKiE
njocIV72t98NeW32dQLzPlOx7d2YaQ==
=VlQZ
-----END PGP SIGNATURE-----


M
M
Marius Bakke wrote on 21 Jul 2020 23:06
87o8o8fuin.fsf@gnu.org
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (8 lines)
> Hi,
>
> Thanks for the feedback.
>
> I fixed the patch although I'm not sure what to do with the
> description/summary - I don't know what those are either, I just know
> that it's a cool audio plugin. Feel free to edit it.

OK.

I applied the patch after fixing the indentation. Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl8XWMAACgkQoqBt8qM6
VPqkyAf/axNOp2BItAuHTvRyRgB1mQJKqtzd7JeqeWvZLYYvFtcS/6DQ3FF/Io03
mbTS5SN94wHx3neD1DKTJylM0+KTrJxzdpG8Y8b/aydUhHTVgsHmMgE+/ZFXzG8v
fNrb+8+gGSiEBurKY1yXSMiPRPUstt65Js7V5yWzbTdkkdaoeecC47VZIEH/JAqf
7ivnQI2tVBDUQNbB/YIpJ2+CDQMZWorV3gcV9GwTpjvM/H5fwhMuI9bQYLlGLid2
Gtp3VrhyI4+02h2mAIYczaJufcelJj27EA8UxFuh/KyVHcXkdeHqinvBXaRCRjJn
cpSwSubnFYeU2+ZLjAmMkNYo66jyFA==
=TzvZ
-----END PGP SIGNATURE-----

Closed
?