[PATCH] gnu: Add python-pyfiglet

  • Done
  • quality assurance status badge
Details
3 participants
  • Edouard Klein
  • Marius Bakke
  • Marius Bakke
Owner
unassigned
Submitted by
Edouard Klein
Severity
normal
E
E
Edouard Klein wrote on 22 May 2020 17:24
(address . guix-patches@gnu.org)
877dx4at6p.fsf@alice.lan
* gnu/packages/python-xyz (python-pyfiglet): New variable.
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d8552276fc..7a1312e87b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20133,3 +20133,21 @@ using multi-select lists, confirmations, free text prompts, completion, etc.")
background tasks, and check these tasks' health by hand, relaunch them, etc. by attaching
to the corresponding pane in tmux.")
(license license:agpl3+)))
+
+(define-public python-pyfiglet
+ (package
+ (name "python-pyfiglet")
+ (version "0.8.post1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyfiglet" version))
+ (sha256
+ (base32
+ "0f9n2076ga2ccsg174k2d7n0z4d44ml96yzc72s6g4nhalbk5hn6"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/pwaller/pyfiglet")
+ (synopsis "Pure-python FIGlet implementation")
+ (description "This module lets you draw large letter from ordinary characters
+ in pure Python.")
+ (license license:expat)))
--
2.26.2
M
M
Marius Bakke wrote on 30 May 2020 14:58
87pnal1swx.fsf@gnu.org
Edouard Klein <edk@beaver-labs.com> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz (python-pyfiglet): New variable.

Thanks!

[...]

Toggle quote (11 lines)
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index d8552276fc..7a1312e87b 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -20133,3 +20133,21 @@ using multi-select lists, confirmations, free text prompts, completion, etc.")
> background tasks, and check these tasks' health by hand, relaunch them, etc. by attaching
> to the corresponding pane in tmux.")
> (license license:agpl3+)))
> +
> +(define-public python-pyfiglet

This depends on some missing context in python-xyz.scm and does not
apply. Can you rebase this on 'master'?

Toggle quote (3 lines)
> + (package
> + (name "python-pyfiglet")

The indentation here is off. If you are not using Emacs, there is a
script to help with the indentation.

Toggle quote (14 lines)
> + (version "0.8.post1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "pyfiglet" version))
> + (sha256
> + (base32
> + "0f9n2076ga2ccsg174k2d7n0z4d44ml96yzc72s6g4nhalbk5hn6"))))
> + (build-system python-build-system)
> + (home-page "https://github.com/pwaller/pyfiglet")
> + (synopsis "Pure-python FIGlet implementation")
> + (description "This module lets you draw large letter from ordinary characters
> + in pure Python.")

It would be good to define FIGlet here somewhere.

Can you send an updated patch?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7SWF4ACgkQoqBt8qM6
VPopcggAyGtSFjIqioGrOSmI4IZ01WlCK59eRtL0siW7jgtjrGCurHIf+dFwKiqJ
bsmaoOnkh4tU1gJgXfEHzylC1jfQLTmlCo2j5nYX/AO4SuSYNSYDegzpM/wznQxw
EJVuuIkGRK54nUgcl7+tQU63IzkTSB54mflb8EPt4b/Nj2a/AU+asGA67CppFCoV
dWR9ZuKo03WQVq+ef9mSdMXf6mmMfIkR5FL0lGToGSSmC7aUDP93byWri+2La2QO
0s4fuRHvOxv7QVqaFM9L3s4c7XkUbbKCHwnMvE/YdbTYvTtFNelDsCUKp9LmXBhA
spCJ+SJnABIxEIT6FnjX5po26nC4Fw==
=rZns
-----END PGP SIGNATURE-----

E
E
Edouard Klein wrote on 2 Jun 2020 13:39
[PATCH] gnu: Add python-pyfiglet
(address . 41460@debbugs.gnu.org)
87zh9lbss8.fsf@alice.lan
* gnu/packages/python-xyz.scm (python-pyfiglet): New variable.
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6aa666430a..3ecfaab081 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10087,6 +10087,24 @@ interface to the Amazon Web Services (AWS) API.")
(define-public python2-botocore
(package-with-python2 python-botocore))
+(define-public python-pyfiglet
+ (package
+ (name "python-pyfiglet")
+ (version "0.8.post1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyfiglet" version))
+ (sha256
+ (base32
+ "0f9n2076ga2ccsg174k2d7n0z4d44ml96yzc72s6g4nhalbk5hn6"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/pwaller/pyfiglet")
+ (synopsis "Draw ASCII art big letters in pure-python")
+ (description "This module lets you draw large letter from ordinary characters
+ in pure Python.")
+ (license license:expat)))
+
(define-public python-xdo
(package
(name "python-xdo")
--
2.26.2
M
M
Marius Bakke wrote on 22 Jun 2020 21:44
87sgemc2bx.fsf@gnu.org
Edouard Klein <edk@beaver-labs.com> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-pyfiglet): New variable.

Applied, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7xCjIACgkQoqBt8qM6
VPqLLQgAjjMdSgIMqwy+hx5zIiIRzCDNyMIrp69zTKb0GsU25SxcJYJn5nFqE4sc
tfTrHXc3mxjYBliWHGeKUO2xJumlos+L4FWFE8nVjHdqAAkiuxizg+vuXKGPDCv2
hszdSrb7dXkznh1FOurJeBBYUGOPwEKV941L/m6ax+EJW+YR7/ut7V6wzdloGagx
3SFT7w2/acZ54AhUWrNuYPVZLZh4g2V8U4y9/dij0O/DroWKWaJ1AqU5l7uzJ+5r
iS61+85X0rAijvhIZK6RtHfXeQZk9suj1Y2hiHxOny9otThROzXFMdWzIToknREK
H9DyNUGPwv7SA0wyNJQD/kxiYeIhMQ==
=jiKc
-----END PGP SIGNATURE-----

Closed
?