[PATCH] Add python-pyramid

  • Done
  • quality assurance status badge
Details
2 participants
  • Holger Peters
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Holger Peters
Severity
normal
Merged with
H
H
Holger Peters wrote on 16 May 2020 13:15
(address . guix-patches@gnu.org)(name . Holger Peters)(address . holger.peters@posteo.de)
20200516111500.97408-1-holger.peters@posteo.de
Package python-pyramid, a (popular) web framework.

Furthermore bump python-webob to the latest available version on
PyPI.

Holger Peters (2):
gnu: python-webob: Update to 1.8.6
gnu: Add python-pyramid and dependencies

gnu/packages/python-web.scm | 179 +++++++++++++++++++++++++++++++++++-
1 file changed, 177 insertions(+), 2 deletions(-)

--
2.26.0
H
H
Holger Peters wrote on 16 May 2020 18:43
[PATCH 1/2] gnu: python-webob: Update to 1.8.6
(address . 41331@debbugs.gnu.org)(name . Holger Peters)(address . holger.peters@posteo.de)
20200516164329.98088-1-holger.peters@posteo.de
* gnu/packages/python-web.scm (python-webob): Update to 1.8.6.
---
gnu/packages/python-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d64f698dbc..05c26610e9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1012,14 +1012,14 @@ your Web app.")
(define-public python-webob
(package
(name "python-webob")
- (version "1.8.3")
+ (version "1.8.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "WebOb" version))
(sha256
(base32
- "1cpqskanmvwia8wqlpcr3ykyxysynjdnbl5namvpg8vw6jnkv1dh"))))
+ "026i3z99nr3px75isa9mbnky5i7rffiv4d124h5kxfjjsxz92fma"))))
(build-system python-build-system)
(native-inputs
`(("python-nose" ,python-nose)))
--
2.26.0
H
H
Holger Peters wrote on 16 May 2020 18:43
[PATCH 2/2] gnu: Add python-pyramid and dependencies
(address . 41331@debbugs.gnu.org)(name . Holger Peters)(address . holger.peters@posteo.de)
20200516164329.98088-2-holger.peters@posteo.de
* gnu/packages/python-web.scm Added several packages
(python-venusian): Added 3.0.0
(python-python-zope-deprecation): Added 4.4.0
(python-python-translationstring): Added 1.3
(python-python-plaster): Added 1.0
(python-python-plaster-pastedeploy): Added 0.7
(python-hupper): Added 1.10.2
(python-pyramid): Added 1.10.4
---
gnu/packages/python-web.scm | 175 ++++++++++++++++++++++++++++++++++++
1 file changed, 175 insertions(+)

Toggle diff (185 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 05c26610e9..bbd7796c2e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3769,3 +3769,178 @@ Selenium specifically provides infrastructure for the W3C WebDriver specificatio
— a platform and language-neutral coding interface compatible with all
major web browsers.")
(license license:asl2.0)))
+
+(define-public python-venusian
+ (package
+ (name "python-venusian")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "venusian" version))
+ (sha256
+ (base32 "0f7f67dkgxxcjfhpdd5frb9pszkf04lyzzpn5069q0xi89r2p17n"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-runner" ,python-pytest-runner)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (arguments '(#:test-target "pytest"))
+ (home-page "https://docs.pylonsproject.org/projects/venusian")
+ (synopsis "Library for defering decorator actions")
+ (description
+ "Venusian is a library which allows framework authors to defer decorator
+ actions. Instead of taking actions when a function (or class) decorator
+ is executed at import time, you can defer the action usually taken by
+ the decorator until a separate scan phase.")
+ (license license:repoze)))
+
+(define-public python-zope-deprecation
+ (package
+ (name "python-zope-deprecation")
+ (version "4.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "zope.deprecation" version))
+ (sha256
+ (base32
+ "1pz2cv7gv9y1r3m0bdv7ks1alagmrn5msm5spwdzkb2by0w36i8d"))))
+ (build-system python-build-system)
+ (native-inputs `())
+ (propagated-inputs `())
+ (home-page "https://zopedeprecation.readthedocs.io/")
+ (synopsis "Provides a function for marking deprecations")
+ (description "The zope.deprecation module provides a function for marking
+ modules, classes, functions, methods and properties as
+ deprecated, displaying warnings when usaged in application
+ code.")
+ (license license:zpl2.1)))
+
+(define-public python-translationstring
+ (package
+ (name "python-translationstring")
+ (version "1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "translationstring" version))
+ (sha256
+ (base32
+ "0bdpcnd9pv0131dl08h4zbcwmgc45lyvq3pa224xwan5b3x4rr2f"))))
+ (build-system python-build-system)
+ (native-inputs `())
+ (propagated-inputs `())
+ (home-page "http://docs.pylonsproject.org/projects/translationstring")
+ (synopsis "Internationalization tooling for the Pylons project")
+ (description "A library used by various Pylons project packages for
+ internationalization (i18n) duties related to translation.")
+ (license license:repoze)))
+
+(define-public python-plaster
+ (package
+ (name "python-plaster")
+ (version "1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "plaster" version))
+ (sha256
+ (base32
+ "1hy8k0nv2mxq94y5aysk6hjk9ryb4bsd13g83m60hcyzxz3wflc3"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs `())
+ (home-page "https://docs.pylonsproject.org/projects/plaster/en/latest/")
+ (synopsis "Configuration loader for multiple config file formats")
+ (description
+ "Plaster is a loader interface around multiple config file formats. It
+ exists to define a common API for applications to use when they wish to
+ load configuration. The library itself does not aim to handle anything
+ except a basic API that applications may use to find and load
+ configuration settings. Any specific constraints should be implemented
+ in a pluggable loader which can be registered via an entrypoint.")
+ (license license:repoze)))
+
+(define-public python-plaster-pastedeploy
+ (package
+ (name "python-plaster-pastedeploy")
+ (version "0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "plaster_pastedeploy" version))
+ (sha256
+ (base32
+ "1zg7gcsvc1kzay1ry5p699rg2qavfsxqwl17mqxzr0gzw6j9679r"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-plaster" ,python-plaster)
+ ("python-pastedeploy" ,python-pastedeploy)))
+ (home-page "https://github.com/Pylons/plaster_pastedeploy")
+ (synopsis "Plugin for `python-plaster' adds support for PasteDeploy
+ syntax")
+ (description
+ "This plugin for `python-plaster' adds support for PasteDeploy syntax, it
+ provides a plaster Loader object that can parse ini files according to
+ the standard set by PasteDeploy ")
+ (license license:expat)))
+
+(define-public python-hupper
+ (package
+ (name "python-hupper")
+ (version "1.10.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "hupper" version))
+ (sha256
+ (base32
+ "0am0p6g5cz6xmcaf04xq8q6dzdd9qz0phj6gcmpsckf2mcyza61q"))))
+ (build-system python-build-system)
+ (arguments '(#:test-target "pytest"))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-watchdog" ,python-watchdog)
+ ("python-mock" ,python-mock)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (propagated-inputs
+ `(("python-pytz" ,python-pytz)))
+ (home-page "https://readthedocs.org/projects/hupper")
+ (synopsis
+ "Integrated process monitor tracking changes to imported
+ Python files")
+ (description
+ "Hupper is an integrated process monitor that will track changes to any
+ imported Python files in sys.modules as well as custom paths. When
+ files are changed the process is restarted.")
+ (license license:expat)))
+
+(define-public python-pyramid
+ (package
+ (name "python-pyramid")
+ (version "1.10.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyramid" version))
+ (sha256
+ (base32
+ "0rkxs1ajycg2zh1c94xlmls56mx5m161sn8112skj0amza6cn36q"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-hupper" ,python-hupper)
+ ("python-plaster-pastedeploy" ,python-plaster-pastedeploy)
+ ("python-translationstring" ,python-translationstring)
+ ("python-venusian" ,python-venusian)
+ ("python-webob" ,python-webob)
+ ("python-zope-deprecation" ,python-zope-deprecation)
+ ("python-zope-interface" ,python-zope-interface)
+ ("python-webtest" ,python-webtest)
+ ("python-zope-component" ,python-zope-component)
+ ("python-plaster" ,python-plaster)))
+ (native-inputs `())
+ (home-page "https://trypyramid.com/")
+ (synopsis "Python web-framework suitable for small and large sites")
+ (description
+ "Pyramid makes it easy to write web applications. From minimal
+ request/response web apps to larger, grown applications.")
+ (license license:repoze)))
--
2.26.0
R
R
Ricardo Wurmus wrote on 20 May 2020 09:34
merge issues
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
877dx7f4ax.fsf@elephly.net
merge 41416 41331
quit
?