[PATCH] rawdog RSS reader

  • Done
  • quality assurance status badge
Details
2 participants
  • ???
  • raingloom
Owner
unassigned
Submitted by
raingloom
Severity
normal
R
R
raingloom wrote on 12 May 2020 01:58
(address . guix-patches@gnu.org)
20200512015811.2ca6bc70@riseup.net
It was rather trivial to package. Just a single dependency.

There is, however, a recommended dependency (PyTidy) that I did not add,
since it doesn't seem to be included in the Nix package either and
doesn't seem to be packaged in Guix. It just tidies up the HTML output,
so it's not all that important.
From baa6940b9035e196eb0b870dc08fdd50212a8708 Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@protonmail.com>
Date: Tue, 12 May 2020 01:50:30 +0200
Subject: [PATCH] gnu: Add rawdog.

* gnu/packages/syndication.scm (rawdog): New variable.
---
gnu/packages/syndication.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 5bc3d19a92..a9e69cd8d6 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -30,6 +30,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages python-web)
@@ -169,3 +170,26 @@ file system, and many more features.")
"Tuir provides a simple terminal viewer for Reddit (Terminal UI for Reddit).")
(license (list license:expat
license:gpl3+)))) ; tuir/packages/praw
+
+(define-public rawdog
+ (package
+ (name "rawdog")
+ (version "2.23")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://offog.org/files/rawdog-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "18nyg19mwxyqdnykplkqmzb4n27vvrhvp639zai8f81gg9vdbsjp"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2.7))
+ (inputs
+ `(("python2-feedparser" ,python2-feedparser)))
+ (home-page "https://offog.org/code/rawdog/")
+ (synopsis "RSS Aggregator Without Delusions Of Grandeur")
+ (description
+ "An RSS aggregator that produces static HTML pages from feeds")
+ (license license:gpl2)))
--
2.26.2
?
(name . raingloom)(address . raingloom@riseup.net)(address . 41199-done@debbugs.gnu.org)
874ksg5i98.fsf@member.fsf.org
raingloom <raingloom@riseup.net> writes:

Toggle quote (2 lines)
> It was rather trivial to package. Just a single dependency.

Hello, thank you for this package, pushed!

Toggle quote (6 lines)
>
> There is, however, a recommended dependency (PyTidy) that I did not add,
> since it doesn't seem to be included in the Nix package either and
> doesn't seem to be packaged in Guix. It just tidies up the HTML output,
> so it's not all that important.

I have also package 'python2-pytidylib' and add it as a input for this
rawdog.
Toggle quote (49 lines)
>
>>From baa6940b9035e196eb0b870dc08fdd50212a8708 Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@protonmail.com>
> Date: Tue, 12 May 2020 01:50:30 +0200
> Subject: [PATCH] gnu: Add rawdog.
>
> * gnu/packages/syndication.scm (rawdog): New variable.
> ---
> gnu/packages/syndication.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
> index 5bc3d19a92..a9e69cd8d6 100644
> --- a/gnu/packages/syndication.scm
> +++ b/gnu/packages/syndication.scm
> @@ -30,6 +30,7 @@
> #:use-module (gnu packages gettext)
> #:use-module (gnu packages ncurses)
> #:use-module (gnu packages pkg-config)
> + #:use-module (gnu packages python)
> #:use-module (gnu packages python-check)
> #:use-module (gnu packages python-xyz)
> #:use-module (gnu packages python-web)
> @@ -169,3 +170,26 @@ file system, and many more features.")
> "Tuir provides a simple terminal viewer for Reddit (Terminal UI for Reddit).")
> (license (list license:expat
> license:gpl3+)))) ; tuir/packages/praw
> +
> +(define-public rawdog
> + (package
> + (name "rawdog")
> + (version "2.23")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://offog.org/files/rawdog-"
> + version ".tar.gz"))
> + (sha256
> + (base32
> + "18nyg19mwxyqdnykplkqmzb4n27vvrhvp639zai8f81gg9vdbsjp"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:python ,python-2.7))
> + (inputs
> + `(("python2-feedparser" ,python2-feedparser)))
> + (home-page "https://offog.org/code/rawdog/")
> + (synopsis "RSS Aggregator Without Delusions Of Grandeur")
> + (description
> + "An RSS aggregator that produces static HTML pages from feeds")
It should end with '.', well I change the description to the first 2
lines of README.

Toggle quote (1 lines)
> + (license license:gpl2)))
And this to 'license:gpl2+'.

Thank you!
Closed
?