`guix` command segfaults after doing Ctrl-C during a frozen `guix pull`

  • Done
  • quality assurance status badge
Details
2 participants
  • JoJo
  • zimoun
Owner
unassigned
Submitted by
JoJo
Severity
normal
J
(address . bug-guix@gnu.org)
87zhahq7hr.fsf@jo.zone
Due to an unrelated issue, I was updating my system with `guix
pull`. During update, the process seemed to freeze / get stuck. My
system was responsive and all, but the `guix pull` output was stuck. I
don't remember what the last line in the output was, but after
studying the output of an application of
`/run/current-system/profile/bin/guix`, I think the output stuck at
the last step, "building profile with 1 package...". It definitely
said something about "profile" and "1 package" at least. I don't know
what caused the freeze. A casual guess is that it's related to my
screen blanking and the screen locker (`slock`) activatin due to no
input for a while.

Anyways, I decided to end the apparently frozen command, so I killed
it with Ctrl-C. Immediately afterwards when trying to `guix pull`
another time, `guix` just started segfaulting. Doesn't matter what
subcommand I try, or if I call `guix` with no subbcommand -- it just
segfaults in either case.

```
jojo@astoria ~$ guix pull
Segmentation fault
jojo@astoria ~$ guix
Segmentation fault
jojo@astoria ~$ guix show
Segmentation fault
```

I'm on Guix System, with a linux-nonfree kernel (due to wifi card).
Installing `strace` with
`/run/current-system/profile/bin/guix install strace`
and running `strace -f guix 2>&1 | tee tmp/log` prints:

```
execve("/home/jojo/.config/guix/current/bin/guix", ["guix"], 0x7fffc51e4718 /* 67 vars */) = 0
brk(NULL) = 0x1a31000
mmap(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f5de4d32000
access("/etc/ld.so.preload", R_OK) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.guix-profile/lib/tls/x86_64/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.guix-profile/lib/tls/x86_64/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.guix-profile/lib/tls/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.guix-profile/lib/tls/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.guix-profile/lib/tls/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.guix-profile/lib/tls/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.guix-profile/lib/tls/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.guix-profile/lib/tls", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.guix-profile/lib/x86_64/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.guix-profile/lib/x86_64/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.guix-profile/lib/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.guix-profile/lib/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.guix-profile/lib/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.guix-profile/lib/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.guix-profile/lib/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.guix-profile/lib", {st_mode=S_IFDIR|0555, st_size=12288, ...}) = 0
openat(AT_FDCWD, "/home/jojo/.local/lib/tls/x86_64/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.local/lib/tls/x86_64/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.local/lib/tls/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.local/lib/tls/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.local/lib/tls/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.local/lib/tls/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.local/lib/tls/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.local/lib/tls", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.local/lib/x86_64/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.local/lib/x86_64/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.local/lib/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.local/lib/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.local/lib/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.local/lib/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/.local/lib/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/.local/lib", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/Hack/carth/foreign-core/target/release/tls/x86_64/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/Hack/carth/foreign-core/target/release/tls/x86_64/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/Hack/carth/foreign-core/target/release/tls/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/Hack/carth/foreign-core/target/release/tls/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/Hack/carth/foreign-core/target/release/tls/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/Hack/carth/foreign-core/target/release/tls/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/Hack/carth/foreign-core/target/release/tls/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/Hack/carth/foreign-core/target/release/tls", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/Hack/carth/foreign-core/target/release/x86_64/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/Hack/carth/foreign-core/target/release/x86_64/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/Hack/carth/foreign-core/target/release/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/Hack/carth/foreign-core/target/release/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/Hack/carth/foreign-core/target/release/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/Hack/carth/foreign-core/target/release/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/home/jojo/Hack/carth/foreign-core/target/release/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/jojo/Hack/carth/foreign-core/target/release", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "tls/x86_64/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "tls/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "tls/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "tls/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "x86_64/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/tls/x86_64/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/tls/x86_64/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/tls/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/tls/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/tls/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/tls/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/tls/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/tls", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/x86_64/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/x86_64/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/x86_64/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/x86_64", 0x7fff1b7444a0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/libguile-3.0.so.1", O_RDONLY|O_CLOEXEC) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\200s\3\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0555, st_size=1529768, ...}) = 0
mmap(NULL, 1318592, PROT_READ, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7f5de4bf0000
mprotect(0x7f5de4c23000, 999424, PROT_NONE) = 0
mmap(0x7f5de4c23000, 741376, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x33000) = 0x7f5de4c23000
mmap(0x7f5de4cd8000, 253952, PROT_READ, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0xe8000) = 0x7f5de4cd8000
mmap(0x7f5de4d17000, 73728, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x126000) = 0x7f5de4d17000
mmap(0x7f5de4d29000, 36544, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7f5de4d29000
close(3) = 0
openat(AT_FDCWD, "/home/jojo/.guix-profile/lib/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "tls/x86_64/x86_64/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "tls/x86_64/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "tls/x86_64/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "tls/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "x86_64/x86_64/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "x86_64/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "x86_64/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/tls/x86_64/x86_64/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/tls/x86_64/x86_64", 0x7fff1b744470) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/tls/x86_64/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/tls/x86_64", 0x7fff1b744470) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/tls/x86_64/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/tls/x86_64", 0x7fff1b744470) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/tls/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/tls", 0x7fff1b744470) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/x86_64/x86_64/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/x86_64/x86_64", 0x7fff1b744470) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/x86_64/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/x86_64", 0x7fff1b744470) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/x86_64/libgc.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/x86_64", 0x7fff1b744470) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/libgc.so.1", O_RDONLY|O_CLOEXEC) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\360\6\1\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0555, st_size=247920, ...}) = 0
mmap(NULL, 484128, PROT_READ, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7f5de4b79000
mprotect(0x7f5de4b88000, 143360, PROT_NONE) = 0
mmap(0x7f5de4b88000, 98304, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0xf000) = 0x7f5de4b88000
mmap(0x7f5de4ba0000, 40960, PROT_READ, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x27000) = 0x7f5de4ba0000
mmap(0x7f5de4bab000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x31000) = 0x7f5de4bab000
mmap(0x7f5de4bad000, 271136, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7f5de4bad000
close(3) = 0
openat(AT_FDCWD, "/home/jojo/.guix-profile/lib/libpthread.so.0", O_RDONLY|O_CLOEXEC) = 3
read(3, "\177ELF\2\1\1\3\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\240l\0\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0555, st_size=147048, ...}) = 0
mmap(NULL, 132256, PROT_READ, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7f5de4b58000
mmap(0x7f5de4b5e000, 61440, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x6000) = 0x7f5de4b5e000
mmap(0x7f5de4b6d000, 24576, PROT_READ, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x15000) = 0x7f5de4b6d000
mmap(0x7f5de4b73000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x1a000) = 0x7f5de4b73000
mmap(0x7f5de4b75000, 13472, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7f5de4b75000
close(3) = 0
openat(AT_FDCWD, "/home/jojo/.guix-profile/lib/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "tls/x86_64/x86_64/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "tls/x86_64/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "tls/x86_64/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "tls/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "x86_64/x86_64/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "x86_64/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "x86_64/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/paf4dmxasqvp1i1d1px6wybmiwrydpdc-guile-3.0.2/lib/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/iycnpxxrg8m9wf9w58d6zvp9sdby6m9d-libgc-7.6.12/lib/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/tls/x86_64/x86_64/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/tls/x86_64/x86_64", 0x7fff1b744410) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/tls/x86_64/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/tls/x86_64", 0x7fff1b744410) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/tls/x86_64/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/tls/x86_64", 0x7fff1b744410) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/tls/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/tls", 0x7fff1b744410) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/x86_64/x86_64/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/x86_64/x86_64", 0x7fff1b744410) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/x86_64/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/x86_64", 0x7fff1b744410) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/x86_64/libffi.so.7", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/x86_64", 0x7fff1b744410) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/gnu/store/bw15z9kh9c65ycc2vbhl2izwfwfva7p1-libffi-3.3/lib/libffi.so.7", O_RDONLY|O_CLOEXEC) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\260\"\0\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0555, st_size=54432, ...}) = 0
mmap(NULL, 50792, PROT_READ, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7f5de4b4b000
mmap(0x7f5de4b4d000, 28672, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x2000) = 0x
This message was truncated. Download the full message here.
Z
Z
zimoun wrote on 29 Oct 2020 00:10
(name . JoJo)(address . jo@jo.zone)(address . 41158@debbugs.gnu.org)
86r1pix7yo.fsf@gmail.com
Dear,

Thank you for the report.

On Sat, 09 May 2020 at 20:38, JoJo <jo@jo.zone> wrote:
Toggle quote (12 lines)
> Due to an unrelated issue, I was updating my system with `guix
> pull`. During update, the process seemed to freeze / get stuck. My
> system was responsive and all, but the `guix pull` output was stuck. I
> don't remember what the last line in the output was, but after
> studying the output of an application of
> `/run/current-system/profile/bin/guix`, I think the output stuck at
> the last step, "building profile with 1 package...". It definitely
> said something about "profile" and "1 package" at least. I don't know
> what caused the freeze. A casual guess is that it's related to my
> screen blanking and the screen locker (`slock`) activatin due to no
> input for a while.

Hum? Weird…

Toggle quote (15 lines)
> Anyways, I decided to end the apparently frozen command, so I killed
> it with Ctrl-C. Immediately afterwards when trying to `guix pull`
> another time, `guix` just started segfaulting. Doesn't matter what
> subcommand I try, or if I call `guix` with no subbcommand -- it just
> segfaults in either case.
>
> ```
> jojo@astoria ~$ guix pull
> Segmentation fault
> jojo@astoria ~$ guix
> Segmentation fault
> jojo@astoria ~$ guix show
> Segmentation fault
> ```

What do these commands

/run/current-system/profile/bin/guix pull -p ~/.config/guix/current
guix pull

do?


All the best,
simon
J
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 41158@debbugs.gnu.org)
87mtzpcs5k.fsf@jo.zone
Sorry, but I changed distro to Arch again some months ago for the time
being, so I can't reproduce this.

Johan

On tor, okt 29 2020, zimoun wrote:

Toggle quote (45 lines)
> Dear,
>
> Thank you for the report.
>
> On Sat, 09 May 2020 at 20:38, JoJo <jo@jo.zone> wrote:
>> Due to an unrelated issue, I was updating my system with `guix
>> pull`. During update, the process seemed to freeze / get stuck. My
>> system was responsive and all, but the `guix pull` output was stuck. I
>> don't remember what the last line in the output was, but after
>> studying the output of an application of
>> `/run/current-system/profile/bin/guix`, I think the output stuck at
>> the last step, "building profile with 1 package...". It definitely
>> said something about "profile" and "1 package" at least. I don't know
>> what caused the freeze. A casual guess is that it's related to my
>> screen blanking and the screen locker (`slock`) activatin due to no
>> input for a while.
>
> Hum? Weird…
>
>> Anyways, I decided to end the apparently frozen command, so I killed
>> it with Ctrl-C. Immediately afterwards when trying to `guix pull`
>> another time, `guix` just started segfaulting. Doesn't matter what
>> subcommand I try, or if I call `guix` with no subbcommand -- it just
>> segfaults in either case.
>>
>> ```
>> jojo@astoria ~$ guix pull
>> Segmentation fault
>> jojo@astoria ~$ guix
>> Segmentation fault
>> jojo@astoria ~$ guix show
>> Segmentation fault
>> ```
>
> What do these commands
>
> /run/current-system/profile/bin/guix pull -p ~/.config/guix/current
> guix pull
>
> do?
>
>
>
> All the best,
> simon
Z
Z
zimoun wrote on 10 Nov 2020 14:34
(name . JoJo)(address . jo@jo.zone)(address . 41158-done@debbugs.gnu.org)
CAJ3okZ0aX5rU+kvO-zf+++xavSivuB0=B+2BEm9r5Zua6KWOBw@mail.gmail.com
Dear,

On Tue, 10 Nov 2020 at 13:28, JoJo <jo@jo.zone> wrote:
Toggle quote (4 lines)
>
> Sorry, but I changed distro to Arch again some months ago for the time
> being, so I can't reproduce this.

Since the bug cannot be reproduced, I am closing. Feel free to
reopen it if you hit it again.


All the best,
simon
Closed
?