[core-updates] fakeroot fails its test suite (breaks spacefm)

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Marius Bakke
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 5 May 2020 02:05
(name . bug-guix)(address . bug-guix@gnu.org)
878si72qle.fsf@gmail.com
Hello,

Testing the core-updates branch, I got this failure from fakeroot:

Toggle snippet (109 lines)
make check-TESTS
make[2]: Entering directory '/tmp/guix-build-fakeroot-1.24.drv-0/fakeroot-1.24/test'
make[3]: Entering directory '/tmp/guix-build-fakeroot-1.24.drv-0/fakeroot-1.24/test'
PASS: t.falsereturn
PASS: t.truereturn
PASS: t.option
PASS: t.echoarg
FAIL: t.mknod
PASS: t.touchinstall
FAIL: t.chmod_dev
PASS: t.no_ld_preload
PASS: t.no_ld_preload_link
FAIL: t.xattr
PASS: t.cp-a
PASS: t.tar
========================================
fakeroot 1.24: test/test-suite.log
========================================

# TOTAL: 12
# PASS: 9
# SKIP: 0
# XFAIL: 0
# FAIL: 3
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: t.chmod_dev
=================

-rw-r--r-- 1 nixbld nixbld 0 May 5 00:04 t.chmod_dev.dir/hda3
FAIL t.chmod_dev (exit status: 1)

FAIL: t.mknod
=============

-rw-r--r-- 1 nixbld nixbld 0 May 5 00:04 t.mknod.dir/hda3
FAIL t.mknod (exit status: 1)

FAIL: t.xattr
=============

unable to set CAP_SETFCAP effective capability: Operation not permitted
FAIL t.xattr (exit status: 1)

============================================================================
Testsuite summary for fakeroot 1.24
============================================================================
# TOTAL: 12
# PASS: 9
# SKIP: 0
# XFAIL: 0
# FAIL: 3
# XPASS: 0
# ERROR: 0
============================================================================
See test/test-suite.log
Please report to clint@debian.org
============================================================================
make[3]: *** [Makefile:549: test-suite.log] Error 1
make[3]: Leaving directory '/tmp/guix-build-fakeroot-1.24.drv-0/fakeroot-1.24/test'
make[2]: *** [Makefile:657: check-TESTS] Error 2
make[2]: Leaving directory '/tmp/guix-build-fakeroot-1.24.drv-0/fakeroot-1.24/test'
make[1]: *** [Makefile:808: check-am] Error 2
make[1]: Leaving directory '/tmp/guix-build-fakeroot-1.24.drv-0/fakeroot-1.24/test'
make: *** [Makefile:688: check-recursive] Error 1

Test suite failed, dumping logs.

--- ./test/test-suite.log ---------------------------------------------------

========================================
fakeroot 1.24: test/test-suite.log
========================================

# TOTAL: 12
# PASS: 9
# SKIP: 0
# XFAIL: 0
# FAIL: 3
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: t.chmod_dev
=================

-rw-r--r-- 1 nixbld nixbld 0 May 5 00:04 t.chmod_dev.dir/hda3
FAIL t.chmod_dev (exit status: 1)

FAIL: t.mknod
=============

-rw-r--r-- 1 nixbld nixbld 0 May 5 00:04 t.mknod.dir/hda3
FAIL t.mknod (exit status: 1)

FAIL: t.xattr
=============

unable to set CAP_SETFCAP effective capability: Operation not permitted
FAIL t.xattr (exit status: 1)


command "make" "check" "-j" "24" failed with status 2

Perhaps caused by running the tests in parallel.

Maxim
M
M
Marius Bakke wrote on 5 May 2020 16:36
87mu6mzbw9.fsf@devup.no
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (46 lines)
> Hello,
>
> Testing the core-updates branch, I got this failure from fakeroot:
>
> --8<---------------cut here---------------start------------->8---
> make check-TESTS
> make[2]: Entering directory '/tmp/guix-build-fakeroot-1.24.drv-0/fakeroot-1.24/test'
> make[3]: Entering directory '/tmp/guix-build-fakeroot-1.24.drv-0/fakeroot-1.24/test'
> PASS: t.falsereturn
> PASS: t.truereturn
> PASS: t.option
> PASS: t.echoarg
> FAIL: t.mknod
> PASS: t.touchinstall
> FAIL: t.chmod_dev
> PASS: t.no_ld_preload
> PASS: t.no_ld_preload_link
> FAIL: t.xattr
> PASS: t.cp-a
> PASS: t.tar
> ========================================
> fakeroot 1.24: test/test-suite.log
> ========================================
>
> # TOTAL: 12
> # PASS: 9
> # SKIP: 0
> # XFAIL: 0
> # FAIL: 3
> # XPASS: 0
> # ERROR: 0
>
> .. contents:: :depth: 2
>
> FAIL: t.chmod_dev
> =================
>
> -rw-r--r-- 1 nixbld nixbld 0 May 5 00:04 t.chmod_dev.dir/hda3
> FAIL t.chmod_dev (exit status: 1)
>
> FAIL: t.mknod
> =============
>
> -rw-r--r-- 1 nixbld nixbld 0 May 5 00:04 t.mknod.dir/hda3
> FAIL t.mknod (exit status: 1)

These two tests create a block device with 'mknod' inside the fakeroot,
and afterwards verifies with 'ls' that they are in fact block devices.

It turns out that the 'ls' invokation does not work because the newer
'ls' uses statx() which is not supported/caught by fakeroot, and thus it
does not see the fake block device. So I changed these tests to use
'test -b' as a stopgap measure.

Toggle quote (6 lines)
> FAIL: t.xattr
> =============
>
> unable to set CAP_SETFCAP effective capability: Operation not permitted
> FAIL t.xattr (exit status: 1)

This turned out to be a regression in 'libcap', fixed by providing a
newer version.

Fixed in ba151b7e1a9cc0baf932b5c5e0c916e54d2e27f4, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6xegYACgkQoqBt8qM6
VPrp9Af/Q4EQkoWMQ8bZsH9yA9qyieVMH5JxeADzE9FfTOY5ishK2yyp5Dj/nRUb
Ly4/k3ustVC1ZTgpjfUzPVIFdToJkOhtUG7yoU4YEAU7QKxcaHmh3zXtDaap8Ywp
wJzIULtpVTJ9wuFZb9NeZ54UEPEF2Sj56v6cCDefJAPwCBEOL9Iwu2WeRwsbyyvK
P1tHm1oo9y69Qbs6DXyMXWcWZdYeSQNCe0YoTeY+bE9N0dnlp0bH1zEG1gEJdlof
bMIMSq1Hw+YNK3NUONzc+YCohS6Yr06kjxXfgCnDqJzJ8s1YVuvL2sf46/6lwNxH
XfTX4BHDuirePRtWRFh4C4BqFA0tIQ==
=yis3
-----END PGP SIGNATURE-----

Closed
?