[PATCH] Add apt-mirror package

  • Done
  • quality assurance status badge
Details
2 participants
  • Jean-Baptiste Note
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jean-Baptiste Note
Severity
normal
J
J
Jean-Baptiste Note wrote on 27 Apr 2020 21:50
(address . guix-patches@gnu.org)
87ftcok8sd.fsf@m4x.org
Dear guix maintainers,

Please find attached a patch adding the apt-mirror utility as a package.

I've tried to follow the guidelines (thanks for such detailed
instructions), please advise any mistake.

Kind regards,
Jean-Baptiste
From 82ad467853beae1969720323b4b19d49ed69c2f0 Mon Sep 17 00:00:00 2001
From: Jean-Baptiste Note <jean-baptiste.note@m4x.org>
Date: Sun, 26 Apr 2020 05:59:48 -0400
Subject: [PATCH] gnu: Add apt-mirror.

* gnu/packages/debian.scm (apt-mirror): New variable.
---
gnu/packages/debian.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index ff4cccb03d..a3bbd2b907 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -27,6 +27,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages wget)
#:use-module (gnu packages perl))
(define-public debian-archive-keyring
@@ -190,3 +191,40 @@ scratch, without requiring the availability of @code{dpkg} or @code{apt}.
It does this by downloading .deb files from a mirror site, and carefully
unpacking them into a directory which can eventually be chrooted into.")
(license license:gpl2)))
+
+
+(define-public apt-mirror
+ (let ((commit "e664486a5d8947c2579e16dd793d762ea3de4202")
+ (revision "1"))
+ (package
+ (name "apt-mirror")
+ (version (git-version "0.5.4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/apt-mirror/apt-mirror/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qj6b7gldwcqyfs2kp6amya3ja7s4vrljs08y4zadryfzxf35nqq"))))
+ (build-system gnu-build-system)
+ (outputs '("out"))
+ (arguments
+ `(#:tests? #f
+ ;; sysconfdir is not PREFIXed in the makefile but DESTDIR is
+ ;; honored correctly; we therefore use DESTDIR for our
+ ;; needs. A more correct fix would involve patching.
+ #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+ "PREFIX=/")
+ #:phases (modify-phases %standard-phases (delete 'configure))))
+ (inputs
+ `(("wget" ,wget)
+ ("perl" ,perl)))
+ (home-page "http://apt-mirror.github.io/")
+ (synopsis "Script for mirroring a Debian repository")
+ (description
+ "apt-mirror is a small tool that provides the ability to
+selectively mirror Debian and Ubuntu GNU/Linux distributions or any
+other apt sources typically provided by open source developers.")
+ (license license:gpl2))))
--
2.26.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEPxcq3dp4FVY5UpckkC0pVsuz75YFAl6nN4IACgkQkC0pVsuz
75aS9BAAp7+NzmaT+ZwdPnffLvjdafgJUn9QX6bd5zpp9Tnm4ejGTHCIxxjlh/a6
40xuvAm4qXLCmDmJVl1EmlKjotuaPRrC5wI0xf0OyrKESPxbur6xWkthfJHz3gkP
hBTVBnUIQgKV1KkYL2ZYYazIwkG6ccbetc0Lyw3K6oGVYDlK70InKasbeMBTa1aS
nmSymeZHpqp3l0HOzUflGzjSTCp7WEAZ/A989UX2keM7wq8hpIMCtXLybgHwg4Js
b3OEcWGm8PIyzhbwyIeDfDDFCZGrHrm1VlplLUANIbnswjZ0YrjBfhMXNN/T55IH
YcVaOKvs+co/hxuEhH1forwUt7a4fd95PyszO0YEWj3dGZuBLcRGotkkqzg1avlE
M4OlFCF1R3u/2iadpOUd6L0YyFH7KwjPs0lwHLtFH0SirFjTzHT1NOD2EdeY6RUx
v3CJRaYpQHp75IZyI1ufjdaLZsz1hTOj2SwnUdVib+YKwQXU6hXM6GYVb5CLZxGh
mBnbFl3VMJ3JC84Bl+dxTFjzYmzg53kRAJ3IKaJdj1yEIPuDi1EPprXBU3iAdskq
JPouxF909T0Il4Hfp6d9Cl1pFxnWJGyqKW3nasWQqJKk1ZFSOtI74zCRfYMjGdj9
d02p0pLFCb8bvYNpJ1s6hieXGOWlwI+tBjsFdcyUTeqJjfodC1g=
=yIRP
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 1 May 2020 01:14
(name . Jean-Baptiste Note)(address . jean-baptiste.note@m4x.org)(address . 40910-done@debbugs.gnu.org)
87o8r8in29.fsf@gnu.org
Hi,

Jean-Baptiste Note <jean-baptiste.note@m4x.org> skribis:

Toggle quote (7 lines)
> From 82ad467853beae1969720323b4b19d49ed69c2f0 Mon Sep 17 00:00:00 2001
> From: Jean-Baptiste Note <jean-baptiste.note@m4x.org>
> Date: Sun, 26 Apr 2020 05:59:48 -0400
> Subject: [PATCH] gnu: Add apt-mirror.
>
> * gnu/packages/debian.scm (apt-mirror): New variable.

Applied. Thanks, and welcome! :-)

Ludo’.
Closed
?