Update Qt

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Tom
Owner
unassigned
Submitted by
Tom
Severity
normal
T
(address . guix-patches@gnu.org)
2419210.ElGaqSPkdT@peach
This updates all Qt components to their latest versions.

Notice that the qtcanvas3d doens't seem to be shipped after 5.12, so this
updated to the latest from that series.

I compiled all components and all finished successfully. Except for the
qtwebengine one
which generates a compile/link error I did not manage to resolve.

This patch should thus be seen as a work-in-progress as it did most of the
work and I hope someone can help me finish this.

Additionally, I'm sure some dependencies will need upgrading too.
For instance kitemviews 5-63 fails to compile and upstream has 5.69 already...

Thanks
T
rebased patch
(address . 40791@debbugs.gnu.org)
12618542.O9o76ZdvQC@peach
This patch incorporates feedback from IRC (many fixlets).

I rebased it onto the core-updates branch.

The webengine fails with an error I fail to understand:

make[3]: Entering directory '/tmp/guix-build-qtwebengine-5.14.2.drv-0/qtwebengine-everywhere-src-5.14.2/src/core'
ninja -k1 -j12 -C /tmp/guix-build-qtwebengine-5.14.2.drv-0/qtwebengine-everywhere-src-5.14.2/src/core/release QtWebEngineCore
ninja: Entering directory `/tmp/guix-build-qtwebengine-5.14.2.drv-0/qtwebengine-everywhere-src-5.14.2/src/core/release'
ninja: error: '../../3rdparty/chromium/third_party/boringssl/linux-x86_64/crypto/third_party/sike/asm/fp-x86_64.S', needed by 'host/obj/third_party/boringssl/boringssl_asm/fp-x86_64.o', missing and no known rule to make it
M
M
Marius Bakke wrote on 24 Apr 2020 00:23
87sggtg7th.fsf@devup.no
Hello Tom!

Thanks a lot for this work.

Tom via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (11 lines)
> This patch incorporates feedback from IRC (many fixlets).
>
> I rebased it onto the core-updates branch.
>
> The webengine fails with an error I fail to understand:
>
> make[3]: Entering directory '/tmp/guix-build-qtwebengine-5.14.2.drv-0/qtwebengine-everywhere-src-5.14.2/src/core'
> ninja -k1 -j12 -C /tmp/guix-build-qtwebengine-5.14.2.drv-0/qtwebengine-everywhere-src-5.14.2/src/core/release QtWebEngineCore
> ninja: Entering directory `/tmp/guix-build-qtwebengine-5.14.2.drv-0/qtwebengine-everywhere-src-5.14.2/src/core/release'
> ninja: error: '../../3rdparty/chromium/third_party/boringssl/linux-x86_64/crypto/third_party/sike/asm/fp-x86_64.S', needed by 'host/obj/third_party/boringssl/boringssl_asm/fp-x86_64.o', missing and no known rule to make it

This is because QtWebEngine has a whitelist of allowed "third_party"
directories. Presumably adding
"third_party/boringssl/linux-x86_64/crypto/third_party/sike" to the list
solves it.

Also preserve the related directory below "linux-aarch64" if it exists
(I'm guessing from reading commit
7f2e852267d3484c3b0a3457ad6f3f9ad4debe6a in Guix). :-)

A few comments on the other patches:

Toggle quote (14 lines)
> From 4c90d4de70b3a87cfebf33ef1ef8b07a284ca523 Mon Sep 17 00:00:00 2001
> From: TomZ <tomz@freedommail.ch>
> Date: Thu, 23 Apr 2020 00:21:31 +0200
> Subject: [PATCH] gnu: Qt: update to 5.14.2
>
> * gnu/packages/qt.scm (qtbase, qtsvg, qtimageformats,
> qtx11extras, qtxmlpatterns, qtdeclarative, qtconnectivity,
> qtwebsockets, qtsensors, qtmultimedia, qtwayland,
> qtserialport, qtserialbus, qtwebchannel, qtwebglplugin,
> qtwebview, qtlocation, qttools, qtscript, qtquickcontrols,
> qtquickcontrols2, qtgraphicaleffects, qtgamepad, qtscxml,
> qtpurchasing, qtcharts, qtdatavis3d, qtnetworkauth,
> qtremoteobjects, qtspeech, qtwebengine): Update to 5.14.2

Please also mention the changed [arguments] etc for each of the
variables that contain other changes than just the version bump.

Toggle quote (2 lines)
> * gnu/packages/qt.scm (qtcanvas3d): Update to 5.12.8

As nothing depends on this, perhaps we should just remove it? Do you
know if it was merged with some other Qt package?

Toggle quote (55 lines)
> diff --git a/gnu/packages/patches/qtbase-use-TZDIR.patch b/gnu/packages/patches/qtbase-use-TZDIR.patch
> index 11c737d844..b6c377b133 100644
> --- a/gnu/packages/patches/qtbase-use-TZDIR.patch
> +++ b/gnu/packages/patches/qtbase-use-TZDIR.patch
> @@ -4,8 +4,8 @@ important to be able to update it fast.
>
> Based on a patch fron NixOS.
> ===================================================================
> ---- qtbase-opensource-src-5.9.4.orig/src/corelib/tools/qtimezoneprivate_tz.cpp
> -+++ qtbase-opensource-src-5.9.4/src/corelib/tools/qtimezoneprivate_tz.cpp
> +--- qtbase-opensource-src-5.14.2.orig/src/corelib/time/qtimezoneprivate_tz.cpp
> ++++ qtbase-opensource-src-5.15.2/src/corelib/time/qtimezoneprivate_tz.cpp
> @@ -70,7 +70,11 @@
> // Parse zone.tab table, assume lists all installed zones, if not will need to read directories
> static QTzTimeZoneHash loadTzTimeZones()
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index 8a57127771..dbea4e2cef 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -351,7 +351,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
> (define-public qtbase
> (package
> (name "qtbase")
> - (version "5.12.7")
> + (version "5.14.2")
> (source (origin
> (method url-fetch)
> (uri (string-append "https://download.qt.io/official_releases/qt/"
> @@ -360,11 +360,9 @@ developers using C++ or QML, a CSS & JavaScript like language.")
> version ".tar.xz"))
> (sha256
> (base32
> - "0pb68d30clksdhgy8n6rrs838bb3qcsfq4pv463yy2nr4p5kk2di"))
> - ;; Use TZDIR to avoid depending on package "tzdata".
> + "12mjsahlma9rw3vz9a6b5h2s6ylg8b34hxc2vnlna5ll429fgfa8"))
> (patches (search-patches "qtbase-use-TZDIR.patch"
> - "qtbase-moc-ignore-gcc-macro.patch"
> - "qtbase-QTBUG-81715.patch"))
> + "qtbase-moc-ignore-gcc-macro.patch"))
> (modules '((guix build utils)))
> (snippet
> ;; corelib uses bundled harfbuzz, md4, md5, sha3
> @@ -570,14 +568,6 @@ developers using C++ or QML, a CSS & JavaScript like language.")
> "src/network/kernel/qhostinfo_unix.cpp")
> (("^\\s*(lib.setFileName\\(QLatin1String\\(\")(resolv\"\\)\\);)" _ a b)
> (string-append a glibc "/lib/lib" b))))
> - ;; X11/locale (compose path)
> - (substitute* "src/plugins/platforminputcontexts/compose/generator/qtablegenerator.cpp"
> - ;; Don't search in /usr/…/X11/locale, …
> - (("^\\s*m_possibleLocations.append\\(QStringLiteral\\(\"/usr/.*/X11/locale\"\\)\\);" line)
> - (string-append "// " line))
> - ;; … but use libx11's path
> - (("^\\s*(m_possibleLocations.append\\(QStringLiteral\\()X11_PREFIX \"(/.*/X11/locale\"\\)\\);)" _ a b)
> - (string-append a "\"" (assoc-ref inputs "libx11") b)))

What happened here? Did the Qt build system get smart enough to embed
the libx11 file name by itself?

Toggle quote (11 lines)
> (arguments
> (substitute-keyword-arguments (package-arguments qtsvg)
> ((#:tests? _ #f) #f))) ; TODO: Enable the tests
> @@ -796,7 +786,8 @@ xmlpatternsvalidator.")))
> ("pkg-config" ,pkg-config)
> ("python" ,python)
> ("python-wrapper" ,python-wrapper)
> - ("qtsvg" ,qtsvg)))
> + ("qtsvg" ,qtsvg)
> + ("vulkan-headers" ,vulkan-headers)))

The new input should also be mentioned in the commit message. See the
commit log for examples.

Toggle quote (23 lines)
> @@ -962,17 +953,13 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
> (delete-file-recursively "examples")
> #t))))
> (arguments
> - (substitute-keyword-arguments (package-arguments qtsvg)
> - ((#:phases phases)
> - `(modify-phases ,phases
> - (add-before 'check 'set-ld-library-path
> - ;; <https://lists.gnu.org/archive/html/guix-devel/2017-09/msg00019.html>
> - ;;
> - ;; Make the uninstalled libQt5WaylandClient.so.5 available to the
> - ;; wayland platform plugin.
> - (lambda _
> - (setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/lib"))
> - #t))))))
> + (substitute-keyword-arguments (package-arguments qtsvg)
> + ((#:phases phases)
> + `(modify-phases ,phases
> + ;; Tests fail due to missing plugin.
> + ;; Set https://lists.gnu.org/archive/html/guix-devel/2017-09/msg00019.html
> + ;; LD_LIBRARY PATH trick doesn't work anymore, so just disable
> + (delete 'check)))))

So the test fails because libQt5WaylandClient.so is missing? Perhaps it
was moved elsewhere? Try building with --keep-failed and inspect the
build directory, hopefully it's enough to adjust LD_LIBRARY_PATH with
the new library location.

Also, if you must disable tests, use '#:tests? #f' instead of deleting
the check phase.

Toggle quote (8 lines)
> @@ -1099,7 +1086,8 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
> `(("mesa" ,mesa)
> ("qtbase" ,qtbase)
> ("qtdeclarative" ,qtdeclarative)
> - ("qtwebsockets" ,qtwebsockets)))
> + ("qtwebsockets" ,qtwebsockets)
> + ("zlib" ,zlib)))

Add to commit message ^

Toggle quote (9 lines)
> @@ -1515,6 +1503,10 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
> (substitute* "tests/auto/qml/qml.pro"
> (("integration") "# integration")
> (("usertypes") "# usertypes"))
> + ;; disable failing tests
> + (substitute* "tests/auto/auto.pro"
> + (("integration_multiprocess proxy_multiprocess integration_external restart")
> + "integration_multiprocess"))

Indentation is off here. It would be good to comment on why they are
failing. Perhaps just some /bin/sh invokation need patching?

Again, thank you very much for this. You mentioned some KDE packages
failed with this new Qt, could you try updating them too? It should be
a lot easier thanks to the KDE updater: try e.g. './pre-inst-env guix
refresh -t kde -u'. :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6iFWoACgkQoqBt8qM6
VPpjXQf/YOAhdZzftrvalGoTos+BrhClMBo5oiY6o9rP4ldTi3q1lvvMl+7tELHl
vH81I8dMJv9dNHbQvizoiUb3jLpUL0cu7lXaySRKJrOMKzsrby9FV1A6jXwHGjZq
WzA7fc6U/g9qOKgjJoKCKXYnNUWglQf8rEjp0+9ro6GV8M8ogfZLihoMIzs1BjLW
e9DdlDuVnXeN0+10ZrovjBl8SmVoPhiIsg79KoLKG1Xafjfa8IfPit33yfQ4Oj2E
Cjzb5fmNaFuu+MxwEKnjrCDZfL8byTKtF/yeBQYrU4hMzp0ukY4pIJ+6QD0KyJ5F
PlYnUtuT/wnT119CoSSFXpa0kk10Yw==
=8vVL
-----END PGP SIGNATURE-----

T
2691858.b7GtGmxQoC@peach
On Friday, 24 April 2020 00:23:38 CEST Marius Bakke wrote:
Toggle quote (20 lines)
> > @@ -570,14 +568,6 @@ developers using C++ or QML, a CSS & JavaScript like
> > language.") "src/network/kernel/qhostinfo_unix.cpp")
> > (("^\\s*(lib.setFileName\\(QLatin1String\\(\")(resolv\"\\)\\);)" _ a b)
> > (string-append a glibc "/lib/lib" b))))
> > - ;; X11/locale (compose path)
> > - (substitute*
> > "src/plugins/platforminputcontexts/compose/generator/qtablegenerator.cpp"
> > - ;; Don't search in /usr/…/X11/locale, …
> > -
> > (("^\\s*m_possibleLocations.append\\(QStringLiteral\\(\"/usr/.*/X11/local
> > e\"\\)\\);" line) - (string-append "// " line))
> > - ;; … but use libx11's path
> > -
> > (("^\\s*(m_possibleLocations.append\\(QStringLiteral\\()X11_PREFIX
> > \"(/.*/X11/locale\"\\)\\);)" _ a b) - (string-append a
> > "\"" (assoc-ref inputs "libx11") b)))

> What happened here? Did the Qt build system get smart enough to embed
> the libx11 file name by itself?

What happened is that the 'generator' directory is no longer there. I don't see any equivalent to what is being substituted. Hence the patch was removed.

I am not sure what the original was trying to accomplish, the current code doesn't seem to do anything with the libx11 file you talk about.

Any way to test if the functionality is what you expect after removal?
T
todays patch
(address . 40791@debbugs.gnu.org)
1819894.BzRgMNaeKi@peach
This incorporates all suggestions.

As each individual missing item in the qtwebengine requires a full rebuild to
get one line of error, I've done enough for today. See the amount of lines
added ;)
T
Append: KDE upgrade
(address . 40791@debbugs.gnu.org)
2279991.lqa9Gxa31U@peach
I ran the script and fixed several build failures.

Notable failure is kwayland in cmake configure step.
I have no idea why.

Would like some assist there.

CMake Error at /gnu/store/j8kh897ak4xn376zcdxdsmjb20c6didx-qtbase-5.14.2/lib/
cmake/Qt5/Qt5Config.cmake:28 (find_package):
Could not find a package configuration file provided by "Qt5WaylandClient"
M
M
Marius Bakke wrote on 2 May 2020 16:23
Re: [bug#40791] todays patch
87mu6q2z5u.fsf@devup.no
Tom via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (6 lines)
> This incorporates all suggestions.
>
> As each individual missing item in the qtwebengine requires a full rebuild to
> get one line of error, I've done enough for today. See the amount of lines
> added ;)

Thanks! I plan to do a proper review on a couple of days, but have one
suggestion for qtwebengine: moving the 'snippet' code into a phase
allows for faster iterations. Still not trivial, but better than
repacking for every change!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6tgn0ACgkQoqBt8qM6
VPrrbQf/VK5kFbbx2dLbLLNjdXvyN+o2ePdHBE8aeSA0N6Ypunp+fIUUiN0vFuD2
DwIICnoiO1WXlr0zTgr3aUZ06JavhTdagK8PokdDdwx0iyC1aaCaDJ5FWauK24dx
6pDTwtkpYPXx80ZgQWpKIoGkyOph3r2Mzrc263qMX43lkPraBN4z3QDL1UHPYvPo
jgge1C+n0zNQDIdeHjSqt0OtHjCrRdI5X5eRQnIyLCRjSzMZABO+8zSN+p9lAc7A
uaFTzN9GL7v6VgDOxt5Q8V83h2/dQyN90ubsyxDxRCeZo4LriSzw3GO07V5oOlrk
zXH9RumE0RQ6D+b0w5zxL0pnSZkMuw==
=gH1K
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 2 May 2020 16:28
Re: [bug#40791] Append: KDE upgrade
87k11u2yys.fsf@devup.no
Tom via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (7 lines)
> I ran the script and fixed several build failures.
>
> Notable failure is kwayland in cmake configure step.
> I have no idea why.
>
> Would like some assist there.

I wonder if these KDE updates can be applied on the current master
branch (without the Qt upgrade)? Does the same error occur then?

If it works on 'master', let's merge this first.

Meanwhile, please adjust the commit message to mention all the changed
variables, [arguments], etc.

I will have a deeper look in a couple of days. Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6tg3sACgkQoqBt8qM6
VPr2tQf8DNwEV2LaulmmC1PP9tgtzOq29iTl6mx7t/vTaBff7kt+YjPNccibwv3X
hbcbLJCNTW9cY9YBrQTlRheoQJeuLYR5x0OntiQg+ddZWgx1dWeJ7CEYt8MdjVjW
UnUgBTe8fyCTMOia6jU/fIkgEx+IIFkLNSW3N4HLY/lG/OOsumTKKyuvR2COxEbN
grV84xUuWHhlvSVnVb2VN3OxVZtYHrQ0xKdddTVJE12N5lZLzqnuD7Aa57BoZygd
bafF7pSF74ryNpSgiSmKTenmTa0EP1UnaLFFnOYYB9y850DSbcOJOYmTGt+XxVvx
fqu+bH0mloG5A/KUx3inTuD75+X1IA==
=pC7c
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 2 May 2020 16:29
87imhe2yx2.fsf@devup.no
Tom via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (7 lines)
> I ran the script and fixed several build failures.
>
> Notable failure is kwayland in cmake configure step.
> I have no idea why.
>
> Would like some assist there.

I wonder if these KDE updates can be applied on the current master
branch (without the Qt upgrade)? Does the same error occur then?

If it works on 'master', let's merge this first.

Meanwhile, please adjust the commit message to mention all the changed
variables, [arguments], etc.

I will have a deeper look in a couple of days. Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6tg7kACgkQoqBt8qM6
VPqTNwf+JuvDyB+lxqVH4+Kkk55AyA2mWSjePL2UURdioCI4IDzgVNEhNoVX1InP
f4jvq4ocYQEnenOPLdFy6f+uOJjmT9TgtGdv0ZH1YpGUNF0bcUjYfeexYVytXQko
EPpsOUJt85orVzWKsiwQtyDv/Ixg7zCVr6tDKeHfz8Ip+j80czUT8kbXJND37ggl
kPrZYTH02CPjoaSNdM4ZmCQSqIF2ug5xVi296e4LT8QqNaKkbEL3U7OCRfX5pEff
ELoJVq/RxH0Jeulgb/GTBYMf7e+y6zSz4uaSO5bT/+UJE6fMkbyjUoyyJ2sQREpq
Gpjaja6WmIfdDlJ4uRZUHNSxA9bt+Q==
=Sv/2
-----END PGP SIGNATURE-----

T
T
Tom Zander wrote on 2 May 2020 22:02
5410741.DvuYhMxLoT@cherry
The kwayland issue looks like a missing dependency. Likely something that is
an input but not a propagated input up the stack.
A little tricky as I don't see any 'wayland-client' package.

I postponed upgrading kwayland for now so the rest of the kde upgrades can
continue.

Would it be wise to open a new bug for the KDE upgrade, especially since it
can be applied on master?

On zaterdag 2 mei 2020 16:29:13 CEST Marius Bakke wrote:
Toggle quote (19 lines)
> Tom via Guix-patches via <guix-patches@gnu.org> writes:
> > I ran the script and fixed several build failures.
> >
> > Notable failure is kwayland in cmake configure step.
> > I have no idea why.
> >
> > Would like some assist there.
>
> I wonder if these KDE updates can be applied on the current master
> branch (without the Qt upgrade)? Does the same error occur then?
>
> If it works on 'master', let's merge this first.
>
> Meanwhile, please adjust the commit message to mention all the changed
> variables, [arguments], etc.
>
> I will have a deeper look in a couple of days. Thanks!


--
Tom Zander
M
M
Marius Bakke wrote on 18 May 2020 01:26
87lflqrvm4.fsf@devup.no
Tom via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> I ran the script and fixed several build failures.
>
> Notable failure is kwayland in cmake configure step.
> I have no idea why.

Apologies for the delay here! It turns out that KDE cannot be updated
on 'master' because 'extra-cmake-modules' has loads of dependents.

I ended up not using your patch because it failed to apply and lacked a
commit message, and because KDE 5.70.0 has since been released. Sorry
for the wasted effort!

The reason kwayland failed to build was because of a missing dependency
on 'qtwayland'.

I pushed a KDE frameworks update to 'staging' in commit
5ca251ab4b8dd7dfa948ce8181fc2e82f6de200f.

Now, there are still many other KDE packages that are outdated.
Unfortunately the updater misses some because the upstream URL has
changed... If you want more packaging practice here is a good
opportunity, and should be safe for 'master'. ;-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7ByDMACgkQoqBt8qM6
VPrHrAf8D5oUMS+mrCBjAQKzdZweAMM/8dDyVoXZ5SHjd+Vgw/fViBeg36VU9ycR
nxR+5vvnYXg7Bx82mc5AeeC1ueXNkx34mKiAzvDasptUNkuu9Zmqx4mjb4W7/Whk
VRMH0uqhqYPnk2lCYXwEdqGhn+v9ljmfqP79qsj9dAy+ogyarlp49nnxvHHISNX6
pHxnzmTGVQZtGX16HtegoxvH6/h/sAfehexH2zeE7sf5c4PmiSvjg2W+pjRIWSc2
+tRFmVwj9PiDP5V97q6y79yJHKYND+4OLUOQv11zIQxaOeSW1CgLOvuorJRcl3OK
2OLXvEjilpRytvNy4lEPwcZkh0rZzg==
=qb5U
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 18 May 2020 01:37
Re: [bug#40791] todays patch
87imgurv3p.fsf@devup.no
Hello!

Tom via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (6 lines)
> This incorporates all suggestions.
>
> As each individual missing item in the qtwebengine requires a full rebuild to
> get one line of error, I've done enough for today. See the amount of lines
> added ;)

Phew, there was still a _lot_ of dependencies missing. Even without
repacking for every iteration it took hours just to collect them all.

Toggle quote (5 lines)
> From 180da08e2b2d17cafab4b92b1074867516a2d6eb Mon Sep 17 00:00:00 2001
> From: TomZ <tomz@freedommail.ch>
> Date: Thu, 23 Apr 2020 00:21:31 +0200
> Subject: [PATCH 1/2] gnu: Qt: update to 5.14.2

Please use full sentences in commit messages, i.e. capitalization and
full stops.

Toggle quote (13 lines)
> * gnu/packages/qt.scm (qtsvg, qtimageformats, qtx11extras,
> qtxmlpatterns, qtconnectivity, qtwebsockets, qtsensors,
> qtmultimedia, qtserialport, qtserialbus, qtwebchannel,
> qtwebview, qtlocation, qttools, qtscript, qtquickcontrols,
> qtquickcontrols2, qtgraphicaleffects, qtgamepad, qtscxml,
> qtpurchasing, qtcharts, qtdatavis3d, qtnetworkauth,
> qtspeech, qtwebengine): Update to 5.14.2
>
> * gnu/packages/qt.scm (qtcanvas3d): removed. Upstream deprected it.
>
> * gnu/packages/qt.scm (qtbase): drop TZDIR patch, patched code no
> longer exists.

Here you meant qtbase-QTBUG-81715.patch.

Toggle quote (6 lines)
> Drop X11lib substitute: patched dir no longer exists.
> Update to 5.14.2
>
> * gnu/packages/qt.scm (qtwayland): disable tests because most of
> them crash without message.

Actually only two failed, with fairly clear error messages. Figuring
out how to disable them took some time though.

I did not look very closely into what caused the failures, as one of the
first hits on a web search was that Debian disables the exact same test:


So we're in good company, at least. :-)

Toggle quote (4 lines)
> Update to 5.14.2
>
> * gnu/packages/qt.scm (qtwebglplugin):[inputs] add zlib

Nit-pick: colon after the [section].

Toggle quote (3 lines)
> Update to 5.14.2
>
> * gnu/packages/qt.scm (qtremoteobjects): disable some tests that
missing [arguments]
Toggle quote (6 lines)
> fail due to missing network.
> Update to 5.14.2
>
> * gnu/packages/qt.scm (qtdeclarative):[inputs] add vulcan-headers
> Update to 5.14.2

I fixed these issues and typos for you.

Toggle quote (18 lines)
> ---
> gnu/packages/patches/qtbase-use-TZDIR.patch | 4 +-
> gnu/packages/qt.scm | 222 ++++++++------------
> 2 files changed, 92 insertions(+), 134 deletions(-)
>
> diff --git a/gnu/packages/patches/qtbase-use-TZDIR.patch b/gnu/packages/patches/qtbase-use-TZDIR.patch
> index 11c737d844..b6c377b133 100644
> --- a/gnu/packages/patches/qtbase-use-TZDIR.patch
> +++ b/gnu/packages/patches/qtbase-use-TZDIR.patch
> @@ -4,8 +4,8 @@ important to be able to update it fast.
>
> Based on a patch fron NixOS.
> ===================================================================
> ---- qtbase-opensource-src-5.9.4.orig/src/corelib/tools/qtimezoneprivate_tz.cpp
> -+++ qtbase-opensource-src-5.9.4/src/corelib/tools/qtimezoneprivate_tz.cpp
> +--- qtbase-opensource-src-5.14.2.orig/src/corelib/time/qtimezoneprivate_tz.cpp
> ++++ qtbase-opensource-src-5.15.2/src/corelib/time/qtimezoneprivate_tz.cpp

We both forgot to mention this part in the commit message though!

Toggle quote (23 lines)
> @@ -70,7 +70,11 @@
> // Parse zone.tab table, assume lists all installed zones, if not will need to read directories
> static QTzTimeZoneHash loadTzTimeZones()
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index 8a57127771..aa121fbb5f 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -351,7 +351,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
> (define-public qtbase
> (package
> (name "qtbase")
> - (version "5.12.7")
> + (version "5.14.2")
> (source (origin
> (method url-fetch)
> (uri (string-append "https://download.qt.io/official_releases/qt/"
> @@ -360,11 +360,9 @@ developers using C++ or QML, a CSS & JavaScript like language.")
> version ".tar.xz"))
> (sha256
> (base32
> - "0pb68d30clksdhgy8n6rrs838bb3qcsfq4pv463yy2nr4p5kk2di"))
> - ;; Use TZDIR to avoid depending on package "tzdata".

I preserved this comment.

Toggle quote (6 lines)
> + "12mjsahlma9rw3vz9a6b5h2s6ylg8b34hxc2vnlna5ll429fgfa8"))
> (patches (search-patches "qtbase-use-TZDIR.patch"
> - "qtbase-moc-ignore-gcc-macro.patch"
> - "qtbase-QTBUG-81715.patch"))
> + "qtbase-moc-ignore-gcc-macro.patch"))

Remember to delete patches from git as well as gnu/local.mk too. Fixed!

I finally pushed this as 883d0484ddcf3b9f3ff8bd8e6de70627201f2763.

However, qtwebengine is not finished building yet and may still be
missing some dependencies. I'll fix any remaining issues tomorrow.

Thanks a lot for the effort here, and sorry for the delay!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7BysoACgkQoqBt8qM6
VPo7Vwf+OG55MfYaRuliA+Dde0WoSZo1qGWN5KTAQ3MDfVF6RC0HxM72FpHZL/bv
ZTlPSPgHxIrTIaoEOZLc2LaOKpWwCJ7cKNH9w/PZffaDTj6xshVYG21BBxhByHcK
30iWYqrUUz1rTQa+Bjo6NgeThFkHeo6uVZfpFQ2RPjKvS+awMUCHSUVFIcCJ3Bng
6Vtyzc+K8racUJ9aCCRYWXYjNc/BDgpaaxJOAc7fmLaPxq9q1kM1HbPzbB1jH9qW
mpQJ66MalzKJY8jfN1ZxlcaS60x9zh3EJqGVOVNO1XJzv7wlSOvapLQWjauSswFZ
7hEdkyqCZa98DUEs+y/qOHTPRsvylg==
=X78+
-----END PGP SIGNATURE-----

Closed
?