new package; hexer

  • Done
  • quality assurance status badge
Details
3 participants
  • Brice Waegeneire
  • Kyle Meyer
  • Tom
Owner
unassigned
Submitted by
Tom
Severity
normal
T
(address . guix-patches@gnu.org)
5401348.DvuYhMxLoT@peach
This is a text editor for binary files, please let me know if you are Ok with
the file I picked for it.
From 2c0ba963679e37f444094ec4b5f21160d27ab361 Mon Sep 17 00:00:00 2001
From: TomZ <tomz@freedommail.ch>
Date: Wed, 22 Apr 2020 22:31:03 +0200
Subject: [PATCH] gnu: Add hexer

* gnu/packages/text-editors.scm (hexer): New Variable
---
gnu/packages/text-editors.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 36571e7846..9af3b15f8d 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -967,3 +967,35 @@ keybindings, autocomplete and unlimited undo. It can pipe a marked block
of text through any command line filter. It can also open very large binary
files. It was originally developed on the Amiga 3000T.")
(license license:gpl3+)))
+
+(define-public hexer
+ (package
+ (name "hexer")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://devel.ringlet.net/files/editors/hexer/"
+ "hexer-" version ".tar.xz"))
+ (sha256
+ (base32 "14ap9zmwya9m8v896jdvjkbv234yl8w9wfa4apyfh14vcgjkb8rr"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "LTERMCAP=-lncurses")
+ (string-append "LDFLAGS=-L" (assoc-ref %build-inputs "ncurses")
+ "/lib"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ;no configure script
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (home-page "https://devel.ringlet.net/editors/hexer/")
+ (synopsis "Multi buffer editor for binary files with vi-like interface")
+ (description "Hexer is a multi-buffer editor for binary files for Unix-like systems
+that displays its buffer(s) as a hex dump. The user interface is kept
+similar to vi/ex.")
+ (license license:bsd-3)))
--
2.26.2
B
B
Brice Waegeneire wrote on 1 May 2020 19:05
(address . tomz@freedommail.ch)(address . 40782@debbugs.gnu.org)
5176e4dd335766c41e5cb50a3813a1f2@waegenei.re
Hello Tom,

Thank you for the patch!

There a few minor thing to adjust from your patch:
1. Add your copyright at the top of the file.
2. End your git title and message lines with a colon.
2. Use the latest version of the package, 1.0.6.
3. Keep the description line under 80 character.
4. Add a comment about why the tests are disabled, in our case
there is no test suite.

Cheers,
- Brice
K
K
Kyle Meyer wrote on 2 May 2020 00:55
Re: [bug#40782] patch#40782 new package; hexer
(address . 40782@debbugs.gnu.org)
87y2qb5kpv.fsf@kyleam.com
Brice Waegeneire writes:

Toggle quote (2 lines)
> 2. End your git title and message lines with a colon.

s/colon/period/ :)
T
Update
(address . 40782@debbugs.gnu.org)
1744544.PYTXIkNuev@peach
Updated patch with the suggested changes.
From ab228533702e3a99b6495350699cefb2cfcabb6f Mon Sep 17 00:00:00 2001
From: TomZ <tomz@freedommail.ch>
Date: Wed, 22 Apr 2020 22:31:03 +0200
Subject: [PATCH 1/2] gnu: Add hexer.

* gnu/packages/text-editors.scm (hexer): New Variable.
---
gnu/packages/text-editors.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 072760ee10..886babf3fa 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Tom Zander <tomz@freedommail.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -967,3 +968,35 @@ keybindings, autocomplete and unlimited undo. It can pipe a marked block
of text through any command line filter. It can also open very large binary
files. It was originally developed on the Amiga 3000T.")
(license license:gpl3+)))
+
+(define-public hexer
+ (package
+ (name "hexer")
+ (version "1.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://devel.ringlet.net/files/editors/hexer/"
+ "hexer-" version ".tar.xz"))
+ (sha256
+ (base32 "157z17z8qivdin2km2wp86x1bv1nx15frrwcz11mk0l3ab74mf76"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no upstream tests
+ #:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "LTERMCAP=-lncurses")
+ (string-append "LDFLAGS=-L" (assoc-ref %build-inputs "ncurses")
+ "/lib"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ;no configure script
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (home-page "https://devel.ringlet.net/editors/hexer/")
+ (synopsis "Multi buffer editor for binary files with vi-like interface")
+ (description "Hexer is a multi-buffer editor for binary files for Unix-like
+systems that displays its buffer(s) as a hex dump. The user interface is kept
+similar to vi/ex.")
+ (license license:bsd-3)))
--
2.26.2
B
B
Brice Waegeneire wrote on 6 May 2020 11:14
Re: patch#40782 new package; hexer
(address . 40782-done@debbugs.gnu.org)
96e6bc6de76447a8acc4bb91e68b9936@waegenei.re
Pushed as 8b95f741353248c19a5d70dc19e311ed059143f3.
Closed
?