gnu: spacefm: Add missing dependencies.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Jan Nieuwenhuizen
  • Maxim Cournoyer
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
Raghav Gururajan wrote on 21 Apr 2020 23:28
(address . guix-patches@gnu.org)
20200421172812.6227b2eb.raghavgururajan@disroot.org
BLOCKERS: #40630 and #40752.
From fac881e2820c08e09c8f3e42699ba25b8b9f4004 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Tue, 21 Apr 2020 17:23:21 -0400
Subject: [PATCH 3/3] gnu: spacefm: Add missing dependencies.

* gnu/packages/lxde.scm (spacefm): Add missing dependencies.
---
gnu/packages/lxde.scm | 50 +++++++++++++++++++++++++++++++------------
1 file changed, 36 insertions(+), 14 deletions(-)

Toggle diff (94 lines)
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index f5dc027e03..eeb9feb745 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -29,13 +29,16 @@
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages disk)
#:use-module (gnu packages docbook)
+ #:use-module (gnu packages file-systems)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image-viewers)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages lsof)
#:use-module (gnu packages openbox)
@@ -43,9 +46,12 @@
#:use-module (gnu packages polkit)
#:use-module (gnu packages text-editors)
#:use-module (gnu packages video)
+ #:use-module (gnu packages wget)
#:use-module (gnu packages wm)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (guix download)
@@ -249,8 +255,8 @@ with freedesktop.org standard.")
"https://github.com/IgnorantGuru/spacefm/archive/"
version ".tar.gz"))
(sha256
- (base32
- "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
+ (base32
+ "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -262,18 +268,34 @@ with freedesktop.org standard.")
"#include <sys/sysmacros.h>\n")))
#t))
(file-name (string-append name "-" version ".tar.gz"))))
- (build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)
- ("desktop-file-utils" ,desktop-file-utils)
- ("intltool" ,intltool)))
- (inputs `(("bash" ,bash)
- ("gtk+" ,gtk+)
- ("eudev" ,eudev)
- ("shared-mime-info" ,shared-mime-info)
- ("ffmpegthumbnailer" ,ffmpegthumbnailer)
- ("jmtpfs" ,jmtpfs)
- ("lsof" ,lsof)
- ("udisks" ,udisks)))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("bash" ,bash)
+ ("cairo" ,cairo)
+ ("curlftpfs" ,curlftpfs)
+ ("dbus" ,dbus)
+ ("eject" ,eject)
+ ("eudev" ,eudev)
+ ("fakeroot" ,fakeroot)
+ ("ffmpegthumbnailer" ,ffmpegthumbnailer)
+ ("fuseiso" ,fuseiso)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("ifuse" ,ifuse)
+ ("jmtpfs" ,jmtpfs)
+ ("libx11" ,libx11)
+ ("lsof" ,lsof)
+ ("pango" ,pango)
+ ("shared-mime-info" ,shared-mime-info)
+ ("startup-notification" ,startup-notification)
+ ("udevil" ,udevil)
+ ("wget" ,wget)))
(arguments
`(#:configure-flags (list (string-append "--with-bash-path="
(assoc-ref %build-inputs "bash")
--
2.26.1
R
J
J
Jan Nieuwenhuizen wrote on 22 Apr 2020 08:46
Re: [bug#40753] gnu: spacefm: Add missing dependencies.
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40753@debbugs.gnu.org)
87ftcw81bl.fsf@gnu.org
Raghav Gururajan writes:

Hello!

Toggle quote (2 lines)
> BLOCKERS: #40630 and #40752.

...what does this mean?

Toggle quote (7 lines)
>>From fac881e2820c08e09c8f3e42699ba25b8b9f4004 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Tue, 21 Apr 2020 17:23:21 -0400
> Subject: [PATCH 3/3] gnu: spacefm: Add missing dependencies.

> * gnu/packages/lxde.scm (spacefm): Add missing dependencies.

It builds OK without this patch; it does not seem that any dependencies
are missing. Could it be that these dependencies change or amend its
behaviour?

After applying this patch, spacefm does not build for me, I get

Toggle snippet (6 lines)
$ ./pre-inst-env guix build spacefm
ice-9/eval.scm:223:20: In procedure proc:
error: eject: unbound variable
hint: Did you forget a `use-modules' form?

I am feeling a bit uncomfortable about the fact that you pinged me to
"push" this patch, it seems it needs a bit more attention than that.

Greetings,
janneke

--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
R
R
Raghav Gururajan wrote on 22 Apr 2020 18:28
(name . Jan Nieuwenhuizen)(address . janneke@gnu.org)(address . 40753@debbugs.gnu.org)
20200422122833.076c8a60.raghavgururajan@disroot.org
Hi Jan!

Toggle quote (4 lines)
> > BLOCKERS: #40630 and #40752.
>
> ...what does this mean?

They are dependencies of this patch, that needs to be pushed before this patch.

Toggle quote (4 lines)
> It builds OK without this patch; it does not seem that any dependencies
> are missing. Could it be that these dependencies change or amend its
> behaviour?

It is to change and amend the behaviour. It adds missing features and fixes
icons+privilege-management+disk-management.

Toggle quote (9 lines)
> After applying this patch, spacefm does not build for me, I get
>
> --8<---------------cut here---------------start------------->8---
> $ ./pre-inst-env guix build spacefm
> ice-9/eval.scm:223:20: In procedure proc:
> error: eject: unbound variable
> hint: Did you forget a `use-modules' form?
> --8<---------------cut here---------------end--------------->8---

That's correct. Eject is provided by one of the blockers.

Toggle quote (3 lines)
> I am feeling a bit uncomfortable about the fact that you pinged me to
> "push" this patch, it seems it needs a bit more attention than that.

I apologize. I spent whole day to create these patches and throughly testing
them. If I missed anything, please understand it would not have been
intentional. Also, there is a v2 patch in #40753 thread that has 3 blockers.

Thank you for considering my request.

Regards,
RG.
J
J
Jan Nieuwenhuizen wrote on 22 Apr 2020 19:59
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40753@debbugs.gnu.org)
87k127o0z6.fsf@gnu.org
Raghav Gururajan writes:

Hello Raghav,

Toggle quote (7 lines)
>> > BLOCKERS: #40630 and #40752.
>>
>> ...what does this mean?
>
> They are dependencies of this patch, that needs to be pushed before
> this patch.

Right. So we'll have to wait for those then, right?

Toggle quote (7 lines)
>> It builds OK without this patch; it does not seem that any dependencies
>> are missing. Could it be that these dependencies change or amend its
>> behaviour?
>
> It is to change and amend the behaviour. It adds missing features and fixes
> icons+privilege-management+disk-management.

Okay, it would be nice to say something about that in the commit
message. What about

gnu: spacefm: Add dependencies for extra functionality.

Adding these inputs provides adds icons, privilege-management and
disk-management.

Other than that, LGTM (assuming that it builds). I'm not really able
to test it, I assume it works for you as you expected?

Toggle quote (9 lines)
>> I am feeling a bit uncomfortable about the fact that you pinged me to
>> "push" this patch, it seems it needs a bit more attention than that.
>
> I apologize. I spent whole day to create these patches and throughly testing
> them. If I missed anything, please understand it would not have been
> intentional. Also, there is a v2 patch in #40753 thread that has 3 blockers.
>
> Thank you for considering my request.

No worries! I did not have much time this morning and from your ping
assumed a trivial task. Teaches me not to assume things.

I would suggest that when you get an OK on the last dependency for this
one, you mention this patch again.

Please consider sending patches that depend on eachother in one bug
report if that makes sense.

Greetings,
janneke

--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
R
R
Raghav Gururajan wrote on 22 Apr 2020 22:22
Re: [bug#40753] gnu: spacefm: Add missing dependencies. (v3)
(name . Jan Nieuwenhuizen)(address . janneke@gnu.org)(address . 40753@debbugs.gnu.org)
20200422162239.0a98a5c3.raghavgururajan@disroot.org
Hi Jan!

Toggle quote (2 lines)
> Right. So we'll have to wait for those then, right?

Pardon me, I should have communicated better. I was asking to push including
the blockers. Would you be able to please? If not, that's okay.

Toggle quote (8 lines)
> Okay, it would be nice to say something about that in the commit
> message. What about
>
> gnu: spacefm: Add dependencies for extra functionality.
>
> Adding these inputs provides adds icons, privilege-management and
> disk-management.

Thanks. Please find the revised patch attached with this email.

Toggle quote (3 lines)
> Other than that, LGTM (assuming that it builds). I'm not really able
> to test it, I assume it works for you as you expected?

Yes, all works good. :-)

Toggle quote (3 lines)
> No worries! I did not have much time this morning and from your ping
> assumed a trivial task. Teaches me not to assume things.

No, you did not do anything wrong. I should have communicated better.

Toggle quote (3 lines)
> I would suggest that when you get an OK on the last dependency for this
> one, you mention this patch again.

Sure. But let me know if you would be able to process the blockers as well.

Toggle quote (3 lines)
> Please consider sending patches that depend on eachother in one bug
> report if that makes sense.

Sorry, I did not plan on fixing spacefm. I came across the issues with spacefm
after sending those other patches.

Regards,
RG.
From b4f659e7c43eebb4f27f5c1d208a0326d7f2e6a6 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Wed, 22 Apr 2020 16:15:34 -0400
Subject: [PATCH 4/4] gnu: spacefm: Add dependencies for extra functionality.

* gnu/packages/lxde.scm (spacefm): Add dependencies for extra functionality.

Adding these inputs and making required changes to build-system+arguments;
provides icons, privilege-management and disk-management.
---
gnu/packages/lxde.scm | 50 +++++++++++++++++++++++++++++++------------
1 file changed, 36 insertions(+), 14 deletions(-)

Toggle diff (94 lines)
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index f5dc027e03..eeb9feb745 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -29,13 +29,16 @@
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages disk)
#:use-module (gnu packages docbook)
+ #:use-module (gnu packages file-systems)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image-viewers)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages lsof)
#:use-module (gnu packages openbox)
@@ -43,9 +46,12 @@
#:use-module (gnu packages polkit)
#:use-module (gnu packages text-editors)
#:use-module (gnu packages video)
+ #:use-module (gnu packages wget)
#:use-module (gnu packages wm)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (guix download)
@@ -249,8 +255,8 @@ with freedesktop.org standard.")
"https://github.com/IgnorantGuru/spacefm/archive/"
version ".tar.gz"))
(sha256
- (base32
- "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
+ (base32
+ "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -262,18 +268,34 @@ with freedesktop.org standard.")
"#include <sys/sysmacros.h>\n")))
#t))
(file-name (string-append name "-" version ".tar.gz"))))
- (build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)
- ("desktop-file-utils" ,desktop-file-utils)
- ("intltool" ,intltool)))
- (inputs `(("bash" ,bash)
- ("gtk+" ,gtk+)
- ("eudev" ,eudev)
- ("shared-mime-info" ,shared-mime-info)
- ("ffmpegthumbnailer" ,ffmpegthumbnailer)
- ("jmtpfs" ,jmtpfs)
- ("lsof" ,lsof)
- ("udisks" ,udisks)))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("bash" ,bash)
+ ("cairo" ,cairo)
+ ("curlftpfs" ,curlftpfs)
+ ("dbus" ,dbus)
+ ("eject" ,eject)
+ ("eudev" ,eudev)
+ ("fakeroot" ,fakeroot)
+ ("ffmpegthumbnailer" ,ffmpegthumbnailer)
+ ("fuseiso" ,fuseiso)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("ifuse" ,ifuse)
+ ("jmtpfs" ,jmtpfs)
+ ("libx11" ,libx11)
+ ("lsof" ,lsof)
+ ("pango" ,pango)
+ ("shared-mime-info" ,shared-mime-info)
+ ("startup-notification" ,startup-notification)
+ ("udevil" ,udevil)
+ ("wget" ,wget)))
(arguments
`(#:configure-flags (list (string-append "--with-bash-path="
(assoc-ref %build-inputs "bash")
--
2.26.1
R
R
Raghav Gururajan wrote on 24 Apr 2020 21:35
gnu: spacefm: Add dependencies for extra functionality. (v3)
(address . 40753@debbugs.gnu.org)
20200424153558.2aa79ef0.raghavgururajan@disroot.org

From c8ffa0953bd26a4ce22cae17b55d0392908b0f71 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 24 Apr 2020 15:33:15 -0400
Subject: [PATCH 2/2] gnu: spacefm: Add dependencies for extra functionality.

* gnu/packages/lxde.scm (spacefm): Add dependencies for extra functionality.

Adding these inputs and making required changes to build-system+arguments;
provides icons, privilege-management and disk-management.
---
gnu/packages/lxde.scm | 50 +++++++++++++++++++++++++++++++------------
1 file changed, 36 insertions(+), 14 deletions(-)

Toggle diff (94 lines)
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index f5dc027e03..1ddac97dee 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -29,13 +29,16 @@
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages disk)
#:use-module (gnu packages docbook)
+ #:use-module (gnu packages file-systems)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image-viewers)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages lsof)
#:use-module (gnu packages openbox)
@@ -43,9 +46,12 @@
#:use-module (gnu packages polkit)
#:use-module (gnu packages text-editors)
#:use-module (gnu packages video)
+ #:use-module (gnu packages wget)
#:use-module (gnu packages wm)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (guix download)
@@ -249,8 +255,8 @@ with freedesktop.org standard.")
"https://github.com/IgnorantGuru/spacefm/archive/"
version ".tar.gz"))
(sha256
- (base32
- "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
+ (base32
+ "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -262,18 +268,34 @@ with freedesktop.org standard.")
"#include <sys/sysmacros.h>\n")))
#t))
(file-name (string-append name "-" version ".tar.gz"))))
- (build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)
- ("desktop-file-utils" ,desktop-file-utils)
- ("intltool" ,intltool)))
- (inputs `(("bash" ,bash)
- ("gtk+" ,gtk+)
- ("eudev" ,eudev)
- ("shared-mime-info" ,shared-mime-info)
- ("ffmpegthumbnailer" ,ffmpegthumbnailer)
- ("jmtpfs" ,jmtpfs)
- ("lsof" ,lsof)
- ("udisks" ,udisks)))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("bash" ,bash)
+ ("cairo" ,cairo)
+ ("curlftpfs" ,curlftpfs)
+ ("dbus" ,dbus)
+ ("eudev" ,eudev)
+ ("fakeroot" ,fakeroot)
+ ("ffmpegthumbnailer" ,ffmpegthumbnailer)
+ ("fuseiso" ,fuseiso)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("ifuse" ,ifuse)
+ ("jmtpfs" ,jmtpfs)
+ ("libx11" ,libx11)
+ ("lsof" ,lsof)
+ ("pango" ,pango)
+ ("shared-mime-info" ,shared-mime-info)
+ ("startup-notification" ,startup-notification)
+ ("udevil" ,udevil)
+ ("util-linux" ,util-linux)
+ ("wget" ,wget)))
(arguments
`(#:configure-flags (list (string-append "--with-bash-path="
(assoc-ref %build-inputs "bash")
--
2.26.1
J
J
Jan Nieuwenhuizen wrote on 24 Apr 2020 22:09
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40753@debbugs.gnu.org)
87h7x8wsr8.fsf@gnu.org
Raghav Gururajan writes:

Hi Raghav,

Pushed to master with small cosmetic change below.

Thanks for the patch!
janneke

Toggle quote (9 lines)
>>From c8ffa0953bd26a4ce22cae17b55d0392908b0f71 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Fri, 24 Apr 2020 15:33:15 -0400
> Subject: [PATCH 2/2] gnu: spacefm: Add dependencies for extra functionality.
> #:use-module (gnu packages wm)
> #:use-module (gnu packages xml)
> + #:use-module (gnu packages xdisorg)
> #:use-module (gnu packages xorg)

Changed this to

#:use-module (gnu packages wm)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)

--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
R
R
Raghav Gururajan wrote on 26 Apr 2020 04:11
Re: [bug#40753] gnu: spacefm: Add dependencies for extra functionality.
(name . Jan Nieuwenhuizen)(address . janneke@gnu.org)(address . 40753@debbugs.gnu.org)
20200425221143.1a587483.raghavgururajan@disroot.org
Hi Jan!

Toggle quote (4 lines)
> Pushed to master with small cosmetic change below.
>
> Thanks for the patch!

I accidentally sent the wrong patch that missed some things. So sorry. I have
attached a patch with this email to append the previous. Could you please push
it as new commit. Thanks!

Regards,
RG.
From ea9e9909c2929639c1b6574ae61ca9fb0b319177 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sat, 25 Apr 2020 21:43:25 -0400
Subject: [PATCH] gnu: spacefm: Fix privilege management and icons.

* gnu/packages/lxde.scm (spacefm): Fix privilege management and icons.

This commit contains changes that were accidentally left out in
commit bf37b49cdd345bcedeb7142f61968d3a6e15e8d8.
---
gnu/packages/lxde.scm | 37 ++++++++++++++++++++++++++++++-------
1 file changed, 30 insertions(+), 7 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 9de96a21cb..3fd2eaff69 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -27,6 +27,7 @@
(define-module (gnu packages lxde)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
#:use-module (gnu packages disk)
@@ -276,7 +277,8 @@ with freedesktop.org standard.")
("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(inputs
- `(("bash" ,bash)
+ `(("adwaita-icon-theme" ,adwaita-icon-theme) ; Hard-coded theme
+ ("bash" ,bash)
("cairo" ,cairo)
("curlftpfs" ,curlftpfs)
("dbus" ,dbus)
@@ -288,21 +290,42 @@ with freedesktop.org standard.")
("gtk+" ,gtk+)
("ifuse" ,ifuse)
("jmtpfs" ,jmtpfs)
+ ("ktsuss" ,ktsuss)
("libx11" ,libx11)
("lsof" ,lsof)
("pango" ,pango)
("shared-mime-info" ,shared-mime-info)
("startup-notification" ,startup-notification)
+ ("sudo" ,sudo)
("udevil" ,udevil)
("util-linux" ,util-linux)
("wget" ,wget)))
(arguments
- `(#:configure-flags (list (string-append "--with-bash-path="
- (assoc-ref %build-inputs "bash")
- "/bin/bash")
- (string-append "--sysconfdir="
- (assoc-ref %outputs "out")
- "/etc"))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-spacefm-conf
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "etc/spacefm.conf"
+ (("#terminal_su=/bin/su")
+ (string-append "terminal_su="
+ (string-append (assoc-ref inputs "sudo")
+ "/bin/sudo"))))
+ (substitute* "etc/spacefm.conf"
+ (("#graphical_su=/usr/bin/gksu")
+ (string-append "graphical_su="
+ (string-append (assoc-ref inputs "ktsuss")
+ "/bin/ktsuss"))))
+ #t)))
+ #:configure-flags (list
+ (string-append "--with-preferable-sudo="
+ (assoc-ref %build-inputs "ktsuss")
+ "/bin/ktsuss")
+ (string-append "--with-bash-path="
+ (assoc-ref %build-inputs "bash")
+ "/bin/bash")
+ (string-append "--sysconfdir="
+ (assoc-ref %outputs "out")
+ "/etc"))))
(home-page "https://ignorantguru.github.io/spacefm/")
(synopsis "Multi-panel tabbed file manager")
(description "SpaceFM is a graphical, multi-panel, tabbed file manager
--
2.26.1
J
J
Jan Nieuwenhuizen wrote on 26 Apr 2020 16:00
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40753@debbugs.gnu.org)
87lfmis5wm.fsf@gnu.org
Raghav Gururajan writes:

Hello Raghav,

Toggle quote (8 lines)
>> Pushed to master with small cosmetic change below.
>>
>> Thanks for the patch!
>
> I accidentally sent the wrong patch that missed some things. So sorry. I have
> attached a patch with this email to append the previous. Could you please push
> it as new commit. Thanks!

Don't worry, we all make mistakes.

Toggle quote (9 lines)
> From ea9e9909c2929639c1b6574ae61ca9fb0b319177 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Sat, 25 Apr 2020 21:43:25 -0400
> Subject: [PATCH] gnu: spacefm: Fix privilege management and icons.

>>>HERE<<<

> * gnu/packages/lxde.scm (spacefm): Fix privilege management and icons.

Please move this remark:

Toggle quote (3 lines)
> This commit contains changes that were accidentally left out in
> commit bf37b49cdd345bcedeb7142f61968d3a6e15e8d8.

beteen subject and "* gnu/packages/lxde", so to >>>HERE<<<

Toggle quote (17 lines)
> (arguments
> - `(#:configure-flags (list (string-append "--with-bash-path="
> - (assoc-ref %build-inputs "bash")
> - "/bin/bash")
> - (string-append "--sysconfdir="
> - (assoc-ref %outputs "out")
> - "/etc"))))
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'patch-spacefm-conf
> + (lambda* (#:key inputs #:allow-other-keys)
> + (substitute* "etc/spacefm.conf"
> + (("#terminal_su=/bin/su")
> + (string-append "terminal_su="
> + (string-append (assoc-ref inputs "sudo")
> + "/bin/sudo"))))

Does this work; SU is not SUDO? Also, I don't see how <sudo>/bin/sudo
would work. When I run this

$(guix build sudo)/bin/sudo

I get

sudo: /gnu/store/l320ig872ny66d1yi6v7n4zb93iz50dx-sudo-1.8.31p1/bin/sudo must be owned by uid 0 and have the setuid bit set

Am I missing something?

Toggle quote (7 lines)
> + (substitute* "etc/spacefm.conf"
> + (("#graphical_su=/usr/bin/gksu")
> + (string-append "graphical_su="
> + (string-append (assoc-ref inputs "ktsuss")
> + "/bin/ktsuss"))))
> + #t)))

Changing the default configurations does not seem to work for me. When
I select

/File/Root Window

there is a pop-up that says: Please configure a valid Terminal SU
command. Does it work for You?

Toggle quote (1 lines)
> + #:configure-flags (list
^
Trailing space.

Greetings,
janneke

--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
R
R
Raghav Gururajan wrote on 27 Apr 2020 08:29
(name . Jan Nieuwenhuizen)(address . janneke@gnu.org)(address . 40753@debbugs.gnu.org)
20200427022956.7c7d7263.raghavgururajan@disroot.org
Hi Jan!

Toggle quote (11 lines)
> >>>HERE<<<
>
> > * gnu/packages/lxde.scm (spacefm): Fix privilege management and icons.
>
> Please move this remark:
>
> > This commit contains changes that were accidentally left out in
> > commit bf37b49cdd345bcedeb7142f61968d3a6e15e8d8.
>
> beteen subject and "* gnu/packages/lxde", so to >>>HERE<<<

Sure.

Toggle quote (30 lines)
> > (arguments
> > - `(#:configure-flags (list (string-append "--with-bash-path="
> > - (assoc-ref %build-inputs
> > "bash")
> > - "/bin/bash")
> > - (string-append "--sysconfdir="
> > - (assoc-ref %outputs "out")
> > - "/etc"))))
> > + `(#:phases
> > + (modify-phases %standard-phases
> > + (add-after 'unpack 'patch-spacefm-conf
> > + (lambda* (#:key inputs #:allow-other-keys)
> > + (substitute* "etc/spacefm.conf"
> > + (("#terminal_su=/bin/su")
> > + (string-append "terminal_su="
> > + (string-append (assoc-ref inputs "sudo")
> > + "/bin/sudo"))))
>
> Does this work; SU is not SUDO? Also, I don't see how <sudo>/bin/sudo
> would work. When I run this
>
> $(guix build sudo)/bin/sudo
>
> I get
>
> sudo: /gnu/store/l320ig872ny66d1yi6v7n4zb93iz50dx-sudo-1.8.31p1/bin/sudo
> must be owned by uid 0 and have the setuid bit set
>
> Am I missing something?

The option just has the name "su". It can be sudo too. I wouldn't worry about
this terminal_su option. This is just has to be set, so that spacefm doesn't
throw "no valid program found" error, now and then, because of default FHS path.
SpaceFM primarily uses graphical_su, which has been set to 'ktsuss'.

Toggle quote (15 lines)
> > + (substitute* "etc/spacefm.conf"
> > + (("#graphical_su=/usr/bin/gksu")
> > + (string-append "graphical_su="
> > + (string-append (assoc-ref inputs "ktsuss")
> > + "/bin/ktsuss"))))
> > + #t)))
>
> Changing the default configurations does not seem to work for me. When
> I select
>
> /File/Root Window
>
> there is a pop-up that says: Please configure a valid Terminal SU
> command. Does it work for You?

This is exactly the error I was talking about above. Once we apply this patch,
the error appearing stops and ktsuss will pop right up.

Toggle quote (5 lines)
>
> > + #:configure-flags (list
> ^
> Trailing space.

Thanks! I have attached revised patch with this email.

Regards,
RG.
From 636d358dc3290433b929ebd72ad087dbfa50c8a5 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Mon, 27 Apr 2020 02:27:16 -0400
Subject: [PATCH] gnu: spacefm: Fix privilege management.

* gnu/packages/lxde.scm (spacefm): Fix privilege management.
---
gnu/packages/lxde.scm | 34 ++++++++++++++++++++++++++++------
1 file changed, 28 insertions(+), 6 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 9de96a21cb..8b9759bc9c 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -27,6 +27,7 @@
(define-module (gnu packages lxde)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
#:use-module (gnu packages disk)
@@ -288,21 +289,42 @@ with freedesktop.org standard.")
("gtk+" ,gtk+)
("ifuse" ,ifuse)
("jmtpfs" ,jmtpfs)
+ ("ktsuss" ,ktsuss)
("libx11" ,libx11)
("lsof" ,lsof)
("pango" ,pango)
("shared-mime-info" ,shared-mime-info)
("startup-notification" ,startup-notification)
+ ("sudo" ,sudo)
("udevil" ,udevil)
("util-linux" ,util-linux)
("wget" ,wget)))
(arguments
- `(#:configure-flags (list (string-append "--with-bash-path="
- (assoc-ref %build-inputs "bash")
- "/bin/bash")
- (string-append "--sysconfdir="
- (assoc-ref %outputs "out")
- "/etc"))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-spacefm-conf
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "etc/spacefm.conf"
+ (("#terminal_su=/bin/su")
+ (string-append "terminal_su="
+ (string-append (assoc-ref inputs "sudo")
+ "/bin/sudo"))))
+ (substitute* "etc/spacefm.conf"
+ (("#graphical_su=/usr/bin/gksu")
+ (string-append "graphical_su="
+ (string-append (assoc-ref inputs "ktsuss")
+ "/bin/ktsuss"))))
+ #t)))
+ #:configure-flags (list
+ (string-append "--with-preferable-sudo="
+ (assoc-ref %build-inputs "ktsuss")
+ "/bin/ktsuss")
+ (string-append "--with-bash-path="
+ (assoc-ref %build-inputs "bash")
+ "/bin/bash")
+ (string-append "--sysconfdir="
+ (assoc-ref %outputs "out")
+ "/etc"))))
(home-page "https://ignorantguru.github.io/spacefm/")
(synopsis "Multi-panel tabbed file manager")
(description "SpaceFM is a graphical, multi-panel, tabbed file manager
--
2.26.2
E
E
Efraim Flashner wrote on 27 Apr 2020 08:38
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)
20200427063812.GH5243@E5400
On Guix System $(guix build sudo)/bin/sudo isn't setuid, we'd need the
one from /run/setuid-programs.

(ins)efraim@E5400 ~$ which sudo
/run/setuid-programs/sudo


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl6mfdQACgkQQarn3Mo9
g1Gx6A/+N+NOEUUxNdyK8zVBxErqHud6Au9Qka3C2pimb1JcNnWL/2j0NzzZZe7c
D0OXnqARwcxGiNEbgmrz4HMOGTNz/17FGoJsYO1KbRJyrDRQnOPSPF7ztqsPto6i
2vTCpF4RbuXTLssQA4/R7ynwCGELIB+9/m88C1uZzvwI3gv/Ot+PrBjzzcP4hq54
Nciwldkqc8i5sFFebpXODh35yvH4Yu0rmIRjp/a8Mo5ZnuImfoH6JnzESNtHRz8C
Xe5T+P5SpsCuVAo71WBd/1pXBRymlB7brNi3xi5ibSrp0qiIbL/HYKEeyi2w+y3a
KIanwHHBhmmKvhwmLlX6mKiGT5xUf2k/36vS5GVhfA+SzxnOpq74Mc53ez8Ls9mb
RmZUqmu3NEKT80GXqC0+xtzTiTz1fh3b9mwhtf0mUGDB2B79YsVnGDyOzcCIuVJz
LMkCo/WNwJSsJYVnmRi5hWPO7uHB38Og6bAvKX0uFGFIDhcLhCoSWkEzu/CQ1DW4
HZHLmvc2oH9T85sKbNX7k++dFZSNTSHook2p/SprKd0AXbuRAUDJTatJAAstp/pV
IWjWmoFy8lUCxEIs7Lhzd1TZOuIXag5YQdOJpHGwpzf7MyWp0HG8XuKxbzeT8AtU
YHNQ3uxsjqgqxh1M5a+8hlkCj+DQQ1aWwLNAYPl1BqoNUOQcNns=
=1qa7
-----END PGP SIGNATURE-----


J
J
Jan Nieuwenhuizen wrote on 27 Apr 2020 10:37
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40753@debbugs.gnu.org)
87368p5nof.fsf@gnu.org
Raghav Gururajan writes:

Hello Raghav,

Toggle quote (15 lines)
>> Does this work; SU is not SUDO? Also, I don't see how <sudo>/bin/sudo
>> would work. When I run this
>>
>> $(guix build sudo)/bin/sudo
>>
>> I get
>>
>> sudo: /gnu/store/l320ig872ny66d1yi6v7n4zb93iz50dx-sudo-1.8.31p1/bin/sudo
>> must be owned by uid 0 and have the setuid bit set
>>
>> Am I missing something?
>
> The option just has the name "su". It can be sudo too. I wouldn't worry about
> this terminal_su option.

That's okay, I'm not really worried :-)

When I read a patch, and I cannot imagine how that would work, I would
like to learn more to understand it beter, or remove it. I do not like
adding code that I do not understand, and also does not work.

Toggle quote (4 lines)
> This is just has to be set, so that spacefm doesn't throw "no valid
> program found" error, now and then, because of default FHS path.
> SpaceFM primarily uses graphical_su, which has been set to 'ktsuss'.

Okay, that would explain something. So, TERMINAL_SU just needs to be
set to "some" existing executable, but is not used? What about

`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-spacefm-conf
(lambda _
;; If terminal_su is unset, users get a popup:
;; "Please configure a valid Terminal SU command."
(substitute* "etc/spacefm.conf"
(("#terminal_su=/bin/su")
"terminal_su=/run/current-system/profile/bin/false"))
#t)))

I tested this, and it hase the same, partially functional result, as
using sudo and setting #graphical_su. WDYT?

Toggle quote (18 lines)
>> > + (substitute* "etc/spacefm.conf"
>> > + (("#graphical_su=/usr/bin/gksu")
>> > + (string-append "graphical_su="
>> > + (string-append (assoc-ref inputs "ktsuss")
>> > + "/bin/ktsuss"))))
>> > + #t)))
>>
>> Changing the default configurations does not seem to work for me. When
>> I select
>>
>> /File/Root Window
>>
>> there is a pop-up that says: Please configure a valid Terminal SU
>> command. Does it work for You?
>
> This is exactly the error I was talking about above. Once we apply this patch,
> the error appearing stops and ktsuss will pop right up.

Hmm. Can you double check? I tested your patch again today it (still)
does not work. I get

Please configure a valid Terminal SU command.

Only when I manually point spacefm to it's configuration file, like so

/gnu/store/y24705ci3dcjiqdig3k3x18pc6aymnzc-spacefm-1.0.6/bin/spacefm -c /gnu/store/y24705ci3dcjiqdig3k3x18pc6aymnzc-spacefm-1.0.6/etc/spacefm/

then the popup disappears. So now I am wondering, is the problem with
your setup or with mine? What do you think?

By the way, the KTSUSS popup (when I see it) does not work for me. Have
you tested KTSUSS?

Greetings,
janneke

--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
J
J
Jan Nieuwenhuizen wrote on 27 Apr 2020 10:42
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87y2qh48vu.fsf@gnu.org
Efraim Flashner writes:

Toggle quote (6 lines)
> On Guix System $(guix build sudo)/bin/sudo isn't setuid, we'd need the
> one from /run/setuid-programs.
>
> (ins)efraim@E5400 ~$ which sudo
> /run/setuid-programs/sudo

Yes, that's what I wanted to suggest...but then I saw that the setting
is called TERMINAL_SU (not SUDO). That got me thinking: this is
possibly not used at all...could be dead code?

janneke

--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
R
R
Raghav Gururajan wrote on 28 Apr 2020 11:11
(name . Jan Nieuwenhuizen)(address . janneke@gnu.org)
20200428051108.7dee10d7.raghavgururajan@disroot.org
Hi Jan!

Sorry again for messing this up. I have attached revised patch with this email.

This, along with #40922 and new patch at #40901, makes SpaceFM to work
perfectly. :-)

Regards,
RG.
From b623508a4e673e53e63336ee5d97c39e85b52b75 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Tue, 28 Apr 2020 05:02:06 -0400
Subject: [PATCH 3/3] gnu: spacefm: Fix privilege and disk management.

* gnu/packages/lxde.scm (spacefm): Fix privilege and disk management.

Patched references to su, ktsuss and udevil; to load them correctly.
---
gnu/packages/lxde.scm | 34 +++++++++++++++++++++++++++-------
1 file changed, 27 insertions(+), 7 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 9de96a21cb..d152f6f79d 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -27,6 +27,7 @@
(define-module (gnu packages lxde)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
#:use-module (gnu packages disk)
@@ -279,7 +280,6 @@ with freedesktop.org standard.")
`(("bash" ,bash)
("cairo" ,cairo)
("curlftpfs" ,curlftpfs)
- ("dbus" ,dbus)
("eudev" ,eudev)
("fakeroot" ,fakeroot)
("ffmpegthumbnailer" ,ffmpegthumbnailer)
@@ -288,6 +288,7 @@ with freedesktop.org standard.")
("gtk+" ,gtk+)
("ifuse" ,ifuse)
("jmtpfs" ,jmtpfs)
+ ("ktsuss" ,ktsuss)
("libx11" ,libx11)
("lsof" ,lsof)
("pango" ,pango)
@@ -297,12 +298,31 @@ with freedesktop.org standard.")
("util-linux" ,util-linux)
("wget" ,wget)))
(arguments
- `(#:configure-flags (list (string-append "--with-bash-path="
- (assoc-ref %build-inputs "bash")
- "/bin/bash")
- (string-append "--sysconfdir="
- (assoc-ref %outputs "out")
- "/etc"))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Patch config file to load programs correctly.
+ (substitute* "etc/spacefm.conf"
+ (("#terminal_su=/bin/su")
+ "terminal_su=/run/setuid-programs/su")
+ (("#graphical_su=/usr/bin/gksu")
+ (string-append "graphical_su="
+ (string-append (assoc-ref inputs "ktsuss")
+ "/bin/ktsuss"))))
+ ;; SpaceFM expects udevil to have uid set to root.
+ ;; User has to manually add udevil to setuid-programs.
+ (substitute* "src/settings.c"
+ (("/usr/bin/udevil")
+ "/run/setuid-programs/udevil"))
+ #t)))
+ #:configure-flags (list
+ (string-append "--with-bash-path="
+ (assoc-ref %build-inputs "bash")
+ "/bin/bash")
+ (string-append "--sysconfdir="
+ (assoc-ref %outputs "out")
+ "/etc"))))
(home-page "https://ignorantguru.github.io/spacefm/")
(synopsis "Multi-panel tabbed file manager")
(description "SpaceFM is a graphical, multi-panel, tabbed file manager
--
2.26.2
R
R
Raghav Gururajan wrote on 30 Apr 2020 15:57
(name . Jan Nieuwenhuizen)(address . janneke@gnu.org)
20200430095707.02a4eaad.raghavgururajan@disroot.org
Hi Jan!

Since #40753 is already closed. I have sent revised patch as #40982.

So #40982 and #40922, should fix current spacefm disk issues.

Regards,
RG.
M
M
Maxim Cournoyer wrote on 30 May 2020 07:08
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)
877dwuxb4w.fsf@gmail.com
Raghav Gururajan <raghavgururajan@disroot.org> writes:

Toggle quote (9 lines)
> Hi Jan!
>
> Since #40753 is already closed. I have sent revised patch as #40982.
>
> So #40982 and #40922, should fix current spacefm disk issues.
>
> Regards,
> RG.

Alright, I'm closing this one then, by sending a reply to
40753-done@debbugs.gnu.org (that is, simply add the '-done' suffix to
the bug number in the debbugs email).

Thank you,

Maxim
Closed
?