[PATCH] gnu: Add python-diceware.

  • Done
  • quality assurance status badge
Details
3 participants
  • Matthew Kraai
  • Leo Famulari
  • Christopher Baines
Owner
unassigned
Submitted by
Matthew Kraai
Severity
normal
M
M
Matthew Kraai wrote on 12 Apr 2020 17:00
(address . guix-patches@gnu.org)(name . Matthew Kraai)(address . kraai@ftbfs.org)
20200412150036.6508-1-kraai@ftbfs.org
* gnu/packages/python-xyz.scm (python-diceware, python2-diceware): New public
variables.
---
gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2ecf7115ab..081bc0eb5d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -75,6 +75,7 @@
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
+;;; Copyright © 2020 Matthew Kraai <kraai@ftbfs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19521,3 +19522,30 @@ there are extensions that allow you to use it with other frameworks.")
register external CLI commands via setuptools entry-points.")
(home-page "https://github.com/click-contrib/click-plugins")
(license license:bsd-3)))
+
+(define-public python-diceware
+ (package
+ (name "python-diceware")
+ (version "0.9.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "diceware" version))
+ (sha256
+ (base32
+ "0klb0ysybzlh2wihvir82hgq62v0jjmlcqklwajyms7c0p529yby"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/ulif/diceware/")
+ (synopsis "Generates memorable passphrases")
+ (description "This package generates passphrases by concatenating words
+randomly picked from wordlists. It supports several sources of
+randomness (including real life dice) and different wordlists (including
+cryptographically signed ones).")
+ (license license:gpl3+)))
+
+(define-public python2-diceware
+ (package-with-python2 python-diceware))
--
2.26.0
L
L
Leo Famulari wrote on 13 Apr 2020 23:02
(name . Matthew Kraai)(address . kraai@ftbfs.org)(address . 40575@debbugs.gnu.org)
20200413210209.GA31853@jasmine.lan
On Sun, Apr 12, 2020 at 08:00:36AM -0700, Matthew Kraai wrote:
Toggle quote (3 lines)
> * gnu/packages/python-xyz.scm (python-diceware, python2-diceware): New public
> variables.

Thanks! Overall LGTM...

Toggle quote (3 lines)
> +(define-public python2-diceware
> + (package-with-python2 python-diceware))

Do you have a use case for the Python 2 variant? We recently updated our
Python packaging standards to not add these variants unless we need
them:

M
M
Matthew Kraai wrote on 13 Apr 2020 23:50
(name . Leo Famulari)(address . leo@famulari.name)(address . 40575@debbugs.gnu.org)
20200413215052.GA20331@inspiron-3147
Hi Leo,

On Mon, Apr 13, 2020 at 05:02:09PM -0400, Leo Famulari wrote:
Toggle quote (15 lines)
> On Sun, Apr 12, 2020 at 08:00:36AM -0700, Matthew Kraai wrote:
> > * gnu/packages/python-xyz.scm (python-diceware, python2-diceware): New public
> > variables.
>
> Thanks! Overall LGTM...
>
> > +(define-public python2-diceware
> > + (package-with-python2 python-diceware))
>
> Do you have a use case for the Python 2 variant? We recently updated our
> Python packaging standards to not add these variants unless we need
> them:
>
> https://git.savannah.gnu.org/cgit/guix.git/commit/?id=39356057bce20f74120b6d227567a943556717cc

No, I don't have a use case for the Python 2 variant. I'll update the
patch.

--
Matthew Kraai
M
M
Matthew Kraai wrote on 13 Apr 2020 23:55
[PATCH] gnu: Add python-diceware.
(address . 40575@debbugs.gnu.org)(name . Matthew Kraai)(address . kraai@ftbfs.org)
20200413215550.21733-1-kraai@ftbfs.org
* gnu/packages/python-xyz.scm (python-diceware, python2-diceware): New public
variables.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2ecf7115ab..e089d91979 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -75,6 +75,7 @@
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
+;;; Copyright © 2020 Matthew Kraai <kraai@ftbfs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19521,3 +19522,27 @@ there are extensions that allow you to use it with other frameworks.")
register external CLI commands via setuptools entry-points.")
(home-page "https://github.com/click-contrib/click-plugins")
(license license:bsd-3)))
+
+(define-public python-diceware
+ (package
+ (name "python-diceware")
+ (version "0.9.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "diceware" version))
+ (sha256
+ (base32
+ "0klb0ysybzlh2wihvir82hgq62v0jjmlcqklwajyms7c0p529yby"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/ulif/diceware/")
+ (synopsis "Generates memorable passphrases")
+ (description "This package generates passphrases by concatenating words
+randomly picked from wordlists. It supports several sources of
+randomness (including real life dice) and different wordlists (including
+cryptographically signed ones).")
+ (license license:gpl3+)))
--
2.26.0
L
L
Leo Famulari wrote on 14 Apr 2020 00:47
(name . Matthew Kraai)(address . kraai@ftbfs.org)(address . 40575@debbugs.gnu.org)
20200413224754.GA13339@jasmine.lan
On Mon, Apr 13, 2020 at 02:55:50PM -0700, Matthew Kraai wrote:
Toggle quote (3 lines)
> * gnu/packages/python-xyz.scm (python-diceware, python2-diceware): New public
> variables.

Thanks! Pushed as ab3ad88ded0734401667f6fb4c927ce26c39ad2e
C
C
Christopher Baines wrote on 14 Apr 2020 20:50
(address . 40575-done@debbugs.gnu.org)
87a73d7vg7.fsf@cbaines.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (6 lines)
> On Mon, Apr 13, 2020 at 02:55:50PM -0700, Matthew Kraai wrote:
>> * gnu/packages/python-xyz.scm (python-diceware, python2-diceware): New public
>> variables.
>
> Thanks! Pushed as ab3ad88ded0734401667f6fb4c927ce26c39ad2e

Closing the bug now.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl6WBghfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdzOxAAhSs5RV/F6OYm2e7Qs5sIyykQmuzjDgdQqM321RcIqS9UIpHoqDkPI2dz
3kfO0YYMk90+nykdbRfox/BPM1wuvXjW7cyTTZtCvLHq7RismgH+wE/7LoXl10nM
UM6ZCFdu7urtRVSgWyhsCAERtyvK6VwpX6io7SGVv0vupDyBC+/Sd+XbmftKWU6k
nnN5fcmGP4Hqw+VAV8YVvx+yR1TkyUJ9GYMJ1GxnSqISz9YMjlNehQ3CzkD5mUwo
ZktGrXMOh8rlTe+9k2KQdoYm/AyHlQppaXic00SazqhjkWXZyj7RU+jDk7qteXKj
NUq+Vs08ltKUZbDnmoCpAV9R3vu8eKViD/CveZ85OjZ44OVV1rZ57fRD+AKHDPWj
Ogs1sK+tTxlFM9RT3f5mdFViWdMrrIURHlsuMgtBvd0sTaqbd1fCWbfv1HAhgXBX
nG9Mq8w00ZYIyXuS6SQFUDxN8CdIzxezW7vxJShV3oi2Wum1zHuM0Ju3epyumo5U
wqoSJhroYK6Y0rfzM8Gp1tbjZD8MlW194/bLg/RFqgarBCDocJwcZrf9hltAjcxM
Ur3Xdk0rT1OS0CA+Uu3t5lA2fiAC6/Vfl4IlBKIySvRwJN25E25joOMBFIo2irNx
8Y9wY2YNmIB2jj7//SAKLpYYj7/qVdbi+T9v6yI9y8wt8y28hX4=
=x36d
-----END PGP SIGNATURE-----

Closed
?