[PATCH] gnu: Add lsp-plugins.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Efraim Flashner
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 6 Apr 2020 17:08
(name . Guix patches)(address . guix-patches@gnu.org)
5e2c5de3bd13ab94f1a9fc48f65e002b75cde9df.camel@zrythm.org
Hi,

This patch adds LSP plugins (https://lsp-plug.in/).

Thanks,
Alex
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6LRfIACgkQAi6uQjE9
cPPKhAf/VwFkAOyVUKC7A+QlBeEXDEMI8lca6XAXqvViWAHB3E/OwLb2OG1reO9w
HsqG25SrjHym9ClZn60Ljui3bMgIK5zZKv7QDBECuexLhIChb9aTDeaM/M8Amc0M
sBC6ZBlem2TFnK8QM1n6kwPNRg6aby9w8NdE1Ch/iXP2wFTOS4WZ3M8Z1hS3GOj+
Nnm8ouK+Gd/lzqfZQEC7bCIkvtjuXOU+PZAsuRbTBQWp8uRsiK4V2L73yIJ62y2R
wlKihu/iWWlda+6n5AQCMDZKMkucRlF/mUGzlS2wx7mXv73dFGcHmPGefdx40mHB
03BUWkOWUCpMPrAcrG56wxK9SlfuQg==
=/Lom
-----END PGP SIGNATURE-----


A
A
Alexandros Theodotou wrote on 7 Apr 2020 22:08
(address . 40471@debbugs.gnu.org)
2ba1186e3cdefb109e293aba0337c95ab6cea6f4.camel@zrythm.org
Oops, here's the patch.
From 5426409d1d392b8f5fab184a64526d597dd690fa Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Mon, 6 Apr 2020 16:07:19 +0100
Subject: [PATCH] gnu: Add lsp-plugins.

* gnu/packages/music.scm (lsp-plugins): new variable.
---
gnu/packages/music.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ee402bad4d..41c93c5a90 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5380,3 +5380,46 @@ filtered, pitch shifted and ultimately disintegrated. This is an unofficial
port of the Regrader plugin created by Igorski. It is available as an LV2
plugin and a standalone JACK application.")
(license license:expat)))
+
+(define-public lsp-plugins
+ (package
+ (name "lsp-plugins")
+ (version "1.1.17")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sadko4u/lsp-plugins.git")
+ (commit (string-append "lsp-plugins-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04w3lhnbnfynrr3zpcr7cdrlddxa6v3mdmj7rvbxi2xbczbqpa15"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc" "BUILD_MODULES=\"lv2 ladspa jack\"" "VST_UI=0"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "ETC_PATH=" (assoc-ref %outputs "out") "/etc"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure
+ (replace 'check
+ (lambda _
+ (invoke "make" "test"))))))
+ (inputs
+ `(("cairo", cairo)
+ ("hicolor-icon-theme", hicolor-icon-theme)
+ ("jack", jack-1)
+ ("ladspa", ladspa)
+ ("libsndfile", libsndfile)
+ ("lv2", lv2)
+ ("mesa", mesa)))
+ (native-inputs
+ `(("pkg-config", pkg-config)))
+ (synopsis "Audio plugin collection")
+ (description "LSP (Linux Studio Plugins) is a collection of audio
+plugins available as LADSPA/LV2 plugins and as standalone JACK
+applications.")
+ (home-page "https://lsp-plug.in/")
+ (license license:lgpl3)))
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6M3acACgkQAi6uQjE9
cPNBvgf/ZX3L8Q178uA0Ja2isHl8R1nKaLyZtde9Q7r8J8A9em5RQK1FO0JrmhJy
Rcz/ALRlbSNueokN/HkMZjwy+/9mBUnGN+V2II7lbLzbBiVKbHxig0lCba/iu/lX
YX2N+Co4ds/Y44TcZBRNIQ2BvtPLGd0xSSHJeSnBt1fDpENIn1cl+2UoTSyXTgd/
EG3D8P6WsaGCKn0IhSPkkCkeGGRQSSpQHf91kC6sq8pSfXpKcj7WiGZ4C/I7V1Bg
w9b8zjyHnkNLd2uD25heWXeSsd68ZFj/dpwWsDKQ5nhgaupHTBEUprZFD69B4asg
7orYEb8Ct3eBdhj4/5k39SKtW1DAoQ==
=xWQ0
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 6 May 2020 21:55
Re: [bug#40471] [PATCH] gnu: Add lsp-plugins.
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40471@debbugs.gnu.org)
20200506195525.GF2359@E5400
This actually failed to build for me, even when I bumped the version up
to 1.1.19. Can you take a look at it?

Thanks


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl6zFioACgkQQarn3Mo9
g1E29BAAwhvPi/r4wZTBeF4x+DtAvvgXXO3CWoVc45MyZ8ilEAQ8uO/nCg5vM1H+
XWh5l1ewjQXnergeAFeFidre79M79+KqeLlLLxEhPDXZjNxLpptKQSdGTVMXNVt1
neNJdAG7Jk4N54PymkBKVUbAudi+NWfsMx99WsgnxNwkV7sSWNTXFhy9Ei8LArvz
iemeVzgm3AcqXUD/2oTQb6SaAZqYeEoaJfjQwrEj0aQCFBo+ZSQxG/8Lh/f+XHZ6
sjG+yWi5iFm70TPPDRHQJUC6q1W3zclOik0+yiQBKoRZ9lNkIv/C80KruZ36ly/R
8izBPrAc2VaNRDzlDOBuIf1hFJXpWhP3VobHEgydlpy8DQ9XC/axTGiT4XFGTpS7
dLgPBtCDeScLgZWtXinWcS/kJxob05WQNwH+B2jM75/MTaQoDvqjk7Md52fssmwy
xDPiaBZ7hXoy90FuRKWlNXz9tnOKCO7WHUWTgXB+owRw/tZ8R3LveJTsbUv34Adp
GzIehhvbVMgDg/RkDm6n5D11gjphk6wzvlwiQqsymMPhfG2IHZOf042RC/HBmjoM
V3A0SYIRJxAj1pEqOHv1z5q3dYqlq3KezUsW2wr7tXoBLT5xla7z9RhS3roNxPDI
aXVxbiZ60UuVFmRtzcW/5YAiDdcbaKkRYh5TReGjssg96+RLkOs=
=uXyK
-----END PGP SIGNATURE-----


A
A
Alexandros Theodotou wrote on 27 May 2020 02:06
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 40471@debbugs.gnu.org)
4df3ebd1eb7b6bfbdac5f4840e13756427ca0a8f.camel@zrythm.org
Fixed! The failure was due to the lv2 upgrade. The upstream has fixed
this in the new release.

See new patch attached.

Thanks,
Alex

On Wed, 2020-05-06 at 22:55 +0300, Efraim Flashner wrote:
Toggle quote (7 lines)
> This actually failed to build for me, even when I bumped the version
> up
> to 1.1.19. Can you take a look at it?
>
> Thanks
>
>
From b3aa2ea22bc2be15a7ab11c792ea85a1ec3900d6 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 27 May 2020 01:04:42 +0100
Subject: [PATCH] gnu: Add lsp-plugins.

* gnu/packages/music.scm (lsp-plugins): new variable.
---
gnu/packages/music.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2c6be8eba8..f01978d118 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4863,6 +4863,49 @@ effects. It contains a bitcrusher, delay, distortion, equalizer, compressor,
and reverb.")
(license license:gpl2+)))
+(define-public lsp-plugins
+ (package
+ (name "lsp-plugins")
+ (version "1.1.21")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sadko4u/lsp-plugins.git")
+ (commit (string-append "lsp-plugins-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zw0iip6ki9k65kh8dp53x7l4va4mi5rj793n2yn4p9y84qzwrz9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc" "BUILD_MODULES=\"lv2 ladspa jack\"" "VST_UI=0"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "ETC_PATH=" (assoc-ref %outputs "out") "/etc"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure
+ (replace 'check
+ (lambda _
+ (invoke "make" "test"))))))
+ (inputs
+ `(("cairo", cairo)
+ ("hicolor-icon-theme", hicolor-icon-theme)
+ ("jack", jack-1)
+ ("ladspa", ladspa)
+ ("libsndfile", libsndfile)
+ ("lv2", lv2)
+ ("mesa", mesa)))
+ (native-inputs
+ `(("pkg-config", pkg-config)))
+ (synopsis "Audio plugin collection")
+ (description "LSP (Linux Studio Plugins) is a collection of audio
+plugins available as LADSPA/LV2 plugins and as standalone JACK
+applications.")
+ (home-page "https://lsp-plug.in/")
+ (license license:lgpl3)))
+
(define-public sherlock-lv2
(package
(name "sherlock-lv2")
--
2.26.2
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl7Nrw4ACgkQAi6uQjE9
cPPylQf+O4NUhHBFHv3apavXunEjOlvgd6h2/4j+ECgg58prGI3ZhB9x0n03C7ap
KkOR3F67E/RAl0J1YCoUsLl0DFVYmdqqI3TrM0GL/McjC/XL7/SnIA70MOLJv0uX
/WU55RqLn62/KSJ3u7ZIiG0jRNcWSx7Uq5ssE0w7/ol3Ysj+iZsQHYsqNS/KScB6
/bF7GvXWVIjskICr3Q28+wqtaLBh6sMAq2bXQS5K3pI2qM0rW8RcBhVEBeKD2hDL
sJGD0Wwgsad8hxahCaNdSf1CdaXf+9qPscZ/2dLjcyBnYejs+JxQhsOIUBl9npvp
91wJF6DKA0ra1w138mtBdxQpBXmCog==
=EmPu
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 27 May 2020 11:25
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40471-done@debbugs.gnu.org)
20200527092508.GA10771@E5400
Patched pushed with a few changes:

On Wed, May 27, 2020 at 01:06:38AM +0100, Alexandros Theodotou wrote:
Toggle quote (53 lines)
> Fixed! The failure was due to the lv2 upgrade. The upstream has fixed
> this in the new release.
>
> See new patch attached.
>
> Thanks,
> Alex
>
> On Wed, 2020-05-06 at 22:55 +0300, Efraim Flashner wrote:
> > This actually failed to build for me, even when I bumped the version
> > up
> > to 1.1.19. Can you take a look at it?
> >
> > Thanks
> >
> >

> From b3aa2ea22bc2be15a7ab11c792ea85a1ec3900d6 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Wed, 27 May 2020 01:04:42 +0100
> Subject: [PATCH] gnu: Add lsp-plugins.
>
> * gnu/packages/music.scm (lsp-plugins): new variable.
> ---
> gnu/packages/music.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 43 insertions(+)
>
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index 2c6be8eba8..f01978d118 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -4863,6 +4863,49 @@ effects. It contains a bitcrusher, delay, distortion, equalizer, compressor,
> and reverb.")
> (license license:gpl2+)))
>
> +(define-public lsp-plugins
> + (package
> + (name "lsp-plugins")
> + (version "1.1.21")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/sadko4u/lsp-plugins.git")
> + (commit (string-append "lsp-plugins-" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1zw0iip6ki9k65kh8dp53x7l4va4mi5rj793n2yn4p9y84qzwrz9"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:make-flags

I changed the CC=gcc line so that it can cross compile

Toggle quote (7 lines)
> + (list "CC=gcc" "BUILD_MODULES=\"lv2 ladspa jack\"" "VST_UI=0"
> + (string-append "PREFIX=" (assoc-ref %outputs "out"))
> + (string-append "ETC_PATH=" (assoc-ref %outputs "out") "/etc"))
> + #:phases
> + (modify-phases %standard-phases
> + (delete 'configure) ; no configure

I changed this to a #:test-flag

Toggle quote (4 lines)
> + (replace 'check
> + (lambda _
> + (invoke "make" "test"))))))

And I re-indented so that the ` was under the 'i' in inputs.
Same with native-inputs.

Toggle quote (27 lines)
> + (inputs
> + `(("cairo", cairo)
> + ("hicolor-icon-theme", hicolor-icon-theme)
> + ("jack", jack-1)
> + ("ladspa", ladspa)
> + ("libsndfile", libsndfile)
> + ("lv2", lv2)
> + ("mesa", mesa)))
> + (native-inputs
> + `(("pkg-config", pkg-config)))
> + (synopsis "Audio plugin collection")
> + (description "LSP (Linux Studio Plugins) is a collection of audio
> +plugins available as LADSPA/LV2 plugins and as standalone JACK
> +applications.")
> + (home-page "https://lsp-plug.in/")
> + (license license:lgpl3)))
> +
> (define-public sherlock-lv2
> (package
> (name "sherlock-lv2")
> --
> 2.26.2
>




--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl7OMfQACgkQQarn3Mo9
g1Ef/Q/9Fk0B5fQQFzxBD21aCb1i5syEecx2UJ+gs4Gm2oWzRmwFlPgw+bC0fo87
/lWViW+s4bgtkR1PwZoFKIFpZmJcL9VZS82uKY/rrkCfiPa7KX4pbivWJidRD9B+
TGzgmEHAW9qLo9X1OhTmK4pG5hYE87BxSZu0i9lk7ygGPhNY8+RZcEQ5W8mrBlFV
yJRC8uhVcK/dG9qts8nSI3H2DVv4ZScA9z1pqLCoFMbMMegexlrHM22KLFavm6vx
9nEgkGSUei9rIKoxXGAV3taMiyWxgz3T94ddtBrPC27t743Uo7p1jJOxLFGTPPxC
xeO54Pnk3XhaHbflmGmKwrDcAHVSPlGadn0sW/IO9EljW6eT/qABaV6LLxTaHVo+
qyFMFVDDS2OS207s8ajBUEDmVz4T3iLExTY+VUoN0w7FboET27yxBPCBPTBuppO6
aXpj8tCrxm9MhCZdKA/vEnCBnp3R37GERYqwtRZMcvEWpnsSq1xo5idJ8P8tsY+s
Fqe7bNn+vCJviWDuXQj86jLlo5COotYNP1loKGbJZHFk/AdpHm0/kbTOGvncoqhJ
Fo4VQUZs3bVxeMp503P5IRUoAWt6KdIZVUKshghZ2NzRIG6UFydFIFm6PY5kG3A1
s8FA2/ff6d3CmehhUg7Lf24pLn7jNGygsJP8kkaUdDiiO1CXzOk=
=VMGw
-----END PGP SIGNATURE-----


Closed
?